Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Howto author AVI->DVD with menus using Linux only !
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 27, 28, 29, 30, 31  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Sat Jul 15, 2006 6:23 pm    Post subject: Reply with quote

I still see it listed in portage.
Both on the website: http://packages.gentoo.org/search/?sstring=dvd
And in my portage tree:
Code:
/home/bubba $ emerge -pv dvd+rw-tools

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-cdr/dvd+rw-tools-6.1-r1  118 kB


It isn't available for all architectures though. Check the website link for currently supported arches and versions.
Back to top
View user's profile Send private message
vbmaster
n00b
n00b


Joined: 31 May 2006
Posts: 52
Location: Portugal

PostPosted: Sat Jul 15, 2006 7:04 pm    Post subject: Reply with quote

Altight, but till now I didn't need that package.

At this moment i'm trying to add the subtitle to the mpg file, but spumux command gives me this output:

Quote:

INFO: Locale=C
INFO: Converting filenames to ANSI_X3.4-1968
INFO: Detected subtitle file format: subviewer
INFO: Opened iconv descriptor. *UTF-8* *ISO8859-1*
INFO: Read 1520 subtitles
INFO: Adjusted 8 subtitle(s).
ERR: New_Face failed. Maybe the font path is wrong.
Please supply the text font file (Vera.ttf).
WARN: subtitle font: load_sub_face failed.
Segmentation fault


And I have both subtitle.xml and Vera.ttf on my home directory.



EDIT: Oh, foget it... it was a problem between the chair and the keyboard...
Back to top
View user's profile Send private message
dinsmore
n00b
n00b


Joined: 19 Apr 2006
Posts: 54

PostPosted: Sun Jul 30, 2006 10:09 pm    Post subject: transcode error Reply with quote

Hi there, I just bought a new computer with a dvd-rw drive, and wanted to make dvd's from my avi files... But I'm getting a problem when transcoding the movie... It says something about a buffer underflow and a broken pipe :S any ideas?
Here's the output:

Code:

$ transcode -i Igby.Goes.Down.XviD.avi -y ffmpeg --export_prof dvd-ntsc --export_asr 3 -o Igby_Goes_Down -D0 -b224 -N 0x2000 -s2 -m Igby_Goes_Down.ac3 -J modfps=clonetype=3 --export_fps 29.97

transcode v1.0.2 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
(dvd_reader.c) no support for DVD reading configured - exit.
[transcode] (probe) suggested AV correction -D 0 (0 ms) | AV 0 ms | 0 ms
[transcode] auto-probing source Igby.Goes.Down.XviD.avi (ok)
[transcode] V: import format    | XviD RIFF data, AVI (V=ffmpeg|A=mp3)
[transcode] V: import frame     | 640x272  2.35:1 
XXX: zoom=yes pre_clip=yes
[transcode] V: pre clip frame   | 640x382 (-56,0,-54,0)
[transcode] V: zoom             | 720x480  2.11:1 (Lanczos3)
[transcode] V: bits/pixel       | 0.217
[transcode] V: decoding fps,frc | 23.976,1
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x55    MPEG layer-3 [32000,16,2]   97 kbps
[transcode] A: export format    | 0x2000  AC3          [32000,16,2]  224 kbps
[transcode] V: encoding fps,frc | 29.970,4
[transcode] A: bytes per frame  | 4272 (4270.933333)
[transcode] A: adjustment       | -1064@1000
[transcode] A: rescale stream   | 2.000
[transcode] V: IA32/AMD64 accel | sse2 (sse2 sse mmxext mmx asm C)
tc_memcpy: using sse for memcpy
[transcode] V: video buffer     | 10 @ 720x480
[import_mp3.so] v0.1.4 (2003-08-04) (audio) MPEG
[import_ffmpeg.so] v0.1.12 (2004-05-07) (video) ffmpeg: MS MPEG4v1-3/MPEG4/MJPEG
[filter_modfps.so] v0.10 (2003-08-18) plugin to modify framerate
[filter_modfps.so] converting from 23.9760fps to 29.9700fps
[export_ffmpeg.so] v0.3.13 (2004-08-03) (video) Lavc51.0.0 | (audio) MPEG/AC3/PCM
[import_mp3.so] MP3->PCM
[import_mp3.so] tcextract -a 0 -i "Igby.Goes.Down.XviD.avi" -x mp3 -d 0 | tcdecode -x mp3 -d 0 -z 32000
tc_memcpy: using sse for memcpy
[export_ffmpeg.so] Using FFMPEG codec 'mpeg2video' (FourCC 'mpg2', MPEG2 compliant video).
[export_ffmpeg.so]: INFO: Selected dvd profile, ntsc video type for video
[export_ffmpeg.so]: INFO: Set interlacing to bottom-first
[export_ffmpeg.so]: INFO: Set frame rate to 29.97
[export_ffmpeg.so]: INFO: Set video bitrate to 5000
[export_ffmpeg.so]: INFO: Set GOP size to 18
[export_ffmpeg.so] Neither './ffmpeg.cfg' nor '~/.transcode/ffmpeg.cfg'
[export_ffmpeg.so] found. Default settings will be used instead.
[export_ffmpeg.so]: INFO: Starting 1 thread(s)
[export_ffmpeg.so]: INFO: Display aspect ratio calculated as 1.777778
[export_ffmpeg.so]: INFO: Sample aspect ratio calculated as 1.185185
[export_ffmpeg.so]: INFO: Selected dvd profile for audio
[export_ffmpeg.so]: INFO: Resampling filter inactive
[export_ffmpeg.so]: INFO: Set number of audio channels to 2
[export_ffmpeg.so]: INFO: Set number of audio bits to 16
[export_ffmpeg.so]: WARNING: Set audio sample rate to 48000 Hz, input rate is 32000 Hz
[export_ffmpeg.so]: WARNING:    loading resample plugin
[filter.c] Filter "resample" with args (resample)
[filter.c] Filter "resample" not loaded. Loading ...
[filter.c] Loading (resample) ..
[filter_resample.so] v0.1.4 (2003-08-22) audio resampling filter plugin
[filter_resample.so] options=(null)
[mpeg2video @ 0xb5809ea4]rc buffer underflow
sh: line 1:  7236 Broken pipe             tcextract -a 0 -i "Igby.Goes.Down.XviD.avi" -x mp3 -d 0
      7237                       | tcdecode -x mp3 -d 0 -z 32000
Segmentation fault


I read something about tracking down the problem, but I don't know how :S

dinsmore
Back to top
View user's profile Send private message
vbmaster
n00b
n00b


Joined: 31 May 2006
Posts: 52
Location: Portugal

PostPosted: Mon Jul 31, 2006 12:41 am    Post subject: Reply with quote

I would say that you don't have the ffmpeg package....
Back to top
View user's profile Send private message
dinsmore
n00b
n00b


Joined: 19 Apr 2006
Posts: 54

PostPosted: Tue Aug 01, 2006 12:53 am    Post subject: . Reply with quote

Ahmm, I do have the ffmpeg v. 0.4.9_p20051216 package installed, but maybe I need to emerge another package (transcode) with some ffmpeg use flag or to add support to it? :S
Back to top
View user's profile Send private message
vbmaster
n00b
n00b


Joined: 31 May 2006
Posts: 52
Location: Portugal

PostPosted: Tue Aug 01, 2006 12:03 pm    Post subject: Reply with quote

I emerged it normally and it was fine... :\
Back to top
View user's profile Send private message
dinsmore
n00b
n00b


Joined: 19 Apr 2006
Posts: 54

PostPosted: Tue Aug 01, 2006 2:08 pm    Post subject: ffmpeg must be then Reply with quote

I tried with tovid, which doesn't use ffmpeg as default (really slower too :S), and it worked fine, so then it must be the ffmpeg... I'll try re-emerging and see what happens...
Back to top
View user's profile Send private message
drfresh
n00b
n00b


Joined: 02 Aug 2006
Posts: 2

PostPosted: Wed Aug 02, 2006 1:09 pm    Post subject: Got m2v, ac3 and subtitle dir - DVD how on Windows? Reply with quote

Sorry to ask. But I can't figure it out...

I have the tools on windows and some program should have created the DVD using these tools but didn't do it right. What I have is:

title1.m2v
title2.ac3
directory with subpictures including a subtitle.xml file.

The program generated a author.xml file that seems corrupt. It looks like:
Code:
<dvdauthor dest="E:\OUT\MyMovie\DVD\">
  <vmgm />

I have the following list of programs in the program directory, that I probably need:
    dvdauthor.exe
    mkisofs.exe
    mplex.exe
    spumux.exe
and then what must be the cygwin environment.

Can someone help me please? I'm ready to be flamed with RTFM and "Use Linux" type of comments...

Thanks in advance for anyone taking this serious.

Dr. Fresh
Back to top
View user's profile Send private message
dinsmore
n00b
n00b


Joined: 19 Apr 2006
Posts: 54

PostPosted: Wed Aug 02, 2006 5:00 pm    Post subject: author.xml Reply with quote

Have you tried editing the xml file so that it looks similar to the one posted in this thread? I'm just thinking outloud anyway, but I don't think it will do no harm to try... :P
Back to top
View user's profile Send private message
drfresh
n00b
n00b


Joined: 02 Aug 2006
Posts: 2

PostPosted: Wed Aug 02, 2006 5:08 pm    Post subject: Reply with quote

Nope - I need to know how to handle the subtitles. I don't quite know the steps? Can you perhaps point to where that's described? On the first post in this intire thread I can't quite find it except for handling srt subs. But I have them as .png files, with an XML that looks like this:

Code:
- <subpictures>
- <stream>
  <spu start="00:00:07.88" end="00:00:08.40" image="E:\OUT\MyMovie\Title_1_Subtitle_0x23_DA\1.png" transparent="FF0000" force="no" />
  <spu start="00:01:42.12" end="00:01:44.60" image="E:\OUT\MyMovie\Title_1_Subtitle_0x23_DA\2.png" transparent="FF0000" force="no" />
  <spu start="00:01:45.04" end="00:01:47.12" image="E:\OUT\MyMovie\Title_1_Subtitle_0x23_DA\3.png" transparent="FF0000" force="no" />
Back to top
View user's profile Send private message
rodoval
n00b
n00b


Joined: 03 Aug 2006
Posts: 2

PostPosted: Thu Aug 03, 2006 7:43 pm    Post subject: Reply with quote

Hello all and thanks for the guide of the first post of the thread! But... I can't change the subtitle colors using "palette" as described in dvdauthor config file. I've applied the patch but the text is always yellow (not gray) with black (or dark) border. The only change is that the program not stop with error message, but the palette.rgb file is ignored! ¿Any help with this?

Greetings to the Gentoo community!

rodoval
Back to top
View user's profile Send private message
rodoval
n00b
n00b


Joined: 03 Aug 2006
Posts: 2

PostPosted: Fri Aug 04, 2006 12:19 pm    Post subject: Reply with quote

[quote="rodoval"]Hello all and thanks for the guide of the first post of the thread! But... I can't change the subtitle colors using "palette" as described in dvdauthor config file. I've applied the patch but the text is always yellow (not gray) with black (or dark) border. The only change is that the program not stop with error message, but the palette.rgb file is ignored! ¿Any help with this?
[/quote]

It works fine now! I can't identify my fail, maybe related to Xine which I have using for testing.

Best regards,

rodoval
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Aug 06, 2006 8:38 am    Post subject: Re: transcode error Reply with quote

dinsmore wrote:
Hi there, I just bought a new computer with a dvd-rw drive, and wanted to make dvd's from my avi files... But I'm getting a problem when transcoding the movie... It says something about a buffer underflow and a broken pipe :S any ideas?
Here's the output:

Code:

$ transcode -i Igby.Goes.Down.XviD.avi -y ffmpeg --export_prof dvd-ntsc --export_asr 3 -o Igby_Goes_Down -D0 -b224 -N 0x2000 -s2 -m Igby_Goes_Down.ac3 -J modfps=clonetype=3 --export_fps 29.97

transcode v1.0.2 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
(dvd_reader.c) no support for DVD reading configured - exit.
[transcode] (probe) suggested AV correction -D 0 (0 ms) | AV 0 ms | 0 ms
[transcode] auto-probing source Igby.Goes.Down.XviD.avi (ok)
[transcode] V: import format    | XviD RIFF data, AVI (V=ffmpeg|A=mp3)
[transcode] V: import frame     | 640x272  2.35:1 
XXX: zoom=yes pre_clip=yes
[transcode] V: pre clip frame   | 640x382 (-56,0,-54,0)
[transcode] V: zoom             | 720x480  2.11:1 (Lanczos3)
[transcode] V: bits/pixel       | 0.217
[transcode] V: decoding fps,frc | 23.976,1
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x55    MPEG layer-3 [32000,16,2]   97 kbps
[transcode] A: export format    | 0x2000  AC3          [32000,16,2]  224 kbps
[transcode] V: encoding fps,frc | 29.970,4
[transcode] A: bytes per frame  | 4272 (4270.933333)
[transcode] A: adjustment       | -1064@1000
[transcode] A: rescale stream   | 2.000
[transcode] V: IA32/AMD64 accel | sse2 (sse2 sse mmxext mmx asm C)
tc_memcpy: using sse for memcpy
[transcode] V: video buffer     | 10 @ 720x480
[import_mp3.so] v0.1.4 (2003-08-04) (audio) MPEG
[import_ffmpeg.so] v0.1.12 (2004-05-07) (video) ffmpeg: MS MPEG4v1-3/MPEG4/MJPEG
[filter_modfps.so] v0.10 (2003-08-18) plugin to modify framerate
[filter_modfps.so] converting from 23.9760fps to 29.9700fps
[export_ffmpeg.so] v0.3.13 (2004-08-03) (video) Lavc51.0.0 | (audio) MPEG/AC3/PCM
[import_mp3.so] MP3->PCM
[import_mp3.so] tcextract -a 0 -i "Igby.Goes.Down.XviD.avi" -x mp3 -d 0 | tcdecode -x mp3 -d 0 -z 32000
tc_memcpy: using sse for memcpy
[export_ffmpeg.so] Using FFMPEG codec 'mpeg2video' (FourCC 'mpg2', MPEG2 compliant video).
[export_ffmpeg.so]: INFO: Selected dvd profile, ntsc video type for video
[export_ffmpeg.so]: INFO: Set interlacing to bottom-first
[export_ffmpeg.so]: INFO: Set frame rate to 29.97
[export_ffmpeg.so]: INFO: Set video bitrate to 5000
[export_ffmpeg.so]: INFO: Set GOP size to 18
[export_ffmpeg.so] Neither './ffmpeg.cfg' nor '~/.transcode/ffmpeg.cfg'
[export_ffmpeg.so] found. Default settings will be used instead.
[export_ffmpeg.so]: INFO: Starting 1 thread(s)
[export_ffmpeg.so]: INFO: Display aspect ratio calculated as 1.777778
[export_ffmpeg.so]: INFO: Sample aspect ratio calculated as 1.185185
[export_ffmpeg.so]: INFO: Selected dvd profile for audio
[export_ffmpeg.so]: INFO: Resampling filter inactive
[export_ffmpeg.so]: INFO: Set number of audio channels to 2
[export_ffmpeg.so]: INFO: Set number of audio bits to 16
[export_ffmpeg.so]: WARNING: Set audio sample rate to 48000 Hz, input rate is 32000 Hz
[export_ffmpeg.so]: WARNING:    loading resample plugin
[filter.c] Filter "resample" with args (resample)
[filter.c] Filter "resample" not loaded. Loading ...
[filter.c] Loading (resample) ..
[filter_resample.so] v0.1.4 (2003-08-22) audio resampling filter plugin
[filter_resample.so] options=(null)
[mpeg2video @ 0xb5809ea4]rc buffer underflow
sh: line 1:  7236 Broken pipe             tcextract -a 0 -i "Igby.Goes.Down.XviD.avi" -x mp3 -d 0
      7237                       | tcdecode -x mp3 -d 0 -z 32000
Segmentation fault


I read something about tracking down the problem, but I don't know how :S

dinsmore


Hi Dinsmore,
The problem lies with Transcode's filter_resample.so plugin.
'--export_prof' invokes the resample plugin automatically if the audio stream's sample rate is not equal to 48000Hz.
This is normal enough, but if the audio stream is not absolutely perfect and contains even the most minor glitch, it will segfault in this way.

Here's a workaround:
You can either run the file through Mencoder first, using the relevant line listed in the guide under the heading 'File types other than AVI or MPEG', or you can do the following ....
Code:
transcode -i Igby.Goes.Down.XviD.avi -y ffmpeg -F mpeg2 -Z 720x480 --export_asr 3 --pre_clip=no -j -56,0,-54,0 -o Igby_Goes_Down -D0 -b224 -N 0x2000 -s2 -m Igby_Goes_Down.ac3 -J modfps=clonetype=3 --export_fps 29.97

ffmpeg -i Igby_Goes_Down.ac3 -ab 224 -ar 48000 Igby_Goes_Down_new.ac3


As a side note, you are converting from 23.976fps source to 29.97fps. Might I suggest you use '--pulldown' instead of '-J modfps=clonetype=3 --export_fps 29.97' to achieve the same conversion. This will give you a much smoother video, especially noticeable in panning/zooming.
'--pulldown' will not work with '-y ffmpeg', only '-y mpeg2enc', slightly slower than ffmpeg, but result is worth it.
Like this:
Code:
transcode -i Igby.Goes.Down.XviD.avi -y mpeg2enc,ffmpeg -F8,-I0 --pulldown -Z 720x480 --export_asr 3 --pre_clip=no -j -56,0,-54,0 -o Igby_Goes_Down -D0 -b224 -N 0x2000 -s2 -m Igby_Goes_Down.ac3


Cheers,
Shiznix :D
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Aug 19, 2006 7:23 pm    Post subject: Reply with quote

Thanks for helping me make my first DVD ever. It came out great. I just think the suggested font-size for subtitles was too small. I had to squeeze my eyes to read them (but then I was not wearing glasses).
Back to top
View user's profile Send private message
gessy
n00b
n00b


Joined: 16 Nov 2005
Posts: 28
Location: Belo Horizonte - MG

PostPosted: Mon Aug 21, 2006 12:23 pm    Post subject: Subtitles and DVDauthor Reply with quote

Hi,

Is there a way to use dvdauthor to create a dvd of a movie that shows two subtitles at the same time (one on top and another on bottom), once it doesn't have full support for ass subtitles?

DVDauthor man page:

Quote:

subtitle (s2, rw)
The subtitle track, ranging from 0-31. If you want the subtitle
to always be displayed, then you should add 64 (i.e. choose
64-95). Simply selecting the track (0-31) means that only the
forced subtitles will be displayed, whereas enabling the track
(64-95) means that all the subtitles will be displayed. This
allows you to have forced subtitles only for the parts of the
movie where the actors are speaking a foreign (to the viewer)
language, but still have normal subtitles for the hearing
impaired. The hearing impaired viewers would enable the track
(64-95) while the other viewers would just select the track
(0-31) they would be able to share the track.


See that Simply selecting the track (0-31) means that only the
forced subtitles will be displayed, whereas enabling the track
(64-95) means that all the subtitles will be displayed. This
allows you to have forced subtitles only for the parts of the
movie where the actors are speaking a foreign (to the viewer)
language, but still have normal subtitles for the hearing
impaired


But i don't understanding how it works, someone had already done it?

thanks a lot!


Last edited by gessy on Mon Aug 21, 2006 9:17 pm; edited 2 times in total
Back to top
View user's profile Send private message
gessy
n00b
n00b


Joined: 16 Nov 2005
Posts: 28
Location: Belo Horizonte - MG

PostPosted: Mon Aug 21, 2006 12:41 pm    Post subject: Re: Put subtilte on DVD Reply with quote

khiraly wrote:
gessy wrote:
Hi

I made one download of a movie and it he came in the following format:

VIDEO_TS/
16K VIDEO_TS.BUP
16K VIDEO_TS.IFO
250M VIDEO_TS.VOB
80K VTS_01_0.BUP
80K VTS_01_0.IFO
748K VTS_01_0.VOB
1,0G VTS_01_1.VOB
1,0G VTS_01_2.VOB
1,0G VTS_01_3.VOB
1,0G VTS_01_4.VOB
42M VTS_01_5.VOB

And i would add one more subtitle and i don't know how, anyone knows?


I have exactly the same problem.
I have an *original* DVD video which I have buyed in Netherlands, and I want to add hungarian subtitle to enjoy my family.

All the tutorial what I have readed create a .mpg file and *after* create the menu and the dvd structure.
I didnt found any tutorial to add subtitle an already created dvd structure.
My DVD structure is pretty the same.

Can somebody help to gessy?;)



Well, reading a web documentation, i found a topic called "DVD9 to DVD5 guide"http://www.linuxquestions.org/questions/showthread.php?s=&threadid=244913.

Using transcode package (mainly tcextract) is possibles extract the streams. This how to explain verywell
p.s. the step 4 on the How to is only necessary if you work with dvd9.

p.p.s I don't know why, but this method doesn't work for some audio format like dts.
Back to top
View user's profile Send private message
thebiggiantmouse
n00b
n00b


Joined: 11 Sep 2006
Posts: 6
Location: Da Bronx

PostPosted: Mon Sep 11, 2006 6:05 pm    Post subject: Reply with quote

this is great. this thread is about two years old and its still really relevant. this has saved me a lot of searching. is there an update to this?
_________________
As long as i have my books, my mind and google; I am as knowledgeable as any linux guru
Back to top
View user's profile Send private message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Sun Oct 08, 2006 10:39 am    Post subject: Reply with quote

Hello, I followed all the steps, and I have a DVD image now. It is playing perfectly with xine.
However, when issueing the growisofs command, I get this error:
Code:
Executing 'mkisofs -dvd-video dvd/ | builtin_dd of=/dev/hdd obs=32k seek=0'
mkisofs: Unable to make a DVD-Video image.
:-( write failed: Input/output error


What could that be? I tried to burn the DVD with k3b, but it won't work in my DVD player, this way...
I am using dvd+rw-tools version 6.1-r1

EDIT: Found the problem - the dvd image apparently must not reside on a FAT32 partition. I recreated it on an ext3 disk and now it works.

thomas
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
vectorsigma
n00b
n00b


Joined: 02 Apr 2004
Posts: 29
Location: Sydney, Australia

PostPosted: Fri Oct 20, 2006 7:32 pm    Post subject: Reply with quote

I'm having the exact problem as the person below but there doesn't seem to be a reply. Anyone know how to fix it? I've tried everything I can think of.

Pumaman wrote:
Hi,

when I make a menu, it looks fine on my widescreen TV but messes up on my 4:3 TV. It seams that the buttons aren't scaled when the image is letterboxed.

To illustrate, this is what a menu might look like in widescreen, and this is what the same menu would look like letterboxed on a standard TV.

Does anyone have the same problem, and can anyone help?

My spumux xml looks like this:
Code:
<subpictures>
  <stream>
    <spu start="00:00:00.0" end="00:00:00.0"
         image="buttons.png"
         highlight="buttonsh.png"
         select="buttonsh.png"
         force="yes"
         autooutline="infer"
         autoorder="rows"/>
  </stream>
</subpictures>


and my dvdauthor xml looks like this:
Code:
   <menus>
      <video aspect="16:9" widescreen="nopanscan" />
      <pgc>
         <vob file="menu.mpg" pause="0" />
         <button>{jump title 1;}</button>
         <button>{jump title 2;}</button>
         <post>jump cell 1;</post>
      </pgc>
   </menus>



thanks
David
Back to top
View user's profile Send private message
vectorsigma
n00b
n00b


Joined: 02 Apr 2004
Posts: 29
Location: Sydney, Australia

PostPosted: Sun Oct 22, 2006 7:15 pm    Post subject: Reply with quote

I found a couple of solutions to the above problem.

The first I tried was to have 2 versions of the menu VOB, one for 16:9 and another for 4:3, both with the exact same mpeg but mplexed with different highlight and select images. The 4:3 images were scaled down to 720x405 (make sure not to use antialiasing, it will create more than 4 colours) then the canvas size increased back to 720x576. I then added some code to select which menu to use based on the dvd player's settings (widescreen or letterbox):

Code:

<pre> g7=s14; g7=g7 and 768; if (g7 eq 512) jump menu 2; </pre>


This works but it's a bit silly to have 2 copies of the one menu when DVD players support multiple subpicture streams in the same VOB.


The best solution is to use the latest CVS version of dvdauthor. It has a new feature that lets you select a subpicture stream for the menu. So you would still create 2 versions of the highlight and select images as I described above but they would all be mplexed into the one image, like so:

Code:

spumux -s 0 menu169.xml < menu.vob | spumux -s 1 menu43.xml > menu.vob


So the 16:9 subpicture stream has id 0 and 4:3 has id 1.

Then all you need to do is list the subpicture steams for the menu in the dvdauthor XML file. e.g:

Code:

 <menus>
   <video widescreen="nopanscan" format="pal" aspect="16:9" />
   <subpicture>
     <stream id="0" mode="widescreen" />
     <stream id="1" mode="letterbox" />
   </subpicture>
   <pgc>
etc.


I found the solution on the dvdauthor mailing list, more info can be seen here:
http://sourceforge.net/mailarchive/message.php?msg_id=11833372
Back to top
View user's profile Send private message
rekonrad
Apprentice
Apprentice


Joined: 01 Jun 2003
Posts: 186
Location: Winnipeg, MB

PostPosted: Sat Nov 11, 2006 4:37 am    Post subject: some help... Reply with quote

I've followed the instructions on this thread with the exception of encoding. For this I've been using Tovid.. Because I've had difficulty following the instructions regarding making menus with gimp (I think the new version of gimp must be quite different than the one in 2003 - date of this thread).

In any case I'm quite happy authoring with no menus. I've used the sample DVD.xml without menus in this thread successfully but now suddenly my final product will only read the first track (mpg). I have 12 separate titles but only the first is read. I thought at first it was my standalone DVD player but xine confirms that only the track 1 will play.
Here is my xml file:

<dvdauthor dest="DVD">
<vmgm />
<titleset>
<titles>
<video widescreen="nopanscan" />
<pgc>
<vob file="1.mpg" />
</pgc>
<pgc>
<vob file="2.mpg" />
</pgc>

<pgc>
<vob file="3.mpg" />
</pgc>
<pgc>
<vob file="4.mpg" />
</pgc>
<pgc>
<vob file="5.mpg" />
</pgc>
<pgc>
<vob file="6.mpg" />
</pgc>
<pgc>
<vob file="11.mpg" />
</pgc>
<pgc>
<vob file="22.mpg" />
</pgc>
<pgc>
<vob file="33.mpg" />
</pgc>
<pgc>
<vob file="44.mpg" />
</pgc>
<pgc>
<vob file="55.mpg" />
</pgc>
<pgc>
<vob file="66.mpg" />
</pgc>


</titles>
</titleset>
</dvdauthor>

During "dvdauthor -x DVD.xml" it shows all 12 tracks/titles being processed.

Any thoughts? Thanks in advance.

Richard
Back to top
View user's profile Send private message
gkmac
Guru
Guru


Joined: 19 Jan 2003
Posts: 319
Location: West Sussex, UK

PostPosted: Sun Nov 12, 2006 3:52 pm    Post subject: Re: some help... Reply with quote

rekonrad wrote:
I've used the sample DVD.xml without menus in this thread successfully but now suddenly my final product will only read the first track (mpg). I have 12 separate titles but only the first is read. I thought at first it was my standalone DVD player but xine confirms that only the track 1 will play.

Any thoughts? Thanks in advance.
You mean it pauses at the end of title 1? That seems to be the default behaviour after a title plays.

If you just want to let each title play one by one, you need to put a <post> command at the end of each pgc to make it jump to the next title. So the first few pgcs of your xml file go something like this; I've made the additional lines in bold...

<pgc>
<vob file="1.mpg" />
<post>jump title 2 chapter 1;</post>
</pgc>
<pgc>
<vob file="2.mpg" />
<post>jump title 3 chapter 1;</post>
</pgc>
<pgc>
<vob file="3.mpg" />
<post>jump title 4 chapter 1;</post>
</pgc>

Of course, what to do after the last one? Leaving it as it is will pause it, but I prefer to make the player stop completely, which you can do like this...

<pgc>
<vob file="66.mpg" />
<post>exit;</post>
</pgc>
_________________
If ~amd64 ebuilds are cutting edge, then git-9999 ebuilds are chainsaws.
"Not everyone can ride a unicycle, does that mean we should put another wheel on it?" - Lokheed
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Wed Nov 29, 2006 11:17 pm    Post subject: Reply with quote

Hi all,

I'm trying to convert something from an old VHS tape (somebody else converted it into an avi file) into a DVD. The original video was 4:3 and running the film through mplayer gives me the output below. When I go through the steps of creating the DVD (including specifying the right ar in transcode), all seems to work out. However, I cannot seem to get a 4:3 version or something approaching that as the final project. Any tips?

Best,

Alex

Code:

AVI file format detected.
VIDEO:  [DX50]  576x304  24bpp  29.970 fps  780.0 kbps (95.2 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
alsa-init: using device default
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 576 x 304 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.89:1 - prescaling to correct movie aspect.
VO: [xv] 576x304 => 576x304 Planar YV12
alsa-uninit: pcm closed-0.011 ct:  0.053  56/ 56  7%  4%  2.8% 1 0

Exiting... (Quit)
Back to top
View user's profile Send private message
csab
Apprentice
Apprentice


Joined: 15 Apr 2005
Posts: 152
Location: Atlanta, GA

PostPosted: Fri Dec 01, 2006 7:00 pm    Post subject: Reply with quote

Hi,

I've used this tutorial for while but now I encountered the first problem. In the "tweakage" part, the following command line is given:

Quote:
transcode -i matrix.avi -y ffmpeg -F mpeg2 -Z 352x240 --export_asr 2 --encode_fields b -o matrix -D0 -E 48000,16,2 -b 224 -N 0x2000 -s2 -m matrix.ac3 -J modfps --export_fps 29.97


I let my computer run overnight on a few AVI files with this command line, and in the morning, I was shocked to see that audio in the resulting ac3's were *not* resampled from 44100 Hz to 48000 Hz. I guess the parameter -J resample would be necessary (I tried and it worked.) So is there any reason that it is not included in the tutorial? Maybe it used to work like this?

The man page says that you need -J resample if the audio export module cannot resample. I'm pretty sure that ffmpeg is able to resample. Maybe the resampling routine is never invoked from transcode?

Also: why on Earth does each command line in the tutorial includes the "-s2" option? When I was a beginner and believed it was necessary (or at least it didn't hurt), I encoded a video once, in which the original audio was quite loud and the additional gain caused distortion. Since then, I always leave that option out and I never had a problem with too quiet material. If it's fine on your coputer, it is going to be fine on your TV, too.
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 507

PostPosted: Thu Dec 07, 2006 12:21 am    Post subject: Reply with quote

Quote:
Can you (or anyone else) confirm for sure that this fixes the NTSC overscan problem ?


The widescreen="nopanscan" option did not fix it for me. I export to 4:3 (I don't have a widescreen TV). NTSC, of course.

Shiznix, it would be awesome if you could release a new version that allows me to use the -j -18,-34,-22,-34 option.
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 27, 28, 29, 30, 31  Next
Page 28 of 31

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum