Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA and esound
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
fidler
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 162
Location: Utah

PostPosted: Tue Aug 13, 2002 6:16 pm    Post subject: ALSA and esound Reply with quote

I am having problems running esound with alsa 0.9rc2 installed. All other sound apps seem fine...


I get the following:

Code:

Audio device open for 44.1Khz, stereo, 16bit failed
Trying 44.1Khz, 8bit stereo.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 48Khz, 16bit stereo.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 22.05Khz, 8bit stereo.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 22.05Khz, stereo, 8bit failed
Trying 44.1Khz, 16bit mono.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 44.1Khz, mono, 8bit failed
Trying 22.05Khz, 8bit mono.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 22.05Khz, mono, 8bit failed
Trying 11.025Khz, 8bit stereo.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 11.025Khz, stereo, 8bit failed
Trying 11.025Khz, 8bit mono.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 11.025Khz, mono, 8bit failed
Trying 8.192Khz, 8bit mono.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Audio device open for 8.192Khz, mono, 8bit failed
Trying 8Khz, 8bit mono.
ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or                                                           
 resource busy
Sound device inadequate for Esound. Fatal.


when no sound app is running. When an alsa sound app is running, I get the following:

Code:

ALSA lib pcm_hw.c:791:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy


It seems that alsa doesn't allow multiple opening of the sound card. It did under my previous linux distribution ....

I thought it may be my /etc/modules.d/alsa file, but I think I got it right....



I wonder if anyone has gotten esd working with alsa...

Code:

# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf,v 1.3 2002/06/24 18:05:58 agenkin Exp $
                               
# ALSA portion                 
alias char-major-116 snd       
# OSS/Free portion             
alias char-major-14 soundcore   
                               
##                             
## IMPORTANT:                   
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##                             
##  ALSA portion               
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
                               
alias snd-card-0 snd-intel8x0
alias snd-card-1 snd-intel8x0
alias snd-card-2 snd-intel8x0
alias snd-card-3 snd-intel8x0
alias snd-card-4 snd-intel8x0
alias snd-card-5 snd-intel8x0
alias snd-card-6 snd-intel8x0
alias snd-card-7 snd-intel8x0

##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss


I did run update-modules. I also tried making sure that all the modules were loaded via the mrdules.autoload file:

Code:

# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/modules.autoload,v 1.3 2002/05/12 21:48:18 azarah Exp $

# /etc/modules.autoload:  kernel modules to load when system boots.
#
# Add the names of modules that you'd like to load when the system
# starts into this file, one per line.  Comments begin with # and
# are ignored.  Read man modules.autoload for additional details.

# For example:
# 3c59x
# CDRW
ide-scsi
# PCMCIA
#pcmcia_core
#i82365
#ds
# NVidia
NVdriver
# clik?
ide-floppy
#sound
snd-intel8x0
snd-pcm
snd-pcm-oss
snd-mixer-oss
snd-seq-oss


I'm baffled ... 8O

Any suggestions?
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1379
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Tue Aug 13, 2002 8:59 pm    Post subject: Reply with quote

I personally wouldn't add the snd-intel8x0 module to your modules.autoload file given you don't need to. Anytime I do something that I don't need to I generally end up with problems. I'd recommend reading through the Desktop Guide very closely and following everything in there exactly (so you will need to remove the reference to snd-intel8x0 from modules.autoload since the guide does not have you do this) -- At the same time you will need to be very sure that you have alsa-sound added into your boot runlevel (not default), but if you follow the Desktop Guide you will have already done that!! :)

Thats just what I would start with, let me know how it goes!!

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
fidler
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 162
Location: Utah

PostPosted: Tue Aug 13, 2002 11:11 pm    Post subject: Reply with quote

I tried it both ways... It doesn't work either way....

It sucks.
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1379
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Tue Aug 13, 2002 11:50 pm    Post subject: Reply with quote

Well looking over the (updated?) Desktop Guide it doesn't seem (am I blind?) to mention putting ANYTHING AT ALL into the modules.autoload anymore (I know it used to say to put snd-pcm-oss and snd-oss-mixer). So you might aswell trying leaving ALL sound related modules out of your modules.autoload just to see . . . Maybe? I don't know. I know there are lots of issues to be had with ALSA and I'm sure there are TONS of ways to get it working, but I have always taken a "keep it simple silly[edited from stupid to protect egos]" approach with my own machines, friends machines, and others I (try to) help in the forums.

My last guesses would be to unmerge any oss related stuff (except alsa-oss) and any other sound daemons (arts, esd, etc, etc) and then possibly even re-emerge your alsa-driver package. Remember to save time when building ALSA always pass the argument for just your card (so you only build the module you will use, instead of ALL of them). To emerge alsa with only your cards support simply reference it in the call using this syntax.

Code:
ALSA_CARDS=<your card> emerge alsa-driver


where <your card> is simply replaced with the alsa driver name with the preceeding 'snd-' prefix. In my case this would look exactly like this

Code:
ALSA_CARDS=snd-intel8x0 emerge alsa-driver


Again before you bother to re-emerge you might take a look at your USE settings to be sure that you have removed support (-arts, -esd) for 'other' sound daemons. I want to re-iterate that these are not suggestions from experience, these are suggestions on what I would try next if it were my machine --- So feel free to call me crazy and write-off the suggestions as mentally challenged. :)

Hope that helps!

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1145
Location: Williamsburg Virginia

PostPosted: Wed Aug 14, 2002 5:14 am    Post subject: Reply with quote

i cant comment on esound...but i just installed alsa and configured to work (almost) with arts. i put nothing in modules.autoload and i found this site to be kinda helpful. take anything dealing with sound out of the modules.autoload and in your kernel only compile as modules soundcore.o and sound.o...to modules.autoload you then should add soundcore and sound...but nothing else and no driver for your sound card in the kernel
Back to top
View user's profile Send private message
fidler
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 162
Location: Utah

PostPosted: Wed Aug 14, 2002 5:46 pm    Post subject: Reply with quote

rommel wrote:
i cant comment on esound...but i just installed alsa and configured to work (almost) with arts. i put nothing in modules.autoload and i found this site to be kinda helpful. take anything dealing with sound out of the modules.autoload and in your kernel only compile as modules soundcore.o and sound.o...to modules.autoload you then should add soundcore and sound...but nothing else and no driver for your sound card in the kernel


OK. I will add sound and soundcore to the modules.autoload and make sure that all the OSS sound.o and soundcore.o are compiled instead of how I had the situation before --- sound and soundcore statically compiled in the kernel, and see how it does . . .

My sound does work right now, but it will not allow multiple streams . . . This is the reason esound doesn't start (I think).

Oh well.

thanks

see if it works in a few.
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1379
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Wed Aug 14, 2002 5:58 pm    Post subject: Reply with quote

You may be ever so slightly interesting in this other thread. You might ask Herodot how he got his working. Just a thought.

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
fidler
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 162
Location: Utah

PostPosted: Wed Aug 14, 2002 8:19 pm    Post subject: Reply with quote

OK the previous tip told me that I couldn't use software for playing simultaneous streams . . . I think.

Anyhow, it used to be able to do such a thing. Therefore I am chaning my use flags to -esd alsa to see if that will help any....
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1145
Location: Williamsburg Virginia

PostPosted: Thu Aug 15, 2002 7:57 am    Post subject: Reply with quote

again this is for arts but i had to emerge arts again to get kde's sound server to see alsa as an option....then i was able to select it to use as the I/O method....so this might be a sinilar issue with esound
Back to top
View user's profile Send private message
fidler
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 162
Location: Utah

PostPosted: Thu Aug 15, 2002 3:25 pm    Post subject: Reply with quote

I actaully got esound by:

1) adding -alsa to the USE variable
2) Re-emerging esound
3) Adding alsa to the USE variable.

However all sound apps now freeze when trying to access the ALSA interface or any other interface other than esound . . .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum