Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Installing ipe from an overlay
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Sat Jul 23, 2022 7:00 pm    Post subject: [Solved] Installing ipe from an overlay Reply with quote

Hello all,

I'm back with gentoo after about a 12 year absence. I was using ubuntu, but it is starting to piss me off. Install was a breeze, which I didn't expect. I installed it over a few days from my ubuntu install at my leisure. totally easy. pleasant surprise.

Anyway, I am having overlay emerge troubles. I am trying to install the program media-gfx/ipe (drawing program). it is in the overlay "mv", which I have enabled. There are two use flags, one for lua-3 and one for lua-4. I independently tried to emerge with each one enabled and the emerge failed. Here is the error.

Code:

* ERROR: media-gfx/ipe-7.2.24::mv failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-gfx/ipe-7.2.24::mv'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/ipe-7.2.24::mv'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/ipe-7.2.24/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/ipe-7.2.24/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/ipe-7.2.24/work/ipe-7.2.24/src'
 * S: '/var/tmp/portage/media-gfx/ipe-7.2.24/work/ipe-7.2.24/src'


ok. I don't know how to fix this. Can anyone help?

One issue is that on this page

https://overlays.gentoo.org/

it is stated the "mv" overlay is not well-maintained. Ok. There is another person who maintains an overlay for ipe. it is here.

https://www.sthu.org/misc/gentooOverlay.html

This appears to be an unofficial overlay (I think). I could try this overlay, but how do I enable it?

Thanks.

Edit: his overlay is here.

http://git.sthu.org/?p=shuber-gentoo-overlay.git;a=summary


Last edited by juniper on Tue Aug 09, 2022 7:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
CooSee
l33t
l33t


Joined: 20 Nov 2004
Posts: 938
Location: Earth

PostPosted: Sat Jul 23, 2022 7:50 pm    Post subject: Reply with quote

hello,

sorry, i misread the first time :roll:

clone the overlay to an folder with:

Code:
git clone https://git.sthu.org/repos/shuber-gentoo-overlay.git

and copy the ebuilds to your local overlay >>> https://wiki.gentoo.org/wiki/Creating_an_ebuild_repository

if you're frequently using ebuilds from other official repositories via eselect repository, better use following method or it'll jumble with the ebuilds from Gentoo:

https://forums.gentoo.org/viewtopic-p-8659032-highlight-.html#8659032

greetings
_________________
" Die Realität ist eine Illusion, die durch Mangel an ehrlicher Kommunikation entsteht "


Last edited by CooSee on Sat Jul 23, 2022 8:14 pm; edited 2 times in total
Back to top
View user's profile Send private message
CaptainBlood
Advocate
Advocate


Joined: 24 Jan 2010
Posts: 2865

PostPosted: Sat Jul 23, 2022 8:00 pm    Post subject: Re: Installing ipe from an overlay Reply with quote

juniper,
Welcome back.
juniper wrote:
https://overlays.gentoo.org/
it is stated the "mv" overlay is not well-maintained. Ok. There is another person who maintains an overlay for ipe. it is here.
Code:
mv   Ebuilds for packages not in the Gentoo tree (lack of maintainer or too experimental) and live ebuilds or extensions/bugfixes for packages in the tree   Martin Väth
Imho it would be erronous to think mv repository lacks of maintainer. Rather, above seems to mean that mv takes care of some ebuild he consider to lack maintenance in the official portage tree imo.
mv is the author of eix ebuild and source code, which is a big helper aside the official portage app stack.

While writing, I see CooSee has answered for the rest of your post.

Thks 4 ur attention, interest & support.
_________________
Unique LP assert induced thought agreed upon here: Poor testing hurts everyone... climate diversity included. ;)


Last edited by CaptainBlood on Thu Aug 04, 2022 9:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
CaptainBlood
Advocate
Advocate


Joined: 24 Jan 2010
Posts: 2865

PostPosted: Sat Jul 23, 2022 8:18 pm    Post subject: Reply with quote

Indeed media-gfx/ipe:mv failed here too.

Thks 4 ur attention, interest & support.
_________________
Unique LP assert induced thought agreed upon here: Poor testing hurts everyone... climate diversity included. ;)
Back to top
View user's profile Send private message
CaptainBlood
Advocate
Advocate


Joined: 24 Jan 2010
Posts: 2865

PostPosted: Sat Jul 23, 2022 8:40 pm    Post subject: Reply with quote

Overlay resets connection when trying to access ipe ebuild here:(.
Thks 4 ur attention, interest & support.
_________________
Unique LP assert induced thought agreed upon here: Poor testing hurts everyone... climate diversity included. ;)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 19532

PostPosted: Sat Jul 23, 2022 10:13 pm    Post subject: Re: Installing ipe from an overlay Reply with quote

juniper wrote:
Here is the error.
Code:
* ERROR: media-gfx/ipe-7.2.24::mv failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-gfx/ipe-7.2.24::mv'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/ipe-7.2.24::mv'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/ipe-7.2.24/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/ipe-7.2.24/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/ipe-7.2.24/work/ipe-7.2.24/src'
 * S: '/var/tmp/portage/media-gfx/ipe-7.2.24/work/ipe-7.2.24/src'
ok. I don't know how to fix this. Can anyone help?
Based on the output shown, it appears that the compilation failed. If you need more help, please follow the instructions that it printed and you posted here.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Sat Jul 23, 2022 10:47 pm    Post subject: Reply with quote

CaptainBlood wrote:

juniper,
Welcome back.


Cheers. I like the emerge system significantly better than apt. Apt is pretty good, but I was pretty lost if something didn't work. portage is pretty transparent (I guess that has it downsides too, but I think overall it is better).

One question: I see that you said that mv maintains eix? I see it in both the overlay and the main gentoo tree. I don't get this. I guess there are non mainline updates in mv?

I followed CooSee suggestions (git cloning and running local ebuilds, masking everything). I have been using the guru overlay. I guess I should be masking everything for there too that I don't need? (I used guru to get neovim-qt).

Anyway, I installed ipe from the shuber overlay as per CooSee's instruction. it worked.

@Hu: Sorry. I just saw your message, so I can't post emerge info.


Last edited by juniper on Sat Jul 23, 2022 11:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
CooSee
l33t
l33t


Joined: 20 Nov 2004
Posts: 938
Location: Earth

PostPosted: Sat Jul 23, 2022 10:52 pm    Post subject: Reply with quote

Quote:
I guess I should be masking everything?

to be on a safer side, yes.

Quote:
Anyway, I installed from the shuber overlay. It worked!


great 8) - welcome back and have fun with Gentoo :)
_________________
" Die Realität ist eine Illusion, die durch Mangel an ehrlicher Kommunikation entsteht "
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Sat Jul 23, 2022 11:02 pm    Post subject: Reply with quote

CooSee wrote:
Quote:
I guess I should be masking everything?

to be on a safer side, yes.

Quote:
Anyway, I installed from the shuber overlay. It worked!


great 8) - welcome back and have fun with Gentoo :)


ok. Thanks. all is masked. Fun is different nowadays. You and I appeared to have joined this forums at approximately the same time (OMG 18 years ago!). now I am oldish. But I can still learn.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Sat Jul 23, 2022 11:33 pm    Post subject: Reply with quote

One issue that has cropped up.

I ran a eclean distfiles after all this, and I get the following error caused by that shuber overlay.

Code:

* Building file list for distfiles cleaning...
 * ERROR: dev-util/edb-0.9.17::shuber failed (depend phase):
 *   eutils: EAPI 0 not supported
 *
 * Call stack:
 *           ebuild.sh, line 618:  Called source '/var/db/repos/shuber/dev-util/edb/edb-0.9.17.ebuild'
 *   edb-0.9.17.ebuild, line   5:  Called inherit 'eutils' 'multilib'
 *           ebuild.sh, line 298:  Called __qa_source '/var/db/repos/gentoo/eclass/eutils.eclass'
 *           ebuild.sh, line 114:  Called source '/var/db/repos/gentoo/eclass/eutils.eclass'
 *       eutils.eclass, line  30:  Called die
 * The specific snippet of code:
 *      *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/edb-0.9.17::shuber'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/edb-0.9.17::shuber'`.
 * Working directory: '/usr/lib/python3.10/site-packages'
 * S: '/var/tmp/portage/dev-util/edb-0.9.17/work/edb-0.9.17'
 * ERROR: app-misc/v800_downloader-6::shuber failed (depend phase):
 *   qmake-utils: EAPI 6 not supported
 *
 * Call stack:
 *                  ebuild.sh, line 618:  Called source '/var/db/repos/shuber/app-misc/v800_downloader/v800_downloader-6.ebuild'
 *   v800_downloader-6.ebuild, line   6:  Called inherit 'eutils' 'qmake-utils'
 *                  ebuild.sh, line 298:  Called __qa_source '/var/db/repos/gentoo/eclass/qmake-utils.eclass'
 *                  ebuild.sh, line 114:  Called source '/var/db/repos/gentoo/eclass/qmake-utils.eclass'
 *         qmake-utils.eclass, line  19:  Called die
 * The specific snippet of code:
 *      *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=app-misc/v800_downloader-6::shuber'`,
 * the complete build log and the output of `emerge -pqv '=app-misc/v800_downloader-6::shuber'`.
 * Working directory: '/usr/lib/python3.10/site-packages'
 * S: '/var/tmp/portage/app-misc/v800_downloader-6/work/v800_downloader-6'
 * ERROR: dev-util/edb-0.9.18::shuber failed (depend phase):
 *   eutils: EAPI 0 not supported
 *
 * Call stack:
 *           ebuild.sh, line 618:  Called source '/var/db/repos/shuber/dev-util/edb/edb-0.9.18.ebuild'
 *   edb-0.9.18.ebuild, line   3:  Called inherit 'eutils' 'multilib'
 *           ebuild.sh, line 298:  Called __qa_source '/var/db/repos/gentoo/eclass/eutils.eclass'
 *           ebuild.sh, line 114:  Called source '/var/db/repos/gentoo/eclass/eutils.eclass'
 *       eutils.eclass, line  30:  Called die
 * The specific snippet of code:
 *      *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/edb-0.9.18::shuber'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/edb-0.9.18::shuber'`.
 * Working directory: '/usr/lib/python3.10/site-packages'
 * S: '/var/tmp/portage/dev-util/edb-0.9.18/work/edb-0.9.18'
 * Your distfiles directory was already clean.


if it helps i can post emerge --info of those files. These ebuilds from this overlay should be masked and they are local (they don't get synced from a remote server). I am also not using them. the only ebuilds I used from this overlay to build ipe is

Code:

equery has repository shuber
 * Searching for repository shuber ...
[I-O] [  ] media-gfx/ipe-7.2.24:0
[I-O] [  ] media-libs/libspiro-20200505:0


Can I just delete edb and v800-downloader in those /var/db/repos/shuber directories.
Back to top
View user's profile Send private message
CooSee
l33t
l33t


Joined: 20 Nov 2004
Posts: 938
Location: Earth

PostPosted: Sat Jul 23, 2022 11:46 pm    Post subject: Reply with quote

your local overlay is called shuber, or did you have complete shuber overlay in that folder?

if you just copied the ebuilds to your local overlay folder and tried to install those ebuilds, which won't work obviously, just remove them.

give your local overlay a better name and copy those ebuilds to the right subfolder.
_________________
" Die Realität ist eine Illusion, die durch Mangel an ehrlicher Kommunikation entsteht "
Back to top
View user's profile Send private message
CaptainBlood
Advocate
Advocate


Joined: 24 Jan 2010
Posts: 2865

PostPosted: Sun Jul 24, 2022 11:20 pm    Post subject: Reply with quote

juniper wrote:
I followed CooSee suggestions (git cloning and running local ebuilds, masking everything).
Oops my bad, I missed it.
Work in progress here...
Thks 4 ur attention, interest & support.
_________________
Unique LP assert induced thought agreed upon here: Poor testing hurts everyone... climate diversity included. ;)
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Sun Jul 31, 2022 10:49 pm    Post subject: Reply with quote

CooSee wrote:
your local overlay is called shuber, or did you have complete shuber overlay in that folder?

if you just copied the ebuilds to your local overlay folder and tried to install those ebuilds, which won't work obviously, just remove them.

give your local overlay a better name and copy those ebuilds to the right subfolder.


Maybe I did something bad.

I used your git clone command to get the ebuilds. Then I created a local overlay called shuber, moved the ebuilds there, and then enabled the overlay. I then emerge --sync and emerged ipe. That all worked.

Was that wrong? That all worked smoothly. I only ran into trouble when I executed the eclean command.

My basic problem was that I didn't know how to set up an unofficial overlay. Official ones work just fine.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 19532

PostPosted: Mon Aug 01, 2022 2:10 am    Post subject: Reply with quote

The shuber overlay appears to be badly out of date. It is offering edb-0.9.17, but Gentoo is up to 1.32 and 1.34. The version in shuber uses an EAPI that the Gentoo main tree no longer supports. The maintainer of the shuber overlay needs to update or delete the edb ebuild, either of which will resolve the eclean diagnostic.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Mon Aug 01, 2022 4:05 am    Post subject: Reply with quote

Hu wrote:
The shuber overlay appears to be badly out of date. It is offering edb-0.9.17, but Gentoo is up to 1.32 and 1.34. The version in shuber uses an EAPI that the Gentoo main tree no longer supports. The maintainer of the shuber overlay needs to update or delete the edb ebuild, either of which will resolve the eclean diagnostic.


I don't think my system is setup to auto get the new ebuilds if he updates it because I created this overlay and just happen to name it shuber.

What if I just delete the offending ebuilds?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 19532

PostPosted: Mon Aug 01, 2022 1:53 pm    Post subject: Reply with quote

That should suffice, if you keep the metadata consistent. However, I would expect that if you copied the ebuilds from the HEAD of shuber recently, and the overlay was maintained, then it would not have some of the offending ebuilds that it does have.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Mon Aug 01, 2022 6:14 pm    Post subject: Reply with quote

Hu wrote:
That should suffice, if you keep the metadata consistent. However, I would expect that if you copied the ebuilds from the HEAD of shuber recently, and the overlay was maintained, then it would not have some of the offending ebuilds that it does have.


Because this is an official repo, I didn't know how to set it up to sync. When I set up this repo as "shuber" I just created a local repo.

My file /etc/portage/repos.conf/eselect-repo.conf says

/etc/portage/repos.conf/eselect-repo.conf:

# created by eselect-repo

[guru]
location = /var/db/repos/guru
sync-type = git
sync-uri = https://github.com/gentoo-mirror/guru.git

[shuber]
location = /var/db/repos/shuber

[argent-main]
location = /var/db/repos/argent-main
sync-type = git
sync-uri = https://github.com/gentoo-mirror/argent-main.git


So it makes sense I think there is no update (my git clone didn't bring in any files telling the repo where the repository is. So my question to you is, how do I setup the repository so it does update?
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6611

PostPosted: Mon Aug 01, 2022 8:43 pm    Post subject: Re: Installing ipe from an overlay Reply with quote

juniper wrote:
I am trying to install the program media-gfx/ipe (drawing program). it is in the overlay "mv", which I have enabled. There are two use flags, one for lua-3 and one for lua-4. I independently tried to emerge with each one enabled and the emerge failed.

If you realize issues with the mv overlay, please report them on github.
I do not regularly recompile every package in the overlay, so unless I receive bugreports or run into an error myself, I assume that it still works.
Indeed, in this case, my last re-compile was from January 15, 2022. It seems that some upgrade of qtcore since then moved "moc" out from /usr/bin into /usr/$(get_libdir)/qt5/bin which is not in $PATH. so that a patch in the build system is necessary. The new version in the mv overlay should work (at least, it works for me with LUA_SINGLE_TARGET=lua5-4 on amd64).

I did not bump the ipe version (yet?) because the newest version has some new dependencies I have no time to add in the moment. (Actually, I am currently not using ipe, so I am not highly motivated to bump at all.) So if you want the latest shiny ipe version you might have to use another overlay.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Tue Aug 02, 2022 7:28 pm    Post subject: Reply with quote

Hey mv,

Thanks for the heads up. As you can see from above, I am a born again gentoo user, so there are a few things that I am still trying to learn re overlays. Also, that other overlay worked pretty easily. As I am new, I am not sure I can help you maintain it. I do happen to use ipe regularly so it is critical I get it working.

I am still having my eclean issue, which likely stems from me not knowing how to properly set up an unofficial repository. If you have some wise words on that, I'd appreciate it.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 19532

PostPosted: Wed Aug 03, 2022 12:54 pm    Post subject: Reply with quote

There is nothing special to Portage about official versus unofficial repositories, though the tooling may make official repositories easier to enable or disable. Your problem is you somehow got hold of some very outdated ebuilds, which no longer work. I originally thought you copied those directly from the public shuber git repository, but I don't see any app-emacs/ anything in the public shuber git repository. Thus, I find it strange you have an extremely outdated app-emacs/edb when shuber does not offer that in HEAD at all. Is it possible you copied the edb ebuilds from some other repository, and dropped them in your local overlay which is named shuber?

man 5 portage describes repos.conf at some length. However, for your purpose, I think manually syncing by deleting the ebuilds that the public shuber git does not offer would suffice.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Wed Aug 03, 2022 11:44 pm    Post subject: Reply with quote

Hi Hu,

Why do you think I have an app-emacs/edb? Do you mean dev-util/edb? I definitely have that, and it appears to be one of the things causing problems for eclean distfiles.

So I am confused by your last post. There is an app-emacs/edb, and from what I can tell it is in the official main gentoo repository, not shuber.
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6611

PostPosted: Thu Aug 04, 2022 5:23 am    Post subject: Reply with quote

I decided to byte the bullet and bump ipe to the newest version despite the new questionable (since non-optional) dependency on qtspell.
Note that the qtspell ebuild of the mv overlay compared to the version from the shuber overlay fixes a dependency bug, uses only non-deprecated eclasses (hence has up-to-date EAPI=8), and filters some flags. For this reason, I would recommend installation from the mv overlay now.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 19532

PostPosted: Thu Aug 04, 2022 3:07 pm    Post subject: Reply with quote

juniper wrote:
Why do you think I have an app-emacs/edb? Do you mean dev-util/edb? I definitely have that, and it appears to be one of the things causing problems for eclean distfiles.

So I am confused by your last post. There is an app-emacs/edb, and from what I can tell it is in the official main gentoo repository, not shuber.
I do not have the shuber overlay cloned, so I searched the main repository and found the app-emacs/edb. I made a mistake in assuming that the shuber overlay was also offering that same package, at a much older version. Instead, it is offering a package that confusingly has the same base name as the app-emacs/ package, but may be completely unrelated to the package in the main tree.

Regardless, yes, shuber's edb is using a deprecated eclass and this is causing problems for eclean.
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 831
Location: EU

PostPosted: Thu Aug 04, 2022 7:05 pm    Post subject: Reply with quote

Thanks all.

@mv: I am away, but I will install from your overlay when I get back on Sunday and let you know how it goes.
Back to top
View user's profile Send private message
CaptainBlood
Advocate
Advocate


Joined: 24 Jan 2010
Posts: 2865

PostPosted: Thu Aug 04, 2022 9:28 pm    Post subject: Reply with quote

@mv: Nice.
Switched here too.

Thks 4 ur attention, interest & support.
_________________
Unique LP assert induced thought agreed upon here: Poor testing hurts everyone... climate diversity included. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum