Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Poor performance in games with custom kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
gaycutie
n00b
n00b


Joined: 30 Dec 2021
Posts: 4

PostPosted: Thu Dec 30, 2021 10:01 am    Post subject: Poor performance in games with custom kernel Reply with quote

Hey! It seems like I have bad performance in games when I use my custom kernel, however genkernel works fine.
In CS:GO for an example I get around 200 FPS with my kernel however genkernel gives me 400.

My setup:
CPU: AMD Ryzen 7 5800H
GPU: NVIDIA GeForce RTX 3050 Mobile
RAM: DDR4 16GB

Output of glxinfo:
Code:
glxinfo | grep direct
direct rendering: Yes
    GL_AMD_multi_draw_indirect, GL_AMD_seamless_cubemap_per_texture,
    GL_ARB_direct_state_access, GL_ARB_draw_buffers,
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
    GL_ARB_indirect_parameters, GL_ARB_instanced_arrays,
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect,
    GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
    GL_NV_bindless_multi_draw_indirect,
    GL_NV_bindless_multi_draw_indirect_count, GL_NV_bindless_texture,
    GL_AMD_multi_draw_indirect, GL_AMD_seamless_cubemap_per_texture,
    GL_ARB_direct_state_access, GL_ARB_draw_buffers,
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
    GL_ARB_indirect_parameters, GL_ARB_instanced_arrays,
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect,
    GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
    GL_NV_bindless_multi_draw_indirect,
    GL_NV_bindless_multi_draw_indirect_count, GL_NV_bindless_texture,


According to nvidia-smi I'm running the 495.46 driver.
Back to top
View user's profile Send private message
psycho
Guru
Guru


Joined: 22 Jun 2007
Posts: 475
Location: New Zealand

PostPosted: Sat Jan 01, 2022 5:47 am    Post subject: Reply with quote

Hi there.

It could be a vast range of settings, as so many kernel settings affect performance. Assuming you were careful to read the documentation as you went through the configuration (avoiding options where it explained there'd be a performance impact, etc.), all I can suggest is the slow and painful but guaranteed-to-work method of starting with your genkernel .config file (already giving you 400fps) and then customizing it one section at a time (so in menuconfig you could do the "General setup" section and then build a kernel with just that much customised), testing after each build. Obviously it pays to backup your configs each time, before editing. At some point you will hit the problem (i.e. in your testing you'll drop to 200fps) and from there can narrow things down, reverting individual settings to their genkernel originals until you identify the issue.

Your custom kernel isn't necessarily going to be faster than a generic one (though I'd expect it to be a little faster, at least in some contexts) but it certainly shouldn't be slower (unless you've made it so deliberately through settings that trade efficiency for security or whatever). If you can't be bothered testing systematically by building your custom kernel gradually as above, and don't figure out or receive advice re a specific setting that fixes the problem, you might as well just use your genkernel, if it works and is faster.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 3718
Location: Frankfurt, Germany

PostPosted: Sat Jan 01, 2022 5:21 pm    Post subject: Reply with quote

Please post the output of
Code:
cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

Please post the kernel config of your custom kernel using wgetpaste.
Back to top
View user's profile Send private message
elmon
n00b
n00b


Joined: 21 Jan 2022
Posts: 1

PostPosted: Sat Jan 22, 2022 10:30 pm    Post subject: Reply with quote

Did you fix it?
I have similar problems like you but with genkernel which is kinda strange because my configuration should handle it pretty easily.
My setup:
I9 10900K @ 5.1GHZ
MSI Z490-A Pro MoBo
Liquid Cool 240mm
I also updated my GPU recently from 2070 Super to this one https://productz.com/en/evga-geforce-rtx-3070-xc3-ultra-gaming/p/eJdD3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum