Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Silo stuck at boot printing only SI
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message

Joined: 18 Mar 2005
Posts: 477

PostPosted: Wed Jul 14, 2021 5:04 pm    Post subject: [solved] Silo stuck at boot printing only SI Reply with quote

I updated my system, and now I cannot make it boot any more.
Silo get stuck at boot after printing its first two letters SI.
From what I can gather from old documentation, it means that it cannot load one of its stages (I guess the third one).

I am not sure how I got into this situation, because Silo was not one of the updated packages.
According to my emerge.log the last time it was emerged was more than six months ago.

Anyway, I tried to netboot and chroot to run silo again, but the only tftpboot images I could find on the mirrors are more than 10 years old.
When I try to chroot into my system I get an error "Kernel too old".

I also tried running silo without chrooting, but it complains about glibc being too old (obviously).
I am not sure if I could make that work using some LD_LIBRARY_PATH magic, but I did not make it so far.

Is there anywhere a tftboot with a recent kernel?
Do you have any advice?

Last edited by bender86 on Fri Jul 30, 2021 3:58 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 18 Mar 2005
Posts: 477

PostPosted: Fri Jul 30, 2021 3:49 pm    Post subject: Reply with quote

A bit sad to see the community so quiet, but I guess sparc is a dying architecture :(

Anyway, I did manage to recover, and this is how I did it.
Maybe it will help someone else in the future (maybe even myself again, something something XKCD 979 :D ).

I downloaded the latest Debian ISO image from here:
I installed QEMU with support for sparc and sparc64 architectures.
env QEMU_SOFTMMU_TARGETS="sparc sparc64" emerge qemu

I attached the harddrive of the broken installation to my laptop through USB.
I ran QEMU passing the raw device (/dev/sda) as disk, booting from the Debian cdrom.

qemu-system-sparc64 --machine sun4u,accel=tcg,usb=off -m 512 \
    -smp 1,sockets=1,cores=1,threads=1 \
    -rtc base=utc -no-reboot -no-shutdown \
    -boot strict=on \
    -drive file=/dev/sda,if=ide,format=raw \
    -drive file=debian-10.0-sparc64-NETINST-1.iso,format=raw,if=ide,bus=1,unit=0,media=cdrom,readonly=on \
    -netdev user,id=n1 \
    -device virtio-net-pci,bus=pciB,netdev=n1 \
    -boot d -serial pty -nographic

On another terminal I attached to the serial output
cu -l /dev/pts/2
(or whatever number QEMU tells you to) and waited until the Debian installer finished loading.

At that point, I switched to a console inside the emulated machine (ctrl+a+n), mounted the partitions (mount -t ext3 /dev/sda /mnt, specifying the filesystem explicitly, otherwise it failed with a cryptic "file not found" error), mounted the pseudo filesystems (mount -o bind /dev /mnt/dev && mount -o bind /sys /mnt/sys && mount -o bind /proc /mnt/proc), and chrooted (chroot /mnt /bin/bash).

Inside the chroot, I updated the environment (env-update), and ran silo (silo -C /etc/silo.conf).

Then I quit the chroot, unmounted everything, turned off the emulated machine, detached the disk, reattached it to the physical machine, and turned this one on...

... to be greeted by a "kernel not found" error by silo :D

But that was unrelated, I did try to change /etc/silo.conf in order to solve the original problem, and I must have made some syntax error.
Anyway, that was an easy fix, and I could even do it from the ancient Gentoo's tftpboot image.

So, lo and behold, in all its glory:

bender86@netra ~ $ neofetch
         -/oyddmdhs+:.                bender86@netra
     -odNMMMMMMMMNNmhy+-`             ----------------------------------
   -yNMMMMMMMMMMMNNNmmdhy+-           OS: Gentoo/Linux sparc64
 `omMMMMMMMMMMMMNmdmmmmddhhy/`        Host: SUNW,375-3015
 omMMMMMMMMMMMNhhyyyohmdddhhhdo`      Kernel: 5.10.27-gentoo
.ydMMMMMMMMMMdhs++so/smdddhhhhdm+`    Uptime: 11 hours, 9 mins
 oyhdmNMMMMMMMNdyooydmddddhhhhyhNd.   Packages: 360 (emerge)
  :oyhhdNNMMMMMMMNNNmmdddhhhhhyymMh   Shell: bash 5.1.8
    .:+sydNMMMMMNNNmmmdddhhhhhhmMmy   Terminal: /dev/pts/0
       /mMMMMMMNNNmmmdddhhhhhmMNhs:   CPU: TI UltraSparc IIe (Hummingbird) (0)
    `oNMMMMMMMNNNmmmddddhhdmMNhs+`    Memory: 129MiB / 485MiB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum