Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
El tema de las referencias circulares (solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 513
Location: LANDETE (Cuenca)

PostPosted: Wed Jul 28, 2021 1:20 pm    Post subject: El tema de las referencias circulares (solucionado) Reply with quote

Últimamente, cada vez es más complicado instalar Gento, porqué ?????
Veamos ...
Siguiendo al pie de la letra del manual de Gentoo, en los primeros compases me encuentro con que el comando:
emerge -a --update --deep --newuse @world
me devuelve un mogollón de referencias circulares incumplidas.
Deshacer ese entuerto se me está convirtiendo en una quimera ...
Ni anteponiendo USE="static-libs" al comando surte efecto alguno. Devuelve lo mismo, un mogollón de referencias circulares.
Si en el make.conf relleno la variable USE con los parámetros necesarios a la pretendida instalación y/o escritorio, sucede lo mismo.
Si al seleccionar cualquiera de la retahila de perfiles que devuelve el comando eselect profile list, devuelve lo mismo.
Qué es en lo que se diferencian los siguientes comandos:
eselect profile set 5
eselect profile set default/linux/amd64/17.1/openrc
si el resultado de eselect profile list es el mismo marcado con un asterisco.
Más se complica si los intentos de instalación se pretenden con systemd ... ¡¡¡uffffff!!!

¡Ah! otra cosa, porqué una actualización de una Gentoo instalada en la mayoría de las veces se quiebra, se rompe, o no se admite ...
Demasieeee ... ¿no?
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.


Last edited by Luciernaga on Mon Oct 18, 2021 1:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1438

PostPosted: Wed Jul 28, 2021 7:25 pm    Post subject: Reply with quote

¿Puedes publicar algunos ejemplos de las dependencias circulares que te salen?

Code:
eselect profile set default/linux/amd64/17.1/openrc
debría producirte un error porque no existe ningún perfil con ese nombre. Si previamente tenías seleccionado el perfil 5, aparte del mensaje de error, se sigue manteniendo seleccionado el perfil 5, normalmente:
Code:
default/linux/amd64/17.1/desktop
.

¿Puedes poner el nombre de archivo de stage3 que te descargaste?
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 513
Location: LANDETE (Cuenca)

PostPosted: Thu Jul 29, 2021 9:44 am    Post subject: Reply with quote

Hola quilosaq, gracias por responder y aclarar un poco mis ideas sobre Gentoo, ¡¡¡JO!!! a esas alturas.
Veamos con más profundidad sobre el tema que me confunde ...
Admito que me confundí en mi anterior mensaje al escribir
eselect profile set 5
eselect profile set default/linux/amd64/17.1/openrc

cuando lo que realmente es como dices ...
eselect profile set default/linux/x86/17.0/desktop
Bien, dado que en mi despacho tengo seis equipos con dos redes locales, afloró confundir un equipo amd64 con otro cualquiera, en este caso con un equipo de pruebas X86, lo que no invalida el tema de fondo, es decir, las referencias circulares.
Con más concreción en este caso con un equipo tal como:
Procesador: Intel Pentium E2220 @ 2.4GHz.
Memoria: DDR2-663 (4GB)
Gráfica: Nvidia GeForce GT1030 con 2GB
Almacenamiento: SSD Sandisk de 240GB
---------------------------------------------------------
Si al seleccionar un perfil determinado (eselect profile set 5) se supone que debería funcionar la actualización del perfil al emitir emerge -a --update --deep --newuse @world lo que NO SUCEDE al quejarse el sistema con las susodichas referencias circulares.
Con núcleos anteriores a los actuales no tuve ningún problema, aún teniendo que agregar algún parámetro USE en el make.conf y/o en el comando temporal.
Esto me viene sucediendo en el kernel 5.10.27 y en el actual 5.10.52-gentoo.
Como resultado lo siguiente:
Code:
These are the packages that would be merged, in order:

Calculating dependencies  . ...... done!
[nomerge       ] sys-apps/dbus-1.12.20-r1::gentoo  USE="X elogind -debug -doc (-selinux) -static-libs -systemd -test -user-session"
[nomerge       ]  sys-auth/elogind-246.10-r1::gentoo  USE="acl pam policykit -audit -debug -doc (-selinux)"
[nomerge       ]   sys-auth/polkit-0.119-r2::gentoo  USE="elogind gtk introspection nls pam -examples -kde (-selinux) -systemd -test"
[ebuild  N     ]    gnome-extra/polkit-gnome-0.105-r2::gentoo  304 KiB
[ebuild  N     ]     sys-auth/polkit-0.119-r2::gentoo  USE="elogind gtk introspection nls pam -examples -kde (-selinux) -systemd -test" 1.355 KiB
[nomerge       ] sys-auth/polkit-0.119-r2::gentoo  USE="elogind gtk introspection nls pam -examples -kde (-selinux) -systemd -test"
[nomerge       ]  dev-lang/spidermonkey-78.11.0:78::gentoo  USE="jit -clang -debug -lto -test"
[nomerge       ]   virtual/rust-1.52.1::gentoo
[nomerge       ]    dev-lang/rust-1.52.1:stable/1.52::gentoo  USE="-clippy -debug -doc (-miri) (-nightly) (-parallel-compiler) -rls -rustfmt (-system-bootstrap) (-system-llvm) -test -verify-sig -wasm" CPU_FLAGS_X86="sse2" LLVM_TARGETS="(X86) -AArch64 -AMDGPU -ARM -AVR -BPF -Hexagon -Lanai -MSP430 -Mips -NVPTX -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore"
[nomerge       ]     dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test"
[nomerge       ]      dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test"
[nomerge       ]       x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama"
[nomerge       ]        net-print/cups-2.3.3_p2-r2::gentoo  USE="X acl dbus pam ssl threads usb -debug -kerberos (-selinux) -static-libs -systemd -xinetd -zeroconf"
[ebuild  N     ]         net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf" 1.468 KiB
[ebuild  N     ]          app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW" 40.401 KiB
[ebuild  N     ]        x11-themes/adwaita-icon-theme-40.1.1::gentoo  USE="branding" 16.857 KiB
[ebuild  N     ]      dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test" 49.005 KiB
[ebuild  N     ]       x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" 20.896 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[ebuild  N     ]  app-text/mupdf-1.18.0-r4:0/1.18.0::gentoo  USE="X javascript opengl ssl" 52.365 KiB
[ebuild  N     ]   media-libs/freeglut-3.2.1-r1::gentoo  USE="-debug -static-libs" 430 KiB
[ebuild  N     ]    virtual/glu-9.0-r2::gentoo  0 KiB
[ebuild  N     ]     media-libs/glu-9.0.2::gentoo  USE="-static-libs" 426 KiB
[nomerge       ] dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test"
[nomerge       ]  x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test"
[nomerge       ]   media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test"
[nomerge       ]    media-gfx/graphite2-1.3.14::gentoo  USE="-perl -test"
[nomerge       ]     dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test"
[nomerge       ]      dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo  USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland"
[nomerge       ]       virtual/jpeg-100::gentoo  USE="-static-libs"
[ebuild  N     ]        media-libs/libjpeg-turbo-2.1.0-r2:0/0.2::gentoo  USE="-java -static-libs" 2.218 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[ebuild  N     ]  app-text/poppler-21.05.0:0/110::gentoo  USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss" 1.661 KiB
[ebuild  N     ]   dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo  USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" 0 KiB
[ebuild  N     ]    dev-qt/qtdbus-5.15.2:5/5.15::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ]   dev-qt/qtxml-5.15.2:5/5.15::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ]    dev-qt/qtcore-5.15.2-r2:5/5.15.2::gentoo  USE="icu -debug -old-kernel -systemd -test" 0 KiB
[ebuild  N     ]     dev-libs/double-conversion-3.1.5:0/3::gentoo  6.860 KiB
[nomerge       ] app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
[nomerge       ]  x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama"
[ebuild  N     ]   media-libs/libepoxy-1.5.5::gentoo  USE="X egl -test" 325 KiB
[ebuild  N     ]   gnome-base/librsvg-2.50.7:2::gentoo  USE="introspection vala" 21.704 KiB
[ebuild  N     ]    x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test" 2.003 KiB
[ebuild  N     ]     media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test" 17.520 KiB
[ebuild  N     ]      media-gfx/graphite2-1.3.14::gentoo  USE="-perl -test" 6.475 KiB
[ebuild  N     ] dev-lang/spidermonkey-78.11.0:78::gentoo  USE="jit -clang -debug -lto -test" 325.283 KiB
[ebuild  N     ]  virtual/rust-1.52.1::gentoo  0 KiB
[ebuild  N     ]   dev-lang/rust-1.52.1:stable/1.52::gentoo  USE="-clippy -debug -doc (-miri) (-nightly) (-parallel-compiler) -rls -rustfmt (-system-bootstrap) (-system-llvm) -test -verify-sig -wasm" CPU_FLAGS_X86="sse2" LLVM_TARGETS="(X86) -AArch64 -AMDGPU -ARM -AVR -BPF -Hexagon -Lanai -MSP430 -Mips -NVPTX -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore" 320.761 KiB
[nomerge       ] dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test"
[nomerge       ]  dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo  USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland"
[ebuild  N     ]   virtual/opengl-7.0-r2::gentoo  0 KiB
[nomerge       ] gnome-extra/polkit-gnome-0.105-r2::gentoo
[nomerge       ]  x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama"
[nomerge       ]   x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test"
[ebuild  N     ]    x11-libs/cairo-1.16.0-r4::gentoo  USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind" 41.014 KiB
[ebuild  N     ]     media-libs/mesa-21.1.4::gentoo  USE="X classic dri3 egl gallium gbm gles2 llvm zstd -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc -zink" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 (-v3d) (-vc4) -virgl (-vivante) -vmware" 14.898 KiB
[ebuild  N     ]      sys-devel/llvm-12.0.0:12::gentoo  USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit -test -xar -z3" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR (-CSKY) -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -VE -WebAssembly -XCore" 131.274 KiB
[nomerge       ] app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
[ebuild  N     ]  media-libs/openjpeg-2.4.0:2/7::gentoo  USE="-doc -static-libs -test" 2.181 KiB
[ebuild  N     ]   dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test" 8.766 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[ebuild  N     ]  app-text/qpdf-10.3.2:0/28::gentoo  USE="ssl -doc -examples -test" 18.500 KiB
[nomerge       ] x11-themes/adwaita-icon-theme-40.1.1::gentoo  USE="branding"
[nomerge       ]  x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama"
[ebuild  N     ]   dev-util/gtk-update-icon-cache-3.24.26::gentoo  90 KiB
[ebuild  N     ]    x11-libs/gdk-pixbuf-2.42.6:2::gentoo  USE="introspection jpeg tiff -gtk-doc" 7.528 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[ebuild  N     ]  media-libs/lcms-2.12:2::gentoo  USE="jpeg threads tiff zlib -doc -static-libs -test" 7.246 KiB
[ebuild  N     ]   media-libs/tiff-4.3.0::gentoo  USE="cxx jpeg zlib -jbig -lzma -static-libs -test -webp -zstd" 2.743 KiB
[ebuild  N     ]    virtual/jpeg-100::gentoo  USE="-static-libs" 0 KiB
[nomerge       ] x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test"
[nomerge       ]  media-libs/fontconfig-2.13.1-r2:1.0::gentoo  USE="-doc -static-libs"
[ebuild  N     ]   app-eselect/eselect-fontconfig-1.1-r1::gentoo  2 KiB
[ebuild  N     ]  x11-libs/libXft-2.3.3::gentoo  USE="-doc" 346 KiB
[ebuild  N     ]   media-libs/fontconfig-2.13.1-r2:1.0::gentoo  USE="-doc -static-libs" 1.684 KiB
[ebuild  N     ]    virtual/ttf-fonts-1-r1::gentoo  0 KiB
[ebuild  N     ]     media-fonts/liberation-fonts-2.1.3::gentoo  USE="X -fontforge" 2.315 KiB
[nomerge       ] app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
[ebuild  N     ]  media-fonts/urw-fonts-2.4.9::gentoo  USE="X" 3.124 KiB
[ebuild  N     ]   media-fonts/encodings-1.0.5-r1::gentoo  698 KiB
[ebuild  N     ]    x11-apps/mkfontscale-1.2.1::gentoo  148 KiB
[ebuild  N     ]     media-libs/freetype-2.10.4:2::gentoo  USE="X adobe-cff bzip2 cleartype_hinting harfbuzz png -bindist -brotli -debug -doc -fontforge (-infinality) -static-libs -utils" 2.360 KiB

Total: 47 packages (47 new), Size of downloads: 1.133.216 KiB

The following packages are causing rebuilds:

  (dev-lang/perl-5.34.0:0/5.34::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (perl-core/File-Temp-0.231.100:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Parser-2.440.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MIME-Charset-1.12.2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Metadata-1.0.37-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TermReadKey-2.370.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-podlators-4.140.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-YAML-0.18.0-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Pod-Parser-1.630.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (app-text/po4a-0.57-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Parse-CPAN-Meta-2.150.10-r5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/SGMLSpm-1.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Temp-0.231.100:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Scalar-List-Utils-1.550.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-LineBreak-2019.1.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-ParseWords-3.300.0-r8:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Parser-1.630.0-r8:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-2.150.10-r5:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Perl-OSType-1.10.0-r5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)

Postdata:
stage3-i686-openrc-20210706T203912Z.tar.xz
stage3-i686-openrc-20210706T203912Z.tar.xz.DIGESTS.asc
verificación sha512sum OK
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1438

PostPosted: Thu Jul 29, 2021 8:08 pm    Post subject: Reply with quote

En lo que has publicado no puedo ver ningún error debido a dependencias circulares en la forma que las define el Manual de Gentoo:
https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage/es#Dependencias_circulares

El paquete dev-lang/perl-5.34.0:0 que provoca la reconstrucción de varios paquetes tiene una news reciente que da información adicional para solucionar posibles problemas que aparezcan:
https://www.gentoo.org/support/news-items/2021-07-20-perl-5_34-upgrade.html

Parece que quieres usar la arquitectura x86 para tu instalación. Hasta donde he podido ver el procesador que usas (Intel Pentium E2220) admite la arquitectura de 64 bits x86_64 aunque debería funcionar sin errores con x86.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 513
Location: LANDETE (Cuenca)

PostPosted: Sun Aug 01, 2021 8:11 am    Post subject: Reply with quote

Quote:
Parece que quieres usar la arquitectura x86 para tu instalación. Hasta donde he podido ver el procesador que usas (Intel Pentium E2220) admite la arquitectura de 64 bits x86_64 aunque debería funcionar sin errores con x86.
Vamos a ver ahora, amigo quilosaq ...
Desde el repositorio alemán https://mirror.netcologne.de/gentoo/releases/amd64/autobuilds/current-install-amd64-minimal/ me he descargado el tarball install-amd64-minimal-20210725T170534Z.iso y su contraparte de verificación *.DIGESTS.asc con resultado de verificación OK.
Grabada la imagen ISO en un pendrive USB con rufus-3.14.exe para la instalación de Gentoo en mi equipo de pruebas citado.
Arranco el equipo con ese pendrive USB y aparece Gentoo en pantalla sin problemas.
Formateo las particiones (2 y 4), también la swap (3), y monto el sistema (openrc) en el disco SSD.
Como resultado estoy en el indicador de sistema ... livecd ~ # _
Emito links https://www.gentoo.org/downloads/mirrors/ y selecciono el repo alemán, para descargar lo siguiente ...
stage3-amd64-openrc-20210725T170534Z.tar.xz
stage3-amd64-openrc-20210725T170534Z.tar.xz.DIGESTS.asc

verificación sha512sum OK
Observo que el tarball stage3-*openrc*.tar.xz existe también en otro directorio, sin poder determinar cual es el idóneo para el escritorio de que se trate. No obstante descargo el existente dentro del directorio "desktop".
Emito tar xpvf stage3-*openrc*.tar.xz --xattrs-include='*.*' --numeric-owner
Configuro el make.conf y demás y entro en el enjaulado (chroot).
Emito emerge --sync sin problemas ...
Aparece una incidencia (eselect news read) que redirijo a un archivo (eselect news read all > news.txt)
Más adelante haré cita de parte de esas "news" ...
Emito eselect profile list y aparece una retahila de líneas de archivos para seleccionar.
Ahí puede prestarse a confusión en dependencia de lo que se desee instalar, en mi caso opto por el desktop estable, es decir, por seleccionar el perfil default/linux/amd64/17.1/desktop ...
y emitir luego emerge -a --verbose --update --deep --newuse @world y ahí surgen los problemas de referencias circulares que me trae desquiciado.
También, tanto en X86 como en amd64.
Qué diferencia existe en lo siguiente:
Index of /gentoo/releases/amd64/autobuilds/current-install-amd64-minimal/stage3-amd64-openrc-20210725T170534Z.tar.xz
Index of /gentoo/releases/amd64/autobuilds/current-stage3-amd64-openrc/stage3-amd64-openrc-20210725T170534Z.tar.xz
¿cuál es el correcto que se corresponde con el perfil?
¿acaso no son el mismo stage3-*?

Bien, ahora pasamos con las "news" ...
Quote:
El paquete dev-lang/perl-5.34.0:0 que provoca la reconstrucción de varios paquetes tiene una news reciente que da información adicional para solucionar posibles problemas que aparezcan:
https://www.gentoo.org/support/news-items/2021-07-20-perl-5_34-upgrade.html

Traducción de parte de las "news" con referencia a Perl ...
Code:
2021-07-20-actualización-perl-5_34
La actualización del título Perl 5.34 ahora es estable
Autor      Sam James <sam@gentoo.org>
Publicado   2021-07-20
Revisión   1
El proyecto Perl en Gentoo ha comenzado la estabilización de Perl 5.34 [0], que es la última versión estable lanzada upstream.
Si bien el administrador de paquetes generalmente maneja esta actualización de manera limpia, hay algunos errores [1] [2] [3] que afectan la resolución de dependencias de Portage que a veces significan que las recons-trucciones ocurren en el orden incorrecto; esto se ve agravado por el modelo de empaquetado utilizado para Perl (pero no es culpa suya).
Por lo tanto, recomendamos el siguiente procedimiento para los usuarios:
1. Sincroniza tu árbol:
# emerge --sync
2. Realice una actualización world completa, por ejemplo:
# emerge -a -uvDU @world --keep-going=y
3. Si ocurre alguna falla, ejecute perl-cleaner --all, luego intente nuevamente:
# perl-cleaner --all
4. Realice una actualización world de nuevo.
5. Una vez terminado, depclean:
# emerge -a --depclean
Si la actualización falla con conflictos, intente --backtrack=1000 o algún otro número grande.
En raras ocasiones, puede ser necesario realizar una instalación única de un paquete, pero normalmente `perl-cleaner` resolverá el problema. Si aparece un mensaje de error después de ejecutar perl-cleaner, intente, por ejemplo, para un paquete ficticio dev-perl/foo:
# emerge -a --oneshot --verbose dev-perl/foo
Si tiene algún problema, consulte los canales de asistencia estándar [4] (tales como nuestros foros o canales de IRC) y haremos todo lo posible para que su sistema vuelva a funcionar bien.
[0] https://bugs.gentoo.org/802639
[1] https://bugs.gentoo.org/592880
[2] https://bugs.gentoo.org/793992
[3] https://bugs.gentoo.org/199856
[4] https://www.gentoo.org/support/
Pues fallaron los puntos (2) y (3) sin poder visualizar (en pantalla) cualquier respuesta que condujera a una posible solución.
Devolviendo siempre las susodichas referencias circulares.
Sospecho que existe en el ánimo de los desarrolladores implementar cambios para mejorar el sistema, pero hasta que surtan efecto esos cambios en Gentoo habrá que esperar ...
Por de pronto me voy a permitir un tiempo 'sabático' (por lo menos tres meses) antes de volver a intentar instalar una Gento en cualquiera de mis equipos, me quedo (de momento) con la distro Calculate Linux que ésta si que no me falla.
Saludetes ....
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
chrootman
n00b
n00b


Joined: 18 Aug 2020
Posts: 44

PostPosted: Sun Aug 01, 2021 9:44 am    Post subject: Reply with quote

Podrías haber posteado que te retornó algo de esto:
https://wiki.gentoo.org/wiki/Perl
Code:
USE="perl" emerge --ask --update --changed-use --deep --autounmask-keep-masks=y @world

Code:
# emerge -1av perl $(qlist -IC dev-perl/*)

La última vez que instalé gentoo y aparecían rebuilds relacionados con perl la solución fue sacar -doc de /etc/portage/make.conf y ahí pude o el problema era que un paquete como -networkmanager o algo no permitía instalar cosas de systemd y era un circulo vicioso interminable.

Lo otro es sacar paquetes dependientes de perl (emerge --deselect sth; emerge -C sth) de /var/lib/portage/world y ejecutar emerge -e --fetchonly @system && emerge -e @system

También ejecutar un:
Code:
# emerge -a -uDU --with-bdeps=y @world --autounmask-write --autounmask-backtrack=y --keep-going --backtrack=50

y un:
Code:
# emerge --ask --update --deep --newuse --verbose --keep-going @world


El 05-04 agregué esto y me solucionó uno que otro problema.
Code:
>=dev-lang/perl-5.30.3-r1 berkdb gdbm

https://forums.gentoo.org/viewtopic-t-1113258-start-0.html
https://forums.gentoo.org/viewtopic-t-1066310-start-0.html
https://forums.gentoo.org/viewtopic-p-8558434.html?sid=f67cd37afe05a83d47f64a046ecc22ec
https://wiki.gentoo.org/wiki/Perl#TL.3BDR:_Blockers
https://forums.gentoo.org/viewtopic-p-8582511.html?sid=eeb35f690e49cb36ebec8496e13882bc
https://forums.gentoo.org/viewtopic-t-1136229.html
https://forums.gentoo.org/viewtopic-p-8477948.html?sid=c0d6d7448f1ee1f325cff39813bd61da

Sobre static-libs lo último recuerdo era necesario para compilar json-c o algo como cryptosetup o habilitarla en sys-libs/libseccomp.

No sé si tenga algo que ver pero ya migraste a libxcrypt, yo lo hice con éxito...

https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html

Si instalas la próxima systemd yo te diré todo lo que hice porque anoté paso por paso todo.

Para el instalador en el pendrive ocupé algo como:
https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/releases/amd64/autobuilds/current-stage3-amd64-systemd/install-amd64-minimal-20210725T170534Z.iso

Y el stage algo como:
https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/releases/amd64/autobuilds/current-stage3-amd64-hardened-selinux/stage3-amd64-hardened-selinux-20210627T214502Z.tar.xz o el stage que se usa normalmente...por ejemplo https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/releases/amd64/autobuilds/current-stage3-amd64-systemd/stage3-amd64-systemd-20210725T170534Z.tar.xz pero antecedido por autobuilds/current-stage3 y no lo otro. Da lo mismo el mirror, solamente ocupé ese porque un manual en de lo indicaba.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1438

PostPosted: Sun Aug 01, 2021 6:23 pm    Post subject: Reply with quote

Luciernaga wrote:
...
Formateo las particiones (2 y 4), también la swap (3), y monto el sistema (openrc) en el disco SSD.
...
Desde hace no mucho se ha actualizado el Manual de Gentoo y el esquema de particionamiento por defecto solo contempla 3 particiones. Ya no se usa la partición de arranque BIOS.
https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Disks/es#Esquema_de_particionamiento_por_defecto

Luciernaga wrote:
...
y emitir luego emerge -a --verbose --update --deep --newuse @world y ahí surgen los problemas de referencias circulares que me trae desquiciado.
...
La dependencia circular que he encontrado es:
media-libs/harfbuzz depende de media-libs/freetype y viceversa y un aviso que dice:
Quote:
Note that circular dependencies can often be avoided by temporaly disabling USE flag that trigger optional dependencies.

La manera de eliminar esa dependencia circular sería:
Code:
USE="-harzbuff" emerge -v --oneshot freetype

Después de instalado freetype ya se puede usar:
Code:
emerge -a --verbose --update --deep --newuse @world

Luciernaga wrote:
...
Qué diferencia existe en lo siguiente:
Index of /gentoo/releases/amd64/autobuilds/current-install-amd64-minimal/stage3-amd64-openrc-20210725T170534Z.tar.xz
Index of /gentoo/releases/amd64/autobuilds/current-stage3-amd64-openrc/stage3-amd64-openrc-20210725T170534Z.tar.xz
¿cuál es el correcto que se corresponde con el perfil?
¿acaso no son el mismo stage3-*?
...
No hay ninguna diferencia. Son el mismo archivo.

Luciernaga wrote:
...
Sospecho que existe en el ánimo de los desarrolladores implementar cambios para mejorar el sistema, pero hasta que surtan efecto esos cambios en Gentoo habrá que esperar ...
En mi opinión una de las características de Gentoo es que está en un proceso de actualización (mejora) continuo y estas situaciones siempres se podrán repetir. La flexibilidad y posibilidad de personalización tienen ese precio. Las decisiones del usuario son necesarias incluso durante el proceso de instalación. Por eso existen artículos dedicados a orientar a los usuarios en la resolución de incidencias:
https://wiki.gentoo.org/wiki/Handbook:AMD64/Full/Working/es#Cuando_Portage_se_queja...
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 513
Location: LANDETE (Cuenca)

PostPosted: Mon Aug 02, 2021 9:17 am    Post subject: Reply with quote

Hola de nuevo amigo quilosaq
Mis opiniones sobre tus cuatro respuestas son como sigue:
[1] El tema del particionado.-
Efectivamente, ya lo conocía, pero va relacionado con el diseño que pretende el usuario sobre un determinado equipo, es decir, si el volumen total del almacenamiento es pequeño o grande.
En mi caso, tengo discos convencionales de 80GB, 120GB, 200GB, 500GB, y hasta 1TB. También discos digitales SSD con volúmenes de 240GB, 250GB, 480GB, y de 512GB.
Si la instalación de Gento se pretende hacer en un disco por completo vale el diseño de tres divisiones en formato MSDOS, o también en formato LVM, en cambio si se pretenden varias/diversas instalaciones de Linux en un disco (por ejemplo de 500GB) será necesario un formato de divisiones en GPT para poder alojar múltiples particiones. Otro condicionante reside en si el equipo incorpora una BIOS o una UEFI.
[2] El tema de las quejas de Portage.-
Hasta ahora al iniciar la instalación de una determinada ebuild y Portage se quejaba de la falta o carencia de algún indicador USE, normalmente en su respuesta indicaba la posible solución y/o incorporación del mismo, ahora no, y da como respuesta las susodichas referencias circulares.
Para soslayar el problema era suficiente incluir el indicador en la variable USE del make.conf, o incluir la variable USE temporalmente anteponiéndola en el comando a emitir, también la inclusión de las indicaciones correspondientes en el archivo /etc/portage/package.use/package.use, esos métodos hasta ahora me funcionaban.
[3] La descarga de tarballs.-
No me negará que se presta a confusión el listado de los tarballs en los repos.
[4] Opiniones sobre Gentoo.-
Allá por los albores del nacimiento de Linux, donde aprendí a conocer Gentoo fué leyendo/traduciendo los HOWTOs de Mr. Patrick Volkerding sobre la distro Slackware 0.99 y posteriores, jamás encontré enseñanzas tan provechosas e instrucciones docentes de informática en otro lugar que, a dia de hoy, me hayan conducido y llenado de conocimientos para continuar con Gentoo.
Mi favorita sobre todas las distros existentes de Linux.
Me ratifico en tomar un tiempo sabático, no por ello dejaré de leer "news" y algo más ....
Felices vacaciones a todos :D
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 513
Location: LANDETE (Cuenca)

PostPosted: Mon Aug 02, 2021 10:04 am    Post subject: Reply with quote

Para chrootman:
emerge --sync https://www.imagebam.com/view/ME2IHA7
emerge -a --update --deep --newuse @world https://www.imagebam.com/view/ME2IHAC

Code:
 * IMPORTANT: config file '/etc/portage/package.use/zz-autounmask' needs updating.

These are the packages that would be merged, in order:

Calculating dependencies   * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
...... done!
[nomerge       ] sys-apps/shadow-4.8.1-r4::gentoo [4.9-r1::gentoo] USE="acl nls pam (split-usr) su xattr -audit -bcrypt -cracklib (-selinux) -skey"
[nomerge       ]  sys-auth/pambase-20210201.1::gentoo  USE="elogind* nullok passwdqc sha512 -caps -debug -gnome-keyring -homed -minimal -mktemp -pam_krb5 -pam_ssh -pwhistory -pwquality -securetty (-selinux) -systemd"
[nomerge       ]   sys-auth/elogind-246.10-r1::gentoo  USE="acl pam policykit -audit -debug -doc (-selinux)"
[nomerge       ]    sys-auth/polkit-0.119-r2::gentoo  USE="elogind gtk introspection nls pam -examples -kde (-selinux) -systemd -test"
[ebuild  N     ]     gnome-extra/polkit-gnome-0.105-r2::gentoo  304 KiB
[ebuild  N     ]      sys-auth/polkit-0.119-r2::gentoo  USE="elogind gtk introspection nls pam -examples -kde (-selinux) -systemd -test" 1355 KiB
[nomerge       ] virtual/os-headers-0-r2::gentoo
[nomerge       ]  sys-kernel/linux-headers-5.10::gentoo  USE="-headers-only"
[nomerge       ]   dev-lang/perl-5.34.0:0/5.34::gentoo  USE="gdbm -berkdb -debug -doc -ithreads -minimal"
[nomerge       ]    sys-libs/gdbm-1.19:0/6::gentoo  USE="berkdb nls readline -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]     sys-devel/automake-1.16.3-r1:1.16::gentoo  USE="-test"
[nomerge       ]      sys-apps/help2man-1.48.3::gentoo  USE="nls"
[nomerge       ]       dev-perl/Locale-gettext-1.70.0::gentoo
[nomerge       ]        sys-devel/gettext-0.21-r1::gentoo  USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]         dev-libs/libxml2-2.9.12-r3:2::gentoo  USE="icu* ipv6 python readline -debug -examples -lzma -static-libs -test -verify-sig" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_9 -python3_8"
[nomerge       ]          dev-lang/python-3.9.6:3.9::gentoo [3.9.5_p2:3.9::gentoo] USE="bluetooth* gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -test -tk -verify-sig -wininst"
[nomerge       ]           net-wireless/bluez-5.58-r1:0/3::gentoo  USE="cups mesh obex readline udev -btpclient -debug -deprecated -doc -experimental -extra-tools -midi (-selinux) -systemd -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_9 -python3_8"
[nomerge       ]            dev-libs/libical-3.0.10:0/3::gentoo  USE="glib introspection -berkdb -doc -examples -static-libs -test -vala"
[nomerge       ]             dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test"
[nomerge       ]              dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test"
[nomerge       ]               x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]                x11-themes/adwaita-icon-theme-40.1.1::gentoo  USE="branding" 16857 KiB
[nomerge       ] sys-auth/polkit-0.119-r2::gentoo  USE="elogind gtk introspection nls pam -examples -kde (-selinux) -systemd -test"
[ebuild  N     ]  dev-lang/spidermonkey-78.11.0:78::gentoo  USE="jit -clang -debug -lto -test" 325283 KiB
[nomerge       ] net-wireless/bluez-5.58-r1:0/3::gentoo  USE="cups mesh obex readline udev -btpclient -debug -deprecated -doc -experimental -extra-tools -midi (-selinux) -systemd -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_9 -python3_8"
[nomerge       ]  net-print/cups-2.3.3_p2-r2::gentoo  USE="X acl dbus pam ssl threads usb -debug -kerberos (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[nomerge       ]    app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
[nomerge       ]     x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]      gnome-base/librsvg-2.50.7:2::gentoo  USE="introspection vala" ABI_X86="(64) -32 (-x32)" 21704 KiB
[ebuild  N     ]       virtual/rust-1.53.0::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]        dev-lang/rust-1.53.0:stable/1.53::gentoo  USE="-clippy -debug -doc (-miri) (-nightly) (-parallel-compiler) -rls -rustfmt (-system-bootstrap) (-system-llvm) -test -verify-sig -wasm" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2" LLVM_TARGETS="(X86) -AArch64 -AMDGPU -ARM -AVR -BPF -Hexagon -Lanai -MSP430 -Mips -NVPTX -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore" 252676 KiB
[ebuild  N     ] net-wireless/bluez-5.58-r1:0/3::gentoo  USE="cups mesh obex readline udev -btpclient -debug -deprecated -doc -experimental -extra-tools -midi (-selinux) -systemd -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_9 -python3_8" 2013 KiB
[ebuild  N     ]  dev-libs/libical-3.0.10:0/3::gentoo  USE="glib introspection -berkdb -doc -examples -static-libs -test -vala" 869 KiB
[ebuild  N     ]  dev-libs/json-c-0.15:0/5::gentoo  USE="-doc -static-libs -threads" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="-rdrand" 354 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[nomerge       ]  app-text/poppler-21.07.0:0/111::gentoo  USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -boost -cjk -curl -debug -doc -nss"
[nomerge       ]   virtual/jpeg-100::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]    media-libs/libjpeg-turbo-2.1.0-r2:0/0.2::gentoo  USE="-java -static-libs" ABI_X86="(64) -32 (-x32)" 2218 KiB
[ebuild  N     ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf" 1468 KiB
[ebuild  N     ]  app-text/mupdf-1.18.0-r4:0/1.18.0::gentoo  USE="X javascript opengl ssl" 52365 KiB
[ebuild  N     ]   media-libs/freeglut-3.2.1-r1::gentoo  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)" 430 KiB
[ebuild  N     ]  app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW" 40401 KiB
[ebuild  N     ]  app-text/poppler-21.07.0:0/111::gentoo  USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -boost -cjk -curl -debug -doc -nss" 1670 KiB
[nomerge       ] net-wireless/bluez-5.58-r1:0/3::gentoo  USE="cups mesh obex readline udev -btpclient -debug -deprecated -doc -experimental -extra-tools -midi (-selinux) -systemd -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_9 -python3_8"
[nomerge       ]  sys-apps/dbus-1.12.20-r1::gentoo  USE="X elogind -debug -doc (-selinux) -static-libs -systemd -test -user-session" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   x11-libs/libXt-1.2.1::gentoo  USE="-doc -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]    x11-base/xorg-proto-2021.4::gentoo  USE="-test"
[nomerge       ]     dev-util/meson-format-array-0::gentoo  PYTHON_TARGETS="python3_9 -python3_8"
[nomerge       ]      dev-lang/python-3.9.6:3.9::gentoo [3.9.5_p2:3.9::gentoo] USE="bluetooth* gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -test -tk -verify-sig -wininst"
[nomerge       ]       sys-libs/gdbm-1.19:0/6::gentoo  USE="berkdb nls readline -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]        sys-devel/autoconf-2.69-r5:2.69::gentoo  USE="-emacs"
[nomerge       ]         dev-lang/perl-5.34.0:0/5.34::gentoo  USE="gdbm -berkdb -debug -doc -ithreads -minimal"
[nomerge       ]          app-admin/perl-cleaner-2.30::gentoo
[nomerge       ]           app-portage/portage-utils-0.90::gentoo  USE="nls openmp qmanifest qtegrity -static"
[nomerge       ]            app-crypt/gpgme-1.15.1:1/11::gentoo  USE="cxx qt5* -common-lisp -python -static-libs" PYTHON_TARGETS="python3_9 -python3_8"
[nomerge       ]             app-crypt/gnupg-2.2.27::gentoo  USE="bzip2 nls readline smartcard ssl usb* -doc -ldap -scd-shared-access (-selinux) -tofu -tools -user-socket -wks-server"
[nomerge       ]              app-crypt/pinentry-1.1.0-r4::gentoo  USE="gtk* ncurses qt5* -caps -emacs -gnome-keyring"
[nomerge       ]               dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test"
[nomerge       ]                x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]                 x11-libs/cairo-1.16.0-r4::gentoo  USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind" ABI_X86="(64) -32 (-x32)"
[nomerge       ]                  media-libs/mesa-21.1.4::gentoo  USE="X classic dri3 egl gallium gbm gles2 llvm zstd -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc -zink" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 (-v3d) (-vc4) -virgl (-vivante) -vmware"
[nomerge       ]                   sys-devel/llvm-12.0.0:12::gentoo  USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit -test -xar -z3" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR (-CSKY) -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -VE -WebAssembly -XCore"
[nomerge       ]                    dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test"
[nomerge       ]                     dev-qt/qtcore-5.15.2-r2:5/5.15.2::gentoo  USE="icu -debug -old-kernel -systemd -test"
[ebuild  N     ]                      dev-libs/double-conversion-3.1.5:0/3::gentoo  6860 KiB
[nomerge       ] gnome-extra/polkit-gnome-0.105-r2::gentoo
[nomerge       ]  x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]    media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]     media-gfx/graphite2-1.3.14::gentoo  USE="-perl -test" ABI_X86="(64) -32 (-x32)" 6475 KiB
[nomerge       ] dev-lang/spidermonkey-78.11.0:78::gentoo  USE="jit -clang -debug -lto -test"
[ebuild  N     ]  sys-devel/llvm-12.0.0:12::gentoo  USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit -test -xar -z3" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR (-CSKY) -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -VE -WebAssembly -XCore" 131274 KiB
[nomerge       ] app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
[ebuild  N     ]  media-libs/openjpeg-2.4.0:2/7::gentoo  USE="-doc -static-libs -test" ABI_X86="(64) -32 (-x32)" 2181 KiB
[ebuild  N     ]   dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test" 8766 KiB
[ebuild   R    ] app-crypt/pinentry-1.1.0-r4::gentoo  USE="gtk* ncurses qt5* -caps -emacs -gnome-keyring" 457 KiB
[nomerge       ] media-libs/freeglut-3.2.1-r1::gentoo  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  virtual/glu-9.0-r2::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]   media-libs/glu-9.0.2::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 426 KiB
[nomerge       ] app-crypt/pinentry-1.1.0-r4::gentoo  USE="gtk* ncurses qt5* -caps -emacs -gnome-keyring"
[nomerge       ]  app-crypt/gcr-3.40.0:0/1::gentoo  USE="gtk introspection vala -gtk-doc -test"
[nomerge       ]   x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]    media-libs/libepoxy-1.5.5::gentoo  USE="X egl -test" ABI_X86="(64) -32 (-x32)" 325 KiB
[ebuild  N     ]  dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test" 49005 KiB
[ebuild  N     ]   dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo  USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" 0 KiB
[ebuild  N     ]    virtual/opengl-7.0-r2::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]     media-libs/mesa-21.1.4::gentoo  USE="X classic dri3 egl gallium gbm gles2 llvm zstd -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc -zink" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 (-v3d) (-vc4) -virgl (-vivante) -vmware" 14898 KiB
[ebuild  N     ]   x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test" ABI_X86="(64) -32 (-x32)" 2003 KiB
[ebuild  N     ]    x11-libs/cairo-1.16.0-r4::gentoo  USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind" ABI_X86="(64) -32 (-x32)" 41014 KiB
[ebuild  N     ]  app-crypt/gcr-3.40.0:0/1::gentoo  USE="gtk introspection vala -gtk-doc -test" 988 KiB
[ebuild  N     ]   x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)" 20896 KiB
[ebuild  N     ]    media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test" ABI_X86="(64) -32 (-x32)" 17520 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[ebuild  N     ]  app-text/qpdf-10.3.2:0/28::gentoo  USE="ssl -doc -examples -test" 18500 KiB
[nomerge       ] x11-themes/adwaita-icon-theme-40.1.1::gentoo  USE="branding"
[nomerge       ]  x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   dev-util/gtk-update-icon-cache-3.24.26::gentoo  90 KiB
[ebuild  N     ]    x11-libs/gdk-pixbuf-2.42.6:2::gentoo  USE="introspection jpeg tiff -gtk-doc" ABI_X86="(64) -32 (-x32)" 7528 KiB
[nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
[ebuild  N     ]  media-libs/lcms-2.12:2::gentoo  USE="jpeg threads tiff zlib -doc -static-libs -test" ABI_X86="(64) -32 (-x32)" 7246 KiB
[ebuild  N     ]   media-libs/tiff-4.3.0::gentoo  USE="cxx jpeg zlib -jbig -lzma -static-libs -test -webp -zstd" ABI_X86="(64) -32 (-x32)" 2743 KiB
[ebuild  N     ]    virtual/jpeg-100::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[nomerge       ] x11-themes/adwaita-icon-theme-40.1.1::gentoo  USE="branding"
[nomerge       ]  gnome-base/librsvg-2.50.7:2::gentoo  USE="introspection vala" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]    media-libs/fontconfig-2.13.1-r2:1.0::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]     app-eselect/eselect-fontconfig-1.1-r1::gentoo  2 KiB
[ebuild  N     ]    x11-libs/libXft-2.3.3::gentoo  USE="-doc" ABI_X86="(64) -32 (-x32)" 346 KiB
[ebuild  N     ]     media-libs/fontconfig-2.13.1-r2:1.0::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 1684 KiB
[nomerge       ] app-portage/portage-utils-0.90::gentoo  USE="nls openmp qmanifest qtegrity -static"
[ebuild   R    ]  app-crypt/gpgme-1.15.1:1/11::gentoo  USE="cxx qt5* -common-lisp -python -static-libs" PYTHON_TARGETS="python3_9 -python3_8" 1660 KiB
[ebuild  N     ]   dev-qt/qttest-5.15.2:5/5.15::gentoo  USE="-debug -test" 0 KiB
[nomerge       ] app-text/poppler-21.07.0:0/111::gentoo  USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -boost -cjk -curl -debug -doc -nss"
[ebuild  N     ]  dev-qt/qtxml-5.15.2:5/5.15::gentoo  USE="-debug -test" 0 KiB
[nomerge       ] media-gfx/graphite2-1.3.14::gentoo  USE="-perl -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  dev-util/cmake-3.18.5::gentoo  USE="ncurses qt5 -doc -emacs -test"
[nomerge       ]   dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo  USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland"
[ebuild  N     ]    dev-qt/qtdbus-5.15.2:5/5.15::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ]     dev-qt/qtcore-5.15.2-r2:5/5.15.2::gentoo  USE="icu -debug -old-kernel -systemd -test" 0 KiB
[nomerge       ] gnome-base/librsvg-2.50.7:2::gentoo  USE="introspection vala" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   x11-libs/cairo-1.16.0-r4::gentoo  USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind" ABI_X86="(64) -32 (-x32)"
[nomerge       ]    media-libs/fontconfig-2.13.1-r2:1.0::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]     virtual/ttf-fonts-1-r1::gentoo  0 KiB
[ebuild  N     ]      media-fonts/liberation-fonts-2.1.3::gentoo  USE="X -fontforge" 2315 KiB
[nomerge       ] app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
[ebuild  N     ]  media-fonts/urw-fonts-2.4.9::gentoo  USE="X" 3124 KiB
[ebuild  N     ]   media-fonts/encodings-1.0.5-r1::gentoo  698 KiB
[ebuild  N     ]    x11-apps/mkfontscale-1.2.1::gentoo  148 KiB
[ebuild  N     ]     media-libs/freetype-2.10.4:2::gentoo  USE="X adobe-cff bzip2 cleartype_hinting harfbuzz png -bindist -brotli -debug -doc -fontforge (-infinality) -static-libs -utils" ABI_X86="(64) -32 (-x32)" 2360 KiB
[nomerge       ] app-admin/perl-cleaner-2.30::gentoo
[nomerge       ]  sys-apps/portage-3.0.20-r6::gentoo  USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux) -test" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
[ebuild     U  ]   dev-lang/python-3.9.6:3.9::gentoo [3.9.5_p2:3.9::gentoo] USE="bluetooth* gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -test -tk -verify-sig -wininst" 18618 KiB

Total: 55 packages (1 upgrade, 52 new, 2 reinstalls), Size of downloads: 1090095 KiB


Gracias por su aportación 8O
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
chrootman
n00b
n00b


Joined: 18 Aug 2020
Posts: 44

PostPosted: Wed Aug 04, 2021 5:21 am    Post subject: Reply with quote

Imagino que entre la primera imagen y la segunda ejecutaste dispatch-conf :u o etc-update -3 y luego entonces se identificó más el problema de harzbuff con el uso de --autounmask-write. Entonces al parecer está solucionado. Si ese es el caso entonces más info si alguien tiene el mismo problema.
https://forums.gentoo.org/viewtopic-p-8632510.html?sid=83f5162ea590c848df43a2428c54285e

Code:
[nomerge       ]    media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo  USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test" ABI_X86="(64) -32 (-x32)"

Code:
[nomerge       ] x11-themes/adwaita-icon-theme-40.1.1::gentoo  USE="branding"
[nomerge       ]  gnome-base/librsvg-2.50.7:2::gentoo  USE="introspection vala" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   x11-libs/pango-1.48.7::gentoo  USE="X introspection -gtk-doc -sysprof -test" ABI_X86="(64) -32 (-x32)"
 [nomerge       ] net-print/cups-filters-1.28.7::gentoo  USE="dbus foomatic jpeg pdf png postscript tiff -ldap -pclm -perl -test -zeroconf"
 [nomerge       ] app-text/ghostscript-gpl-9.53.3-r5:0/9.53::gentoo  USE="X cups dbus gtk jpeg2k (unicode) -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW"
 [nomerge       ]  x11-libs/gtk+-3.24.29:3::gentoo  USE="X cups introspection (-aqua) -broadway -cloudprint -colord -examples -gtk-doc -sysprof -test -vim-syntax -wayland -xinerama"
[nomerge       ] dev-qt/qtwidgets-5.15.2:5/5.15::gentoo  USE="X gtk png -debug -gles2-only -test"
[nomerge       ]  dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo  USE="X dbus egl gif jpeg libinput png udev

Code:
USE="-harfbuzz" emerge --oneshot media-libs/freetype

Code:
USE="-truetype" emerge -1 media-libs/harfbuzz media-libs/freetype

Code:
USE=-harfbuzz emerge -1 --nodeps freetype


Como no estoy ahora en gentoo no puedo probarlo, pero luego esto me puede servir incluso a mí. Saludos y gracias por dilucidar las dudas.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 513
Location: LANDETE (Cuenca)

PostPosted: Mon Oct 18, 2021 1:57 pm    Post subject: Reply with quote

Saludos amigos:
Ha pasado un cierto tiempo desde el mes de julio pasado cuando inicié este hilo ....
Bueno, creo haber dado en el clavo del porqué me surgieron esos problemas con las referencias circulares.
Bien, en principio y siguiendo exactamente las directrices del manual resulta que, posiblemente, fué una malinterpretación de los perfiles en su descarga. Me explico:
Elegir un tarball de stage: independientemente de la selección 'openrc' o bien 'systemd'.
Una vez descomprimido en el manual se indica a través del comando "eselect profile set x", donde la 'x' es el número de un perfil determinado en los repos, poder elegir usar un perfil diferente para el sistema, ahí en ese punto es donde surge la controversia del problema, es decir, el origen de las referencias circulares.
¿Porqué digo esto? Pues sí, al descartar ese comando se obvian los problemas circulares.
Desde el comienzo con un determinado tarball débese proseguir con la selección y no mezclar cualquier otro perfil.
Con esta pauta me han desaparecido los problemas en cualquier instalación de Gento, bien sea en 'openrc', o bien en 'systemd'.
Desde luego, ésta pauta no queda exenta de que surja cualquier otro problema tal como, por ejemplo, la instalación de 'freetype' que requiere la deselección de "harfbuzz", (USE="-harfbuzz" emerge -a media-libs/freetype).
Hasta este momento he efectuado diversas instalaciones de Gentoo y "updates" sin más problemas, por ahora, cruzo los dedos.... jejeje
Hasta la próxima amigos ;-)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
chrootman
n00b
n00b


Joined: 18 Aug 2020
Posts: 44

PostPosted: Wed Oct 20, 2021 11:57 am    Post subject: Reply with quote

Luciernaga wrote:
Saludos amigos:
Ha pasado un cierto tiempo desde el mes de julio pasado cuando inicié este hilo ....
Bueno, creo haber dado en el clavo del porqué me surgieron esos problemas con las referencias circulares.
Bien, en principio y siguiendo exactamente las directrices del manual resulta que, posiblemente, fué una malinterpretación de los perfiles en su descarga. Me explico:
Elegir un tarball de stage: independientemente de la selección 'openrc' o bien 'systemd'.
Una vez descomprimido en el manual se indica a través del comando "eselect profile set x", donde la 'x' es el número de un perfil determinado en los repos, poder elegir usar un perfil diferente para el sistema, ahí en ese punto es donde surge la controversia del problema, es decir, el origen de las referencias circulares.
¿Porqué digo esto? Pues sí, al descartar ese comando se obvian los problemas circulares.
Desde el comienzo con un determinado tarball débese proseguir con la selección y no mezclar cualquier otro perfil.
Con esta pauta me han desaparecido los problemas en cualquier instalación de Gento, bien sea en 'openrc', o bien en 'systemd'.
Desde luego, ésta pauta no queda exenta de que surja cualquier otro problema tal como, por ejemplo, la instalación de 'freetype' que requiere la deselección de "harfbuzz", (USE="-harfbuzz" emerge -a media-libs/freetype).
Hasta este momento he efectuado diversas instalaciones de Gentoo y "updates" sin más problemas, por ahora, cruzo los dedos.... jejeje
Hasta la próxima amigos ;-)
En mi caso, el:
https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/releases/amd64/autobuilds/current-stage3-amd64-hardened-selinux/stage3-amd64-hardened-selinux-XXX.tar.xz
Lo dejé con:
Code:
[19]  default/linux/amd64/17.1/hardened/selinux (stable) *

Y lo cambie a la mala a:
Code:
[16]  default/linux/amd64/17.1/systemd (stable) *
Porque eso de unsymlink-lib --analyze nunca me funcionó(no lo he intentado en los perfiles de desktop).

En otra ocación el https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/releases/amd64/autobuilds/current-stage3-amd64-systemd/stage3-amd64-systemd-XXXX.tar.xz
Lo dejé con:
Code:
[16]  default/linux/amd64/17.1/systemd (stable) *

Y las últimas veces como indica el manual(o el de openrc si bajas el de openrc):
Code:
 [5]   default/linux/amd64/17.1/desktop (stable)
  [6]   default/linux/amd64/17.1/desktop/gnome (stable)
  [7]   default/linux/amd64/17.1/desktop/gnome/systemd (stable)
  [8]   default/linux/amd64/17.1/desktop/plasma (stable)
  [9]   default/linux/amd64/17.1/desktop/plasma/systemd (stable)

En todas las posibles combinaciones en un comienzo he tenido cosas como estas(a veces al comienzo de la instalación, a veces después o mucho después):
Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/pycairo:0

  (dev-python/pycairo-1.19.1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -examples -test" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)" conflicts with
    >=dev-python/pycairo-1.11.1[python_targets_python2_7(-),python_targets_python3_7(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/pygobject-3.34.0:3/3::gentoo, installed) USE="cairo -examples -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 -python3_6 -python3_8 (-python3_9)"
                                                                                                                                                                                                                                                                       

dev-python/setuptools:0

  (dev-python/setuptools-46.4.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)" conflicts with
    dev-python/setuptools[python_targets_python3_8(-),python_single_target_python3_8(+)] required by (dev-libs/libgusb-0.3.4:0/0::gentoo, installed) USE="introspection vala -gtk-doc -static-libs -test" ABI_X86="(64) -32 (-x32)"
                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/certifi-2020.4.5.1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 python3_8 (-pypy3) -python3_6 (-python3_9)"
                                                                                                                                                                                                                                                                                                                           
    >=dev-python/setuptools-42.0.2[python_targets_python2_7(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/certifi-2020.4.5.1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 python3_8 (-pypy3) -python3_6 (-python3_9)"
                                                                                                                                                                                                                                                                                                                                     

dev-python/certifi:0

  (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)" conflicts with
    >=dev-python/certifi-2016.9.26[python_targets_python2_7(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-46.4.0-r1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 python3_8 (-pypy3) -python3_6 (-python3_9)"

O estas:
Code:
dev-lang/perl:0

  (dev-lang/perl-5.30.3-1:0/5.30::gentoo, installed) USE="berkdb gdbm -debug -doc -ithreads" ABI_X86="(64)" pulled in by
    dev-lang/perl:0/5.30= required by (virtual/perl-CPAN-Meta-2.150.10-r5:0/0::gentoo, installed) USE="" ABI_X86="(64)"
                 ^^^^^^^^                                                                                                                                                     
    dev-lang/perl:0/5.30= required by (net-fs/samba-4.13.7:0/0::gentoo, installed) USE="acl client cups pam python regedit system-mitkrb5 systemd -addc -addns -ads -ceph -cluster -debug (-dmapi) (-fam) -glusterfs -gpg -iprint -json -ldap -ntvfs -profiling-data -quota (-selinux) -snapper -spotlight -syslog (-system-heimdal) (-test) -winbind -zeroconf" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_8 -python3_7 -python3_9"
                 ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-lang/perl:0/5.30=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)"
                 ^^^^^^^^                                                                                                                                                           
    dev-lang/perl:0/5.30=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)"
                 ^^^^^^^^                                                                                                                                                             
    dev-lang/perl:0/5.30=[-build(-)] required by (dev-perl/Locale-Maketext-Lexicon-1.0.0:0/0::gentoo, installed) USE="-test" ABI_X86="(64)"
                 ^^^^^^^^                                                                                                                                                                                           
    dev-lang/perl:0/5.30=[-build(-)] required by (dev-perl/GSSAPI-0.280.0-r1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)"
                 ^^^^^^^^                                                                                                                                                                               
    =dev-lang/perl-5.30* required by (virtual/perl-Pod-Parser-1.630.0-r8-1:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    ^              ^^^^^                                                                                                                                                                         
    (and 88 more with the same problems)

  (dev-lang/perl-5.32.1:0/5.32::gentoo, ebuild scheduled for merge) USE="gdbm -berkdb -debug -doc -ithreads -minimal" ABI_X86="(64)" pulled in by
    =dev-lang/perl-5.32* required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r5:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    ^              ^^^^^                                                                                                                                                                             
    (and 38 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-perl/Locale-Maketext-Lexicon-1.0.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-perl/GSSAPI-0.280.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (net-fs/samba-4.13.7:0/0::gentoo, installed): ebuild is masked or unavailable

Y con --autounmask-write las he solucionado o editando package.use
Code:
*/* PYTHON_TARGETS: -* python3_9 python3_8 python3_7
*/* PYTHON_SINGLE_TARGET: -* python3_9
>=dev-libs/boost-1.77.0-r2 python_target_python3_9 -python_target_python3_8 -python_target_python3_10
dev-python/PyQt5 python_targets_python3_7
sys-libs/glibc -crypt
sys-libs/libxcrypt system static-libs
sys-libs/libseccomp static-libs
sys-apps/systemd -sysv-utils
sys-apps/openrc -netifrc

O package.accept_keywords con cosas como estas:
Code:
=dev-python/setuptools-46.4.0-r2 ~amd64

O con -sysvinit -openrc en /etc/portage/make.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum