Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libxcrypt-migration
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 593
Location: Italia

PostPosted: Sun Jul 04, 2021 3:38 pm    Post subject: libxcrypt-migration Reply with quote

Ciao a tutti,
ho un problema durante la migrazione a libxcrypt...
ho seguito questo link:

https://wiki.gentoo.org/wiki/Project:Toolchain/libcrypt_implementation

solo che premetto ho fatto un errore in quanto non ho prima di tutto fatto l'upgrade del sistema con il relativo depclean. Quindi mi sono imbattuto in un errore su sys-apps/util-linux-2.36.2. Dopodichè ho rimesso a posto i file package.use, package.accept_keywords ecc... (li ho rimessi come erano prima) e ho fatto l'upgrade del sistema con depclean.
Successivamente ho impostato "/etc/portage changes" come dice sulla guida ed ho eseguito

Code:
emerge -p -uvDU @world


proprio come dicono di fare, ma ho ricevuto l'errore su sys-apps/util-linux-2.36.2
L'errore è qui:

https://pastebin.com/AehwhfJc

Dopodichè, provando a fare il mio classico

Code:
emerge --ask --update --deep --with-bdeps=y --newuse @world


ma con l'opzione --backtrack=30 altrimenti non partiva nemmeno l'upgrade, mi chiede di effetturre USE changes:

Quote:
The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by virtual/libcrypt-1-r1::gentoo
# required by dev-lang/perl-5.32.1::gentoo
# required by virtual/perl-ExtUtils-Manifest-1.720.0-r1::gentoo
# required by dev-perl/Module-Build-0.422.400::gentoo
# required by dev-perl/SGMLSpm-1.1-r1::gentoo
# required by app-text/po4a-0.57::gentoo
# required by sys-apps/man-db-2.9.4::gentoo[nls]
# required by virtual/man-0-r4::gentoo
# required by @system
# required by @world (argument)
>=sys-libs/glibc-2.33 crypt


Ma con >=sys-libs/glibc-2.33 crypt non migro a libxcrypt... o non ci ho capito niente?
Comunque anche se cambio come dice lui ed eseguo

Code:
etc-update


Ottengo quest'altro errore:

Quote:
# emerge --ask --update --deep --with-bdeps=y --newuse @world --backtrack=30

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild UD ] virtual/libcrypt-1-r1 [2]
[ebuild R ] sys-libs/glibc-2.33 USE="crypt*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/libcrypt:0

(virtual/libcrypt-1-r1:0/1::gentoo, ebuild scheduled for merge) USE="static-libs" ABI_X86="(64) -32 (-x32)" pulled in by
virtual/libcrypt:0/1= required by (x11-apps/xdm-1.1.12-r1:0/0::gentoo, installed) USE="ipv6 pam truetype -systemd -xinerama -xpm" ABI_X86="(64)"
^^^^^
=virtual/libcrypt-1-r1 required by (net-dialup/ppp-2.4.9-r3:0/2.4.9::gentoo, installed) USE="eap-tls gtk ipv6 pam -activefilter -atm -dhcp -radius" ABI_X86="(64)"
^ ^^^^
(and 24 more with the same problems)

(virtual/libcrypt-2:0/2::gentoo, installed) USE="static-libs" ABI_X86="(64) -32 (-x32)" pulled in by
virtual/libcrypt:0/2= required by (dev-lang/python-2.7.18_p10:2.7/2.7::gentoo, installed) USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -examples -hardened -tk -verify-sig -wininst" ABI_X86="(64)"
^^^^^
(and 3 more with the same problem)

sys-libs/glibc:2.2

(sys-libs/glibc-2.33:2.2/2.2::gentoo, ebuild scheduled for merge) USE="crypt multiarch (multilib) ssp (static-libs) -audit -caps (-cet) -compile-locales -custom-cflags -doc -gd -headers-only -multilib-bootstrap -nscd -profile (-selinux) -static-pie -suid -systemtap -test (-vanilla)" ABI_X86="(64)" pulled in by
sys-libs/glibc[crypt(+),static-libs(+)?] required by (virtual/libcrypt-1-r1:0/1::gentoo, ebuild scheduled for merge) USE="static-libs" ABI_X86="(64) -32 (-x32)"


(sys-libs/glibc-2.33:2.2/2.2::gentoo, installed) USE="multiarch (multilib) ssp (static-libs) -audit -caps (-cet) -compile-locales -crypt -custom-cflags -doc -gd -headers-only -multilib-bootstrap -nscd -profile (-selinux) -static-pie -suid -systemtap -test (-vanilla)" ABI_X86="(64)" pulled in by
sys-libs/glibc[-crypt(+)] required by (sys-libs/libxcrypt-4.4.20:0/1::gentoo, installed) USE="compat (split-usr) static-libs system -test" ABI_X86="(64) -32 (-x32)"


NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Ho incasinato il sistema :-)
Spero di essere stato chiaro anche se i passaggi esatti che ho fatto durante questo pomeriggio non me li ricordo esattamente.

Grazie a tutti
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 593
Location: Italia

PostPosted: Sun Jul 04, 2021 4:27 pm    Post subject: Reply with quote

Ho ricominciato da capo rimettendo i vari file su /etc/portage come erano prima e rieseguendo

Code:
emerge -a -uvDU @world


ma ho avuto un errore di file collision su sys-libs/glibc-2.33

Quote:
Detected file collision(s):
*
* /usr/lib64/libcrypt.a
* /usr/include/crypt.h
* /lib64/libcrypt.so.1
* /usr/lib64/libcrypt.so


ho riemerso solo sys-libs/glibc-2.33 con l'opzione FEATURES

Code:
FEATURES="-collision-detect -protect-owned" emerge --ask sys-libs/glibc


dovrebbe essere andato a buon fine anche se la segnalazione di file collision c'è:.

Quote:
plural.y:46.1-7: warning: POSIX Yacc does not support %define [ * This package will overwrite one or more files that may belong to other
* packages (see list below). Add either "collision-protect" or "protect-
* owned" to FEATURES in make.conf if you would like the merge to abort
* in cases like this. See the make.conf man page for more information
* about these features. You can use a command such as `portageq owners /
* <filename>` to identify the installed package that owns a file. If
* portageq reports that only one package owns a file then do NOT file a
* bug report. A bug report is only useful if it identifies at least two
* or more packages that are known to install the same file(s). If a
* collision occurs and you can not explain where the file came from then
* you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at https://bugs.gentoo.org/ unless you report exactly
* which two packages install the same file(s). See
* https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how
* to solve the problem. And once again, please do NOT file a bug report
* unless you have completely understood the above message.
*
* Detected file collision(s):
*
* /usr/lib64/libcrypt.a
* /usr/include/crypt.h
* /lib64/libcrypt.so.1
* /usr/lib64/libcrypt.so
* Package 'sys-libs/glibc-2.33' merged despite file collisions. If
* necessary, refer to your elog messages for the whole content of the
* above message.
* Defaulting /etc/host.conf:multi to on
locale-gen --jobs 8 --config //etc/locale.gen --destdir /
* Building locales in DESTDIR '/'
* Generating 3 locales (this might take a while) with 8 jobs
* (1/3) Generating it_IT.ISO-8859-1 ... [ ok ]
* (3/3) Generating C.UTF-8 ... [ ok ]
* (2/3) Generating it_IT.UTF-8 ... [ ok ]
* Generation complete
* Adding locales to archive ... [ ok ]

>>> Recording sys-libs/glibc in "world" favorites file...

* Messages for package sys-libs/glibc-2.33:

* This package will overwrite one or more files that may belong to other
* packages (see list below). Add either "collision-protect" or "protect-
* owned" to FEATURES in make.conf if you would like the merge to abort
* in cases like this. See the make.conf man page for more information
* about these features. You can use a command such as `portageq owners /
* <filename>` to identify the installed package that owns a file. If
* portageq reports that only one package owns a file then do NOT file a
* bug report. A bug report is only useful if it identifies at least two
* or more packages that are known to install the same file(s). If a
* collision occurs and you can not explain where the file came from then
* you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at https://bugs.gentoo.org/ unless you report exactly
* which two packages install the same file(s). See
* https://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how
* to solve the problem. And once again, please do NOT file a bug report
* unless you have completely understood the above message.
*
* Detected file collision(s):
*
* /usr/lib64/libcrypt.a
* /usr/include/crypt.h
* /lib64/libcrypt.so.1
* /usr/lib64/libcrypt.so
* Package 'sys-libs/glibc-2.33' merged despite file collisions. If
* necessary, refer to your elog messages for the whole content of the
* above message.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.


Poi ho rieseguito

Code:
emerge -a -uvDU @world


e depclean.

Ora aspetto il vostro consiglio prima di andare avanti con la migrazione a libxcrypt.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 593
Location: Italia

PostPosted: Sun Jul 04, 2021 4:42 pm    Post subject: Reply with quote

Ulteriore problema... quando eseguo

Code:
revdep-rebuild.sh


errore:

Quote:
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 2% ] * broken /lib64/security/pam_passwdqc.so (requires libcrypt.so.1)
* broken /lib64/security/pam_pwhistory.so (requires libcrypt.so.1)
* broken /lib64/security/pam_unix.so (requires libcrypt.so.1)
[ 4% ] * broken /sbin/pwhistory_helper (requires libcrypt.so.1)
* broken /sbin/sulogin (requires libcrypt.so.1)
* broken /sbin/unix_chkpwd (requires libcrypt.so.1)
* broken /sbin/unix_update (requires libcrypt.so.1)
[ 9% ] * broken /usr/bin/gpasswd (requires libcrypt.so.1)
[ 16% ] * broken /usr/bin/newgrp (requires libcrypt.so.1)
[ 22% ] * broken /usr/bin/vncagent (requires libcrypt.so.1)
* broken /usr/bin/vncserver-virtuald (requires libcrypt.so.1)
* broken /usr/bin/vncserver-x11 (requires libcrypt.so.1)
* broken /usr/bin/vncserver-x11-core (requires libcrypt.so.1)
[ 23% ] * broken /usr/bin/xdm (requires libcrypt.so.1)
[ 24% ] * broken /usr/bin/Xvnc-core (requires libcrypt.so.1)
[ 33% ] * broken /usr/lib64/libaccountsservice.so.0.0.0 (requires libcrypt.so.1)
[ 41% ] * broken /usr/lib64/libmailutils.so.8.0.0 (requires libcrypt.so.1)
[ 44% ] * broken /usr/lib64/libperl.so.5.32.1 (requires libcrypt.so.1)
[ 55% ] * broken /usr/lib64/python2.7/lib-dynload/crypt.so (requires libcrypt.so.1)
[ 59% ] * broken /usr/lib64/qt5/plugins/kcms/kcm_users.so (requires libcrypt.so.1)
[ 92% ] * broken /usr/lib/python3.7/lib-dynload/_crypt.cpython-37m-x86_64-linux-gnu.so (requires libcrypt.so.1)
[ 93% ] * broken /usr/lib/python3.8/lib-dynload/_crypt.cpython-38-x86_64-linux-gnu.so (requires libcrypt.so.1)
[ 94% ] * broken /usr/lib/python3.8/site-packages/libxml2mod.so (requires libcrypt.so.1)
* broken /usr/lib/python3.8/site-packages/_snack.so (requires libcrypt.so.1)
[ 95% ] * broken /usr/lib/python3.9/lib-dynload/_crypt.cpython-39-x86_64-linux-gnu.so (requires libcrypt.so.1)
[ 96% ] * broken /usr/lib/python3.9/site-packages/libxml2mod.so (requires libcrypt.so.1)
* broken /usr/lib/python3.9/site-packages/_snack.so (requires libcrypt.so.1)
[ 98% ] * broken /usr/sbin/chgpasswd (requires libcrypt.so.1)
* broken /usr/sbin/chpasswd (requires libcrypt.so.1)
[ 99% ] * broken /usr/sbin/pppd (requires libcrypt.so.1)
* broken /usr/sbin/pwcheck (requires libcrypt.so.1)
* broken /usr/sbin/saslauthd (requires libcrypt.so.1)
* broken /usr/sbin/sshd (requires libcrypt.so.1)
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* /lib64/security/pam_passwdqc.so -> sys-auth/passwdqc
* /lib64/security/pam_pwhistory.so -> sys-libs/pam
* /lib64/security/pam_unix.so -> sys-libs/pam
* /sbin/pwhistory_helper -> sys-libs/pam
* /sbin/sulogin -> sys-apps/util-linux
* /sbin/unix_chkpwd -> sys-libs/pam
* /sbin/unix_update -> sys-libs/pam
* /usr/bin/gpasswd -> sys-apps/shadow
* /usr/bin/newgrp -> sys-apps/shadow
* !!! /usr/bin/vncagent not owned by any package is broken !!!
* /usr/bin/vncagent -> (none)
* !!! /usr/bin/vncserver-virtuald not owned by any package is broken !!!
* /usr/bin/vncserver-virtuald -> (none)
* !!! /usr/bin/vncserver-x11 not owned by any package is broken !!!
* /usr/bin/vncserver-x11 -> (none)
* !!! /usr/bin/vncserver-x11-core not owned by any package is broken !!!
* /usr/bin/vncserver-x11-core -> (none)
* /usr/bin/xdm -> x11-apps/xdm
* !!! /usr/bin/Xvnc-core not owned by any package is broken !!!
* /usr/bin/Xvnc-core -> (none)
* /usr/lib64/libaccountsservice.so.0.0.0 -> sys-apps/accountsservice
* /usr/lib64/libmailutils.so.8.0.0 -> net-mail/mailutils
* /usr/lib64/libperl.so.5.32.1 -> dev-lang/perl
* /usr/lib64/python2.7/lib-dynload/crypt.so -> dev-lang/python
* /usr/lib64/qt5/plugins/kcms/kcm_users.so -> kde-plasma/plasma-desktop
* /usr/lib/python3.7/lib-dynload/_crypt.cpython-37m-x86_64-linux-gnu.so -> dev-lang/python
* /usr/lib/python3.8/lib-dynload/_crypt.cpython-38-x86_64-linux-gnu.so -> dev-lang/python
* /usr/lib/python3.8/site-packages/libxml2mod.so -> dev-libs/libxml2
* /usr/lib/python3.8/site-packages/_snack.so -> dev-libs/newt
* /usr/lib/python3.9/lib-dynload/_crypt.cpython-39-x86_64-linux-gnu.so -> dev-lang/python
* /usr/lib/python3.9/site-packages/libxml2mod.so -> dev-libs/libxml2
* /usr/lib/python3.9/site-packages/_snack.so -> dev-libs/newt
* /usr/sbin/chgpasswd -> sys-apps/shadow
* /usr/sbin/chpasswd -> sys-apps/shadow
* /usr/sbin/pppd -> net-dialup/ppp
* /usr/sbin/pwcheck -> dev-libs/cyrus-sasl
* /usr/sbin/saslauthd -> dev-libs/cyrus-sasl
* /usr/sbin/sshd -> net-misc/openssh
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --complete-graph=y --oneshot dev-lang/perl:0/5.32 dev-lang/python:2.7 dev-lang/python:3.7/3.7m dev-lang/python:3.8 dev-lang/python:3.9 dev-libs/cyrus-sasl:2 dev-libs/libxml2:2 dev-libs/newt:0 kde-plasma/plasma-desktop:5 net-dialup/ppp:0/2.4.9 net-mail/mailutils:0 net-misc/openssh:0 sys-apps/accountsservice:0 sys-apps/shadow:0 sys-apps/util-linux:0 sys-auth/passwdqc:0 sys-libs/pam:0 x11-apps/xdm:0
..........
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Running pre-merge checks for dev-lang/python-3.9.5_p2

>>> Running pre-merge checks for net-misc/openssh-8.6_p1-r2

>>> Emerging (1 of 18) dev-lang/perl-5.32.1::gentoo
* perl-5.32.1.tar.xz BLAKE2B SHA512 size ;-) ... [ ok ]
* perl-5.32.0-patches-1.tar.xz BLAKE2B SHA512 size ;-) ... [ ok ]
* perl-cross-1.3.4.tar.gz BLAKE2B SHA512 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking perl-5.32.1.tar.xz to /var/tmp/portage/dev-lang/perl-5.32.1/work
>>> Unpacking perl-5.32.0-patches-1.tar.xz to /var/tmp/portage/dev-lang/perl-5.32.1/work
>>> Unpacking perl-cross-1.3.4.tar.gz to /var/tmp/portage/dev-lang/perl-5.32.1/work
>>> Source unpacked in /var/tmp/portage/dev-lang/perl-5.32.1/work
>>> Preparing source in /var/tmp/portage/dev-lang/perl-5.32.1/work/perl-5.32.1 ...
* Injecting patch-level info into 0006-List-packaged-patches-in-patchlevel.h.patch.desc ( *List-packaged-patches* )
* Applying 0001-Fix-hpux-hints.patch ... [ ok ]
* Applying 0002-aix-gcc-detection-and-shared-library-soname-support.patch ... [ ok ]
* Applying 0003-cpan-ExtUtils-MakeMaker-drop-PORTAGE_TMPDIR-from-LD_.patch ... [ ok ]
* Applying 0004-Remove-rpath-and-append-LDFLAGS-to-lddlflags.patch ... [ ok ]
* Applying 0005-Add-headers-for-opensolaris.patch ... [ ok ]
* Applying 0006-List-packaged-patches-in-patchlevel.h.patch ... [ ok ]
* Applying 0007-Cleanup-PATH-and-shrpenv.patch ... [ ok ]
* Applying 0008-Tweak-enc2xs-to-follow-symlinks-and-ignore-missing-I.patch ... [ ok ]
* Applying 0009-darwin-Use-CC-to-link.patch ... [ ok ]
* Applying 0010-Provide-a-sensible-INSTALLDIRS-default-for-modules-i.patch ... [ ok ]
* Applying 0011-Fix-interix-hints.patch ... [ ok ]
* Applying 0012-Set-libperl-soname.patch ... [ ok ]
* Applying 0013-Add-etc-perl-to-INC.patch ... [ ok ]
* Applying 0014-cpan-ExtUtils-MakeMaker-remove-targets-that-generate.patch ... [ ok ]
* Applying 0015-Don-t-force-fstack-protector-on-everyone.patch ... [ ok ]
* Applying 0016-Do-not-set-custom-CFLAGS-in-cpan-Digest-SHA.patch ... [ ok ]
* Applying 0017-Configure-Don-t-include-sources-in-usr-local-for-com.patch ... [ ok ]
* Applying 0018-cpan-IO-Socket-IP-Disable-network-tests.patch ... [ ok ]
* Applying 0019-Fix-EUMM-podlocal-tests.patch ... [ ok ]
* Applying 0020-Skip-auto-linking-nsl-and-cl.patch ... [ ok ]
* Applying 0021-Disable-porting-tests-which-create-fun-false-failure.patch ... [ ok ]
* Applying 0022-Disable-PathTools-tests-which-fails-under-sandboxing.patch ... [ ok ]
* Applying 0023-Fix-CPAN-FirstTime-defaults-with-nonexisting-site-di.patch ... [ ok ]
* Applying 0024-Pass-LD-settings-through-to-subdirectories.patch ... [ ok ]
* Applying 0025-Memoize-Storable-respect-nstore-option-not-respected.patch ... [ ok ]
* Applying 0026-Better-errors-for-man-pages-from-standard-input.patch ... [ ok ]
* Applying 0027-Respect-umask-during-installation.patch ... [ ok ]
* Applying 0028-Document-that-CCFLAGS-should-include-Config-ccflags.patch ... [ ok ]
* Applying 0029-Fix-parallel-building.patch ... [ ok ]
* Applying 0030-Add-support-for-Dgentoolibdirs.patch ... [ ok ]
* Generating patchlevel-gentoo.h
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-lang/perl-5.32.1/work/perl-5.32.1 ...
* Scanning for old @INC dirs matching '.*/5[.][0-9]+\([.][0-9]+\|\)$' in: /usr/lib64/perl5 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl
* Normalizing/Sorting candidate list: 5.32 5.30.1 5.28.2 5.24.1 5.24.3 5.32 5.26.2 5.22.3
* to remove '5.32'
* This version of perl may partially support modules previously
* installed in any of the following paths:
* /usr/lib64/perl5/vendor_perl/5.30.1/
* /usr/lib64/perl5/vendor_perl/5.28.2/
* /usr/lib64/perl5/vendor_perl/5.26.2/
* /usr/lib64/perl5/vendor_perl/5.24.3/
* /usr/lib64/perl5/vendor_perl/5.24.1/
* /usr/lib64/perl5/vendor_perl/5.22.3/
* This is a temporary measure and you should aim to cleanup these paths
* via world updates and perl-cleaner
First let's make sure your kit is complete. Checking...
Locating common programs...
Checking compatibility between /bin/echo and builtin echo (if any)...
Symbolic links are supported.
Checking how to test for symbolic links...
You can test for symbolic links with 'test -h'.
Checking for cross-compile
No targethost for running compiler tests against defined, running locally
Good, your tr supports [:lower:] and [:upper:] to convert case.
Using [:upper:] and [:lower:] to convert case.
aix dcosx greenhills lynxos os400 super-ux
aix_3 dec_osf haiku midnightbsd posix-bc svr4
aix_4 dos_djgpp hpux minix qnx svr5
altos486 dragonfly i386 mips riscos ti1500
amigaos dynix interix mirbsd sco ultrix_4
atheos dynixptx irix_4 mpc sco_2_3_0 umips
aux_3 epix irix_5 ncr_tower sco_2_3_1 unicos
bitrig esix4 irix_6 netbsd sco_2_3_2 unicosmk
bsdos fps irix_6_0 newsos4 sco_2_3_3 unisysdynix
catamount freebsd irix_6_1 nonstopux sco_2_3_4 utekv
convexos freemint isc openbsd solaris_2 uwin
cxux gnu isc_2 opus stellar vos
cygwin gnukfreebsd linux-android os2 sunos_4_0
darwin gnuknetbsd linux os390 sunos_4_1
Which of these apply, if any? [linux]
Operating system name? [linux]
Operating system version? [5.10.27-gentoo-x86_64]
Installation prefix to use? (~name ok) [/usr]
AFS does not seem to be running...
What installation prefix should I use for installing files? (~name ok) [/usr]
Getting the current patchlevel...
Build a threading Perl? [n]
Build Perl for multiplicity? [n]
Use which C compiler? [x86_64-pc-linux-gnu-gcc]
Checking for GNU cc in disguise and/or its version number...
Now, how can we feed standard input to your C preprocessor...
Directories to use for library searches?
[/usr/local/lib64 /lib64 /usr/lib64 /usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/include-fixed /usr/lib /lib/../lib64 /usr/lib/../lib64 /lib]
What is the file extension used for shared libraries? [so]
Make shared library basenames unique? [n]
Build Perl for SOCKS? [n]
Try to use long doubles if available? [n]
Checking for optional libraries...
What libraries to use? [-lgdbm -ldl -lm -lcrypt -lutil -lc -lgdbm_compat]
What optimizer/debugger flag should be used? [-march=native -O2 -pipe]
Any additional cc flags? [-fwrapv -fno-strict-aliasing -pipe]
Let me guess what the preprocessor flags are...
Any additional ld flags (NOT including libraries)? [-Wl,-O1 -Wl,--as-needed]
Checking your choice of C compiler and flags for coherency...
I've tried to compile and run the following simple program:

#include <stdio.h>
int main() { printf("Ok\n"); return(0); }

I used the command:

x86_64-pc-linux-gnu-gcc -o try -march=native -O2 -pipe -fwrapv -fno-strict-aliasing -pipe -Wl,-O1 -Wl,--as-needed try.c -lgdbm -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
./try

and I got the following output:

/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../libcrypt.so when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../libcrypt.a when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libcrypt.so when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libcrypt.a when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../libcrypt.so when searching for -lcrypt
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libcrypt.so when searching for -lcrypt
collect2: error: ld returned 1 exit status
I can't compile the test program.
You have a BIG problem. Shall I abort Configure [y]
Ok. Stopping Configure.
* ERROR: dev-lang/perl-5.32.1::gentoo failed (configure phase):
* Unable to configure
*
* Call stack:
* ebuild.sh, line 127: Called src_configure
* environment, line 2113: Called die
* The specific snippet of code:
* sh Configure -des -Dinstallprefix="${EPREFIX}"'/usr' -Dinstallusrbinperl='n' "${myconf[@]}" || die "Unable to configure";
*
* If you need support, post the output of `emerge --info '=dev-lang/perl-5.32.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-lang/perl-5.32.1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-lang/perl-5.32.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-lang/perl-5.32.1/temp/environment'.
* Working directory: '/var/tmp/portage/dev-lang/perl-5.32.1/work/perl-5.32.1'
* S: '/var/tmp/portage/dev-lang/perl-5.32.1/work/perl-5.32.1'

>>> Failed to emerge dev-lang/perl-5.32.1, Log file:

>>> '/var/tmp/portage/dev-lang/perl-5.32.1/temp/build.log'

* Messages for package dev-lang/perl-5.32.1:

* ERROR: dev-lang/perl-5.32.1::gentoo failed (configure phase):
* Unable to configure
*
* Call stack:
* ebuild.sh, line 127: Called src_configure
* environment, line 2113: Called die
* The specific snippet of code:
* sh Configure -des -Dinstallprefix="${EPREFIX}"'/usr' -Dinstallusrbinperl='n' "${myconf[@]}" || die "Unable to configure";
*
* If you need support, post the output of `emerge --info '=dev-lang/perl-5.32.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-lang/perl-5.32.1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-lang/perl-5.32.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-lang/perl-5.32.1/temp/environment'.
* Working directory: '/var/tmp/portage/dev-lang/perl-5.32.1/work/perl-5.32.1'
* S: '/var/tmp/portage/dev-lang/perl-5.32.1/work/perl-5.32.1'
*
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
*
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr
* Found some broken files that weren't associated with known packages
* The broken files are:
* /usr/bin/vncagent
* /usr/bin/vncserver-virtuald
* /usr/bin/vncserver-x11
* /usr/bin/vncserver-x11-core
* /usr/bin/Xvnc-core



??
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 593
Location: Italia

PostPosted: Sun Jul 04, 2021 9:23 pm    Post subject: Reply with quote

Per ora in parte ho risolto.
Ho rifatto tutto da capo e sono riuscito a ricompilare tutto senza errori.
Mi manca solo la migrazione a libxcrypt ma per adesso la salto, nell'attesa che qualcuno che già l'ha fatta mi dia consigli.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum