Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
FIXED: Verständnisfrage zu eselect python
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2155
Location: Heidelberg - Germany

PostPosted: Sun Jun 20, 2021 1:37 pm    Post subject: FIXED: Verständnisfrage zu eselect python Reply with quote

Ein "eix -I dev-lang/python$" liefert mir:

Code:

[I] dev-lang/python
     Verfügbare Versionen:   
     (2.7)  2.7.18_p10 ~2.7.18_p11
     (3.6)  3.6.13_p5(3.6/3.6m)^t
     (3.7)  3.7.10_p6(3.7/3.7m)^t
     (3.8)  3.8.10_p2^t
     (3.9)  3.9.5_p2^t
     (3.10) ~3.10.0_beta2^t ~3.10.0_beta3^t
       {berkdb bluetooth build examples gdbm hardened ipv6 +ncurses +readline +sqlite +ssl test +threads tk verify-sig +wide-unicode wininst +xml ELIBC="uclibc"}
     Installierte Versionen: 2.7.18_p10(2.7)(09:05:56 12.06.2021)(bluetooth gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -berkdb -build -examples -hardened -tk -verify-sig -wininst ELIBC="-uclibc") 3.9.5_p2(3.9)^t(09:03:53 12.06.2021)(bluetooth gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -test -tk -verify-sig -wininst)
     Startseite:             https://www.python.org/
     Beschreibung:           An interpreted, interactive, object-oriented programming language

(Man sieht es hier nicht, aber 2.7 und 3.9 sind hell markiert, d. h. also installiert)


Ein "eselect python list" liefert allerdings nur:

Code:

Available Python interpreters, in order of preference:
  [1]   python3.9


Die Frage ist, warum 2.7 nicht in der Liste steht und falls das so ok ist, warum das so ist bzw welche Logik dahinter steht.


Danke und Grüße
Erdie
_________________
Desktop AMD FX-8320 18GB RAM, Asus GF GTX 660. Sound: RME Multiface 20 Kanal + envy24 6 Kanal Soundkarte
Raspberry Pi 1 + 2 + 3B+ + Zero W
Stratux + Skydemon


Last edited by Erdie on Mon Jun 21, 2021 8:38 am; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4658

PostPosted: Sun Jun 20, 2021 2:40 pm    Post subject: Reply with quote

das python eselect modul nutzt python-exec2c ( dev-lang/python-exec) um alle installierten versionen zu bekommen.
Und python 2.7 ist für das ebuild nicht mehr als gültiges python target verfügbar und wohl deshalb kennt python-exec diese version auch nicht
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2155
Location: Heidelberg - Germany

PostPosted: Mon Jun 21, 2021 8:38 am    Post subject: Reply with quote

Verstanden, danke!
_________________
Desktop AMD FX-8320 18GB RAM, Asus GF GTX 660. Sound: RME Multiface 20 Kanal + envy24 6 Kanal Soundkarte
Raspberry Pi 1 + 2 + 3B+ + Zero W
Stratux + Skydemon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum