Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Getting portage running under Solaris 9 (Portaris!)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 11, 12, 13  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Wed Dec 01, 2004 3:51 am    Post subject: Reply with quote

If forgot what hardware you were using.
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Wed Dec 01, 2004 1:12 pm    Post subject: Reply with quote

its an ultra80 450mhz smp 1Gb RAM Solaris 12/03
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Wed Dec 01, 2004 3:19 pm    Post subject: Reply with quote

devsk wrote:
gecklord, thanks for your inputs. I will take care of the render thing.

there are more changes coming, which will make portage on solaris more seamless and reliable.

is there a way to change the ebuild because libXft is a dependency for nearly everything I want to emerge! :?
my attempts ended up in a mess... emerge just fetched the files but didn't unpack the source nor started to configure....
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Wed Dec 01, 2004 4:38 pm    Post subject: Reply with quote

overlayed ebuilds(provided in the tar) should be under /usr/local/portage. look under x11-libs.

they must have changed the file extension recently. the files were available as bz2's sometime back.
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Wed Dec 01, 2004 7:49 pm    Post subject: Reply with quote

So what changes have to be done?
My changed ebuild looked somewhat like this:

Code:
DESCRIPTION="This is XFT"
SRC_URI="http://freedesktop.org/~xlibs/release/render-0.8.tar.gz"
HOMEPAGE="http://freedesktop.org"

SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86 sparc ppc"

src_compile() {
   econf
   emake || die
}

src_install() {
   make MKDIR="mkdir -p" DESTDIR=${D} install || die
}

afterwards I've changed the digest file and the manifest, giving them the right md5 sums..
the ebuild downloaded the file from the uri but didn't do anything else...
it seemed as if the whole emerge command was corrupt (trying to emerge other things ended up the same way) - unfortunately I do not really understand the whole interaction


And my python seems to be corrupt, too (not because of changing the ebuild)
I had to get python from blastwave and linked the new python (python2.3) to /usr/bin before I really could emerge things... otherwise emerge just said that there's a problem with python...
but now other Solaris native stuff seems to refuse it's work (nautilus, csw gkrellm, wmaker)... (it's not as if I didn't expect something like that ;) )
Did you experience the same? How did you solve that issue (did you solve it at all)?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Thu Dec 02, 2004 4:05 am    Post subject: Reply with quote

let's slow down a bit. I want to see the first errors that you got, when you concluded that you needed python re-installed.

all errors reported during portage install and emerge log will also be helpful. if these logs are huge, please upload somewhere and post a link.
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Thu Dec 02, 2004 7:51 pm    Post subject: Reply with quote

I've tried it today on fresh Solaris install with the result that after installing it, emerge complained about the same things...
Code:

# emerge --info
ld.so.1: /usr/bin/python: fatal: libgcc_s.so.1: open failed: No such file or directory
Killed

... I rebooted the machine, windowmaker and gnome refused to load, and emerge runs with out any error-output under CDE

I'm still looking for a place to upload the emerge.log file which counts 1.7 MB[/code]
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Thu Dec 02, 2004 8:59 pm    Post subject: Reply with quote

1. do you have /opt/portage/lib and /opt/portage/usr/lib in LD_LIBRARY_PATH?

2. what is the output of crle?
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Thu Dec 02, 2004 9:23 pm    Post subject: Reply with quote

Code:
# cat $LD_LIBRARY_PATH
cat: /opt/portage/lib:/opt/portage/usr/lib:/lib:/usr/lib:/usr/openwin/lib:/usr/local/lib:/usr/kerberos/lib: No such file or directory


Code:
# crle

Default configuration file (/var/ld/ld.config) not found
  Default Library Path (ELF):   /usr/lib  (system default)
  Trusted Directories (ELF):   /usr/lib/secure  (system default)


found a place for the file portage-emerge.log:
http://scifi.pages.at/syberdoor/portage-emerge.log
Back to top
View user's profile Send private message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Thu Dec 02, 2004 11:51 pm    Post subject: Reply with quote

I get that libgcc error a lot too, and usually for things I didn't compile.
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Fri Dec 03, 2004 12:05 am    Post subject: Reply with quote

after installing it, the first thing you should do is to logout of root and log back in. That way you will have the new env.

Your install went fine except for baselayout part, which is harmless. I will fix that part in the newer version.

So, logout and login into root account again. keep track of whatever you do after this.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Fri Dec 03, 2004 12:08 am    Post subject: Reply with quote

stonent wrote:
I get that libgcc error a lot too, and usually for things I didn't compile.

if you are using gcc from the tar, libgcc_s.so.1 should be present in /opt/portage/usr/lib. If it is not, let me know.
also post the packages which are cribbing.
Back to top
View user's profile Send private message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Sun Dec 05, 2004 7:25 am    Post subject: Reply with quote

I'll do that once i get this straightened out.

/usr/portage/profiles/default-sun-9.0

Anyone have a copy of that?
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Sun Dec 05, 2004 8:20 am    Post subject: Reply with quote

if you have the tar or the area where you untarred the tar, all files that go under default-sun-9.0 should be under profiles/ directory. you might need to look at the respective portion of the install script to see which files need to be copied and how.
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Sun Dec 05, 2004 6:25 pm    Post subject: Reply with quote

Has anybody already figured out what changes have to be done to be ably to emerge render?
Back to top
View user's profile Send private message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Mon Dec 06, 2004 12:41 am    Post subject: Reply with quote

devsk wrote:
if you have the tar or the area where you untarred the tar, all files that go under default-sun-9.0 should be under profiles/ directory. you might need to look at the respective portion of the install script to see which files need to be copied and how.


I got it now. And I reran the install because for some reason it was trying to emerge old stuff as N like Bash 2 instead of Bash 3.

Code:
configure: error: Pango 1.2.0 and Xft backend is required for x11 target

!!! ERROR: x11-libs/gtk+-2.4.13-r1 failed.
!!! Function econf, Line 441, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


Also I've gotten that from the start, never was able to make it work. (Pango also wants xft)
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Mon Dec 06, 2004 3:32 am    Post subject: Reply with quote

I can't find http://freedesktop.org/~xlibs/release anymore. They have recently changed things and I don't know where the xlibs are. cvs access probably works. I will let you know if I can find it.
Back to top
View user's profile Send private message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Mon Dec 06, 2004 4:09 am    Post subject: Reply with quote

Does this look ok? As in things installing in the right place and linking to the right place.

Code:
bash-3.00# ldd `which zsh`
        libzsh-4.2.1.so =>       /usr/lib/zsh/libzsh-4.2.1.so
        libiconv.so.2 =>         /opt/portage/usr/lib/libiconv.so.2
        libsocket.so.1 =>        /lib/libsocket.so.1
        libdl.so.1 =>    /lib/libdl.so.1
        libnsl.so.1 =>   /lib/libnsl.so.1
        libcurses.so.1 =>        /lib/libcurses.so.1
        libm.so.1 =>     /lib/libm.so.1
        libc.so.1 =>     /lib/libc.so.1
        libgcc_s.so.1 =>         /opt/portage/usr/lib/libgcc_s.so.1
        libmp.so.2 =>    /lib/libmp.so.2
        /usr/platform/SUNW,UltraAX-e/lib/libc_psr.so.1
bash-3.00# which zsh
/usr/bin/zsh

_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Mon Dec 06, 2004 4:44 am    Post subject: Reply with quote

they look fine. were you expecting them to be not in /usr?
Back to top
View user's profile Send private message
stonent
Veteran
Veteran


Joined: 07 Aug 2003
Posts: 1139
Location: Texas

PostPosted: Mon Dec 06, 2004 5:12 am    Post subject: Reply with quote

devsk wrote:
they look fine. were you expecting them to be not in /usr?


Well some were in /usr and some were in /opt I didn't know if that was right.
_________________
Inspiron 4100 & Sun UltraAXe
Portage on Solaris|Dell Laptop Hacks
The way you feel about organized religion is the same way I feel about organized socialism.
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Mon Dec 06, 2004 7:10 pm    Post subject: Reply with quote

Isn't there a quick way to change the renderext ebuild to a "render ebuild"?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Mon Dec 06, 2004 9:02 pm    Post subject: Reply with quote

the ebuild in not the problem here. the tar files are not available anymore and I couldn't find them on the net anywhere, as I said in the earlier post.

are you saying that "renderext" package is now renamed to "render" and the tar render-0.8.tar.gz exists on the net somewhere? If that is case, please let me know the link too... I will update the ebuild in that case.
Back to top
View user's profile Send private message
Gecklord
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 174

PostPosted: Tue Dec 07, 2004 6:19 am    Post subject: Reply with quote

It's now named render - that's what I've posted some posts before ;)!
Here's the link:

http://gentoo.ussg.indiana.edu/distfiles/render-0.8.tar.gz
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Tue Dec 07, 2004 6:55 am    Post subject: Reply with quote

I pretty much doubt that. That file is may 2003, I have built packages which were as recent as may this year. renderext is the newer name. But I can't find the official repository of Xlibs. not that the header files included in that package have changed. So, it probably safe.

you just have to rename the ebuild to render-0.8.ebuild and ebuild ./render-0.8.ebuild digest.

anyway, I have the original tbz2's that I built with the same install of portage as yours. if you need those email me.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Thu Dec 09, 2004 12:24 am    Post subject: Reply with quote

any updates regarding emerging tbz2's??
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 11, 12, 13  Next
Page 7 of 13

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum