Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] QEMU/KVM can't enable virtio 3D acceleration
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
dirtboxes
n00b
n00b


Joined: 27 Apr 2021
Posts: 39

PostPosted: Fri Jun 11, 2021 5:37 am    Post subject: [solved] QEMU/KVM can't enable virtio 3D acceleration Reply with quote

I check the 3D acceleration box and get this error.

Code:
 Error changing VM configuration: unsupported configuration: virtio 3d acceleration is not supported

Error changing VM configuration: unsupported configuration: virtio 3d acceleration is not supported

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 334, in change_config_helper
    define_func(devobj=devobj, do_hotplug=False, **define_args)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 853, in define_video
    self._process_device_define(editdev, xmlobj, do_hotplug)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 518, in _process_device_define
    self._redefine_xmlobj(xmlobj)
  File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 383, in _redefine_xmlobj
    self._redefine_xml_internal(origxml, newxml)
  File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 366, in _redefine_xml_internal
    self._define(newxml)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 1064, in _define
    self.conn.define_domain(xml)
  File "/usr/share/virt-manager/virtManager/connection.py", line 554, in define_domain
    return self._backend.defineXML(xml)
  File "/usr/lib/python3.8/site-packages/libvirt.py", line 4380, in defineXML
    raise libvirtError('virDomainDefineXML() failed')
libvirt.libvirtError: unsupported configuration: virtio 3d acceleration is not supported


Any help appreciated :D


Last edited by dirtboxes on Sun Jun 27, 2021 5:24 am; edited 1 time in total
Back to top
View user's profile Send private message
mrbassie
l33t
l33t


Joined: 31 May 2013
Posts: 640

PostPosted: Fri Jun 11, 2021 3:56 pm    Post subject: Reply with quote

iirc you need the the virgl use flag set for app-emulation/qemu.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum