Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202103-03 ] OpenSSL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2554

PostPosted: Wed Mar 31, 2021 2:26 pm    Post subject: [ GLSA 202103-03 ] OpenSSL Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL: Multiple vulnerabilities (GLSA 202103-03)
Severity: normal
Exploitable: local, remote
Date: 2021-03-31
Bug(s): #769785, #777681
ID: 202103-03

Synopsis

Multiple vulnerabilities have been found in OpenSSL, the worst of
which could allow remote attackers to cause a Denial of Service condition.


Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1/v1.1/v1.2/v1.3) as well
as a general purpose cryptography library.


Affected Packages

Package: dev-libs/openssl
Vulnerable: < 1.1.1k
Unaffected: >= 1.1.1k
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in OpenSSL. Please review
the CVE identifiers referenced below for details.


Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All OpenSSL users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.1.1k"
   


References

CVE-2021-23840
CVE-2021-23841
CVE-2021-3449
CVE-2021-3450
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum