Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202103-02 ] Redis
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2554

PostPosted: Wed Mar 31, 2021 1:26 pm    Post subject: [ GLSA 202103-02 ] Redis Reply with quote

Gentoo Linux Security Advisory

Title: Redis: Remote code execution (GLSA 202103-02)
Severity: normal
Exploitable: local, remote
Date: 2021-03-31
Bug(s): #773328
ID: 202103-02

Synopsis

A vulnerability in Redis could lead to remote code execution.

Background

Redis is an open source (BSD licensed), in-memory data structure store,
used as a database, cache and message broker.


Affected Packages

Package: dev-db/redis
Vulnerable: < 6.0.12
Unaffected: >= 5.0.12
Unaffected: >= 6.0.12
Architectures: All supported architectures


Description

It was discovered that there were a number of integer overflow issues in
Redis.


Impact

A remote attacker, able to connect to a Redis instance, could send a
malicious crafted large request possibly resulting in the execution of
arbitrary code with the privileges of the process or a Denial of Service
condition.


Workaround

There is no known workaround at this time.

Resolution

All Redis 5.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/redis-5.0.12"
   
All Redis 6.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/redis-6.0.12"
   


References

CVE-2021-21309
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum