Joined: 04 Mar 2021
|Posted: Thu Mar 04, 2021 6:53 am Post subject: 安装gentoo更新 @world set时出错
|ubuntu / # emerge --ask --verbose --update --deep --newuse @world
These are the packages that would be merged, in order:
Calculating dependencies... done!
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
(dev-lang/perl-5.32.1:0/5.32::gentoo, ebuild scheduled for merge) USE="berkdb gdbm -debug -doc -ithreads -minimal" ABI_X86="(64)" pulled in by
(no parents that aren't satisfied by other packages in this slot)
(dev-lang/perl-5.30.3-r1:0/5.30::gentoo, ebuild scheduled for merge) USE="berkdb gdbm -debug -doc -ithreads -minimal" ABI_X86="(64)" pulled in by
dev-lang/perl:0/5.30=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed) USE="" ABI_X86="(64)"
(and 2 more with the same problem)
NOTE: Use the '--verbose-conflicts' option to display parents omitted above
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
!!! The ebuild selected to satisfy "sys-libs/libseccomp[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" has unmet requirements.
- sys-libs/libseccomp-2.5.1::gentoo USE="python -static-libs" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_8 -python3_7 -python3_9"
The following REQUIRED_USE flag constraints are unsatisfied:
python? ( static-libs )
The above constraints are a subset of the following complete expression:
python? ( static-libs any-of ( python_targets_python3_7 python_targets_python3_8 python_targets_python3_9 ) )
(dependency required by "sys-apps/file-5.39-r3::gentoo" [ebuild])
(dependency required by "@system" [set])
(dependency required by "@world" [argument])
ubuntu / #