Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xscreensaver locks account
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
brundage
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2004
Posts: 121

PostPosted: Sat Jan 23, 2021 2:17 am    Post subject: xscreensaver locks account Reply with quote

I went to unlock my desktop this morning, entered my password incorrectly 3 times and xscreensaver locked me out for 10 minutes. This seems to be new behavior since I updated world and I'd like to turn that off since I'm a fast and loose typer. I run XFCE4 and launch X from my shell startup script (no display manager).

I didn't find anything in the man page, but did find this config setting humorous

Code:
        GetViewPortIsFullOfLies (class Boolean)
               Set  this  to true if the xscreensaver window doesn't cover the
               whole screen.  This works around  a  longstanding  XFree86  bug
               #421.  See the xscreensaver FAQ for details.


Where else should I go looking?
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 456

PostPosted: Sat Jan 23, 2021 3:33 am    Post subject: Reply with quote

You probably want to look at /etc/pam.d/xscreensaver (specifically, pam_faillock) and /etc/security/faillock . If you wish it reconfigure it globally, edit etc/security/faillock . IF you wish to just change it for xscreensaver you'll need to edit /etc/pam.d/xscreensaver . please be careful, PAM configuration files are fragile and its easy to lock yourself out!
Back to top
View user's profile Send private message
brundage
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2004
Posts: 121

PostPosted: Sat Jan 23, 2021 2:23 pm    Post subject: Reply with quote

salahx wrote:
You probably want to look at /etc/pam.d/xscreensaver (specifically, pam_faillock) and /etc/security/faillock . If you wish it reconfigure it globally, edit etc/security/faillock . IF you wish to just change it for xscreensaver you'll need to edit /etc/pam.d/xscreensaver . please be careful, PAM configuration files are fragile and its easy to lock yourself out!


Thanks. I think /etc/security/faillock.conf is what I'm looking for.
Code:
# Deny access if the number of consecutive authentication failures
# for this user during the recent interval exceeds n tries.
# The default is 3.
# deny = 3

# The access will be re-enabled after n seconds after the lock out.
# The value 0 has the same meaning as value `never` - the access
# will not be re-enabled without resetting the faillock
# entries by the `faillock` command.
# The default is 600 (10 minutes).
# unlock_time = 600


Should I just set unlock_time to 1 second, or is there a better way to disable the locking behavior?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16707

PostPosted: Sat Jan 23, 2021 5:09 pm    Post subject: Reply with quote

You could remove pam_faillock.so from the set of modules that xscreensaver uses when processing password entry. For completeness, I will also suggest that you could slow down and be more careful with your password, especially after the first failure.
Back to top
View user's profile Send private message
brundage
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2004
Posts: 121

PostPosted: Sat Jan 23, 2021 11:52 pm    Post subject: Reply with quote

Hu wrote:
For completeness, I will also suggest that you could slow down and be more careful with your password, especially after the first failure.


lol nope
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum