Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Linux support of UHD Graphics 630
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2879
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Dec 15, 2020 1:57 am    Post subject: Linux support of UHD Graphics 630 Reply with quote

After 8 years my current mainboard is starting to show old age and my CPU (i7-3770K) is getting old, so I'd like to build a new system for the next decade.

So I was thinking about the Intel i7-10700K processor and I wanted to see if there are problems with the listed UHD Graphics 630 chip. I found these:

https://www.phoronix.com/scan.php?page=article&item=coffee-uhd-graphics&num=1
https://www.reddit.com/r/linuxhardware/comments/7v6sdr/intel_uhd_graphics_630_support/

sure they are a little bit old, but still since I want to build a system for the next decade, I want to be 100% sure that everything is supported well, I don't want to spend lot of money and realize that not everything is working. So my question is: how is the current support of UHD Graphics 630? When I search for that in google, I can only find these old pages hinting at potential problems.

And I was thinking about using the ASUS PRIME B460-PLUS board. Based on this probe (https://linux-hardware.org/index.php?probe=c1bcb36fc6) it seems that this board is well supported. Is somebody using this board? What has been the experience so far? Do the NVME M.2 work? I had the issue on some Dell PC on my company that I was only able to see the NVME in linux after changing the BIOS setting from RAID to AHCI. Based on this thread in the dell forums (last post), it seems that I'm not the only one dealing with it. So I wonder if I would have the same issue with this board.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
AlexJGreen
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2018
Posts: 149

PostPosted: Tue Dec 15, 2020 2:21 am    Post subject: Reply with quote

_

Last edited by AlexJGreen on Mon Dec 28, 2020 2:58 am; edited 1 time in total
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2879
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Dec 15, 2020 9:22 am    Post subject: Reply with quote

coderanger wrote:

The only problem I observed is the laptop gets stuck on bios post message
if these conditions are met (docked && hdmi monitor attached && driver compiled into kernel).


hmm, this is very specific set of properties, but I had a similar situation with a Dell Latitude notebook but on my case systemd was not able to properly start dbus only when the notebook was on the docking station, so I can relate to that.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
gentoo_ram
Guru
Guru


Joined: 25 Oct 2007
Posts: 439
Location: San Diego, California USA

PostPosted: Fri Dec 18, 2020 11:23 pm    Post subject: Reply with quote

I'm not having any issues with the built-in Intel graphics support on my i7-7700 (UHD 630). Turn on support in the kernel for DRM and UHD graphics. There's a frame buffer driver for that chipset. And Xorg has a server that supports it. Also install the linux-firmware package and it will include firmware for the graphics card. Shouldn't be a problem.

This is on an ATX motherboard with a Z370 chipset. Laptops can be more proprietary and might have other complications going on.

Code:

Linux gateway 5.9.12-gentoo #1 SMP Mon Dec 7 09:48:53 PST 2020 x86_64 Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz GenuineIntel GNU/Linux

gw # dmesg | egrep '(drm|915)'
[    1.650573] fb0: switching to inteldrmfb from EFI VGA
[    1.651280] i915 0000:00:02.0: vgaarb: deactivate vga console
[    1.652713] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    1.653113] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    1.678873] [drm] Initialized i915 1.6.0 20200715 for 0000:00:02.0 on minor 0
[    1.711324] fbcon: i915drmfb (fb0) is primary device
[    1.819551] i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04) (prog-if 00 [VGA controller])
        DeviceName:  Onboard IGD
        Subsystem: ASUSTeK Computer Inc. HD Graphics 630
        Flags: bus master, fast devsel, latency 0, IRQ 127
        Memory at de000000 (64-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Kernel driver in use: i915
Back to top
View user's profile Send private message
AlexJGreen
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2018
Posts: 149

PostPosted: Sat Dec 19, 2020 10:26 am    Post subject: Reply with quote

_

Last edited by AlexJGreen on Mon Dec 28, 2020 2:56 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 50904
Location: 56N 3W

PostPosted: Sat Dec 19, 2020 10:41 am    Post subject: Reply with quote

Moved from Portage & Programming to Kernel & Hardware.

It fits better here
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum