Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[CLOSED - question went to dantrell threa] Package conflict
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sat Dec 05, 2020 5:33 am    Post subject: [CLOSED - question went to dantrell threa] Package conflict Reply with quote

Hi, ALL,

Code:

[ebuild     U  ] dev-lang/python-exec-2.4.6-r1:2::gentoo [2.4.6:2::gentoo] PYTHON_TARGETS="(pypy3) (python2_7) (python3_6) (python3_7*) (python3_8%*) (-python3_9) (-jython2_7%*) (-pypy%*) (-python3_4%*) (-python3_5%*)" 86 KiB
[ebuild  N     ] media-libs/opus-1.3.1-r1::gentoo  USE="-custom-modes -doc -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 1,016 KiB
[ebuild  N     ] virtual/libcrypt-1-r1:0/1::gentoo  USE="static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] app-emulation/virtualbox-modules-5.2.40-r1::gentoo [5.2.14::gentoo] USE="-pax_kernel" 630 KiB
[ebuild  NS    ] dev-lang/python-3.7.8-r2:3.7/3.7m::gentoo [2.7.15:2.7::gentoo, 3.6.5:3.6/3.6m::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl xml -bluetooth% -build -examples -hardened -libressl -test -tk -wininst (-threads%*)" 17,005 KiB
[ebuild     U  ] app-emulation/virtualbox-5.2.40::gentoo [5.2.14-r1::gentoo] USE="alsa opengl pam pulseaudio qt5 sdk udev -debug -doc -dtrace% -headless -java -libressl -lvm -pax_kernel -python -vboxwebsrv -vnc" PYTHON_SINGLE_TARGET="python3_7%* -python3_6% -python3_8%" PYTHON_TARGETS="(-python2_7%*)" 115,517 KiB

Total: 6 packages (3 upgrades, 2 new, 1 in new slot), Size of downloads: 134,252 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/virtualbox:0

  (app-emulation/virtualbox-5.2.40:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-emulation/virtualbox (Argument)

  (app-emulation/virtualbox-5.2.14-r1:0/0::gentoo, installed) pulled in by
    ~app-emulation/virtualbox-5.2.14 required by (app-emulation/virtualbox-extpack-oracle-5.2.14.123301:0/0::gentoo, installed)
    ^                         ^^^^^^                                                                                                                                                 

app-emulation/virtualbox-modules:0

  (app-emulation/virtualbox-modules-5.2.40-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/virtualbox-modules-5.2.40 required by (app-emulation/virtualbox-5.2.40:0/0::gentoo, ebuild scheduled for merge)
    ^                                 ^^^^^^                                                                                                                                             

  (app-emulation/virtualbox-modules-5.2.14:0/0::gentoo, installed) pulled in by
    ~app-emulation/virtualbox-modules-5.2.14 required by (app-emulation/virtualbox-5.2.14-r1:0/0::gentoo, installed)
    ^                                 ^^^^^^                                                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


All I need is to uninstall virtualbox and then merge the newer version, right?

Thank you.

P.S.: Its been a long time...


Last edited by ONEEYEMAN on Mon Dec 07, 2020 11:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25432
Location: here

PostPosted: Sat Dec 05, 2020 6:51 am    Post subject: Reply with quote

Have you tried to add --backtrack=30 option to emerge command?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sat Dec 05, 2020 8:56 am    Post subject: Reply with quote

Hi,
Didn't help.

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25432
Location: here

PostPosted: Sat Dec 05, 2020 9:02 am    Post subject: Reply with quote

app-emulation/virtualbox-5.2.40 is no longer in portage tree current stable version is 6.0.24-r1
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sat Dec 05, 2020 9:13 am    Post subject: Reply with quote

Hi,
OK, so I should just remove it, right?
And install a newer version?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25432
Location: here

PostPosted: Sat Dec 05, 2020 9:26 am    Post subject: Reply with quote

Code:
* Last emerge --sync was 94d 14h 56m 19s ago.

Related at your other thread seems that you not sync your official tree since 94 days, so you should also update official tree but you may have conflicts (many things can be changed in 94 days).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16679

PostPosted: Sat Dec 05, 2020 5:19 pm    Post subject: Re: Package conflict Reply with quote

ONEEYEMAN wrote:
Code:
  (app-emulation/virtualbox-5.2.40:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-emulation/virtualbox (Argument)

  (app-emulation/virtualbox-5.2.14-r1:0/0::gentoo, installed) pulled in by
    ~app-emulation/virtualbox-5.2.14 required by (app-emulation/virtualbox-extpack-oracle-5.2.14.123301:0/0::gentoo, installed)
    ^                         ^^^^^^                                                                                                                                                 

app-emulation/virtualbox-modules:0

  (app-emulation/virtualbox-modules-5.2.40-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/virtualbox-modules-5.2.40 required by (app-emulation/virtualbox-5.2.40:0/0::gentoo, ebuild scheduled for merge)
    ^                                 ^^^^^^                                                                                                                                             

  (app-emulation/virtualbox-modules-5.2.14:0/0::gentoo, installed) pulled in by
    ~app-emulation/virtualbox-modules-5.2.14 required by (app-emulation/virtualbox-5.2.14-r1:0/0::gentoo, installed)
    ^                                 ^^^^^^                                                                                                                               
As I read this, you have two problems. First, you have app-emulation/virtualbox-extpack-oracle, which is installed and not scheduled for an update, and which prohibits updating to a newer upstream version of VirtualBox. Second, you have virtualbox-modules installed that would need to be updated concurrent with virtualbox itself. The latter is easy. The former requires either removing or (if a better version is available) updating app-emulation/virtualbox-extpack-oracle.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sun Dec 06, 2020 8:39 am    Post subject: Reply with quote

Hi, guys,
I did synchronize the main tree as well and it did tell me that the "Update to Portage is available. It is strongly recommended to upgrade Portage first".

However, trying to do that I got:

Code:

IgorReinCloud /var/lib/layman/dantrell-gnome/eclass # emerge portage

 * IMPORTANT: 28 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies -^[... done!
[ebuild     U  ] dev-lang/python-exec-2.4.6-r2 [2.4.6]
PYTHON_TARGETS="(python3_7*) (python3_8%*) (python3_9%*)"
[ebuild  N     ] app-arch/zstd-1.4.4-r4  USE="threads -lz4
-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] virtual/libcrypt-1-r1  USE="static-libs"
ABI_X86="(64) -32 (-x32)"
[ebuild  NS    ] dev-lang/python-3.8.6 [2.7.15, 3.6.5] USE="-bluetooth%"
[ebuild     U  ] dev-python/certifi-10001-r1 [2018.4.16] USE="-test%"
PYTHON_TARGETS="python3_8%* -python3_6* -python3_9%"
[ebuild     U  ] dev-python/setuptools-50.3.0 [36.7.2]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild  N     ] dev-python/setuptools_scm-4.1.2-r1  USE="-test"
PYTHON_TARGETS="python3_8 (-pypy3) -python3_6 -python3_7 -python3_9"
[ebuild     U  ] dev-python/idna-2.10-r1 [2.5]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild     U  ] dev-python/six-1.15.0-r1 [1.11.0]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_9%"
[ebuild     U  ] dev-python/chardet-3.0.4-r1 [3.0.4]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_9%"
[ebuild     U  ] dev-python/ply-3.11-r1 [3.9]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild     U  ] dev-python/PySocks-1.7.1-r1 [1.6.7]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild     U  ] dev-python/pycparser-2.20-r1 [2.14]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild     U  ] dev-python/cffi-1.14.0-r3 [1.11.4]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild     U  ] dev-python/cryptography-3.2.1 [2.2.2-r1] USE="-idna%"
PYTHON_TARGETS="python3_8%* -python3_6* -python3_9%"
[ebuild     U  ] dev-python/pyopenssl-19.1.0-r1 [17.5.0]
PYTHON_TARGETS="python3_8%* -python3_6* -python3_9%"
[ebuild     U  ] dev-python/urllib3-1.25.11 [1.22] USE="-brotli%"
PYTHON_TARGETS="python3_8%* -python3_6* -python3_7% -python3_9%"
[ebuild     U  ] dev-python/requests-2.24.0-r1 [2.18.4-r1]
USE="-test%" PYTHON_TARGETS="python3_8%* -python3_6* -python3_7%
-python3_9%"
[ebuild     U  ] app-crypt/gnupg-2.2.25 [2.2.10-r1]
USE="-scd-shared-access% -user-socket%"
[ebuild     U  ] app-portage/gemato-16.2 [14.0]
PYTHON_TARGETS="python3_8%* (-pypy3) -python3_6* -python3_9%"
[ebuild     U  ] sys-apps/portage-3.0.9 [2.3.79] USE="-apidoc% -test%"
PYTHON_TARGETS="python3_8* (-pypy3) -python3_6* -python3_9%"
[blocks B      ] <=dev-lang/python-2.7.18-r3:2.7
("<=dev-lang/python-2.7.18-r3:2.7" is blocking
dev-lang/python-exec-2.4.6-r2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-3.0.9:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.3.79:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-java/java-config-2.2.0-r4:2/2::gentoo, installed)

    sys-apps/portage[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
-python_single_target_python3_6(-)]
required by (app-portage/layman-2.4.2-r1:0/0::gentoo, installed)

    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),
-python_single_target_python3_7(-)]
required by (app-portage/gentoolkit-0.4.6:0/0::gentoo, installed)


app-portage/gemato:0

  (app-portage/gemato-16.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-portage/gemato-14.5[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (sys-apps/portage-3.0.9:0/0::gentoo, ebuild scheduled for
merge)
    ^^                   ^^^^

  (app-portage/gemato-14.0:0/0::gentoo, installed) pulled in by
    >=app-portage/gemato-14[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)]
required by (sys-apps/portage-2.3.79:0/0::gentoo, installed)


dev-python/setuptools:0

  (dev-python/setuptools-50.3.0:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)
    ^^                      ^^^^^^
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/pycparser-2.20-r1:0/0::gentoo, ebuild
scheduled for merge)

    (and 12 more with the same problems)

  (dev-python/setuptools-36.7.2:0/0::gentoo, installed) pulled in by
    >=dev-python/setuptools-1.0[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),
-python_single_target_python3_7(-)]
required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),-python_single_target_pypy(-),-python_single_target_python2_7(-)]
required by (dev-python/ipaddress-1.0.19:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/pyxattr-0.6.0-r1:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/PySocks-1.6.7:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/six-1.11.0:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/asn1crypto-0.22.0:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/pycparser-2.14:0/0::gentoo, installed)

    >=dev-python/setuptools-34[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (app-portage/gemato-14.0:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/certifi-2018.4.16:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (app-portage/gemato-14.0:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/chardet-3.0.4:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),
-python_single_target_python2_7(-)]
required by (dev-python/enum34-1.1.6:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/ply-3.9:0/3.9::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/pygments-2.2.0:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/pyblake2-1.1.2:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/idna-2.5:0/0::gentoo, installed)

    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/traceback2-1.4.0:0/0::gentoo, installed)


dev-python/certifi:0

  (dev-python/certifi-10001-r1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/setuptools-50.3.0:0/0::gentoo, ebuild
scheduled for merge)

    >=dev-python/certifi-2017.4.17[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)

    dev-python/certifi[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)


  (dev-python/certifi-2018.4.16:0/0::gentoo, installed) pulled in by
    dev-python/certifi[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)

    >=dev-python/certifi-2017.4.17[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)

    >=dev-python/certifi-2016.9.26[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/setuptools-36.7.2:0/0::gentoo, installed)


dev-python/requests:0

  (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    dev-python/requests[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (app-portage/gemato-16.2:0/0::gentoo, ebuild scheduled for
merge)


  (dev-python/requests-2.18.4-r1:0/0::gentoo, installed) pulled in by
    >=dev-python/requests-1.2.1[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/ssl-fetch-0.4:0/0::gentoo, installed)


dev-python/pyopenssl:0

  (dev-python/pyopenssl-19.1.0-r1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/pyopenssl-0.14[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)


  (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed) pulled in by
    >=dev-python/pyopenssl-0.14[-python_single_target_pypy(-),python_targets_python2_7(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
python_targets_python3_6(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)

    >=dev-python/pyopenssl-0.14[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)


dev-python/cryptography:0

  (dev-python/cryptography-3.2.1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/cryptography-1.3.4[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)

    >=dev-python/cryptography-1.3.4[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)

    >=dev-python/cryptography-2.8[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/pyopenssl-19.1.0-r1:0/0::gentoo, ebuild
scheduled for merge)
    ^^                        ^^^

  (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed) pulled in by
    >=dev-python/cryptography-2.1.4[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),
-python_single_target_python3_7(-)]
required by (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed)

    >=dev-python/cryptography-1.3.4[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)

    >=dev-python/cryptography-1.3.4[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)


dev-python/six:0

  (dev-python/six-1.15.0-r1:0/0::gentoo, ebuild scheduled for merge)
pulled in by
    >=dev-python/six-1.5.2[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/pyopenssl-19.1.0-r1:0/0::gentoo, ebuild
scheduled for merge)

    >=dev-python/six-1.4.1[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/cryptography-3.2.1:0/0::gentoo, ebuild
scheduled for merge)


  (dev-python/six-1.11.0:0/0::gentoo, installed) pulled in by
    dev-python/six[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/fixtures-3.0.0:0/0::gentoo, installed)

    >=dev-python/six-1.4.0[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/testtools-2.3.0:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/pyrsistent-0.14.2:0/0::gentoo, installed)

    >=dev-python/six-1.4[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)

    >=dev-python/six-1.4.1[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)

    >=dev-python/six-1.5.2[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed)


dev-python/idna:0

  (dev-python/idna-2.10-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/idna-2.0.0[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)

    >=dev-python/idna-2.5[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)

    <dev-python/idna-3[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)


  (dev-python/idna-2.5:0/0::gentoo, installed) pulled in by
    >=dev-python/idna-2.0.0[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)

    >=dev-python/idna-2.5[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)

    >=dev-python/idna-2.1[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)

    <dev-python/idna-2.7[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)
    ^                ^^^

dev-python/cffi:0

  (dev-python/cffi-1.14.0-r3:0/1.14.0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/cffi-1.8:=[python_targets_python3_6(-)?,-python_single_target_python3_6(-),
python_targets_python3_7(-)?,-python_single_target_python3_7(-),python_targets_python3_8(-)?,
-python_single_target_python3_8(-),python_targets_python3_9(-)?,-python_single_target_python3_9(-)]
required by (dev-python/cryptography-3.2.1:0/0::gentoo, ebuild
scheduled for merge)


  (dev-python/cffi-1.11.4:0/1.11.4::gentoo, installed) pulled in by
    >=dev-python/cffi-1.7:0/1.11.4=[python_targets_python2_7(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_targets_python3_6(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-)]
required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)
                         ^^^^^^^^^^

dev-python/pycparser:0

  (dev-python/pycparser-2.20-r1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    dev-python/pycparser[python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,
python_targets_python3_9(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/cffi-1.14.0-r3:0/1.14.0::gentoo, ebuild
scheduled for merge)


  (dev-python/pycparser-2.14:0/0::gentoo, installed) pulled in by
    dev-python/pycparser[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/cffi-1.11.4:0/1.11.4::gentoo, installed)


dev-python/ply:0

  (dev-python/ply-3.11-r1:0/3.11::gentoo, ebuild scheduled for merge)
pulled in by
    dev-python/ply:=[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/pycparser-2.20-r1:0/0::gentoo, ebuild
scheduled for merge)


  (dev-python/ply-3.9:0/3.9::gentoo, installed) pulled in by
    dev-python/ply[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/pycparser-2.14:0/0::gentoo, installed)


dev-python/urllib3:0

  (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled for merge)
pulled in by
    <dev-python/urllib3-1.26[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)


  (dev-python/urllib3-1.22:0/0::gentoo, installed) pulled in by
    <dev-python/urllib3-1.23[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)
    ^                   ^^^^

dev-python/PySocks:0

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/PySocks-1.5.8[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)

    <dev-python/PySocks-2.0[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/urllib3-1.25.11:0/0::gentoo, ebuild scheduled
for merge)


  (dev-python/PySocks-1.6.7:0/0::gentoo, installed) pulled in by
    >=dev-python/PySocks-1.5.6[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)

    <dev-python/PySocks-2.0[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),
-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/urllib3-1.22:0/0::gentoo, installed)


dev-python/chardet:0

  (dev-python/chardet-3.0.4-r1:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=dev-python/chardet-3.0.2[python_targets_pypy3(-)?,python_targets_python3_6(-)?,
python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,
-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),
-python_single_target_python3_8(-),-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)

    <dev-python/chardet-4[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,
python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),
-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),
-python_single_target_python3_9(-)]
required by (dev-python/requests-2.24.0-r1:0/0::gentoo, ebuild
scheduled for merge)


  (dev-python/chardet-3.0.4:0/0::gentoo, installed) pulled in by
    >=dev-python/chardet-3.0.2[python_targets_python2_7(-),python_targets_python3_6(-),
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]
required by (dev-python/requests-2.18.4-r1:0/0::gentoo, installed)


NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed): ebuild is
masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/pbr-4.2.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pyxattr-0.6.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pyrsistent-0.14.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pycups-1.9.73-r1:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/pycairo-1.17.0:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by
(sys-libs/ldb-1.1.29-r1:0/1.1.29::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by
(app-admin/system-config-printer-1.5.9:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/testtools-2.3.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/traceback2-1.4.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(app-misc/tracker-1.12.4-r1:0/100::dantrell-gnome-3-24, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pygobject-3.24.1:3/3::dantrell-gnome-3-24, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-libs/newt-0.52.20:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(sys-libs/compiler-rt-6.0.1:6.0.1/6.0.1::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/enum34-1.1.6:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/docutils-0.13.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/subunit-1.2.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(net-im/telepathy-mission-control-5.16.4-r1:0/0::dantrell-gnome,
installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-util/anjuta-3.28.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(sys-libs/tevent-0.9.31-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by
(app-accessibility/caribou-0.4.21:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pycurl-7.43.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by
(dev-libs/libxml2-2.9.8:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/ply-3.9:0/3.9::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ssl(+)] required by
(sys-apps/portage-2.3.79:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ncurses,sqlite,ssl,threads]
required by (dev-lang/spidermonkey-38.3.0:38/38::dantrell-gnome,
installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(virtual/python-ipaddress-1.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-util/gtk-doc-1.25-r1:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-vcs/git-2.18.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[ssl(+)] required by
(dev-python/urllib3-1.22:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/chardet-3.0.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/certifi-2018.4.16:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/extras-1.0.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(app-text/gnome-doc-utils-0.20.10-r1:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/m2crypto-0.24.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(app-crypt/mit-krb5-1.16-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(net-libs/telepathy-glib-0.24.1:0/0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by
(dev-lang/spidermonkey-1.8.5-r6:0/mozjs185::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(media-libs/clutter-gst-3.0.26:3.0/3.0::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/asn1crypto-0.22.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(media-libs/gexiv2-0.10.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by
(dev-util/itstool-2.0.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by
(dev-python/setuptools-36.7.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by
(sys-libs/talloc-2.1.9:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(app-emulation/virtualbox-5.2.14-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pyblake2-1.1.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pyatspi-2.24.0:0/0::dantrell-gnome-3-24, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/python-mimeparse-1.6.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+),threads(+)] required by
(sys-apps/portage-2.3.79:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pygments-2.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/bz2file-0.98:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/requests-2.18.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/ipaddress-1.0.19:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/PySocks-1.6.7:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/cffi-1.11.4:0/1.11.4::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(net-wireless/crda-3.18-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(x11-base/xcb-proto-1.13:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(media-libs/mesa-18.1.9:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/dbus-python-1.2.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(sys-devel/clang-6.0.1:6/6::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/linecache2-1.0.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(app-portage/gemato-14.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/idna-2.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(sys-devel/llvm-6.0.1:6/6::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(net-libs/webkit-gtk-2.22.2:4/37::dantrell-gnome, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(net-im/telepathy-logger-0.8.2:0/3::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(sys-libs/compiler-rt-sanitizers-6.0.1:6.0.1/6.0.1::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by
(gnome-base/gconf-3.2.6-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/unittest2-1.1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/six-1.11.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by
(sys-libs/tdb-1.3.13:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by
(dev-python/pyopenssl-17.5.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+),xml(+)] required by
(net-fs/samba-4.5.16:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by
(app-portage/layman-2.4.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-java/java-config-2.2.0-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/fixtures-3.0.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by
(dev-python/pycparser-2.14:0/0::gentoo, installed)


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8123
Location: Austria

PostPosted: Sun Dec 06, 2020 8:47 am    Post subject: Reply with quote

Updating portage alone does not work during a python target switch because it depends on python libraries with the correct (to be updated) target itself, just ignore the advice this time.

Also,
Code:
 * IMPORTANT: 28 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sun Dec 06, 2020 4:11 pm    Post subject: Reply with quote

Hi,
So what should I do?
Unmerge python, merge it again and then update portage?
Or better question is - how to proceed?

My main goal is not to update system, but just virtualbox...

Thank you.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 4644
Location: Illinois, USA

PostPosted: Sun Dec 06, 2020 5:57 pm    Post subject: Reply with quote

Updating only a piece of your system will get you a world of hurt.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sun Dec 06, 2020 6:30 pm    Post subject: Reply with quote

Hi,
As a developer, I prefer to stay with the system, unless absolutely necessary.

Besides, VirtualBox is not part of the system.

Thank you.
Back to top
View user's profile Send private message
GDH-gentoo
l33t
l33t


Joined: 20 Jul 2019
Posts: 620
Location: South America

PostPosted: Sun Dec 06, 2020 8:16 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
Unmerge python, merge it again and then update portage?
You can't uninstall Python, Portage depends on it.

ONEEYEMAN wrote:
My main goal is not to update system, but just virtualbox...
You can try doing emerge --update virtualbox{,-modules,-extpack-oracle} and see what happens... but I doubt you'll have any luck: app-emulation/virtualbox is affected by PYTHON_SINGLE_TARGET.

On the other hand, you know that Gentoo is rolling release, right? Not updating the system is not a feasible goal in the long term.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8123
Location: Austria

PostPosted: Sun Dec 06, 2020 8:29 pm    Post subject: Reply with quote

No, that doesn't work, because the virtualbox build requires python, and the previous `emerge --sync` has changed the default python target. To continue being able to emerge any single python-depending package (without performing the required world upgrade) would require the user to manually change back that python target from 3_8 to 3_7.

ONEEYEMAN wrote:
Besides, VirtualBox is not part of the system.

You install it via Portage, so it is part of the system. You may not use Portage, then it is not part of 'that' system.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Sun Dec 06, 2020 10:32 pm    Post subject: Reply with quote

Hi, guys,
OK, so what is the best course of action?
Update python first? Is there safe way to do that?
Then update Portage and VB, right?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Mon Dec 07, 2020 9:35 am    Post subject: Reply with quote

Hi, guys,
I found this: https://www.gentoo.org/support/news-items/2020-04-22-python3-7.html, but it says that not everything is converted.

Is the way recommended there, i.e.

Code:

  emerge --depclean
  emerge -1vUD @world
  emerge --depclean


will take care of all updates, including Portage and VirtualBox?

Thank you.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 4644
Location: Illinois, USA

PostPosted: Mon Dec 07, 2020 3:44 pm    Post subject: Reply with quote

I would put "-a" into each of those, just in case it wants to do something weird.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Mon Dec 07, 2020 7:10 pm    Post subject: Reply with quote

Hi,
Weird as it:

Code:

IgorReinCloud /var/lib/layman/dantrell-gnome/eclass # echo $PYTHON_TARGETS

IgorReinCloud /var/lib/layman/dantrell-gnome/eclass # emerge --info | grep -i python
Portage 2.3.79 (python 3.6.5-final-0, targets/desktop/gnome/3.24, gcc-7.3.0, glibc-2.26-r7, 4.14.65-gentoo x86_64)
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
USE="acl acpi alsa amd64 berkdb bzip2 cli colord crypt dbus dri dvd elogind firefox gdbm gnome gnome-keyring gnome-online-accounts gtk gtk3 gtkstyle iconv introspection ipv6 libnotify libtirpc multilib nautilus ncurses nls nptl openmp pam pcre policykit pulseaudio readline seccomp split-usr ssl tcpd tracker unicode wxwidgets xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python2_7 python3_8" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
IgorReinCloud /var/lib/layman/dantrell-gnome/eclass #


So, I guess the variable is not exported and used only in the emerge...

Anyway trying the first command I got:

Code:

IgorReinCloud /var/lib/layman/dantrell-gnome/eclass # emerge -a --depclean

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!

!!! The following installed packages are masked:
- dev-libs/gobject-introspection-1.52.1::dantrell-gnome-3-24 (masked by: invalid: DEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 5 in '/var/db/pkg/dev-libs/gobject-introspection-1.52.1/DEPEND', invalid: RDEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 5 in '/var/db/pkg/dev-libs/gobject-introspection-1.52.1/RDEPEND')
- media-sound/gnome-music-3.24.2::dantrell-gnome-3-24 (masked by: invalid: DEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 12 in '/var/db/pkg/media-sound/gnome-music-3.24.2/DEPEND', invalid: RDEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 12 in '/var/db/pkg/media-sound/gnome-music-3.24.2/RDEPEND')
- media-video/totem-3.24.0::dantrell-gnome-3-24 (masked by: invalid: DEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 42 in '/var/db/pkg/media-video/totem-3.24.0/DEPEND', invalid: RDEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 42 in '/var/db/pkg/media-video/totem-3.24.0/RDEPEND')
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=app-arch/gcab-1.0 pulled in by:
 *     dev-libs/appstream-glib-0.6.13
 *
 *   acct-group/input pulled in by:
 *     sys-fs/eudev-3.2.5
 *
 *   acct-group/kvm pulled in by:
 *     sys-fs/eudev-3.2.5
 *
 *   >=x11-apps/mkfontscale-1.2.0 pulled in by:
 *     x11-base/xorg-x11-7.4-r3
 *
 *   acct-group/render pulled in by:
 *     sys-fs/eudev-3.2.5
 *
 *   acct-group/plugdev pulled in by:
 *     net-wireless/gnome-bluetooth-3.20.1
 *
 *   >=gnome-extra/gnome-tweak-tool-3.24.0 pulled in by:
 *     gnome-base/gnome-extra-apps-3.24.0
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
 *
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 *
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the repository, since it may not
 * be possible to satisfy their dependencies.
IgorReinCloud /var/lib/layman/dantrell-gnome/eclass #


So presumably I should start with the second command in that suggestion?

Thank you.
Back to top
View user's profile Send private message
GDH-gentoo
l33t
l33t


Joined: 20 Jul 2019
Posts: 620
Location: South America

PostPosted: Mon Dec 07, 2020 8:24 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
So, I guess the variable is not exported and used only in the emerge...
Yes.

ONEEYEMAN wrote:
Anyway trying the first command I got:
[...]
It is a consequence of your system being outdated.

ONEEYEMAN wrote:
So presumably I should start with the second command in that suggestion?
Which one? This one?
Code:
emerge -1vUD @world
It will try to rebuild all packages that have differing USE flag settings, and this should help migrating Python packages from 3.6 to 3.8, but might also rebuild unrelated packages. Add --pretend and see what it wants to do.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Mon Dec 07, 2020 8:31 pm    Post subject: Reply with quote

Hi,
GDH-gentoo wrote:

ONEEYEMAN wrote:

So, I guess the variable is not exported and used only in the emerge...

Yes.

Thx for confirming.

GDH-gentoo wrote:

ONEEYEMAN wrote:

Anyway trying the first command I got:
[...]

It is a consequence of your system being outdated.

ONEEYEMAN wrote:

So presumably I should start with the second command in that suggestion?

Which one? This one?
Code:

emerge -1vUD @world


Yes.

GDH-gentoo wrote:

It will try to rebuild all packages that have differing USE flag settings, and this includes migration of Python packages fron 3.6 to 3.8, but might also rebuild unrelated packages. Add --pretend and see what it wants to do.


Will do.

Thx.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Mon Dec 07, 2020 9:27 pm    Post subject: Reply with quote

Hi,
So running this command I got following:

Code:

IgorReinCloud /var/lib/layman/dantrell-gnome/eclass # emerge -1vUD --pretend @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1g:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/openssl-1.0.2p:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0= required by (net-misc/wget-1.19.5:0/0::gentoo, installed)
                    ^^^^^                                                                                             
    dev-libs/openssl:0/0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
                    ^^^^^                                                                                                                   
    dev-libs/openssl:0/0= required by (x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo, installed)
                    ^^^^^                                                                                                             
    (and 1 more with the same problems)

sys-kernel/linux-headers:0

  (sys-kernel/linux-headers-4.13:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-kernel/linux-headers-5.4-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-kernel/linux-headers-4.14 required by (sys-apps/shadow-4.8-r5:0/0::gentoo, ebuild scheduled for merge)
    ^^                         ^^^^                                                                                                                                   

media-libs/openjpeg:2

  (media-libs/openjpeg-2.3.0:2/7::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/openjpeg-2.3.1-r1:2/7::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/openjpeg-2.3.0-r1:2= required by (app-text/poppler-0.90.1:0/101::dantrell-gnome, ebuild scheduled for merge)
    ^^                    ^^^^^^^^^^^                                                                                                                                                                 

dev-qt/qtcore:5

  (dev-qt/qtcore-5.15.1-r1:5/5.15.1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.15.1:5= required by (dev-qt/qtgui-5.15.1-r1:5/5.15.1::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^^^                                                                                                                                                           
    (and 2 more with the same problem)

  (dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtxml-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 7 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.15.1-r1:5/5.15.1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.15.1[gles2-only=,png=,X?] required by (dev-qt/qtwidgets-5.15.1:5/5.15::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^                                                                                                                                                             
    (and 1 more with the same problem)

  (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.9.6[-gles2,png,xcb] required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                                                                                       
    (and 4 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.9.6[-gles2] required by (dev-qt/qtopengl-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                                                                           
    (and 1 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.6:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                                                                 

  (dev-qt/qtdbus-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.15.1 required by (dev-qt/qtgui-5.15.1-r1:5/5.15.1::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                         

net-dns/libidn2:0

  (net-dns/libidn2-2.0.4:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-dns/libidn2-2.3.0:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-dns/libidn2-2.3.0 required by (sys-libs/glibc-2.32-r2:2.2/2.2::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^                                                                                                                                       

x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.8-r1:0/1.20.8::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.20[udev] required by (x11-base/xorg-drivers-1.20-r2:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                 
    (and 1 more with the same problem)

  (x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.19.5= required by (x11-drivers/xf86-input-synaptics-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    x11-base/xorg-server:0/1.19.5= required by (x11-drivers/xf86-input-libinput-0.27.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed): ebuild is masked or unavailable
  (app-arch/libarchive-3.3.1:0/13::gentoo, installed): ebuild is masked or unavailable
  (net-misc/wget-1.19.5:0/0::gentoo, installed): ebuild is masked or unavailable
  (x11-drivers/xf86-input-libinput-0.27.1:0/0::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/mesa-20.1.10::gentoo
# required by x11-base/xorg-server-1.20.8-r1::gentoo[-minimal]
# required by x11-drivers/xf86-video-ati-19.1.0::gentoo
# required by x11-base/xorg-drivers-1.20-r2::gentoo[video_cards_radeon,-video_cards_radeonsi]
# required by x11-base/xorg-server-1.19.5-r2::gentoo
# required by x11-drivers/xf86-input-libinput-0.27.1::gentoo
>=media-libs/libglvnd-1.3.2-r2 X

!!! The following updates are masked by LICENSE changes:
- media-fonts/font-bh-type1-1.0.3-r2::gentoo (masked by: bh-luxi license(s))
A copy of the 'bh-luxi' license is located at '/usr/portage/licenses/bh-luxi'.

- sys-kernel/linux-firmware-20201022-r3::gentoo (masked by: || ( ) linux-fw-redistributable no-source-code license(s))
A copy of the 'linux-fw-redistributable' license is located at '/usr/portage/licenses/linux-fw-redistributable'.

A copy of the 'no-source-code' license is located at '/usr/portage/licenses/no-source-code'.

- media-fonts/font-bh-ttf-1.0.3-r2::gentoo (masked by: bh-luxi license(s))
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- dev-libs/gobject-introspection-1.52.1::dantrell-gnome-3-24 (masked by: invalid: DEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 5 in '/var/db/pkg/dev-libs/gobject-introspection-1.52.1/DEPEND', invalid: RDEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 5 in '/var/db/pkg/dev-libs/gobject-introspection-1.52.1/RDEPEND')
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=gnome-base/gnome-shell-3.24.0[bluetooth?]" has unmet requirements.
- gnome-base/gnome-shell-3.24.3-r1::dantrell-gnome-3-24 USE="bluetooth elogind ibus networkmanager -browser-extension -deprecated-background -nsplugin (-systemd) -vanilla-gc -vanilla-motd -vanilla-screen" ABI_X86="(64)" PYTHON_TARGETS="-python3_6 -python3_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_targets_python3_6 python_targets_python3_7 )

  The above constraints are a subset of the following complete expression:
    any-of ( python_targets_python3_6 python_targets_python3_7 ) at-most-one-of ( elogind systemd )

(dependency required by "gnome-base/gnome-3.24.0::dantrell-gnome-3-24" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 28 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.



I should probably uninstall openssl, linux-headers, qt,*, libidn2 and try again.

However, I'm less sure about xorg.

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8123
Location: Austria

PostPosted: Mon Dec 07, 2020 9:29 pm    Post subject: Reply with quote

Don't uninstall *anything* there. Just properly read this ouput. Your problem comes from an overlay and it seems to be extremely outdated.

Code:
!!! The following installed packages are masked:
- dev-libs/gobject-introspection-1.52.1::dantrell-gnome-3-24 (masked by: invalid: DEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 5 in '/var/db/pkg/dev-libs/gobject-introspection-1.52.1/DEPEND', invalid: RDEPEND: Invalid atom (Invalid use dep: '%PYTHON_USEDEP-NEEDS-TO-BE-USED-IN-PYTHON_GEN_COND_DEP%'), token 5 in '/var/db/pkg/dev-libs/gobject-introspection-1.52.1/RDEPEND')
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=gnome-base/gnome-shell-3.24.0[bluetooth?]" has unmet requirements.
- gnome-base/gnome-shell-3.24.3-r1::dantrell-gnome-3-24 USE="bluetooth elogind ibus networkmanager -browser-extension -deprecated-background -nsplugin (-systemd) -vanilla-gc -vanilla-motd -vanilla-screen" ABI_X86="(64)" PYTHON_TARGETS="-python3_6 -python3_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_targets_python3_6 python_targets_python3_7 )

  The above constraints are a subset of the following complete expression:
    any-of ( python_targets_python3_6 python_targets_python3_7 ) at-most-one-of ( elogind systemd )

(dependency required by "gnome-base/gnome-3.24.0::dantrell-gnome-3-24" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2846

PostPosted: Mon Dec 07, 2020 10:12 pm    Post subject: Reply with quote

Hi,
So, what is the proper course of action here.

I updated both main tree and the overlay.

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8123
Location: Austria

PostPosted: Mon Dec 07, 2020 10:34 pm    Post subject: Reply with quote

Well, get rid of the overlay if the problem remains.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
GDH-gentoo
l33t
l33t


Joined: 20 Jul 2019
Posts: 620
Location: South America

PostPosted: Mon Dec 07, 2020 10:43 pm    Post subject: Reply with quote

Or, at least, start by trying to update dev-libs/gobject-introspection and gnome-base/gnome-shell from Dantrell's repository. The installed versions have problems with Python dependencies.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum