Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgrade Mongodb from 3.6 to 4.2 for Unifi Controller
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dewhite
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2003
Posts: 93
Location: Houston, Texas, USA

PostPosted: Mon Nov 23, 2020 9:42 pm    Post subject: Upgrade Mongodb from 3.6 to 4.2 for Unifi Controller Reply with quote

Hello all,

It seems I've made a little mess. I run Unifi Controller on two Gentoo systems (home and small business). I recently upgraded both setups to version 6.1.21, which pulled in an update of Mongodb from 3.6.X to 4.2.8. After the updates, I later noticed that Unifi Controller isn't starting, and I troubleshot that to an error in /var/log/unifi/mongodb.log that reads, in part:

Code:
2020-11-23T15:32:52.803-0600 F  CONTROL  [initandlisten] ** IMPORTANT: UPGRADE PROBLEM: Found an invalid featureCompatibilityVersion document (ERROR: BadValue: Invalid value for version, found 3.6, expected '4.2' or '4.0'. Contents of featureCompatibilityVersion document in admin.system.version: { _id: "featureCompatibilityVersion", version: "3.6" }. See https://docs.mongodb.com/manual/release-notes/4.2-compatibility/#feature-compatibility.). If the current featureCompatibilityVersion is below 4.0, see the documentation on upgrading at https://docs.mongodb.com/manual/release-notes/4.2/#upgrade-procedures.


Easy, right? Just read the docs and upgrade the db file. Small wrinkle - Mongodb seems to require that 3.6 be upgraded to 4.0, then 4.0 to 4.2. OK, no problem.

Wait. All 3.6.X and 4.0.X packages have been masked, because:

Code:
Mask dev-db/mongodb versions which do not support python3 so we can move forward in cleaning python2 from tree. Bug #708954. We keep the ebuilds available since some of those versions are still supported by upstream. See: https://jira.mongodb.org/browse/SERVER-52687
Affected packages
<dev-db/mongodb-4.2.8
Author/Date
Alexys Jacob <ultrabug@gentoo.org> (2020-11-09 00:00:00 +0000 UTC)


Before I started monkeying around under the hood to try to bypass the masks and "downgrade" to a 4.0.X package temporarily, I thought I'd ask for any practical advice the community is willing/able to offer.

Bonus Points: I've already completed the update to Profile 17.1 on one of these systems (of course, on the system with the more elaborate and critical Unifi setup). The other is still on Profile 17.0. Not sure if that matters, but it seemed at least tangentially related...

As always - any thoughts, suggestions, questions, references, rants, etc. will be greatly appreciated.

Thanks,

Dan
_________________
Work WS: R7-1700x | 2x8Gb DDR4 | GT1030 | 275Gb & 1Tb SSD Root/Home
Work FS: i5-6500 | 8Gb DDR4 | 275Gb SSD | 3x 1TB RAID5
Home WS: NUC7i5BNH | 2x8Gb DDR4 | 275Gb SSD
Home FS: FX-8320e | 8Gb DDR3 | 8400GS | 4x 5TB RAID5
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16464

PostPosted: Mon Nov 23, 2020 10:47 pm    Post subject: Reply with quote

Moved from Other Things Gentoo to Duplicate Threads because the OP cross-posted the request to P&P as Temporarily downgrade Mongodb to masked 4.0.X.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum