Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problème 1er boot après install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
polo_c_moi
n00b
n00b


Joined: 22 Nov 2020
Posts: 3

PostPosted: Sat Nov 28, 2020 5:45 pm    Post subject: problème 1er boot après install Reply with quote

bonjour,

j'essaie d'installer gentoo sur un desktop amd 3000g.
Malheureusement il n'a jamais booter correctement, il reste bloqué.
Je crois avoir trouvé une piste, le problème viendrait du drivers AMD.
dans le fichier kern.log je vois :
Nov 15 16:43:15 tux kernel: [ 7.219931] amdgpu 0000:0a:00.0: Direct firmware load for amdgpu/raven2_gpu_info.bin failed with error -2
Nov 15 16:43:15 tux kernel: [ 7.219932] amdgpu 0000:0a:00.0: Failed to load gpu_info firmware "amdgpu/raven2_gpu_info.bin"
Nov 15 16:43:15 tux kernel: [ 7.219933] amdgpu 0000:0a:00.0: Fatal error during GPU init
Nov 15 16:43:15 tux kernel: [ 7.219934] [drm] amdgpu: finishing device.
Nov 15 16:43:15 tux kernel: [ 7.219941] ------------[ cut here ]------------
....
Effectivement je ne trouve pas raven2_gpu_info.bin
J'ai alors suivi les recommandations trouvées ici : https://wiki.gentoo.org/wiki/AMDGPU
Ca n'a rien apporté

ne serait-il pas possible de déposer le fichier raven2_gpu_info.bin à la main?
où pourrais-je le trouver et où le trouver?

Merci de votre aide
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 801
Location: S.O. France

PostPosted: Sun Nov 29, 2020 8:56 am    Post subject: Reply with quote

Tu as bien installé linux-firmware ?
Si oui poste la config de ton noyau et emerge --info

Quote:
Malheureusement il n'a jamais booter correctement, il reste bloqué.

A quel niveau? Tu n'a rien d'autre dans le dmesg?
Back to top
View user's profile Send private message
polo_c_moi
n00b
n00b


Joined: 22 Nov 2020
Posts: 3

PostPosted: Sun Nov 29, 2020 5:18 pm    Post subject: Reply with quote

Bonjour merci, je te réponds asap
Back to top
View user's profile Send private message
polo_c_moi
n00b
n00b


Joined: 22 Nov 2020
Posts: 3

PostPosted: Tue Dec 01, 2020 12:34 pm    Post subject: Reply with quote

bonjour,
désolé de ne pas avoir répondu plus tôt.
depuis la dernière fois j'ai essayé de corriger tout seul, j'ai tout cassé.
je suis en cours de réinstallation, je prends mon temps.
merci
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 28
Location: France

PostPosted: Wed Dec 02, 2020 10:46 am    Post subject: Reply with quote

Salut,

Le fichier raven2.gpu_info.bin est un firmware, tu dois l'installer avant de compiler ton noyau.

Avant le l'installer active le USE flag : initramfs pour le paquet linux-firmware

echo "sys-kernel/linux-firmware initramfs" >> /etc/portage/package.use/linux-firmware.use

Puis

emerge -av --quiet-build linux-firmware


Par contre pourrais tu me donner les informations suivantes :

La version de ton noyau :
Comment tu le compiles lors de l'installation : via genkernel ou manuellement ? Si tu le compiles manuellement tu mets les firmwares en dur ?
Si tu l'as compilé manuellement, peux tu faire un pastebin avec ton fichier .config afin qu'on voit quelles options de compilation tu as utilisées ?

Bon courage,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum