Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
H265 : no hw decoder (core i7-6500U)???
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Thu Oct 22, 2020 8:39 am    Post subject: H265 : no hw decoder (core i7-6500U)??? Reply with quote

Hi,
I'm a little bit puzzled... my laptop is a i7-6500U, I've 4k videos, 60fps, made with a gopro....
I tried both with vlc and mpv, each time I can see the video but soooooooo laggy... I always finish by dropping frames...

I don't know what codec is used by theses 2 players, but when I 'emerge --search 265' I see media-libs/x265 installed, media-libs/libde265 not installed

I don't know how to get a reverse dependency tree (list all packages that are linked with this library

I tried to activate vaapi vdpau cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_mmx cpu_flags_x86_mmxext cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 cpu_flags_x86_xop cpudetection in ffmpeg... still no luck....

I'm a bit surprised that a i7 can't decode smoothly a hevc...

any help?
thanks
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 48133
Location: 56N 3W

PostPosted: Thu Oct 22, 2020 8:52 am    Post subject: Reply with quote

jlm_devel,

What video card do you have?
Code:
lspci -nnk


What video card driver are you actually using?
Code:
wgetpaste /var/log/Xorg.0.log
and tell us the link.

What does
Code:
glxinfo | head -n4
say about direct rendering: ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Thu Oct 22, 2020 2:05 pm    Post subject: Reply with quote

NeddySeagoon wrote:
jlm_devel,

What video card do you have?
Code:
lspci -nnk


Code:
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07)
   Subsystem: Lenovo Skylake GT2 [HD Graphics 520] [17aa:3800]
   Kernel driver in use: i915
   Kernel modules: i915


NeddySeagoon wrote:

What video card driver are you actually using?
Code:
wgetpaste /var/log/Xorg.0.log
and tell us the link.

https://drive.google.com/file/d/1lNU20bop9A1S0gc6Hsn6k-W4yS95fAm2/view?usp=sharing

NeddySeagoon wrote:

What does
Code:
glxinfo | head -n4
say about direct rendering: ?

Code:

name of display: :1.0
display: :1  screen: 0
direct rendering: Yes
server glx vendor string: SGI
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 48133
Location: 56N 3W

PostPosted: Thu Oct 22, 2020 2:07 pm    Post subject: Reply with quote

jlm_devel,

Please don't use Google Drive. It says "You need access"

wgetpaste just works.

The other stuff looks good.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2789
Location: Frankfurt, Germany

PostPosted: Thu Oct 22, 2020 3:41 pm    Post subject: Reply with quote

Please post the output of
Code:
emerge --info
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Thu Oct 22, 2020 5:06 pm    Post subject: Reply with quote

didn't knew about wgetpaste.... here is the link for xorg log : https://dpaste.com/HB5E6LDV4
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Thu Oct 22, 2020 5:09 pm    Post subject: Reply with quote

Code:
# emerge --info
Unavailable repository 'raiagent' referenced by masters entry in '/var/lib/layman/waebbl/metadata/layout.conf'
Portage 3.0.8 (python 3.7.9-final-0, default/linux/amd64/17.0/desktop, gcc-9.3.0, glibc-2.32-r2, 5.6.8-gentoo-x86_64 x86_64)
=================================================================
System uname: Linux-5.6.8-gentoo-x86_64-x86_64-Intel-R-_Core-TM-_i7-6500U_CPU_@_2.50GHz-with-gentoo-2.7
KiB Mem:    16299948 total,   4877800 free
KiB Swap:   17407996 total,  14209560 free
Timestamp of repository gentoo: Sat, 26 Sep 2020 00:45:01 +0000
Head commit of repository gentoo: 057d8d76981d95366ddfc0bf13d1d68456af8140
sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18-r3::gentoo, 3.6.10-r2::gentoo, 3.7.9::gentoo, 3.8.6::gentoo, 3.9.0_rc2::gentoo
dev-util/cmake:           3.18.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.34-r2::gentoo, 2.35.1::gentoo
sys-devel/gcc:            8.3.0-r3::gentoo, 9.3.0::gentoo, 10.2.0-r1::gentoo
sys-devel/gcc-config:     2.3.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: no
    sync-rsync-verify-max-age: 24

science
    location: /var/lib/layman/science
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/proj/sci.git
    masters: gentoo
    priority: 50

waebbl
    location: /var/lib/layman/waebbl
    sync-type: laymansync
    sync-uri: https://github.com/waebbl/waebbl-gentoo.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/ http://gentoo.mirrors.ovh.net/gentoo-distfiles/ ftp://gentoo.mirrors.ovh.net/gentoo-distfiles/ ftp://mirrors.soeasyto.com/distfiles.gentoo.org/ http://mirrors.soeasyto.com/distfiles.gentoo.org/ rsync://mirror.eu.oneandone.net/gentoo/ http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/ http://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp.halifax.rwth-aachen.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://ftp-stud.hs-esslingen.de/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus dri dts dvd dvdr elogind emboss encode exif flac fortran gdbm gif glamor gpm gtk gui iconv icu ipv6 jpeg lcms libglvnd libnotify libtirpc mad mng mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt5 readline sdl seccomp spell split-usr ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="synaptics libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby27" USERLAND="GNU" VIDEO_CARDS="intel i965" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Thu Oct 22, 2020 5:23 pm    Post subject: Reply with quote

I tried to follow : https://github.com/mpv-player/mpv/issues/2912 but there is no vainfo tool.... I found vdpauinfo instead.... but....


Code:
# vdpauinfo
display: :1.0   screen: 0
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2789
Location: Frankfurt, Germany

PostPosted: Thu Oct 22, 2020 5:36 pm    Post subject: Reply with quote

The USE flag "vaapi" (Video Acceleration API) is missing. Add it to the list of USE flags in '/etc/portage/make.conf' and run
Code:
emerge --update --deep --changed-use -av @world

Please install vainfo:
Code:
emerge media-video/libva-utils

After that, run
Code:
vainfo

and post the result, please.

It should be something like:
Code:
libva info: VA-API version 1.8.0
libva info: Trying to open /usr/lib64/va/drivers/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.8 (libva 2.8.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Ivybridge Desktop - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD
Back to top
View user's profile Send private message
pietinger
l33t
l33t


Joined: 17 Oct 2006
Posts: 693
Location: Bavaria

PostPosted: Thu Oct 22, 2020 6:09 pm    Post subject: Reply with quote

jlm_devel wrote:
Code:
# emerge --info
[...] default/linux/amd64/17.0/desktop

It would be better if you use 17.1 !

Do it with "eselect profile set XX" and then do an "emerge -uUNDv @world --backtrack=99". After this reboot and check again your troubles.


P.S.: I have also an INTEL i7 skylake and you can set CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

You may check it with "emerge -1 cpuid2cpuflags" and then run it.


Last edited by pietinger on Thu Oct 22, 2020 6:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 48133
Location: 56N 3W

PostPosted: Thu Oct 22, 2020 6:12 pm    Post subject: Reply with quote

pietinger,

Its not that simple. There is a news item.
The on disk layout changes between 17.0 and 17.1
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pietinger
l33t
l33t


Joined: 17 Oct 2006
Posts: 693
Location: Bavaria

PostPosted: Thu Oct 22, 2020 6:19 pm    Post subject: Reply with quote

NeddySeagoon wrote:
pietinger,

Its not that simple. There is a news item.
The on disk layout changes between 17.0 and 17.1


Oh yes, thank you - but I thought this is a new installation (and he will do it again). In every case he needs 17.1 because troubles will get more in the future.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 48133
Location: 56N 3W

PostPosted: Thu Oct 22, 2020 6:44 pm    Post subject: Reply with quote

pietinger,

Agreed.
If the stage3 tarball was made with the /17.1/ profile, it needs to be /17.1/ all the way.
If it was a /17.0/ profile install, the process to do the switch needs to be followed.

Any other combination is a mess.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pietinger
l33t
l33t


Joined: 17 Oct 2006
Posts: 693
Location: Bavaria

PostPosted: Thu Oct 22, 2020 6:57 pm    Post subject: Reply with quote

NeddySeagoon wrote:
If it was a /17.0/ profile install, the process to do the switch needs to be followed.


Yes, Neddy - you are right (as always). I would recommend this link: https://www.gentoo.org/support/news-items/2019-06-05-amd64-17-1-profiles-are-now-stable.html
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Thu Oct 22, 2020 10:53 pm    Post subject: Reply with quote

thanks all for the help!

I still have the issue, but I noticed that there was some intel driver missing :

Code:

emerge x11-libs/libva-intel-media-driver x11-libs/libva-vdpau-driver media-video/libva-util


after this I could run vainfo :

Code:
$ vainfo
libva info: VA-API version 1.8.0
libva info: Trying to open /usr/lib64/va/drivers/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.8 (libva 2.8.0)
vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.2.0 ()
vainfo: Supported profile and entrypoints
      VAProfileNone                   :   VAEntrypointVideoProc
      VAProfileNone                   :   VAEntrypointStats
      VAProfileMPEG2Simple            :   VAEntrypointVLD
      VAProfileMPEG2Simple            :   VAEntrypointEncSlice
      VAProfileMPEG2Main              :   VAEntrypointVLD
      VAProfileMPEG2Main              :   VAEntrypointEncSlice
      VAProfileH264Main               :   VAEntrypointVLD
      VAProfileH264Main               :   VAEntrypointEncSlice
      VAProfileH264Main               :   VAEntrypointFEI
      VAProfileH264Main               :   VAEntrypointEncSliceLP
      VAProfileH264High               :   VAEntrypointVLD
      VAProfileH264High               :   VAEntrypointEncSlice
      VAProfileH264High               :   VAEntrypointFEI
      VAProfileH264High               :   VAEntrypointEncSliceLP
      VAProfileVC1Simple              :   VAEntrypointVLD
      VAProfileVC1Main                :   VAEntrypointVLD
      VAProfileVC1Advanced            :   VAEntrypointVLD
      VAProfileJPEGBaseline           :   VAEntrypointVLD
      VAProfileJPEGBaseline           :   VAEntrypointEncPicture
      VAProfileH264ConstrainedBaseline:   VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:   VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:   VAEntrypointFEI
      VAProfileH264ConstrainedBaseline:   VAEntrypointEncSliceLP
      VAProfileVP8Version0_3          :   VAEntrypointVLD
      VAProfileHEVCMain               :   VAEntrypointVLD
      VAProfileHEVCMain               :   VAEntrypointEncSlice
      VAProfileHEVCMain               :   VAEntrypointFEI


will try mike155 solution, and also see what it cost to switch to the new profile...

mike solution will be done during the night.... will see the result tomorow
Back to top
View user's profile Send private message
pietinger
l33t
l33t


Joined: 17 Oct 2006
Posts: 693
Location: Bavaria

PostPosted: Thu Oct 22, 2020 11:27 pm    Post subject: Reply with quote

jlm_devel wrote:
emerge x11-libs/libva-intel-media-driver

Hui ... how did you manage to emerge a masked package ? :roll:

I have "x11-libs/libva-intel-driver" instead and also - because it is an old installation - "x11-drivers/xf86-video-intel" (see more for this here: https://wiki.gentoo.org/wiki/Intel#Intel_DDX ). vainfo gives me:
Code:
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib64/va/drivers/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.5.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.4.1
[...]

When I watch a real 4k-movie (on my 43"-4k-monitor) with VLC all 8 cpu cores remain below 5 % ...

P.S.: I have in my make.conf: "VIDEO_CARDS="intel i965 iris" (but I think "iris" is only for mesa).
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2789
Location: Frankfurt, Germany

PostPosted: Fri Oct 23, 2020 12:21 am    Post subject: Reply with quote

Quote:
Hui ... how did you manage to emerge a masked package ? :roll:

Code:
ACCEPT_KEYWORDS="amd64 ~amd64"
Back to top
View user's profile Send private message
pietinger
l33t
l33t


Joined: 17 Oct 2006
Posts: 693
Location: Bavaria

PostPosted: Fri Oct 23, 2020 12:52 am    Post subject: Reply with quote

Hi Mike,

Thank you ... yes I knew that. I did something wrong when I looked for it, I got:
Code:
*  x11-libs/libva-intel-media-driver [ Masked ]
      Latest version available: 9999
      Latest version installed: [ Not Installed ]

and 9999 you cannot install with ~amd64; I didnt saw version 20.2.0 8O ... :oops: (time to go to bed)
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Fri Oct 23, 2020 8:27 am    Post subject: Reply with quote

pietinger wrote:
jlm_devel wrote:
emerge x11-libs/libva-intel-media-driver

Hui ... how did you manage to emerge a masked package ? :roll:

I have "x11-libs/libva-intel-driver" instead and also - because it is an old installation - "x11-drivers/xf86-video-intel" (see more for this here: https://wiki.gentoo.org/wiki/Intel#Intel_DDX ). vainfo gives me:
Code:
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib64/va/drivers/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.5.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.4.1
[...]

When I watch a real 4k-movie (on my 43"-4k-monitor) with VLC all 8 cpu cores remain below 5 % ...

P.S.: I have in my make.conf: "VIDEO_CARDS="intel i965 iris" (but I think "iris" is only for mesa).


- according to the wiki, the DDX driver isn't maintained anymore... but has better performance.... what should I do?

- you have Trying to open /usr/lib64/va/drivers/i965_drv_video.so in your output, that I don't have... maybe the root cause?

- same for Driver version: Intel i965 driver for Intel(R) Skylake - 2.4.1, I have Driver version: Intel iHD driver for Intel(R) Gen Graphics - 20.2.0

- according to wiki, adding iris is for gen8+, seems that the i7-6500U is gen 6.... is there any i7-6500U user here? maybe the wiki is wrong????
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2789
Location: Frankfurt, Germany

PostPosted: Fri Oct 23, 2020 9:12 am    Post subject: Reply with quote

Quote:
- according to wiki, adding iris is for gen8+, seems that the i7-6500U is gen 6.... is there any i7-6500U user here? maybe the wiki is wrong????

Wait... Intel says the i7-6500U is a Skylake CPU (https://ark.intel.com/content/www/us/en/ark/products/88194/intel-core-i7-6500u-processor-4m-cache-up-to-3-10-ghz.html). And https://wiki.gentoo.org/wiki/Intel says that VIDEO_CARDS should be "intel i965 iris" for Skylake CPUs.

Don't be confused by the generation numbers... There's a generation for the CPU and a different generation for the GPU. The i7-6500U is a 6th generation processor, but it has a Gen 9 GPU...

Have you added the "vaapi" USE Flag to make.conf and re-emerged affected packages (see my post above)?

Please read the section "Firmware" on https://wiki.gentoo.org/wiki/Intel.
Quote:
Systems using Skylake, Broxton or newer Intel graphics will need to install additional firmware[1] from sys-kernel/linux-firmware package:
Back to top
View user's profile Send private message
Anon-E-moose
Watchman
Watchman


Joined: 23 May 2008
Posts: 5245
Location: Dallas area

PostPosted: Fri Oct 23, 2020 10:05 am    Post subject: Reply with quote

the cpu part of the chip is powerful, but the gpu is ... a little lacking

Quote:
The i7-6500U incorporates the Intel HD 520 integrated graphics, with a bit better performance than the older HD 5500. Still, it is just a basic integrated GPU which can run only light games and select demanding titles at lowest graphics detail settings.


Edit to add: from a thread on intel about the 520

Quote:
pipeCh: I just received an update on the research we are doing on this matter and just to let you know the Intel® Skylake processors support HW acceleration of VP9 videos at 4k only if it is 24fps, higher frame count will go via Software so depending on the video this would be expected behavior.

And they mention that some files they looked at worked smoothly and others didn't (have lag)

And this talking about the difference between skylake(520) and kabylake(620)
Quote:
The take home message here is that if HEVC/H.265 video encode/decode performance is a point of concern for you, then you’ll want to go with an Intel 7th Gen Kaby Lake processor for the additional decode block that was added this generation. This is a big deal for mobile users as the lower CPU utilization and GPU clock speeds means that you’ll have greatly improved battery life when watching videos. Kaby Lake also supports Google’s upcoming VP9 video coding format, so Intel 7th Gen Core processors are clearly the way to go for H.265 and VP9 video codecs.


In other words, you might just have to live with the hevc decode problems.
_________________
PRIME x570-pro, 3700x, RX 550 - 5.8 zen kernel
Acer E5-575 (laptop), i3-7100u - i965 - 5.5 zen kernel
---both---
gcc 9.3.0, profile 17.1 (no-pie) amd64-no-multilib, eudev, openrc, openbox

The New OTW
Back to top
View user's profile Send private message
pietinger
l33t
l33t


Joined: 17 Oct 2006
Posts: 693
Location: Bavaria

PostPosted: Fri Oct 23, 2020 11:18 am    Post subject: Reply with quote

Anon-E-moose wrote:
In other words, you might just have to live with the hevc decode problems.

No. I have no problems watching 4k (real 2160p with 60fps). As Mike said, he needs also the firmware drivers.

jlm_devel,

I wrote a guide for installing both: Firmware driver together with microcode update. You can read here: https://forums.gentoo.org/viewtopic-t-1065464.html

P.S.: Today it is i915/skl_dmc_ver1_27 !!


Last edited by pietinger on Fri Oct 23, 2020 11:24 am; edited 1 time in total
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Fri Oct 23, 2020 11:19 am    Post subject: Reply with quote

this isn't lag.... after 10s playback vlc, there is about 10s, audio drift, in fact for a 3 min video, it's about 10s frames decoded and the whole audio played...
mpv is a bit better, the image quality is bad, but the video is still playable...

will try to record one at 24fps, to see if this is the root cause...
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Fri Oct 23, 2020 11:33 am    Post subject: Reply with quote

mike155 wrote:
Quote:
- according to wiki, adding iris is for gen8+, seems that the i7-6500U is gen 6.... is there any i7-6500U user here? maybe the wiki is wrong????

Wait... Intel says the i7-6500U is a Skylake CPU (https://ark.intel.com/content/www/us/en/ark/products/88194/intel-core-i7-6500u-processor-4m-cache-up-to-3-10-ghz.html). And https://wiki.gentoo.org/wiki/Intel says that VIDEO_CARDS should be "intel i965 iris" for Skylake CPUs.

Don't be confused by the generation numbers... There's a generation for the CPU and a different generation for the GPU. The i7-6500U is a 6th generation processor, but it has a Gen 9 GPU...

Have you added the "vaapi" USE Flag to make.conf and re-emerged affected packages (see my post above)?

Please read the section "Firmware" on https://wiki.gentoo.org/wiki/Intel.
Quote:
Systems using Skylake, Broxton or newer Intel graphics will need to install additional firmware[1] from sys-kernel/linux-firmware package:


according to https://ark.intel.com/content/www/us/en/ark/products/series/88392/6th-generation-intel-core-i7-processors.html the GPU isn't a iris one... but according to https://www.techpowerup.com/gpu-specs/hd-graphics-520.c2783 it's a 9.0 generation... ok, will be next try... maybe the driver even if designed for iris GPU will perform better

yes, rebuild is in progress for vaapi flag in make.conf

I have the sys-kernel/linux-firmware installed, but can't grep in dmesg because it's totaly filled by i2c_designware i2c_designware.0: timeout waiting for bus ready, don't know how to fix this
Back to top
View user's profile Send private message
jlm_devel
n00b
n00b


Joined: 10 Nov 2007
Posts: 53

PostPosted: Fri Oct 23, 2020 11:39 am    Post subject: Reply with quote

Code:
Device Drivers  --->
    Generic Driver Options  --->
            Firmware loader  --->
                -*- Firmware loading facility
                (i915/skl_dmc_ver1_27.bin) Build named firmware blobs into the kernel binary
                (/lib/firmware) Firmware blobs root directory


will also try this....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum