Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202010-06 ] Ark
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2487

PostPosted: Tue Oct 20, 2020 2:26 pm    Post subject: [ GLSA 202010-06 ] Ark Reply with quote

Gentoo Linux Security Advisory

Title: Ark: Arbitrary code execution (GLSA 202010-06)
Severity: normal
Exploitable: local, remote
Date: 2020-10-20
Bug(s): #743959
ID: 202010-06

Synopsis

Ark was found to allow arbitrary file overwrite, possibly allowing
arbitrary code execution.


Background

Ark is a graphical file compression/decompression utility with support
for multiple formats.


Affected Packages

Package: kde-apps/ark
Vulnerable: < 20.04.3-r2
Unaffected: >= 20.04.3-r2
Architectures: All supported architectures


Description

It was discovered that Ark incorrectly handled symbolic links in tar
archive files.


Impact

A remote attacker could entice a user to open a specially crafted
archive using Ark, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All KDE Ark users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=kde-apps/ark-20.04.3-r2"
   


References

CVE-2020-24654
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum