Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] cannot get X support for emacs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 57

PostPosted: Sun Oct 18, 2020 4:59 pm    Post subject: [SOLVED] cannot get X support for emacs Reply with quote

I recently updated @world and emacs works just inside the terminal. No way to get a separate window. The flags I used for the previous version (26) doesn't work

-motif athena -gtk Xaw3d -sound -alsa xft

I tried also

gtk

but nothing works

Code:
emerge --info emacs
Portage 3.0.8 (python 3.7.8-final-0, default/linux/amd64/17.0/desktop, gcc-9.3.0, glibc-2.31-r6, 4.19.82-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.82-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-gentoo-2.7
KiB Mem:    16174904 total,  14099440 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 17 Oct 2020 22:05:16 +0000
Head commit of repository gentoo: 07c57cbb223c95c2c4826f6ec8b6499f484228b6

Head commit of repository brother-overlay: c226f1d96c35357cf1a42f9c4ffb01ca59721493

Head commit of repository flatpak-overlay: 85b574e89510f6422e0e5177de99f8893eec6608

sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18-r4::gentoo, 3.6.11-r2::gentoo, 3.7.8-r2::gentoo, 3.8.5::gentoo
dev-util/cmake:           3.17.4-r1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo
sys-devel/gcc:            9.3.0-r1::gentoo
sys-devel/gcc-config:     2.3.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    priority: -1000

brother-overlay
    location: /usr/local/overlay/brother-overlay
    sync-type: git
    sync-uri: https://github.com/stefan-langenmaier/brother-overlay.git
    masters: gentoo

flatpak-overlay
    location: /scratch/flatpak-overlay
    sync-type: git
    sync-uri: https://github.com/fosero/flatpak-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms sign splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en it"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus dri dts dvd dvdr elogind emacs emboss encode exif flac fortran gdbm gif gpm gtk gui iconv icu ipv6 jpeg lcms libglvnd libnotify libtirpc lm_sensors mad mng mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt5 readline sdl seccomp spell split-usr ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput synaptics" KERNEL="linux" L10N="en it" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="intel i965 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-editors/emacs-27.1-r1::gentoo was built with the following:
USE="acl alsa cairo dbus gif gmp gpm gtk inotify jpeg lcms png ssl svg threads tiff xpm zlib -Xaw3d (-aqua) -athena -dynamic-loading -games -gconf -gfile -gsettings -gtk2 -gui -gzip-el -harfbuzz -imagemagick -json -kerberos -libxml2 -livecd -m17n-lib -mailutils -motif (-selinux) -sound -source -systemd -toolkit-scroll-bars -wide-int -xft -xwidgets" ABI_X86="(64)"


any idea?

thanks


Last edited by astor86 on Sun Oct 18, 2020 5:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ionen
Veteran
Veteran


Joined: 06 Dec 2018
Posts: 1612

PostPosted: Sun Oct 18, 2020 5:17 pm    Post subject: Reply with quote

Code:
-gui
GUI looks disabled, which seems surprising given it's in your global USE (default for desktop profile).
Back to top
View user's profile Send private message
CaptainBlood
Veteran
Veteran


Joined: 24 Jan 2010
Posts: 1999

PostPosted: Sun Oct 18, 2020 5:20 pm    Post subject: Reply with quote

Here's:
Code:
Installed versions:  26.3-r2(26)(14:16:12 16/10/2020)(gif gpm gui gzip-el imagemagick inotify jpeg libxml2 png sound ssl svg threads tiff toolkit-scroll-bars xft xpm -Xaw3d -acl -alsa -aqua -athena -cairo -dbus -dynamic-loading -games -gconf -gfile -gsettings -gtk -gtk2 -kerberos -lcms -livecd -m17n-lib -mailutils -motif -selinux -source -systemd -wide-int -xwidgets -zlib) 27.1-r1(27)^t(14:00:23 16/10/2020)(cairo gif gmp gpm gui gzip-el harfbuzz inotify jpeg libxml2 png sound ssl svg threads tiff toolkit-scroll-bars xft xpm -Xaw3d -acl -alsa -aqua -athena -dbus -dynamic-loading -games -gconf -gfile -gsettings -gtk -gtk2 -imagemagick -json -kerberos -lcms -livecd -m17n-lib -mailutils -motif -selinux -source -systemd -wide-int -xwidgets -zlib)
both working fine.
Thks 4 ur attention, interest & support.
Back to top
View user's profile Send private message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 57

PostPosted: Sun Oct 18, 2020 5:34 pm    Post subject: Reply with quote

thanks @CaptainBlood and Ionen. I rebuilt emacs adding your flags but nothing changed.. Maybe there is an issue in one of the dependency??
Back to top
View user's profile Send private message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 57

PostPosted: Sun Oct 18, 2020 5:51 pm    Post subject: Reply with quote

solved! running emacs-26 I found a little bug in my .emacs (a required package not installed)

Fixed it, re-emerged emacs-27 (that was unmerged) and now emacs-27 works fine with these flags (the same of emacs-26)

-motif athena -gtk Xaw3d -sound -alsa xft gui -cairo

I am leaning to think that the bug in .emacs caused emacs-27 to fall back in -nw
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum