Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-plugins/alsaequal Problem with control file .alsaequ..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Mon Oct 10, 2016 2:44 pm    Post subject: media-plugins/alsaequal Problem with control file .alsaequ.. Reply with quote

i want an equaliser on gentoo. so i installed media-plugins/alsaequal, and configured it as per http://thedigitalmachine.net/alsaequal.html
Code:
$ equery g alsaequal
 * Searching for alsaequal ...

 * dependency graph for media-plugins/alsaequal-0.6-r2
 `--  media-plugins/alsaequal-0.6-r2  x86
   `--  media-libs/alsa-lib-1.0.29  (>=media-libs/alsa-lib-1.0.27.2) x86  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  media-plugins/caps-plugins-0.9.15  (>=media-plugins/caps-plugins-0.9.15) x86  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
[ media-plugins/alsaequal-0.6-r2 stats: packages (3), max depth (1) ]


i can't get it to work :( i have this problem:
Code:
$ alsamixer -D equal
ALSA lib ctl_equal.c:268:(_snd_ctl_equal_open) Problem with control file .alsaequal.bin, 3.
cannot open mixer: Operation not permitted


i don't have this problem in debian, as the alsa equaliser loads fine with the same .asoundrc on the same machine.
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey


Last edited by josephg on Thu Jul 27, 2017 1:10 am; edited 3 times in total
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Tue Oct 11, 2016 2:41 pm    Post subject: Reply with quote

found this thread from a couple of years ago. didn't fix my problem :(
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Tue Oct 11, 2016 2:44 pm    Post subject: Reply with quote

found this gentoo thread from 3yrs ago.. wonder if those old bugs are still valid on current gentoo packages?
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1841
Location: KUUSANKOSKI, Finland

PostPosted: Tue Oct 11, 2016 5:51 pm    Post subject: Re: equalizer alsa equal Reply with quote

Since you haven't got any replies from others yet, I'll try to help you.
josephg wrote:
i can't get it to work :( i have this problem:
Code:
$ alsamixer -D equal
ALSA lib ctl_equal.c:268:(_snd_ctl_equal_open) Problem with control file .alsaequal.bin, 3.
cannot open mixer: Operation not permitted
Have you tried ruinning that as root? If it succeeds, it must be that you need to add your user to some group... Maybe audio and/or mixer.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Tue Oct 11, 2016 6:37 pm    Post subject: Reply with quote

thank you Zucca

my user is in the audio group. without that, there is no audio.

running as root fails with the same error message.
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1841
Location: KUUSANKOSKI, Finland

PostPosted: Tue Oct 11, 2016 8:09 pm    Post subject: Reply with quote

Well... You can try to create a asoudrc configuration file.
I found that Arch Linux wiki has small section HOWTO just for the case in question.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Tue Oct 11, 2016 8:54 pm    Post subject: Reply with quote

thank you again Zucca. i have tried it before.

i just tried again with my ~/.asoundrc exactly like that
~/.asoundrc:
ctl.equal {
    type equal;
}

pcm.plugequal {
    type equal;
    # Modify the line below if you do not
    # want to use sound card 0.
    #slave.pcm "plughw:0,0";
    # by default we want to play from more sources at time:
    slave.pcm "plug:dmix";
}

# pcm.equal {
# If you do not want the equalizer to be your
# default soundcard comment the following
# line and uncomment the above line. (You can
# choose it as the output device by addressing
# it with specific apps,eg mpg123 -a equal 06.Back_In_Black.mp3)
pcm.!default {
    type plug;
    slave.pcm plugequal;
}

i get the same errors.
Code:
$ alsamixer -D equal
ALSA lib ctl_equal.c:268:(_snd_ctl_equal_open) Problem with control file .alsaequal.bin, 3.
cannot open mixer: Operation not permitted


i wonder if that old gentoo bug re binary file format change is still outstanding. i have no idea how to test it though..
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1841
Location: KUUSANKOSKI, Finland

PostPosted: Wed Oct 12, 2016 12:03 pm    Post subject: Reply with quote

Well have to depend on trial & error -method. :P Let's give alsa the path of .alsaequal.bin.
Try this:
~/.asoundrc:
ctl.equal {
    controls "/home/<HOME_DIRECTORY>/.alsaequal.bin"
    type equal;
}

pcm.plugequal {
    type equal;
    controls "/home/<HOME_DIRECTORY>/.alsaequal.bin"
    slave.pcm "plug:dmix";
}

pcm.!default {
    type plug;
    slave.pcm plugequal;
}
... and replace <HOME_DIRECTORY> accordingly.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Oct 12, 2016 12:30 pm    Post subject: Reply with quote

i also have debian on this system. i installed alsa-utils and libasound2-plugin-equal, and with the same .asoundrc i can load alsamixer -D equal
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1841
Location: KUUSANKOSKI, Finland

PostPosted: Wed Oct 12, 2016 12:48 pm    Post subject: Reply with quote

And you have media-plugins/caps-plugins installed also?
(it's a dependecy of alsaequal, but just to make sure)
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Oct 12, 2016 1:08 pm    Post subject: Reply with quote

Zucca wrote:
Try this:
~/.asoundrc:
ctl.equal {
    controls "/home/<HOME_DIRECTORY>/.alsaequal.bin"
    type equal;
}

pcm.plugequal {
    type equal;
    controls "/home/<HOME_DIRECTORY>/.alsaequal.bin"
    slave.pcm "plug:dmix";
}

pcm.!default {
    type plug;
    slave.pcm plugequal;
}
... and replace <HOME_DIRECTORY> accordingly.

so i did, and then same problem
Code:
$ rm .alsaequal.bin
$ alsamixer -D equal
ALSA lib ctl_equal.c:268:(_snd_ctl_equal_open) Problem with control file /home/jgv.gentoo32/.alsaequal.bin, 3.
cannot open mixer: Operation not permitted


Zucca wrote:
And you have media-plugins/caps-plugins installed also?
(it's a dependecy of alsaequal, but just to make sure)

yes i have, as per my op.
Code:
$ eix -v caps-plugin
* media-plugins/caps-plugins
     Available versions:  0.4.5-r1 ~0.4.5-r2 ~0.9.10 0.9.15 ~0.9.15-r1
     IUSE (all versions): doc ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"
     Installed versions:  Version:   0.9.15
                          Date:      01:43:09 10/10/16
                          USE:       -doc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 -64 -x32"
                          DEPEND:    media-libs/ladspa-sdk
                          RDEPEND:   !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2 !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
                          EAPI:      5
                          0.9.15
     Homepage:            http://quitte.de/dsp/caps.html
     Find open bugs:      https://bugs.gentoo.org/buglist.cgi?quicksearch=media-plugins%2Fcaps-plugins
     Description:         The CAPS Audio Plugin Suite - LADSPA plugin suite
     License:             GPL-3


but i wonder why esearch says [ Not Installed ] :roll:
Code:
$ esearch -v caps-plugin
[ Results for search key : caps-plugin ]
[ Applications found : 1 ]

*  media-plugins/caps-plugins
      Latest version available: 0.9.15
      Latest version installed: [ Not Installed ]
      Unstable version:         0.9.15-r1
      Use Flags (stable):       -doc
      Size of downloaded files: 1,443 kB
      Homepage:    http://quitte.de/dsp/caps.html
      Description: The CAPS Audio Plugin Suite - LADSPA plugin suite
      License:     GPL-3

_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1841
Location: KUUSANKOSKI, Finland

PostPosted: Wed Oct 12, 2016 1:20 pm    Post subject: Reply with quote

... and what does "emerge -s @media-plugins/caps-plugins" say?
Anyway... I'd recompile and reinstall it: emerge -1 media-plugins/caps-plugins.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Oct 12, 2016 1:23 pm    Post subject: Reply with quote

Code:
$ emerge -s @media-plugins/caps-plugins
 
[ Results for search key : @media-plugins/caps-plugins ]
Searching...

*  media-plugins/caps-plugins
      Latest version available: 0.9.15
      Latest version installed: 0.9.15
      Size of files: 668 KiB
      Homepage:      http://quitte.de/dsp/caps.html
      Description:   The CAPS Audio Plugin Suite - LADSPA plugin suite
      License:       GPL-3

[ Applications found : 1 ]


Zucca wrote:
Anyway... I'd recompile and reinstall it: emerge -1 media-plugins/caps-plugins.

good idea. i'll emerge again.. all the research i've done points to .alsaequal.bin file format not recognised or being a different version or corrupt. but i don't know how to verify that.
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey


Last edited by josephg on Wed Oct 12, 2016 1:56 pm; edited 2 times in total
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Oct 12, 2016 1:31 pm    Post subject: Reply with quote

ok, that didn't make any difference.

i also tried recompiling alsaequal.. and no didn't make a difference either. same errors.

strange. this should be very straightforward, as the only thing needed is the .asoundrc which works fine on debian.
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1841
Location: KUUSANKOSKI, Finland

PostPosted: Wed Oct 12, 2016 1:47 pm    Post subject: Reply with quote

It's the imcompability with >=media-plugins/caps-plugins-0.9.10 and alsaequal. :(

However. I found a patched alsaequal. And an overlay that provides it.

After adding that overlay you can try to upgrade alsaequal.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Oct 12, 2016 2:04 pm    Post subject: Reply with quote

Zucca wrote:
It's the imcompability with >=media-plugins/caps-plugins-0.9.10 and alsaequal. :(

sounds like the gentoo bug from about 3yrs ago :roll: and i thought gentoo stable was stable enough
josephg wrote:
found this gentoo thread from 3yrs ago.. wonder if those old bugs are still valid on current gentoo packages?


Zucca wrote:
However. I found a patched alsaequal. And an overlay that provides it.

After adding that overlay you can try to upgrade alsaequal.

i'll have to get my head around overlays, before i can to do something like this.
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Schnulli
Guru
Guru


Joined: 25 Jun 2010
Posts: 320
Location: Bremen DE

PostPosted: Wed Feb 15, 2017 8:27 pm    Post subject: Reply with quote

Hi
if it works on Debian... why to use Alien and get it from Debian to work on Gentoo and waste time ??
Just a idea.....
Give it a try.....

Regards
Back to top
View user's profile Send private message
DaveBullet1050
n00b
n00b


Joined: 18 Oct 2020
Posts: 1

PostPosted: Sun Oct 18, 2020 8:07 pm    Post subject: Reply with quote

Sorry for the dredge, but I think I know the answer.....

Around CAPS v0.9.26 - the name module name of the Equaliser was changed from "Eq" to "Eq10".

Alsaequal 6.17 still refers to "Eq" - hence it cannot load the control file.

The solution is to patch alsaequal and re-compile. Here's the patch file (or apply edit manually and recompile alsaequal).

Code:
--- ctl_equal.c 2009-01-31 23:06:47.000000000 +0100
+++ ctl_equal.c 2014-01-23 15:23:01.000000000 +0100
@@ -167,7 +167,7 @@
        snd_ctl_equal_t *equal;
        const char *controls = ".alsaequal.bin";
        const char *library = "/usr/lib/ladspa/caps.so";
-       const char *module = "Eq";
+       const char *module = "Eq10";
        long channels = 2;
        const char *sufix = " Playback Volume";
        int err, i, index;
--- pcm_equal.c 2010-02-01 23:55:00.000000000 +0100
+++ pcm_equal.c 2014-01-23 15:23:16.000000000 +0100
@@ -151,7 +151,7 @@
        snd_config_t *sconf = NULL;
        const char *controls = ".alsaequal.bin";
        const char *library = "/usr/lib/ladspa/caps.so";
-       const char *module = "Eq";
+       const char *module = "Eq10";
        long channels = 2;
        int err;
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum