Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emacs doesn't recognize Terminus font using xft notation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
etnull
Guru
Guru


Joined: 26 Mar 2019
Posts: 464
Location: Russia

PostPosted: Sun Oct 18, 2020 12:42 pm    Post subject: Emacs doesn't recognize Terminus font using xft notation Reply with quote

My emacs version 27.1-r1 compiled with xft useflag. I'm trying to run emacs with terminus font like so:
emacs --font 'xos4 Terminus-9', I don't have emacs config file or anything defined in .Xresources, apart of Emacs.fontBackend: xft,x
no matter which string I pass, (like with or without xos4, no size specified, small T etc. any permutation) I get:
Font ‘xos4 Terminus-9’ is not defined
If I pass emacs --font '-*-terminus-*-*-*-*-16-*-*-*-*-*-*-*' it is working, although the size is weird, I usually set 9, but it is too small for some reason.
fc-list | grep terminus
Code:
/usr/share/fonts/terminus/ter-x24b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x12b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x32b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x22b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x18b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x28b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x20b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x18n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x28n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x20n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x12n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x32n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x22n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x14n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x24n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x16b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/terminus/ter-x16n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/terminus/ter-x14b.pcf.gz: xos4 Terminus:style=Bold

I found the related information here:
https://bbs.archlinux.org/viewtopic.php?pid=1724895#p1724895
But could not understand what
Quote:
Tried to explicitly re-cofigure the default font (because the name changed from "terminus" to "xos4 terminus")?

meant by the guy...

---

The issue was Emacs.fontBackend: xft,x in the .Xresources, removing x, or commenting out the entire thing helped to get Terminus recognized again.
I will test more things with fonts/themes later, and if everything will be working will mark as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum