Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Messaggio quando lancio un binario
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 383

PostPosted: Wed Oct 21, 2020 4:55 pm    Post subject: [Risolto] Messaggio quando lancio un binario Reply with quote

Ottengo un messaggio che non capisco quando lancio un binario da shell, funziona lo stesso, ma non lo capisco.

il messaggio é questo:

Code:
OMP: Info #262: OMP_NESTED variable deprecated, please use OMP_MAX_ACTIVE_LEVELS instead.


non capisco ne cosa significa e ne se é riferito al mio sistema o al binario (a come é stato compilato)

qualcuno ne sa qualcosa?


Last edited by antonellocaroli on Thu Oct 22, 2020 5:20 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24766
Location: here

PostPosted: Wed Oct 21, 2020 5:08 pm    Post subject: Reply with quote

Cosa stai cercando di fare partire?
Comunque il messaggio dice che quel programma usa la variabile deprecata OMP_NESTED mentre bisognerebbe usare OMP_MAX_ACTIVE_LEVELS, ma e' solo un avviso che non preclude il funzionamento. In futuro dovra' essere risolto.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 383

PostPosted: Wed Oct 21, 2020 5:23 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Cosa stai cercando di fare partire?
Comunque il messaggio dice che quel programma usa la variabile deprecata OMP_NESTED mentre bisognerebbe usare OMP_MAX_ACTIVE_LEVELS, ma e' solo un avviso che non preclude il funzionamento. In futuro dovra' essere risolto.


Ciao fedeliallalinea

si in effetti quello che mi premeva sapere era proprio questo, che non dipende dal mio sistema.
Si in effeti funziona uguale.

E visto che mi trovo, faccio un altra domanda :)

lo stesso binario, facendo partire un pc mac mini 2010 duocore con gentoo, tutto funziona, tranne questo binario che termina con un Illegal instruction e muore, un utente mi dice che con altri sistemi linux invece funziona.


il binario é Hqplayerd (HQPlayer Embedded), che tra l'altro mi hai aiutato tu a creare la ebuild ;)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24766
Location: here

PostPosted: Wed Oct 21, 2020 5:34 pm    Post subject: Reply with quote

antonellocaroli wrote:
lo stesso binario, facendo partire un pc mac mini 2010 duocore con gentoo, tutto funziona, tranne questo binario che termina con un Illegal instruction e muore, un utente mi dice che con altri sistemi linux invece funziona.

Probabilmente e' stato compilato con qualche cflags non compatibile con il processore del mac mini
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 383

PostPosted: Wed Oct 21, 2020 5:49 pm    Post subject: Reply with quote

fedeliallalinea wrote:
antonellocaroli wrote:
lo stesso binario, facendo partire un pc mac mini 2010 duocore con gentoo, tutto funziona, tranne questo binario che termina con un Illegal instruction e muore, un utente mi dice che con altri sistemi linux invece funziona.

Probabilmente e' stato compilato con qualche cflags non compatibile con il processore del mac mini


in questo caso non dovrebbe funzionare anche con altri sistemi linux....

si comunque mi sembra strana la cosa
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24766
Location: here

PostPosted: Wed Oct 21, 2020 6:02 pm    Post subject: Reply with quote

antonellocaroli wrote:
in questo caso non dovrebbe funzionare anche con altri sistemi linux....

Beh dipende dal processore, per esempio il set d'istruzioni AES sono arrivate dopo il Core 2 duo.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 383

PostPosted: Thu Oct 22, 2020 5:20 am    Post subject: Reply with quote

fedeliallalinea wrote:
antonellocaroli wrote:
in questo caso non dovrebbe funzionare anche con altri sistemi linux....

Beh dipende dal processore, per esempio il set d'istruzioni AES sono arrivate dopo il Core 2 duo.


Si, hai ragione, l'autore del binario me lo conferma, ha bisogno di sse4_2....

la cosa che mi mandava fuori logica era che un utente sosteneva che lo stesso binario sullo stesso pc con altri sistemi lunux funzionasse, ma evidentemente mi dava informazioni sbagliate...

grazie
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 828

PostPosted: Thu Oct 22, 2020 7:32 am    Post subject: Reply with quote

Concordo per la "Illegal istruction"

per quanto riguarda "OMP_MAX_ACTIVE_LEVELS", credo sia un parametro del compilatore GCC
_________________
BOINC ed il calcolo distribuito

My LRecoverySystem Repo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum