Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ACER 1691]Problème avec ipw2200
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 838
Location: Switzerland

PostPosted: Sat Feb 18, 2006 6:18 pm    Post subject: [ACER 1691]Problème avec ipw2200 Reply with quote

Bonsoir tout le monde, encore moi :lol:

Donc j'ai installé sur l'ordi de ma copine une bonne vieille Gentoo. Enlevé son Windows etc...

Juste un petit problème persiste, le Wireless, et là je pète un plomb, j'ai donc la meme carte réseau sans fil sur mon Dell et je n'ai rencontré aucun problème, alors que sur le sien rien n'y fait.

J'ai donc un kernel 2.6.14-gentoo-r5 ou le 2.6.15-gentoo-r3, avec les deux le meme résultat, rien, nada.

J'ai installé ipw2200-formware, bien mis toutes les options dans le kernel (du moin je crois), les même que les miennes. et lorsque je charge ipw2200 j'ai une erreur du type :

Quote:
ipw2200: Intel Pro/Wireless 2200/2915 Network Driver, 1.0.0
ipw2200: Copyright 2003-2004 Intel Corporation
ipw2200: Detected Intel Pro/Wireless 2200BG Networks Connection
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: Unable to initialize device after 5 attemps
ipw2200: failed to regidtre network device
ipw2200: prob of 0000:06:03.0 failed with error -5


Truc étrange j'ai le problème que ipw2200 ne cré pas le /dev/eth1 8O
DOnc je sais plus koi faire, mais ce qui me dépasse, c'et lors de l'install, le live cd gentoo n'a pas eu de soucis à ce conecter

Et finalement, le driver ipw2200 se charge belle et bien malgré toutes ses erreurs, j'ai aussi installé acerhk en le lanssant de cette manière

Quote:
modprobe acerhk force_series=1690 autowlan=1 usedritek=1 verbose=3


Help meeee!!!

Merci d'avance pour votre aide
_________________
Macbook Unibody 5.1 - Kernel 2.6.34 - Xorg 1.8.0 - Gnome 2.30
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Sat Feb 18, 2006 6:37 pm    Post subject: Reply with quote

Salut,

tes modules ont été compilés comment : en hard ou pas?

parceque je cite sur wlanfr, même symptomnes mais avec une solution :
Quote:
Pb resolu:
Il m a fallu recompiler le kernel avec le drivers en built-in et pas en module.


Si cela se trouve, il faut les derniers firmwares maskés :
Quote:
net-wireless/ipw2200 ~x86
net-wireless/ipw2200-firmware ~x86
net-wireless/ieee80211 ~x86
:?

Last edited by Mickael on Sat Feb 18, 2006 6:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 838
Location: Switzerland

PostPosted: Sat Feb 18, 2006 6:43 pm    Post subject: Reply with quote

en module. Merci pour l'info, mais j'ai du nouveau à force d'essayer et de réessayer.

Là, j'ai changé deux options au grub, virer acpi=noirq et ajouter noapic
Après reboot sur le kernel 2.6.14, j'ai mis le firmware 2.2 je charge le module ipw2200
Et là aucune erreur 8O
Je démarre une connexion wireless et la miracle, la connexion démarre belle et bien.

Je tiens juste à dire que j'avais deja réeussi à atteindre ce but, mais qui après reboot du PC ne fonctionnait plus à nouveau.
Maintenant sa fait deja 1 moi je m'accroche avec son wireless.

Je vous tiens au courant des évolutions aprsè un prochain boot.
_________________
Macbook Unibody 5.1 - Kernel 2.6.34 - Xorg 1.8.0 - Gnome 2.30
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Sat Feb 18, 2006 6:56 pm    Post subject: Reply with quote

bêtement, y'a pas un switch pour activer le wifi ?

j'ai butté dessus un moment :(
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sat Feb 18, 2006 7:03 pm    Post subject: Reply with quote

Sur ce type de latop, c'est un switch software, donc cette reaction est bizard.

sur mon 1681, lorsque le sitch est on, lors du chargement du driver, on me signale qui faut retireer le switch pour que ca marche.
Mais aucune des ces erreurs.

Tu a essaié la version 1.0.8 dispo dans portage ?
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 838
Location: Switzerland

PostPosted: Sat Feb 18, 2006 10:02 pm    Post subject: Reply with quote

RE, bon de nouveau un probleme, il se trouve que le wireless ne veut plus se connecter.

Dans le dmesg j'ai un truc de suplementaire

Code:
ipw2200. Radio Frequency Kill Switch on:


Hmm que faire ?
_________________
Macbook Unibody 5.1 - Kernel 2.6.34 - Xorg 1.8.0 - Gnome 2.30
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 838
Location: Switzerland

PostPosted: Sat Feb 18, 2006 10:09 pm    Post subject: Reply with quote

MickTux wrote:


parceque je cite sur wlanfr, même symptomnes mais avec une solution :
Quote:
Pb resolu:
Il m a fallu recompiler le kernel avec le drivers en built-in et pas en module.



built-in, ca veut dire koi?? En dur dans le kernel ? Car je ne peux le mettre en dur
_________________
Macbook Unibody 5.1 - Kernel 2.6.34 - Xorg 1.8.0 - Gnome 2.30
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sun Feb 19, 2006 12:17 am    Post subject: Reply with quote

gulivert wrote:
RE, bon de nouveau un probleme, il se trouve que le wireless ne veut plus se connecter.

Dans le dmesg j'ai un truc de suplementaire

Code:
ipw2200. Radio Frequency Kill Switch on:


Hmm que faire ?


Il est clair que ca vient du switch pour deactiver la carte.
Normalemant, il se trouve sur le coté avant du latop, a gauche des prise audio. (sur le 1691)
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 838
Location: Switzerland

PostPosted: Sun Feb 19, 2006 9:33 am    Post subject: Reply with quote

BuBuaBu wrote:
gulivert wrote:
RE, bon de nouveau un probleme, il se trouve que le wireless ne veut plus se connecter.

Dans le dmesg j'ai un truc de suplementaire

Code:
ipw2200. Radio Frequency Kill Switch on:


Hmm que faire ?


Il est clair que ca vient du switch pour deactiver la carte.
Normalemant, il se trouve sur le coté avant du latop, a gauche des prise audio. (sur le 1691)


Roo, non j'y crois pas 8O je n'avais jamais vue ce bouton, ben je testerai, la le acer a booter et directement l'ipw2200
fonctionner, on va tester sa une fois l'erreur arriv. Ce qui devrait arriv au prochain boot ou prochaine fois de la sortie de veille
_________________
Macbook Unibody 5.1 - Kernel 2.6.34 - Xorg 1.8.0 - Gnome 2.30
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 898
Location: France

PostPosted: Sun Feb 19, 2006 12:17 pm    Post subject: Reply with quote

charger le module avec l'option LED=1, alumera la diode se trouvant dans le bouton lorsque la carte sera associé a un reseaux.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum