Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PAM stopped unlocking kwallet while logging in through SDDM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
soya
Guru
Guru


Joined: 29 Jan 2004
Posts: 426

PostPosted: Sun Sep 13, 2020 10:48 am    Post subject: PAM stopped unlocking kwallet while logging in through SDDM Reply with quote

Hi,

suddenly kwallet stopped unlocking automatically while logging into KDE plasma through SDDM. I'm trying to debug but don't know what's going on.

The following is my PAM config, does anyone knows what could i be missing or what has changed?

Thanks in advanced.

Code:
[I] kde-frameworks/kwallet [1]
     Available versions:  (5) 5.57.0(5/5.57) (~)5.59.0(5/5.59)
       {debug doc gpg +man test}
     Installed versions:  5.59.0(5/5.59)(02:38:01 PM 10/02/2019)(man -debug -doc -gpg -test)
     Homepage:            https://kde.org/
     Description:         Framework providing desktop-wide storage for passwords
 
[I] kde-plasma/kwallet-pam [1]
     Available versions:  (5) 5.15.5 (~)5.16.1
       {debug}
     Installed versions:  5.16.1(5)(10:29:25 AM 09/13/2020)(-debug)
     Homepage:            https://kde.org/
     Description:         KWallet PAM module to not enter password again


Code:
egrep -Ri kwall /etc/pam.d/
/etc/pam.d/login:-session    optional     pam_kwallet5.so auto_start
/etc/pam.d/sddm-autologin:-auth       optional    pam_kwallet5.so
/etc/pam.d/sddm-autologin:-session    optional    pam_kwallet5.so auto_start
/etc/pam.d/sddm:-auth           optional        pam_kwallet5.so
/etc/pam.d/sddm:-session        optional        pam_kwallet5.so auto_start
/etc/pam.d/passwd:-auth           optional        pam_kwallet5.so


Code:
 
/etc/pam.d/login                                                                                 
  auth       include      system-local-login
  account    include      system-local-login
  password   include      system-local-login
  session    optional     pam_lastlog.so
  session    include      system-local-login
  -session    optional     pam_kwallet5.so auto_start
 


Code:

/etc/pam.d/sddm-autologin                                                                             
  #%PAM-1.0
  auth        required    pam_env.so
  auth        required    pam_tally.so file=/var/log/faillog onerr=succeed
  auth        required    pam_shells.so
  auth        required    pam_nologin.so
  auth        required    pam_permit.so
  #-auth       optional    pam_gnome_keyring.so
  -auth       optional    pam_kwallet5.so
  account     include     system-local-login
 password    include     system-local-login
 session     include     system-local-login
 #-session    optional    pam_gnome_keyring.so auto_start
 -session    optional    pam_kwallet5.so auto_start



Code:

/etc/pam.d/sddm                                                                                 
  #%PAM-1.0
 
  auth            include         system-login
  #-auth          optional        pam_gnome_keyring.so
  # the hyphens are valid PAM syntax to reduce log entries if these PAM modules should not exist
  -auth           optional        pam_kwallet5.so
 
  account         include         system-login
 
 password        include         system-login
 #-password      optional        pam_gnome_keyring.so use_authtok
 
 session         optional        pam_keyinit.so force revoke
 session         include         system-login
 #-session       optional        pam_gnome_keyring.so auto_start
 # the hyphens are valid PAM syntax to reduce log entries if these PAM modules should not exist
 -session        optional        pam_kwallet5.so auto_start


Code:
 
/etc/pam.d/passwd                                                                                 
  auth            sufficient      pam_rootok.so
  auth            include         system-auth
  -auth           optional        pam_kwallet5.so
  account         include         system-auth
  password        include         system-auth
  #-password      optional        pam_gnome_keyring.so use_authtok


After reemerging sys-libs/pam, the following message is printed but I've never enabled FS_SECURITY in my kernel config.

Code:

 * Alternatively, simply reboot your system.
 * Could not set caps on '/sbin/unix_chkpwd' due to missing filesystem support:
 * * enable XATTR support for 'ext2/ext3' in your kernel (if configurable)
 * * mount the fs with the user_xattr option (if not the default)
 * * enable the relevant FS_SECURITY option (if configurable)


Those are the root FS mount options:
Code:

cat /proc/mounts|grep -i "\/ "
/dev/mapper/isw_bggjiidefd_240GB_BX100v2.56 / ext4 rw,noatime,stripe=32 0 0

_________________
Si el tonto te alaba laméntalo, si el listo te censura piénsalo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum