Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
100dpi version of bitstream font not showing in font config?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 997

PostPosted: Sun Aug 16, 2020 7:38 pm    Post subject: 100dpi version of bitstream font not showing in font config? Reply with quote

I got new monitor that has a 109 ppi. I emerged media-fonts/font-bitstream-100dpi but it does not show up in eselect fontconfig list. Why is that and how do I activate it so I can have my urxvt use it in .Xdefaults?
_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2428
Location: Frankfurt, Germany

PostPosted: Sun Aug 16, 2020 10:07 pm    Post subject: Reply with quote

Wait...

'eselect fontconfig list' was NOT made to select or activate fonts.

You can use 'eselect fontconfig' to set font and rendering properties, to select defaults fonts or to tweak some fonts. But most fonts will never appear in 'eselect fontconfig list'.
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 997

PostPosted: Mon Aug 17, 2020 12:12 am    Post subject: Reply with quote

oh...ok. What would I put in my .Xdefaults to make urxvt use the 100dpi of media-fonts/font-bitstream-100dpi and not the lesser dpi versions?
_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2428
Location: Frankfurt, Germany

PostPosted: Mon Aug 17, 2020 1:22 am    Post subject: Reply with quote

media-fonts/font-bitstream installs bitmap fonts.

Most people try to avoid bitmap fonts - and prefer Truetype or Opentype fonts nowadays. But if you really want bitmap fonts....

emerge rxvt-unicode WITH USE flag 'xft' and add the line below to your .Xdefaults:
Code:
URxvt.font: xft:bitstream terminal
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 997

PostPosted: Mon Aug 17, 2020 2:33 am    Post subject: Reply with quote

Actually, the only font that ever looks proper on my system is the kernel 6x13 font. But now that I am getting bigger monitors that font is to small. When I go up in kernel font sizes in the kernel fonts they do not look good.

Are you using eselect infinality configs for your truetype fonts?
_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2428
Location: Frankfurt, Germany

PostPosted: Mon Aug 17, 2020 10:45 am    Post subject: Reply with quote

6x13? That's again a bitmap font! 6x13 is nice - but we used it 25 years ago, when the typical screen resolution was 1024x768 pixels and CRT tubes provided some kind of built-in anti-aliasing. :)

You really should upgrade to TrueType / OpenType!

I have never used infinality.

I use "Konsole" as terminal, my terminal font is "Source Code Pro" and I use the settings below:
Code:
<match target="font">
    <edit name="antialias" mode="assign"><bool>true</bool></edit>
    <edit name="autohint"  mode="assign"><bool>false</bool></edit>
    <edit name="hinting"   mode="assign"><bool>true</bool></edit>
    <edit name="hintstyle" mode="assign"><const>hintslight</const></edit>
    <edit name="rgba"      mode="assign"><const>none</const></edit>
    <edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
</match>

See:
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 997

PostPosted: Mon Aug 17, 2020 8:52 pm    Post subject: Reply with quote

Just to confirm, that should go into /etc/fonts/local.conf, correct? Right now I don't have one even though I have local 51-local.conf * configured in fontconfig.
_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2428
Location: Frankfurt, Germany

PostPosted: Tue Aug 18, 2020 10:22 am    Post subject: Reply with quote

There are two different ways:
  1. Run 'eselect fontconfig list' and 'eselect fontconfig enable/disable' to enable or disable options like '10-hinting-slight.conf'. Make sure not to enable multiple contradictory options.
  2. Write it to /etc/fonts/local.conf. Disable all related options in 'eselect fontconfig list' and enable '51-local.conf'.
I use the second method. On my machine, the fontconfig options below are enabled:
  • 45-generic.conf *
  • 50-user.conf *
  • 51-local.conf *
  • 57-dejavu-sans-mono.conf *
  • 60-generic.conf *
Everything else is disabled. Below is my /etc/fonts/local.conf:
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file to configure system font access -->
<fontconfig>

    <!-- Global settings  -->
    <match target="font">
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="autohint"  mode="assign"><bool>false</bool></edit>
        <edit name="hinting"   mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintslight</const></edit>
        <edit name="rgba"      mode="assign"><const>none</const></edit>
        <edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
    </match>

    <!-- Monitor resolution -->
    <match target="pattern">
       <edit name="dpi" mode="assign">
          <double>96</double>
       </edit>
    </match>

    <!-- Disable Autohinting for bold fonts -->
    <match target="font">
        <test name="weight" compare="more"><const>medium</const></test>
        <edit name="autohint" mode="assign"><bool>false</bool></edit>
    </match>

    <!-- Disable Anti Aliasing for small fonts -->
    <match target="font">
        <test name="size" compare="less" qual="any"><double>8</double></test>
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
    </match>

    <match target="font">
        <test name="pixelsize" compare="less" qual="any"><double>9</double></test>
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
    </match>

    <!-- Disable embedded Bitmaps: beautifies Calibri, for instance -->
    <match target="font">
        <edit name="embeddedbitmap" mode="assign"><bool>false</bool></edit>
    </match>
   
    <!-- Redefine ugly Fonts -->
    <match target="pattern">
        <test name="family" qual="any"><string>Helvetica</string></test>
        <edit mode="assign" name="family"><string>Arial</string></edit>
    </match>

</fontconfig>
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 997

PostPosted: Wed Aug 19, 2020 1:23 am    Post subject: Reply with quote

Thank you... before I add that.... For my browser....do you know what would be causing this roboto font to look so broken in chrome?

https://imgur.com/P9APmt3 ....the t is real far away from the o

Code:

localhost /home/one # eselect fontconfig list             
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-hinting-full.conf
  [3]   10-hinting-medium.conf
  [4]   10-hinting-none.conf
  [5]   10-hinting-slight.conf
  [6]   10-no-sub-pixel.conf
  [7]   10-scale-bitmap-fonts.conf *
  [8]   10-sub-pixel-bgr.conf
  [9]   10-sub-pixel-rgb.conf *
  [10]  10-sub-pixel-vbgr.conf
  [11]  10-sub-pixel-vrgb.conf
  [12]  10-unhinted.conf
  [13]  11-lcdfilter-default.conf *
  [14]  11-lcdfilter-legacy.conf
  [15]  11-lcdfilter-light.conf
  [16]  20-unhint-small-dejavu-sans-mono.conf
  [17]  20-unhint-small-dejavu-sans.conf
  [18]  20-unhint-small-dejavu-serif.conf
  [19]  20-unhint-small-vera.conf *
  [20]  25-unhint-nonlatin.conf
  [21]  30-metric-aliases.conf *
  [22]  40-nonlatin.conf *
  [23]  45-generic.conf *
  [24]  45-latin.conf *
  [25]  49-sansserif.conf *
  [26]  50-user.conf *
  [27]  51-local.conf *
  [28]  52-infinality.conf
  [29]  57-dejavu-sans-mono.conf *
  [30]  57-dejavu-sans.conf *
  [31]  57-dejavu-serif.conf *
  [32]  59-google-droid-sans-mono.conf *
  [33]  59-google-droid-sans.conf *
  [34]  59-google-droid-serif.conf *
  [35]  60-generic.conf *
  [36]  60-latin.conf *
  [37]  60-liberation.conf *
  [38]  62-croscore-arimo.conf
  [39]  62-croscore-cousine.conf
  [40]  62-croscore-symbolneu.conf
  [41]  62-croscore-tinos.conf
  [42]  63-source-pro.conf *
  [43]  65-fonts-persian.conf *
  [44]  65-khmer.conf
  [45]  65-nonlatin.conf *
  [46]  69-unifont.conf *
  [47]  70-no-bitmaps.conf
  [48]  70-yes-bitmaps.conf
  [49]  75-yes-terminus.conf
  [50]  80-delicious.conf
  [51]  90-roboto-regular.conf *
  [52]  90-synthetic.conf *

_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum