Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qucs Installation - Ebuild?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Tue Aug 11, 2020 9:38 pm    Post subject: Qucs Installation - Ebuild? Reply with quote

I'm trying to install Qucs (http://qucs.sourceforge.net).

There's an ebuild - https://gpo.zugaina.org/sci-electronics/qucs - for version 0.0.19.

How do I install this additional Gentoo package? I don't seem to fully understand portage and overlays.

I can't install it using ./configure ...

Code:
./configure

...
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for Qt headers... configure: error: not found
configure: error: ./configure failed for qucs


Anyone any idea on how to help me?


Last edited by MongoQ on Wed Aug 12, 2020 5:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5858
Location: Removed by Neddy

PostPosted: Tue Aug 11, 2020 10:24 pm    Post subject: Reply with quote

qucs is still QT4 as the QT5 branch is still having issues. https://github.com/Qucs/qucs/tree/refactor+qt5-14
if you need qucs now you will need to install the qt4 libs. its a shame,
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16214

PostPosted: Wed Aug 12, 2020 1:38 am    Post subject: Re: Qucs Installation - Ebuild? Reply with quote

MongoQ wrote:
I can't install it using ./configure ...
If you are using an ebuild, then you don't run ./configure. The ebuild will do that for you.
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 10:45 am    Post subject: Reply with quote

Naib wrote:
qucs is still QT4 as the QT5 branch is still having issues. https://github.com/Qucs/qucs/tree/refactor+qt5-14
if you need qucs now you will need to install the qt4 libs. its a shame,


How do I do that?
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 10:52 am    Post subject: Reply with quote

I know ebuilds and ./configure are two ways of achieving the same goal.

How do I use this overlay: booboo (layman) --> https://gpo.zugaina.org/sci-electronics/qucs
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3541

PostPosted: Wed Aug 12, 2020 11:17 am    Post subject: Reply with quote

MongoQ wrote:
I know ebuilds and ./configure are two ways of achieving the same goal.

How do I use this overlay: booboo (layman) --> https://gpo.zugaina.org/sci-electronics/qucs
You need https://wiki.gentoo.org/wiki//etc/portage/repos.conf#Usage
Code:
emerge --ask eselect-repository
eselect repository enable booboo
emaint sync -r booboo
Then emerge whatever you need from that repository
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 3:10 pm    Post subject: Reply with quote

This:

Code:
emerge --ask eselect-repository
eselect repository enable booboo
emaint sync -r booboo
sudo emerge qucs


Yields:

Code:
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:69: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtsql-4.8.7-r1:4 qt3support

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

emerge: there are no ebuilds to satisfy "<dev-libs/icu-59:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?]".
(dependency required by "dev-qt/qtcore-4.8.7-r4::booboo" [ebuild])
(dependency required by "dev-qt/qt3support-4.8.7::booboo" [ebuild])
(dependency required by "dev-qt/qtgui-4.8.7::booboo[qt3support]" [ebuild])
(dependency required by "dev-qt/qtsvg-4.8.7::booboo" [ebuild])
(dependency required by "sci-electronics/qucs-0.0.19::booboo" [ebuild])
(dependency required by "qucs" [argument])


What now? :?

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 3:50 pm    Post subject: Reply with quote

As I understand it, I should find an ebuild for dev-libs/icu-59.

Now where do I find that, if not with the booboo repository?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24789
Location: here

PostPosted: Wed Aug 12, 2020 4:29 pm    Post subject: Reply with quote

MongoQ wrote:
As I understand it, I should find an ebuild for dev-libs/icu-59.

It's not that simple, icu is reuired by a lot of packages and new package need a newest icu.
So try to disable icu use flag to dev-qt/qtcore-4.8.7-r4
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 4:46 pm    Post subject: Reply with quote

Ok, so:

Code:
sudo USE="-icu" emerge -pv qucs


(hope this is right ... copied from: https://linuxreviews.org/USE_flags_explained:_How_Gentoo_configures_software)

gets me:

Code:
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:69: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)

These are the packages that would be merged, in order:

Calculating dependencies... done!

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtsql-4.8.7-r1:4 qt3support

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

emerge: there are no ebuilds to satisfy "virtual/libmysqlclient:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?]".
(dependency required by "dev-qt/qtsql-4.8.7-r1::booboo" [ebuild])
(dependency required by "dev-qt/qt3support-4.8.7::booboo" [ebuild])
(dependency required by "dev-qt/qtgui-4.8.7::booboo[qt3support]" [ebuild])
(dependency required by "dev-qt/qtcore-4.8.7-r4::booboo[qt3support]" [ebuild])
(dependency required by "dev-qt/qttranslations-4.8.7::booboo" [ebuild])

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24789
Location: here

PostPosted: Wed Aug 12, 2020 6:00 pm    Post subject: Reply with quote

If possible try to disable mysql use flag to dev-qt/qtsql-4.8.7-r1 package.
I don't know if you'll finally be able to install this package is really old.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 6:08 pm    Post subject: Reply with quote

I'm not sure I'm doing the right thing:

Code:
sudo USE="-icu -mysql" emerge qucs


gives me:

Code:
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:69: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)
Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-qtgraphicssystem-1.1.1
[ebuild  NS    ] dev-qt/qtcore-4.8.7-r4 [5.15.0] USE="exceptions%* glib%* iconv%* qt3support%* ssl%* (-aqua) -icu* -libressl% -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qttranslations-4.8.7  ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtscript-4.8.7 [5.15.0] USE="exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtgui-4.8.7 [5.15.0] USE="cups%* exceptions%* glib%* gtkstyle%* mng%* qt3support%* tiff%* xinerama%* xv%* (-aqua) -egl* -nas% -nis% -pch% -trace%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtsql-4.8.7-r1 [5.15.0] USE="exceptions%* qt3support%* (-aqua) -mysql* -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qt3support-4.8.7  USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtsvg-4.8.7 [5.15.0] USE="accessibility%* exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] sci-electronics/qucs-0.0.19  USE="-doc"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qtsql-4.8.7-r1::booboo
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtsql-4.8.7-r1:4 qt3support

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- dev-java/icedtea-web-1.6.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-03-27)
# Vulnerable old version of icedtea-web #711392
# new version is not packaged yet
# package is not going away anytime soon, just masked
# for security. unmask as needed.

- virtual/modutils-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mikle Kolyada <zlogene@gentoo.org> (2020-08-08)
# modutils is obsolete and does not build.
# No consumers in the tree.
# Removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24789
Location: here

PostPosted: Wed Aug 12, 2020 6:23 pm    Post subject: Reply with quote

MongoQ wrote:
I'm not sure I'm doing the right thing:

Code:
sudo USE="-icu -mysql" emerge qucs

For disable/enable use flag to specific package you should use /etc/portage/package.use

EDIT: you can't use another program like sci-electronics/kicad?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 6:44 pm    Post subject: Reply with quote

I added the two use flags described above to /etc/portage/package.use/00-sabayon.package.use

I get:

Code:
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:69: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)
Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-qtgraphicssystem-1.1.1
[ebuild  NS    ] dev-qt/qtcore-4.8.7-r4 [5.15.0] USE="exceptions%* glib%* iconv%* qt3support%* ssl%* (-aqua) -icu* -libressl% -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qttranslations-4.8.7  ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtscript-4.8.7 [5.15.0] USE="exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtgui-4.8.7 [5.15.0] USE="cups%* exceptions%* glib%* gtkstyle%* mng%* qt3support%* tiff%* xinerama%* xv%* (-aqua) -egl* -nas% -nis% -pch% -trace%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtsql-4.8.7-r1 [5.15.0] USE="exceptions%* qt3support%* (-aqua) -mysql* -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qt3support-4.8.7  USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtsvg-4.8.7 [5.15.0] USE="accessibility%* exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] sci-electronics/qucs-0.0.19  USE="-doc"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qtsql-4.8.7-r1::booboo
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtsql-4.8.7-r1:4 qt3support

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- dev-java/icedtea-web-1.6.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-03-27)
# Vulnerable old version of icedtea-web #711392
# new version is not packaged yet
# package is not going away anytime soon, just masked
# for security. unmask as needed.

- virtual/modutils-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mikle Kolyada <zlogene@gentoo.org> (2020-08-08)
# modutils is obsolete and does not build.
# No consumers in the tree.
# Removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I would like to use Qucs because it can calculate / simulate s-parameters (see http://qucs.sourceforge.net/images/q15.png) and I need this for an exam ...
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 7:10 pm    Post subject: Reply with quote

I unmasked icedtea-web in /usr/portage/profiles/package.mask by inserting #dev-java/icedtea-web.

Now I get:

Code:
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:69: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)
Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-qtgraphicssystem-1.1.1
[ebuild  NS    ] dev-qt/qtcore-4.8.7-r4 [5.15.0] USE="exceptions%* glib%* iconv%* qt3support%* ssl%* (-aqua) -icu* -libressl% -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qttranslations-4.8.7  ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtscript-4.8.7 [5.15.0] USE="exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtgui-4.8.7 [5.15.0] USE="cups%* exceptions%* glib%* gtkstyle%* mng%* qt3support%* tiff%* xinerama%* xv%* (-aqua) -egl* -nas% -nis% -pch% -trace%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtsql-4.8.7-r1 [5.15.0] USE="exceptions%* qt3support%* (-aqua) -mysql* -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qt3support-4.8.7  USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtsvg-4.8.7 [5.15.0] USE="accessibility%* exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] sci-electronics/qucs-0.0.19  USE="-doc"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qtsql-4.8.7-r1::booboo
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtsql-4.8.7-r1:4 qt3support

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- virtual/modutils-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mikle Kolyada <zlogene@gentoo.org> (2020-08-08)
# modutils is obsolete and does not build.
# No consumers in the tree.
# Removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46734
Location: 56N 3W

PostPosted: Wed Aug 12, 2020 7:10 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.

Installing old dead software on what looks like Sabayon.

Moved here to warn others that any solution that this topic may reach may not work on Gentoo.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 7:35 pm    Post subject: Reply with quote

Yes, I'm running Sabayon. Shouldn't make a big difference (?!). You should give it a try ;-)

I unmasked modutils in /usr/portage/profiles/package.mask --> #virtual/modutils

Doing an:

Code:
sudo emerge qucs


now gives me:

Code:
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:69: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)
Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-qtgraphicssystem-1.1.1
[ebuild  NS    ] dev-qt/qtcore-4.8.7-r4 [5.15.0] USE="exceptions%* glib%* iconv%* qt3support%* ssl%* (-aqua) -icu* -libressl% -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qttranslations-4.8.7  ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtscript-4.8.7 [5.15.0] USE="exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtgui-4.8.7 [5.15.0] USE="cups%* exceptions%* glib%* gtkstyle%* mng%* qt3support%* tiff%* xinerama%* xv%* (-aqua) -egl* -nas% -nis% -pch% -trace%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS    ] dev-qt/qtsql-4.8.7-r1 [5.15.0] USE="exceptions%* qt3support%* (-aqua) -mysql* -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] dev-qt/qt3support-4.8.7  USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)"
[ebuild  NS    ] dev-qt/qtsvg-4.8.7 [5.15.0] USE="accessibility%* exceptions%* (-aqua) -pch%" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N     ] sci-electronics/qucs-0.0.19  USE="-doc"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtsvg-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by sci-electronics/qucs-0.0.19::booboo
# required by qucs (argument)
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by dev-qt/qt3support-4.8.7::booboo
# required by dev-qt/qtgui-4.8.7::booboo[qt3support]
# required by dev-qt/qtcore-4.8.7-r4::booboo[qt3support]
# required by dev-qt/qttranslations-4.8.7::booboo
>=dev-qt/qtsql-4.8.7-r1:4 qt3support

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Last edited by MongoQ on Wed Aug 12, 2020 8:10 pm; edited 2 times in total
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 7:41 pm    Post subject: Reply with quote

Running:

Code:
sudo emerge qucs --autounmask-write


doesn't help much, I get:

Code:
[...]
Autounmask changes successfully written.
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 7:49 pm    Post subject: Reply with quote

I don't get the meaning of the lines:

Code:
>=dev-qt/qtsql-4.8.7-r1:4 qt3support
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 8:02 pm    Post subject: Reply with quote

Ok, I added:

Code:
>=dev-qt/qtcore-4.8.7-r4:4 qt3support
>=dev-qt/qtgui-4.8.7:4 qt3support
>=dev-qt/qtsql-4.8.7-r1:4 qt3support


to: /etc/portage/package.use/00-sabayon.package.use

Now I can do an:
Code:
sudo emerge qucs


and it seems to start compiling ... :lol:
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7974
Location: Austria

PostPosted: Wed Aug 12, 2020 8:12 pm    Post subject: Reply with quote

MongoQ wrote:
I don't get the meaning of the lines:

Code:
>=dev-qt/qtsql-4.8.7-r1:4 qt3support


dev-qt/qtsql comes with options, we call it USE flags:
Code:
$ equery u qtsql
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for dev-qt/qtsql-5.15.0:
 U I
 - - debug    : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
                https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 - - freetds  : Add support for the TDS protocol to connect to MSSQL/Sybase databases
 - - mysql    : Add mySQL Database support
 - - oci8     : Add Oracle 8 Database Support
 - - odbc     : Add ODBC Support (Open DataBase Connectivity)
 + + postgres : Add support for the postgresql database
 + + sqlite   : Add support for sqlite - embedded sql database
 - - test     : Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)


And you just enabled this option, qt3support, for three packages. It is a flag to be able to build Qt4-based packages that are so old or slowly maintained that they were still not ported away from various Qt3 code, maintaining compatibility.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 8:56 pm    Post subject: Reply with quote

I can get as far as this:

Code:
make: *** [Makefile:17866: .obj/release-shared/qsslsocket_openssl.o] Error 1
make: *** [Makefile:18077: .obj/release-shared/qsslsocket_openssl_symbols.o] Error 1
 * ERROR: dev-qt/qtcore-4.8.7-r4::booboo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtcore-4.8.7-r4::booboo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtcore-4.8.7-r4::booboo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7-abi_x86_32.x86/src/network'
 * S: '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7'

>>> Failed to emerge dev-qt/qtcore-4.8.7-r4, Log file:

>>>  '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/temp/build.log'

 * Messages for package dev-qt/qtcore-4.8.7-r4:

 * ERROR: dev-qt/qtcore-4.8.7-r4::booboo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtcore-4.8.7-r4::booboo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtcore-4.8.7-r4::booboo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7-abi_x86_32.x86/src/network'
 * S: '/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7'


I can go to
Code:
/var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7-abi_x86_32.x86/src/network

and do a make.

This gives me:

Code:
In file included from /usr/include/openssl/crypto.h:25,
                 from /usr/include/openssl/bio.h:20,
                 from /usr/include/openssl/asn1.h:16,
                 from /var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7/src/network/ssl/qsslsocket_openssl_p.h:66,
                 from /var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7/src/network/ssl/qsslsocket_openssl_symbols_p.h:57,
                 from /var/tmp/portage/dev-qt/qtcore-4.8.7-r4/work/qt-everywhere-opensource-src-4.8.7/src/network/ssl/qsslcertificate.cpp:114:
/usr/include/openssl/ossl_typ.h:93:16: Anmerkung: Vorwärtsdeklaration von »EVP_PKEY« {aka »struct evp_pkey_st«}
 typedef struct evp_pkey_st EVP_PKEY;
                ^~~~~~~~~~~
make: *** [Makefile:16790: .obj/release-shared/qsslcertificate.o] Fehler 1
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7974
Location: Austria

PostPosted: Wed Aug 12, 2020 9:14 pm    Post subject: Reply with quote

Qt4 is incompatible with >=OpenSSL-1.1, no big surprise. Unfortunately the overlay you picked made no attempt to keep its Qt4 packages buildable on modern systems, even though there was a bug it could have picked a patch from: https://bugs.gentoo.org/592536
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
MongoQ
n00b
n00b


Joined: 11 Aug 2020
Posts: 39

PostPosted: Wed Aug 12, 2020 9:22 pm    Post subject: Reply with quote

I have checked it, OpenSSL version 1.1.1g is installed.

Sabayon tells me the following packages are installed:

Code:
    @@ Paket: dev-libs/openssl-1.1.1g Branch: 5, [sabayon-weekly]
╠          Verfügbar:      Version: 1.1.1g ~ tag: NoTag ~ Version: 0
╠          Installiert:    Version: 1.1.1g ~ tag: NoTag ~ Version: 0
╠          Slot:           0
╠          Homepage:       https://www.openssl.org/
╠          Beschreibung:   full-strength general purpose
╠                          cryptography library (including
╠                          SSL and TLS)
╠          Lizenz:         openssl
╠      @@ Paket: dev-libs/openssl-compat-1.0.2u Branch: 5, [sabayon-weekly]
╠          Verfügbar:      Version: 1.0.2u ~ tag: NoTag ~ Version: 0
╠          Installiert:    Version: 1.0.2u ~ tag: NoTag ~ Version: 0
╠          Slot:           1.0.0
╠          Homepage:       https://www.openssl.org/
╠          Beschreibung:   full-strength general purpose
╠                          cryptography library (including
╠                          SSL and TLS)
╠          Lizenz:         openssl


Is there anything I can do to get Qucs compile any further?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46734
Location: 56N 3W

PostPosted: Wed Aug 12, 2020 9:24 pm    Post subject: Reply with quote

MongoQ,

Its time to spin up a virtual machne, or maybe just a chroot and do a whole obsolete install that is contemporary with the obsolete software you want to run.
It will be full of security issues, so whatever you do, don't let it connect to the internet.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum