Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade to python 3 issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1642

PostPosted: Fri Jul 10, 2020 9:09 pm    Post subject: upgrade to python 3 issues Reply with quote

Hello

I am trying to upgrade python according to the instructions https://www.gentoo.org/support/news-items/2020-04-22-python3-7.html but I have some issues that I can't resolve right now. I still have python 2.7 too.

Here are few configurations that I have:
Code:

[U]  dev-lang/python
     Available versions: 
     (2.7)  2.7.18
     (3.6)  3.6.10-r2(3.6/3.6m)^t 3.6.11-r1(3.6/3.6m)^t
     (3.7)  3.7.7-r2(3.7/3.7m)^t 3.7.8-r1(3.7/3.7m)^t
     (3.8)  3.8.2-r2^t 3.8.3-r1^t
     (3.9)  ~3.9.0_beta3^t ~3.9.0_beta4^t
       {-berkdb bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test +threads tk +wide-unicode wininst +xml ELIBC="uclibc"}
     Installed versions:  2.7.17(2.7)(20:21:15 12/21/19)(bluetooth gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -berkdb -build -doc -examples -hardened -libressl -tk -wininst ELIBC="-uclibc") 3.6.11-r1(3.6/3.6m)^t(00:00:55 07/11/20)(bluetooth gdbm ipv6 ncurses readline sqlite ssl threads xml -build -examples -hardened -libressl -test -tk -wininst) 3.7.8-r1(3.7/3.7m)^t(23:26:38 07/10/20)(bluetooth gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -libressl -test -tk -wininst) 3.8.3-r1(3.8)^t(23:21:37 07/10/20)(bluetooth gdbm ipv6 ncurses readline sqlite ssl xml -build -examples -hardened -libressl -test -tk -wininst)


emerge -p --update --newuse --deep --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "sys-auth/polkit" has unmet requirements.
- sys-auth/polkit-0.116-r1::gentoo USE="consolekit elogind gtk introspection kde nls pam -examples -jit (-selinux) -systemd -test" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( consolekit elogind systemd )

(dependency required by "sys-auth/elogind-243.7::gentoo[policykit]" [ebuild])
(dependency required by "sys-apps/dbus-1.12.18::gentoo[elogind]" [ebuild])
(dependency required by "net-wireless/bluez-5.54::gentoo[-systemd]" [ebuild])
(dependency required by "dev-lang/python-3.7.8-r1::gentoo[bluetooth]" [ebuild])
(dependency required by "dev-libs/libxml2-2.9.9-r3::gentoo[python_targets_python3_7,python]" [ebuild])
(dependency required by "sys-devel/gettext-0.20.1::gentoo" [ebuild])
(dependency required by "sys-apps/texinfo-6.7::gentoo[nls]" [ebuild])
(dependency required by "sys-libs/gpm-1.20.7-r2::gentoo" [installed])
(dependency required by "sys-libs/ncurses-6.2-r1::gentoo[gpm]" [ebuild])
(dependency required by "sys-libs/readline-7.0_p5-r1::gentoo" [installed])
(dependency required by "sys-libs/gdbm-1.13-r2::gentoo" [installed])
(dependency required by "dev-lang/perl-5.30.3::gentoo[gdbm]" [ebuild])
(dependency required by "sys-kernel/linux-headers-5.4-r1::gentoo" [ebuild])
(dependency required by "dev-libs/libbsd-0.10.0::gentoo" [installed])
(dependency required by "x11-libs/libICE-1.0.10::gentoo" [installed])
(dependency required by "x11-libs/libSM-1.2.3::gentoo" [installed])
(dependency required by "x11-libs/libXt-1.2.0::gentoo" [installed])
[/code]


I don't have
Code:
  PYTHON_TARGETS="python2_7 python3_7"
    PYTHON_SINGLE_TARGET="python3_7"
in any place.

First, can I get rid safely from python 2.7? There are many packages that still depend on it. Like
app-crypt/gcr-3.28.1 (>=dev-lang/python-2.7.5-r2:2.7) and many others (most of them have dependency of 2.7, python 3.6 and 3.7 all together).

I also tried to run
Code:
 emerge --depclean
but I get the following error:
Code:

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=dev-python/setuptools-42.0.2[python_targets_python3_6(-),-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] pulled in by:
 *     app-portage/gemato-14.3
 *
 *   dev-libs/icu:0/64.2=[abi_x86_64(-)] pulled in by:
 *     dev-db/sqlite-3.30.1
 *
 *   >=dev-python/setuptools-42.0.2[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] pulled in by:
 *     dev-python/incremental-17.5.0
 *
 *   >=dev-python/setuptools-42.0.2[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] pulled in by:
 *     dev-python/m2r-0.2.1
 *
 *   >=dev-python/setuptools-42.0.2[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] pulled in by:
 *     dev-python/chardet-3.0.4
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
 *
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 *
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the repository, since it may not
 * be possible to satisfy their dependencies.


I am not sure how to proceed from here. The error for
Code:
 
emerge -p --update --newuse --deep --with-bdeps=y @world
is posted above.

It's like catch 22. :D

Queen
Back to top
View user's profile Send private message
GDH-gentoo
Guru
Guru


Joined: 20 Jul 2019
Posts: 460
Location: South America

PostPosted: Fri Jul 10, 2020 10:03 pm    Post subject: Re: upgrade to python 3 issues Reply with quote

queen wrote:
Code:
!!! The ebuild selected to satisfy "sys-auth/polkit" has unmet requirements.
- sys-auth/polkit-0.116-r1::gentoo USE="consolekit elogind gtk introspection kde nls pam -examples -jit (-selinux) -systemd -test" ABI_X86="(64)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( consolekit elogind systemd )
Is this the only problem you are having? This has nothing to do with Python: you can't have both the elogind and consolekit USE flags set. Unset one of them. If you are using a desktop profile, you should unset consolekit, unless you have explicitly set it for a reason. If you have, please explain.

queen wrote:
First, can I get rid safely from python 2.7? There are many packages that still depend on it. Like
app-crypt/gcr-3.28.1 (>=dev-lang/python-2.7.5-r2:2.7) and many others (most of them have dependency of 2.7, python 3.6 and 3.7 all together).

I also tried to run
Code:
 emerge --depclean
but I get the following error:
...
Retry after the emerge --update --newuse command has been successful.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1778

PostPosted: Fri Jul 10, 2020 10:54 pm    Post subject: Reply with quote

Just so it is pointed out, you are still fine on having 2.7 with 3.x installed at the same time; so having python-2.7 isn't an issue on that part. As far as removing 2.7, it depends on what packages you have installed. It is possible to remove python-2.7, but need to go through what depends on it and remove/update/replace them so they don't have that dependency. It could very well be as simple of updating a USE flag or in case of like firefox using the -bin version.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1642

PostPosted: Fri Jul 10, 2020 10:55 pm    Post subject: Re: upgrade to python 3 issues Reply with quote

GDH-gentoo wrote:
queen wrote:
Code:
!!! The ebuild selected to satisfy "sys-auth/polkit" has unmet requirements.
- sys-auth/polkit-0.116-r1::gentoo USE="consolekit elogind gtk introspection kde nls pam -examples -jit (-selinux) -systemd -test" ABI_X86="(64)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( consolekit elogind systemd )
Is this the only problem you are having? This has nothing to do with Python: you can't have both the elogind and consolekit USE flags set. Unset one of them. If you are using a desktop profile, you should unset consolekit, unless you have explicitly set it for a reason. If you have, please explain.

queen wrote:
First, can I get rid safely from python 2.7? There are many packages that still depend on it. Like
app-crypt/gcr-3.28.1 (>=dev-lang/python-2.7.5-r2:2.7) and many others (most of them have dependency of 2.7, python 3.6 and 3.7 all together).

I also tried to run
Code:
 emerge --depclean
but I get the following error:
...
Retry after the emerge --update --newuse command has been successful.


I didn't deal yet with consolekit. I wanted to take care of that after I finish with the python upgrade. Now I notice that both of them are set. I will unset consolekit and reboot. Yes, I have a desktop profile
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1642

PostPosted: Sat Jul 11, 2020 12:21 am    Post subject: Reply with quote

I disabled consolekit and enabled elogind both in make.conf and in package.use.

Now I try to
Code:

emerge  --changed-use --deep @world
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "~dev-qt/qtcore-5.13.2".
(dependency required by "dev-qt/linguist-tools-5.13.2::gentoo" [installed])
(dependency required by "kde-frameworks/kwindowsystem-5.64.0::gentoo" [installed])
(dependency required by "kde-plasma/polkit-kde-agent-5.16.5::gentoo" [installed])
(dependency required by "sys-auth/polkit-0.116-r1::gentoo[kde]" [ebuild])
(dependency required by "sys-auth/elogind-243.7::gentoo[policykit]" [ebuild])
(dependency required by "sys-apps/dbus-1.12.18::gentoo[elogind]" [ebuild])
(dependency required by "net-wireless/bluez-5.54::gentoo[-systemd]" [ebuild])
(dependency required by "dev-lang/python-2.7.17::gentoo" [installed])
(dependency required by "dev-libs/libxml2-2.9.9-r3::gentoo[python_targets_python2_7,python]" [ebuild])
(dependency required by "dev-libs/wayland-1.17.0::gentoo" [installed])
(dependency required by "media-libs/mesa-20.0.8::gentoo[wayland]" [ebuild])
(dependency required by "x11-libs/cairo-1.16.0-r3::gentoo[opengl]" [installed])
(dependency required by "media-libs/harfbuzz-2.6.4::gentoo[cairo]" [installed])
(dependency required by "x11-libs/pango-1.42.4-r2::gentoo" [installed])
(dependency required by "dev-qt/qtwidgets-5.14.2::gentoo[gtk]" [ebuild])
(dependency required by "sys-auth/polkit-qt-0.113.0::gentoo" [installed])


And there are a lot of qt packages that I can't upgrade.
The version of qtcore I have installed is 5.14.2. So why it asks for an older version?

Also I can't upgrade portage (now it's due to python ...)

Code:

emerge --verbose-conflicts portage portage-utils
Calculating dependencies... done!
[ebuild     U  ] app-portage/portage-utils-0.87 [0.80]
[ebuild     U  ] dev-python/setuptools-46.4.0-r1 [40.6.3] PYTHON_TARGETS="python3_7* -python3_6* -python3_8% (-python3_9)"
[ebuild     U  ] dev-python/certifi-2020.4.5.1 [2019.6.16] PYTHON_TARGETS="python3_7* -python3_6* -python3_8% (-python3_9)"
[ebuild   R    ] app-portage/gemato-14.3  PYTHON_TARGETS="python3_7* -python3_6*"
[ebuild     U  ] sys-apps/portage-2.3.99-r2 [2.3.89-r1] PYTHON_TARGETS="python3_7* -python3_6*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-2.3.99-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 -python3_8" pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.3.89-r1:0/0::gentoo, installed) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 -python3_8" pulled in by
    >=sys-apps/portage-2.1[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),python_single_target_python3_6(+)] required by (app-portage/elogviewer-2.9:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-java/java-config-2.2.0-r4:2/2::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gentoolkit-0.4.6:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                 

app-portage/gemato:0

  (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge) USE="gpg -test -tools" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 -python3_8" pulled in by
    >=app-portage/gemato-14[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.99-r2:0/0::gentoo, ebuild scheduled for merge) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 -python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  (app-portage/gemato-14.3:0/0::gentoo, installed) USE="blake2 bzip2 gpg -lzma -sha3 -test -tools" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7 -python3_8" pulled in by
    >=app-portage/gemato-14[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (sys-apps/portage-2.3.89-r1:0/0::gentoo, installed) USE="(ipc) native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev (-selinux)" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 (-pypy3) -python3_7 -python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

dev-python/setuptools:0

  (dev-python/setuptools-46.4.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)" pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)"
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    >=dev-python/setuptools-42.0.2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (dev-python/enum34-1.1.6-r1:0/0::gentoo, installed) USE="-doc" ABI_X86="(64)" PYTHON_TARGETS="python2_7 -pypy"
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                               
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge) USE="gpg -test -tools" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 -python3_8"
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  (dev-python/setuptools-40.6.3:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7" pulled in by
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/certifi-2019.6.16:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/pygments-2.4.2:0/0::gentoo, installed) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7 -python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/cryptography-2.8:0/0::gentoo, installed) USE="-idna -libressl -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7 -python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_python3_6(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-util/meson-0.51.2:0/0::gentoo, installed) USE="(-test)" ABI_X86="(64)" PYTHON_TARGETS="python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/chardet-3.0.4:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/namespace-zope-1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyxattr-0.6.0-r1:0/0::gentoo, installed) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyblake2-1.1.2:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

dev-python/certifi:0

  (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)" pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-46.4.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  (dev-python/certifi-2019.6.16:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7" pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/setuptools-40.6.3:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    >=dev-python/certifi-2017.4.17[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/requests-2.21.0-r1:0/0::gentoo, installed) USE="ssl -socks5" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    dev-python/certifi[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/urllib3-1.24.2:0/0::gentoo, installed) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy (-pypy3) -python3_5 -python3_7"
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7921
Location: Austria

PostPosted: Sat Jul 11, 2020 12:30 am    Post subject: Reply with quote

queen wrote:
Now I try to
Code:

emerge  --changed-use --deep @world
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "~dev-qt/qtcore-5.13.2".
(dependency required by "dev-qt/linguist-tools-5.13.2::gentoo" [installed])

^ right there.

Because you only use --changed-use here but make no attempt of an upgrade otherwise while having very outdated packages installed.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1642

PostPosted: Sat Jul 11, 2020 11:41 am    Post subject: Reply with quote

asturm wrote:
queen wrote:
Now I try to
Code:

emerge  --changed-use --deep @world
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "~dev-qt/qtcore-5.13.2".
(dependency required by "dev-qt/linguist-tools-5.13.2::gentoo" [installed])

^ right there.

Because you only use --changed-use here but make no attempt of an upgrade otherwise while having very outdated packages installed.


Thanks. Removing the flag solved it and then I ran
Code:
emerge --deep --newuse --update @world
which now installs/rebuild about 500 packages. I had to remove some packages because there were few conflicts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum