Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't start x (xdm crashes) after moving to elogind
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
JohnBlbec
Guru
Guru


Joined: 08 Feb 2003
Posts: 304

PostPosted: Tue Jun 09, 2020 10:31 pm    Post subject: can't start x (xdm crashes) after moving to elogind Reply with quote

hello,

after moving from consolekit to elogind on my home pc (nvidia graphics) everything went well but on my work pc (intel graphics) i can't start x anymore. i'm using kernel 5.4.38, slim and openrc (not systemd) and i've rebuild whole system - it hasn't helped (mostly using stable packages versions).

$ rc-status | grep xdm
Code:

 xdm                                                               [  crashed  ]
 xdm-setup                                                         [  started  ]


$ sudo less /var/log/Xorg.0.log
Code:

.
.
[    28.086] (II) intel(0): [DRI2] Setup complete
[    28.086] (II) intel(0): [DRI2]   DRI driver: i965
[    28.086] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    28.087] (==) intel(0): Backing store enabled
[    28.087] (==) intel(0): Silken mouse enabled
[    28.087] (II) intel(0): Initializing HW Cursor
[    28.087] (II) intel(0): Set up textured video
[    28.087] (II) intel(0): DRI2: Enabled
[    28.087] (II) intel(0): DRI3: Enabled
[    28.087] (WW) intel(0): Option "PreferredMode" is not used
[    28.087] (WW) intel(0): Option "primary" is not used
[    28.087] (WW) intel(0): Option "Enable" is not used
[    28.087] (==) intel(0): hotplug detection: "enabled"
[    28.159] (II) intel(0): Allocated new frame buffer 1280x1024 stride 5120, tiled
[    28.159] (EE)
[    28.159] (EE) Backtrace:
[    28.159] (EE) 0: /usr/bin/X (xorg_backtrace+0x4d) [0x55af988a6fbd]
[    28.159] (EE) 1: /usr/bin/X (0x55af98700000+0x1aac45) [0x55af988aac45]
[    28.159] (EE) 2: /lib64/libpthread.so.0 (0x7f3350e21000+0x13020) [0x7f3350e34020]
[    28.159] (EE) 3: /lib64/libc.so.6 (gsignal+0x141) [0x7f3350ca0571]
[    28.159] (EE) 4: /lib64/libc.so.6 (abort+0x127) [0x7f3350c8a55b]
[    28.159] (EE) 5: /lib64/libc.so.6 (0x7f3350c68000+0x2242f) [0x7f3350c8a42f]
[    28.159] (EE) 6: /lib64/libc.so.6 (0x7f3350c68000+0x30e32) [0x7f3350c98e32]
[    28.159] (EE) 7: /usr/bin/X (0x55af98700000+0x744e3) [0x55af987744e3]
[    28.159] (EE) 8: /usr/lib64/xorg/modules/libfb.so (fbCreatePixmap+0x8a) [0x7f3350abbefa]
[    28.159] (EE) 9: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f3350601000+0x1389a1) [0x7f33507399a1]
[    28.159] (EE) 10: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f3350601000+0x134f4e) [0x7f3350735f4e]
[    28.159] (EE) 11: /usr/bin/X (0x55af98700000+0xd20ac) [0x55af987d20ac]
[    28.159] (EE) 12: /usr/bin/X (xf86CrtcRotate+0x323) [0x55af987d2a53]
[    28.159] (EE) 13: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f3350601000+0x133568) [0x7f3350734568]
[    28.159] (EE) 14: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f3350601000+0x133a6a) [0x7f3350734a6a]
[    28.159] (EE) 15: /usr/bin/X (xf86CrtcSetModeTransform+0x296) [0x55af987c8c16]
[    28.159] (EE) 16: /usr/bin/X (xf86SetDesiredModes+0xc6) [0x55af987c9146]
[    28.159] (EE) 17: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f3350601000+0x1376e0) [0x7f33507386e0]
[    28.159] (EE) 18: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f3350601000+0x137c60) [0x7f3350738c60]
[    28.159] (EE) 19: /usr/bin/X (AddScreen+0xd6) [0x55af98757546]
[    28.159] (EE) 20: /usr/bin/X (InitOutput+0x2b5) [0x55af98796c15]
[    28.159] (EE) 21: /usr/bin/X (0x55af98700000+0x5b083) [0x55af9875b083]
[    28.159] (EE) 22: /lib64/libc.so.6 (__libc_start_main+0xeb) [0x7f3350c8be1b]
[    28.159] (EE) 23: /usr/bin/X (_start+0x2a) [0x55af987451aa]
[    28.159] (EE)
[    28.159] (EE)
Fatal server error:
[    28.159] (EE) Caught signal 6 (Aborted). Server aborting
[    28.159] (EE)
[    28.159] (EE)


$ less /var/log/slim.log
Code:

slim: waiting for X server to begin accepting connections
Giving up.
slim: unable to connect to X server


$ cat /etc/conf.d/xdm
Code:

CHECKVT=7
DISPLAYMANAGER="slim"


$ cat .xinitrc
Code:

DEFAULT_SESSION=startfluxbox

[ -f ~/.Xresources ] && xrdb -merge ~/.Xresources

case $1 in
fluxbox)
  exec dbus-launch --sh-syntax --exit-with-session startfluxbox
  ;;
wmfs)
  exec dbus-launch --sh-syntax --exit-with-session wmfs
  ;;
i3)
  exec dbus-launch --sh-syntax --exit-with-session i3 --force-xinerama
  ;;
*)
  exec dbus-launch --sh-syntax --exit-with-session $DEFAULT_SESSION
  ;;
esac


$ eix -e xorg-server
Code:

[I] x11-base/xorg-server
     Available versions:  1.20.7(0/1.20.7) ~1.20.8(0/1.20.8) **9999(0/9999)*l {debug dmx doc elogind ipv6 kdrive +libglvnd libressl minimal selinux static-libs +suid systemd +udev unwind wayland xcsecurity xephyr xnest xorg xvfb}
     Installed versions:  1.20.7(0/1.20.7)(12:36:27 PM 06/02/2020)(elogind libglvnd suid udev xorg xvfb -debug -dmx -doc -ipv6 -kdrive -libressl -minimal -selinux -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest)
     Homepage:            https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/xserver/xorg-server
     Description:         X.Org X servers


$ eix -e xorg-x11
Code:

[I] x11-base/xorg-x11
     Available versions:  7.4-r3 {+fonts}
     Installed versions:  7.4-r3(07:41:46 AM 06/09/2020)(fonts)
     Homepage:            https://www.x.org/wiki/
     Description:         An X11 implementation maintained by the X.Org Foundation (meta package)


$ eix -e xorg-drivers
Code:

[I] x11-base/xorg-drivers
     Available versions:  1.20-r2 **9999*l {INPUT_DEVICES="elographics evdev joystick libinput synaptics vmmouse void wacom" VIDEO_CARDS="amdgpu ast dummy fbdev freedreno geode glint i915 i965 intel mga nouveau nv nvidia omap qxl r128 radeon radeonsi siliconmotion tegra vc4 vesa via virtualbox vmware"}
     Installed versions:  1.20-r2(07:59:06 AM 06/02/2020)(INPUT_DEVICES="evdev -elographics -joystick -libinput -synaptics -vmmouse -void -wacom" VIDEO_CARDS="i965 intel -amdgpu -ast -dummy -fbdev -freedreno -geode -glint -i915 -mga -nouveau -nv -nvidia -omap -qxl -r128 -radeon -radeonsi -siliconmotion -tegra -vc4 -vesa -via -virtualbox -vmware")
     Homepage:            https://wiki.gentoo.org/wiki/No_homepage
     Description:         Meta package containing deps on all xorg drivers


$ eix -e mesa
Code:

[I] media-libs/mesa
     Available versions:  19.3.5^t ~20.0.4-r1^t ~20.0.7^t ~20.1.0_rc4^t ~20.1.0^t **9999*l^t {+X +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +libglvnd +llvm lm-sensors opencl osmesa pax_kernel selinux test unwind vaapi valgrind vdpau vulkan vulkan-overlay wayland xa xvmc +zstd ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="linux" VIDEO_CARDS="freedreno i915 i965 intel iris lima nouveau panfrost r100 r200 r300 r600 radeon radeonsi vc4 virgl vivante vmware"}
     Installed versions:  19.3.5^t(06:40:41 PM 06/09/2020)(X classic dri3 egl gallium gbm gles2 libglvnd llvm vaapi wayland -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa -pax_kernel -selinux -test -unwind -valgrind -vdpau -vulkan -vulkan-overlay -xa -xvmc ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="linux" VIDEO_CARDS="i965 intel -freedreno -i915 -iris -lima -nouveau -panfrost -r100 -r200 -r300 -r600 -radeon -radeonsi -vc4 -virgl -vivante -vmware")
     Homepage:            https://www.mesa3d.org/ https://mesa.freedesktop.org/
     Description:         OpenGL-like graphic library for Linux


$ eix -e xdm
Code:

[I] x11-apps/xdm
     Available versions:  1.1.12 {consolekit ipv6 pam systemd truetype xinerama xpm}
     Installed versions:  1.1.12(08:32:03 AM 06/09/2020)(pam truetype -consolekit -ipv6 -systemd -xinerama -xpm)
     Homepage:            https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/app/xdm
     Description:         X.Org xdm application


emerge --info

slim.conf

xorg.conf

i've tried to execute startx but the result is the same - unable to start x.

any suggestion, please?
Back to top
View user's profile Send private message
JohnBlbec
Guru
Guru


Joined: 08 Feb 2003
Posts: 304

PostPosted: Thu Jun 11, 2020 4:26 pm    Post subject: Reply with quote

i've just created a Bug 727976 x11-base/xorg-server-1.20.7 always crashes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum