Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Intel HD620 no Xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bambus89
n00b
n00b


Joined: 24 May 2020
Posts: 6

PostPosted: Sun May 24, 2020 12:10 pm    Post subject: [Solved] Intel HD620 no Xorg Reply with quote

Hello there,

I have a fresh install and i can't get X running.

I Have tried all from the handbook and wiki and this https://forums.gentoo.org/viewtopic-t-1081408-start-0.html from gentoo forum but nothing works...

I tried modesetting ddx, intel-ddx and old intel driver.

Xorg.log for:
modesetting http://dpaste.com/1A7BA9K
intel ddx http://dpaste.com/1Y1J4ND
intel old http://dpaste.com/3B4F6Q2

edit:
I even testet different kernels (stock genkernel with gentoo-sources vannilla-kernel, gentoo-source with archlinux .config and gentoo-kernel-bin) Nothing...

What can i do to get X?


Thank you all


Last edited by bambus89 on Sun May 24, 2020 3:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46272
Location: 56N 3W

PostPosted: Sun May 24, 2020 2:15 pm    Post subject: Reply with quote

bambus89,


You have a case of Xorg loading things in the wrong order, resulting in undefined symbols.
Give it a nudge in the right direction.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
bambus89
n00b
n00b


Joined: 24 May 2020
Posts: 6

PostPosted: Sun May 24, 2020 2:54 pm    Post subject: Reply with quote

Thank you NeddySeagoon but i have done this and it did not work. Is there any other thing that could be wrong?
Or should i test the different orders of the modules in this list?

Code:
Section "Module"
   Load "vgahw"
   Load "fb"
   Load "shadowfb"
   Load "shadow"
   Load "glamoregl"
EndSection
Back to top
View user's profile Send private message
bambus89
n00b
n00b


Joined: 24 May 2020
Posts: 6

PostPosted: Sun May 24, 2020 3:07 pm    Post subject: Reply with quote

It works. I was stupid and called the "xorg.conf" file "Xorg.conf" so the system ignored it... Thank you
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46272
Location: 56N 3W

PostPosted: Sun May 24, 2020 3:14 pm    Post subject: Reply with quote

bambus89,

Did not work is not a useful diagnostic. Something may have changed that would be useful information.
It will be in the log.
Just test the modeset driver for now.

Your log posted as modeset shows that Xorg wan using auto detection as it shows

Code:
[    41.959] (==) Matched intel as autoconfigured driver 0
[    41.959] (==) Matched modesetting as autoconfigured driver 1
[    41.959] (==) Matched fbdev as autoconfigured driver 2
[    41.959] (==) Matched vesa as autoconfigured driver 3
[    41.959] (==) Assigned the driver to the xf86ConfigLayout

and the Intel driver fails with
Code:
[    41.960] (EE) Failed to load /usr/lib64/xorg/modules/drivers/intel_drv.so: /usr/lib64/xorg/modules/drivers/intel_drv.so: undefined symbol: vgaHWFreeHWRec


Go back to that setting and try just
Code:
Section "Module"
   Load "vgahw"
EndSection
the automatics may do the rest. That should change the error message.

I'm suggesting Load "vgahw" based on the vgaHWFreeHWRec missing symbol name.

-- edit --

That too :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum