Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Could not find the program 'konsole'
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 257

PostPosted: Mon May 11, 2020 6:23 pm    Post subject: Could not find the program 'konsole' Reply with quote

In dolphin when trying to open a .desktop file that runs a bash script results in "Could not find the program 'konsole'". I did not see anything in the forum/bugtracker so I'm thinking this is probably an edge case.

The only reference I have been able to find to this is https://forum.manjaro.org/t/could-not-find-the-program-konsole-error-after-manjaro-update/140484/9
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 2040
Location: Here and Away Again

PostPosted: Tue May 12, 2020 3:53 am    Post subject: €°(((>< Reply with quote

Does the file have

Code:
Terminal=true

and if yes, do you actually want it to run in a terminal?
_________________
Kind regards,
Chiitoo.

You might remember me from Gentoo projects such as Forums, LXQt, Qt, and Wine.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1830
Location: United Kingdom

PostPosted: Tue May 12, 2020 4:17 am    Post subject: Reply with quote

It's a bug in Plasma 5.18.5 by the look of it:

https://bugs.kde.org/show_bug.cgi?id=421374

Happened to me as well. A work-around until it gets fixed by the KDE developers is to edit the Desktop Configuration file and change the Exec=<command> entry to:

Code:
Exec=/usr/bin/konsole -e <command>


EDIT: Oh, and untick 'Run in terminal' (under 'Advanced Options'). I.e., as Chiitoo intimated, in the Desktop Configuration file:

Code:
Terminal=false


Most of my Bash scripts that are run by Desktop Configuration files have the following lines at the end, anyway:

Code:
echo -n "All done. Press ENTER to close this window: "
read -n1 REPLY
exit

_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 257

PostPosted: Fri May 15, 2020 5:59 am    Post subject: Reply with quote

This annoyed me enough I had to patch it instead of waiting for the official fix in 5.71.
Code:
mkdir -p /etc/portage/patches/kde-frameworks/kio
wget 'https://cgit.kde.org/kio.git/patch/?id=6452a34cf01d03d3167b38bc28a2fe8e13569021' -O /etc/portage/patches/kde-frameworks/kio/1.patch
emerge -av1 kde-frameworks/kio
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7746
Location: Austria

PostPosted: Fri May 15, 2020 8:18 am    Post subject: Reply with quote

You know you can file bugs in Gentoo, right? ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum