Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Odd multi-user pulseaudio issue (fluidsynth conflict)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 518
Location: Florida

PostPosted: Tue May 05, 2020 2:25 pm    Post subject: Odd multi-user pulseaudio issue (fluidsynth conflict) Reply with quote

I run gnome (3.34.4 at the moment) and have two users. One user (my primary account) has stopped working with pulseaudio on a recent update, but the other user appears unaffected.

For the user with no audio, I can run the following two commands to restore it:
Code:
pulseaudio -k
pulseaudio --start
... and all is well again. The other user does not have to do anything.

My 'getfacl' output:
Code:
rich@graendal ~ $ getfacl /dev/snd/controlC0
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/controlC0
# owner: root
# group: audio
user::rw-
user:rich:rw-
group::rw-
mask::rw-
other::---
No user is in the 'audio' group:
Code:
rich@graendal ~ $ grep audio /etc/group
audio:x:18:
What can I look into to figure out why I'm getting different outcomes for different users?
_________________
Life without passion is death in disguise


Last edited by KShots on Wed May 13, 2020 5:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
enkidu
n00b
n00b


Joined: 07 May 2020
Posts: 3

PostPosted: Thu May 07, 2020 11:09 pm    Post subject: Reply with quote

there is no reason (rich) user to be part of the audio group if it is identified as a owner of /dev/snd/controlC0 with rw permissions

ACL allow you to extend ownership , group , ... from one to multiple for specific files without integrating them in the full scope of the role accross the system tree.

you pulseaudio process you should be started by your service manager - systemd or openrc

in your post you dont precise the status of the pulseaudio before you kill it and by whom started it.

i see two possible problem here: pulseaudio is not started correctly with the correct user (rich) or it is not started at all before you start it with your pulseaudio command.
Back to top
View user's profile Send private message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 518
Location: Florida

PostPosted: Fri May 08, 2020 1:58 am    Post subject: Reply with quote

Yep, not sure where to begin on this. Here's what I get on login as far as what's running with pulseaudio:
Code:
gdm         1486  0.0  0.0 1276544 15628 ?       S<sl 20:09   0:00 /usr/bin/pulseaudio --daemonize=no
rich        1782  0.9  0.8 952860 526652 ?       Ssl  20:09   0:58 /usr/bin/fluidsynth -is -a pulseaudio -m alsa_seq -r 48000 /home/rich/sf2/MT-32-32K-v1-r65-Full-Hedsound.sf2
rich        8637  3.0  0.0 1539940 17548 ?       S<sl 21:55   0:00 /usr/bin/pulseaudio --daemonize=no
Note that pulseaudio is running for user 'rich' (PID 8637 in this case), but it is not functional. I'm using systemd, but I know of no service to check for logging purposes. A simple 'systemctl status pulseaudio' claims there is no such service.
_________________
Life without passion is death in disguise
Back to top
View user's profile Send private message
enkidu
n00b
n00b


Joined: 07 May 2020
Posts: 3

PostPosted: Fri May 08, 2020 8:28 am    Post subject: Reply with quote

since the problem looks user oriented - have you tried this after upgrading part from the gentoo wiki : https://wiki.gentoo.org/wiki/PulseAudio to force regenerating user pulseaudio config files ?

No sound:

After installation: If you have no sound while using ALSA, consider unmuting the sound card. Launch alsamixer and make sure each column has a green 00 under it (use the m key to toggle mute/unmute). Install media-sound/pavucontrol and check if there is any output on the pavucontrol panel when playing audio.

After upgrading the system: pulseaudio's user configuration files can become corrupt. Deleting ~/.pulse* configuration files and forcing fresh ones to be generated by restarting the daemon may fix no sound condition.
Back to top
View user's profile Send private message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 518
Location: Florida

PostPosted: Fri May 08, 2020 11:54 pm    Post subject: Reply with quote

enkidu wrote:
since the problem looks user oriented - have you tried this after upgrading part from the gentoo wiki : https://wiki.gentoo.org/wiki/PulseAudio to force regenerating user pulseaudio config files ?

No sound:

After installation: If you have no sound while using ALSA, consider unmuting the sound card. Launch alsamixer and make sure each column has a green 00 under it (use the m key to toggle mute/unmute). Install media-sound/pavucontrol and check if there is any output on the pavucontrol panel when playing audio.

After upgrading the system: pulseaudio's user configuration files can become corrupt. Deleting ~/.pulse* configuration files and forcing fresh ones to be generated by restarting the daemon may fix no sound condition.
alsamixer simply locks up until I CTRL-C it. pavucontrol simply displays a message stating "Establishing connection to PulseAudio. Please wait..." and never gets any further. I have no "~/.pulse*" files to be corrupted.
_________________
Life without passion is death in disguise
Back to top
View user's profile Send private message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 518
Location: Florida

PostPosted: Mon May 11, 2020 10:53 pm    Post subject: Reply with quote

Anyone else seeing similar? What else can I poke to dig up more information on what's going on? I know there's a systemd unit file somewhere, but I have been unable to find it to query about status and such.
_________________
Life without passion is death in disguise
Back to top
View user's profile Send private message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 518
Location: Florida

PostPosted: Tue May 12, 2020 10:15 pm    Post subject: Reply with quote

About the only difference between the accounts I can tell is that one has the fluidsynth systemd service enabled, and the other doesn't. The one with fuildsynth has broken pulseaudio. Below is what's in the fluidsynth service unit file:
Code:
rich@graendal ~ $ systemctl cat fluidsynth
# /lib/systemd/system/fluidsynth.service
[Unit]
Description=FluidSynth Daemon
Documentation=man:fluidsynth(1)
After=sound.target

[Service]
Type=notify
NotifyAccess=main
EnvironmentFile=/etc/fluidsynth.conf
EnvironmentFile=-%h/.config/fluidsynth
ExecStart=/usr/bin/fluidsynth -is $OTHER_OPTS $SOUND_FONT

[Install]
WantedBy=multi-user.target
What might be happening is that fluidsynth is now launching before pulse? Possibly? I can't change the order, as pulse doesn't appear to have a unit file to wait on.
_________________
Life without passion is death in disguise
Back to top
View user's profile Send private message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 518
Location: Florida

PostPosted: Wed May 13, 2020 5:40 pm    Post subject: Reply with quote

Confirmed - fluidsynth is the culprit. I disabled the fluidsynth user service and voila - pulseaudio starts correctly on login. How can I modify the above service file to accommodate the new behavior of pulseaudio?
_________________
Life without passion is death in disguise
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum