Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Black screen with cursor with every display manager
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
popetto
n00b
n00b


Joined: 13 Aug 2019
Posts: 22
Location: Italy

PostPosted: Tue Apr 21, 2020 11:15 am    Post subject: [SOLVED] Black screen with cursor with every display manager Reply with quote

Hi all, I have done a fresh installation of Gentoo and I installed XFCE as DE. Since several Display Managers can be installed, I tried to use lightdm. There is one annoying problem: lightdm (but also sddm and lxdm) stucks on boot, leaving a black screen with a static cursor. Nothing is allowed to me, except rebooting with the physical button (not with CTRL+ALT+CANC). The two weird things are that it happens the same with other DMs and, above all, that booting through recovery mode makes everything working. Last time, I uninstalled Gentoo for this issue (as now, I couldn't find the problem).
Please help me, I will post everything needed.
Thank you in advance

EDIT: for the solution go at the end of the topic


Last edited by popetto on Tue Apr 21, 2020 7:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
alamahant
Apprentice
Apprentice


Joined: 23 Mar 2019
Posts: 294

PostPosted: Tue Apr 21, 2020 11:21 am    Post subject: Reply with quote

Try pressing CTRL+Alt+F2.
This will allow you to login non-graphically.
Then after login run:
Code:

startxfce4

Then in /etc/conf.d/xdm
enter
Code:

DISPLAYMANAGER="lightdm"

and enable dbus service
Code:

rc-update add dbus default
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Tue Apr 21, 2020 11:26 am    Post subject: Reply with quote

popetto,

Disable the display manager, using the chroot if you need to.

Install wgetpaste if you don't have it yet and use it to put the output of dmesg, from booting your own kernel and /var/log/Xorg.0.log onto pastebins please.
Also post the output of
Code:
lspci -nnk
so we can see your hardware.

Your kernel .config file may be useful too.

Your display manager, whatever it is, is one of the layers in a cake.
The upper layers depend on the lower layers working properly.
As none of your display managers work, we need to look for a common problem in the lower layers.

We will look at the lower layers of your 'cake', test them individually, then making your display manager work will be straight forward.
By keeping the problem space small, we can locate problems as they arise.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
popetto
n00b
n00b


Joined: 13 Aug 2019
Posts: 22
Location: Italy

PostPosted: Tue Apr 21, 2020 1:40 pm    Post subject: Reply with quote

alamahant wrote:

Unfortunately CTRL+Alt+F2 doesn't work. I had already tried and everything is already set as you told. :cry:


NeddySeagoon wrote:
I want to punctualize that, using the recovery mode, I manage to reach the display manager and to log in graphically. The problem is when I don't use recovery mode.
However, these are the logs (with xdm disabled):
-dmesg: http://dpaste.com/21ZNNZS
-Xorg.0.log: http://dpaste.com/3G93XEY
-lspci: http://dpaste.com/0Z5D2CX
-kernel .config: http://dpaste.com/0801H5C
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Tue Apr 21, 2020 3:52 pm    Post subject: Reply with quote

popetto,

Here is your video card, with the nvidia_drm and nvidia kernel modules loaded.
lspci:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107 [GeForce GTX 1050] [10de:1c81] (rev a1)
   Subsystem: Micro-Star International Co., Ltd. [MSI] GP107 [GeForce GTX 1050] [1462:8c97]
   Kernel driver in use: nvidia
   Kernel modules: nvidia_drm, nvidia


dmesg:
[    0.552746] simple-framebuffer simple-framebuffer.0: framebuffer at 0xd1000000, 0x300000 bytes, mapped to 0x00000000b79a13b7
[    0.552749] simple-framebuffer simple-framebuffer.0: format=a8r8g8b8, mode=1024x768x32, linelength=4096
[    0.553922] Console: switching to colour frame buffer device 128x48

That's nvidia-drivers compatible, so far so good.


Xorg.0.log:
[    53.035] (II) Server terminated successfully (0). Closing log file.

That worked too.
Code:
[    11.175] (II) event3  - AT Translated Set 2 keyboard: device is a keyboard
[    52.828] (II) event2  - Power Button: device removed

Xorg ran for 42 seconds then exited cleanly. When you hit the big red switch, that message is not written.

I can't prove this, from logs but I suspect that your display manager tried to start but couldn't.
That log is left over from the last time Xorg started and shut down cleanly. I should have made it clear that I wanted the log that remained after a failed start.

No matter. Right now, the next step is the same regardless. See Xorg start without your display manager.

With your display manager disabled, boot to the shell.
If you have an ~/.xinitrc rename it to ~/.xinitrc_broken.
Code:
emerge -1 twm xclock xterm

When emerge completes, run startx
You should get three xterms and an analogue clock all wrapped up in twm.

twm only uses the left mouse button. If that works, we know that Xorg is good and the problem is with your display manager somewhere.
What you are looking at is the default Xorg startup.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
popetto
n00b
n00b


Joined: 13 Aug 2019
Posts: 22
Location: Italy

PostPosted: Tue Apr 21, 2020 4:13 pm    Post subject: Reply with quote

NeddySeagoon wrote:
popetto,
I should have made it clear that I wanted the log that remained after a failed start.


I'm so sorry. :oops:
I can confirm that the problem is not with startx: it works perfectly (I'm writing from Firefox on Gentoo). The problem, as you said, is somewhere in the display manager and I asked for help because I cannot find the problem.
Now I try to boot normally and I will load (from chroot :roll: ) the Xorg.0.log (and, if needed, other logs). I'm using lightdm now.

EDIT: this is the log for Xorg : http://dpaste.com/0PNMF7V
-lightdm.log: http://dpaste.com/17TSC6H
-seat0-greeter.log: http://dpaste.com/0V6NBWJ (the error seems to be here)

It seems like the boot is too fast... because with recovery mode the boot becomes slower and it works... maybe I found the problem
Back to top
View user's profile Send private message
popetto
n00b
n00b


Joined: 13 Aug 2019
Posts: 22
Location: Italy

PostPosted: Tue Apr 21, 2020 5:48 pm    Post subject: Reply with quote

I'm quite sure that the problem is the speed. Googling a bit, I found on Manjaro forum (from Arch) this option on lightdm.conf that could be related to my problem:
Code:
 logind-check-graphical
.
It seems that the system loads too fast and so it starts lightdm before loading nvidia module, I guess.
This is the discussion: https://forum.manjaro.org/t/solved-lightdm-greeter-xorg-problem-occurs-from-2nd-boot-and-later-on-each-stable-update-kernel-4-18-n-4-19/64144
The problem now (with logind-check-graphical=true) is that once or twice it starts, the remaining times lightdm doesn't work and it leaves me login non-graphically.
lightdm.log is blank, while seat0-greeter looks like this: http://dpaste.com/0JB615V
I think the solution is ( :cry: ) to slow down the boot. How can I do?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Tue Apr 21, 2020 5:57 pm    Post subject: Reply with quote

popetto,

Code:
Gdk-Message: 18:19:53.766: lightdm-gtk-greeter: Fatal IO error 11 (Risorsa temporaneamente non disponibile) on X server :0.

If google got it right, the error is "Temporarily unavailable resource".
That says that display:0 is not available but there are no hints as to why.

You can force the nvidia kernel module to load. I don't know exactly how as I don't use systemd.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
popetto
n00b
n00b


Joined: 13 Aug 2019
Posts: 22
Location: Italy

PostPosted: Tue Apr 21, 2020 5:58 pm    Post subject: Reply with quote

NeddySeagoon wrote:
popetto,

Code:
Gdk-Message: 18:19:53.766: lightdm-gtk-greeter: Fatal IO error 11 (Risorsa temporaneamente non disponibile) on X server :0.

If google got it right, the error is "Temporarily unavailable resource".
That says that display:0 is not available but there are no hints as to why.

You can force the nvidia kernel module to load. I don't know exactly how as I don't use systemd.


Neither do I. I use openrc. How can I do?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Tue Apr 21, 2020 6:15 pm    Post subject: Reply with quote

popetto,

I'm pleased to hear it :)

You will have a file called /etc/conf.d/modules it probably has nothing but comments in it.
Add a line
Code:
modules="nvidia"

If the modules= line already exists, its a space separated list, like USE flags.

Use
Code:
rc-update show
to check that the modules service is in the boot runlevel, (it should be).

This forces the nvidia kernel module to load before the default runlevel is entered.
That should be soon enough.
If not, we can add a delay no the end of the modules service. That will be a horrible hack though.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
popetto
n00b
n00b


Joined: 13 Aug 2019
Posts: 22
Location: Italy

PostPosted: Tue Apr 21, 2020 7:03 pm    Post subject: Reply with quote

NeddySeagoon wrote:
popetto,

I'm pleased to hear it :)

You will have a file called /etc/conf.d/modules it probably has nothing but comments in it.
Add a line
Code:
modules="nvidia"

If the modules= line already exists, its a space separated list, like USE flags.

Use
Code:
rc-update show
to check that the modules service is in the boot runlevel, (it should be).

This forces the nvidia kernel module to load before the default runlevel is entered.
That should be soon enough.
If not, we can add a delay no the end of the modules service. That will be a horrible hack though.


Thank you so much!!! It seems that it works now! I can mark this topic as solved! :D

SOLUTION:
if you use lightdm and nvidia:
1) set "logind-check-graphical=true" in /etc/lightdm/lightdm.conf (perhaps this step is optional);
2) force the load of the module nvidia by adding
Code:
modules="nvidia"
to /etc/conf.d/modules
Enjoy!

Thanks again to NeddySeagoon for the solution!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum