Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
multimonitor/multigpu half-screen problem (AMD - no Optimus)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
zolfo
n00b
n00b


Joined: 30 Nov 2009
Posts: 22

PostPosted: Sun Apr 19, 2020 6:12 pm    Post subject: multimonitor/multigpu half-screen problem (AMD - no Optimus) Reply with quote

Hi everybody,
sorry if this has already been explained or solved on another post, but I can't find it or use the right words to search for it.
As the title says I'm trying to setup multimonitors with 2 PCIe GPUs to extend the first monitor with the sole use of xrandr (so to use it on-demand), without any xorg.conf file.
The drivers are compiled and loaded correctly (amdgpu and radeon respectively) and the system recongnizes both GPUs:
Code:
$:\ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x5a cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 5 associated providers: 1 name:Radeon RX Vega @ pci:0000:43:00.0
Provider 1: id: 0xa5 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 4 associated providers: 1 name:ATI FirePro 2270 @ pci:0000:08:00.0

First I ran this command to let X use the second GPU output (I'm using Reverse Prime):
Code:
xrandr --setprovideroutputsource 1 0

Then this one to configure the monitor(s) attached to the second GPU:
Code:
xrandr --auto

My main monitor has a resolution of 2560x1440 (2K) at 60Hz of refresh rate and the second monitor is a 4:3 screen with 1280x1024 of max resolution and 70Hz of refresh rate.
At this point I have output from the monitor and I can manage it inside KDE's control panel to extend the first screen, but the problem is that only half screen seems to be usable.
Here are two photos of the problem I took with my phone (never mind the quality of the image on the screen, is the photo):
I can move the mouse cursor over the whole area of the monitor, but any window or even the wallpaper use only a part of it.
Here is a screenshot taken with scrot of the two screens showing that X/the system is drawing everything correctly.
The monitor and the secondary GPU work correctly if used normally (in a primary gpu configuration), I even tried with another monitor and changing the refresh rate but
I get the same result, so I can exclude an hardware problem (and a driver problem too I think?).
Of course maybe I'm just missing some basic command/step, but I think I'll need to tell the system the geometry of the available area?
Here's the output of xrandr, and as usual emerge --info (minus layman's overlays to reduce the wall of text):
Code:
emerge --info
Portage 2.3.89 (python 3.6.10-final-0, default/linux/amd64/17.1/desktop/plasma/systemd, gcc-8.2.0, glibc-2.29-r7, 5.5.7-gentoolocalmodconfignvmevega64 x86_64)
=================================================================
System uname: Linux-5.5.7-gentoolocalmodconfignvmevega64-x86_64-AMD_Ryzen_Threadripper_1950X_16-Core_Processor-with-gentoo-2.6
KiB Mem:    32804796 total,   3401396 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Tue, 14 Apr 2020 06:30:01 +0000
Head commit of repository gentoo: 990a108c6aaae27d968207b6b75da9eb5a9d0cd9
Head commit of repository dxvk: f89c8eb3d216ff6015f7567ed685fbfc9b457ec7

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r2::gentoo, 3.6.10-r1::gentoo, 3.7.7-r1::gentoo
dev-util/cmake:           3.16.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo, 2.33.1-r1::gentoo
sys-devel/gcc:            8.2.0-r6::gentoo, 9.2.0-r2::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -ftree-vectorize -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/conf.d /etc/init.d /usr/share/config /usr/share/config/kdm /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.3/ext-active/ /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/terminfo"
CXXFLAGS="-O2 -ftree-vectorize -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=7 --load-average=7.0 --keep-going --with-bdeps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news nodoc noinfo parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://archive.mmu.edu.my/gentoo rsync://gentoo.bloodhost.ru/gentoo-distfiles ftp://gentoo.mirrors.tds.net/gentoo ftp://ftp.halifax.rwth-aachen.de/gentoo/ rsync://mirror.neolabs.kz/gentoo http://ftp.gentoo.bg/ http://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://ftp.cc.uoc.gr/mirrors/linux/gentoo/"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it it_IT en en_US"
MAKEOPTS="-j32 -s"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities aiglx alsa amd64 audiofile avahi bash-completion berkdb bidi bzip2 cairo cdda cddb cdr cli cpudetection crypt cups dbus declarative dga dri drm dts dvd dvdr dvdread dvi egl emboss encode exif ext4 fame fat ffmpeg firefox flac fontconfig foomatic-db fortran freetype gcj gdbm gif gimpprint gles gles2 gmp gnutls gphoto2 gpm gsm hfs iconv icu imap inotify ipod ipv6 irc joystick jpeg kde kdeenablefinal kdehiddenvisibility kipi kwallet lame lcd lcms ldap libnotify libtirpc live lm_sensors lzo mad mail matroska mjpeg mng mozdevelop mp3 mp3rtp mp4 mpeg mtp multilib musepack musicbrainz ncurses network networkmanager nls nptl nsplugin ntfs ogg openal opencl openexr opengl openh264 openmax openmp pam pango pcre pda pdf perl phonon plasma png policykit ppds pulseaudio python qml qt5 rar rdesktop readline real scanner sdl seccomp speex spell split-usr ssl startup-notification stream svg sysfs systemd tcpd theora threads tiff truetype udev udisks unicode upower usb vaapi vdpau visualization vorbis vulkan wayland widgets wifi win32codecs wmf wxwidgets x264 x265 xattr xcb xcomposite xfs xinerama xml xpm xprint xulrunner} xv xvid zeroconf zlib" ABI_X86="32 64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="AMDGPU" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python3_6" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby24" SANE_BACKENDS="plustek epson epson2 epjitsu" USERLAND="GNU" VIDEO_CARDS="amdgpu radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Please kindly advise and tell me if I missed some information, I'll try to post it right away.

Thanks
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Sun Apr 19, 2020 6:57 pm    Post subject: Reply with quote

zolfo,

Your /var/log/Xor.0.log may be useful. It will tell what Xorg did when it started.

Make friends with wgetpaste and put it onto a pastebin please.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
zolfo
n00b
n00b


Joined: 30 Nov 2009
Posts: 22

PostPosted: Sun Apr 19, 2020 7:21 pm    Post subject: Reply with quote

NeddySeagoon,
here it is my Xorg.0.log, thanks for suggesting the use of wgetpaste - I didn't know about it.

Thanks
Back to top
View user's profile Send private message
zolfo
n00b
n00b


Joined: 30 Nov 2009
Posts: 22

PostPosted: Thu Apr 23, 2020 9:51 am    Post subject: Reply with quote

Hi,
does anybody have an idea on how to solve this? Or point me to the right forum/ML to ask for help.

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum