Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
r8169 link is up and down frequently!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
prehonor
n00b
n00b


Joined: 13 Nov 2019
Posts: 28

PostPosted: Mon Mar 23, 2020 5:34 am    Post subject: r8169 link is up and down frequently! Reply with quote

After the system starts and enters the desktop environment, the network takes a long time to connect through Networkmanager
there ars some logs as:
http://dpaste.com/3DC3DYP
http://dpaste.com/1PKFGH0

unit file list:
http://dpaste.com/0TRXZGZ

Thanks


Last edited by prehonor on Mon Mar 23, 2020 3:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
alamahant
Tux's lil' helper
Tux's lil' helper


Joined: 23 Mar 2019
Posts: 141

PostPosted: Mon Mar 23, 2020 11:28 am    Post subject: Reply with quote

r8169 is a BS driver.
Indeed it displays erratic behavior.
I had many many problems with this abominable driver and my realtek gigabit ethernet card.
I would advice you to use an external usb ethernet dongle but I know I will be censored for doing so...
So maybe just use wifi...........
OR find and compile a driver from your nic manufacturer if available......
:D
Back to top
View user's profile Send private message
sdauth
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2018
Posts: 90
Location: Frankreich

PostPosted: Mon Mar 23, 2020 11:42 am    Post subject: Reply with quote

Have you tried to replace your gigabit ethernet cable ? Or before that, check that it is correctly attached. I've had similar issue in the past because of defective cable.

Last edited by sdauth on Mon Mar 23, 2020 5:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
alamahant
Tux's lil' helper
Tux's lil' helper


Joined: 23 Mar 2019
Posts: 141

PostPosted: Mon Mar 23, 2020 11:46 am    Post subject: Reply with quote

Quote:
Have you tried to replace your gigabit ethernet cable ? Or before that, check that is correctly attached

It is working just fine in Windows...........
Back to top
View user's profile Send private message
Ionen
Guru
Guru


Joined: 06 Dec 2018
Posts: 525

PostPosted: Mon Mar 23, 2020 1:53 pm    Post subject: Reply with quote

I remember someone recently who had a similar issue except it had nothing to do with hardware but rather it was NetworkManager fighting with other network managing software bringing it up/down in a loop.

Not that I can say if this is what is happening here :) I never tried NetworkManager.


Last edited by Ionen on Mon Mar 23, 2020 1:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4397
Location: Dallas area

PostPosted: Mon Mar 23, 2020 1:56 pm    Post subject: Reply with quote

alamahant wrote:
r8169 is a BS driver.
Indeed it displays erratic behavior.
I had many many problems with this abominable driver and my realtek gigabit ethernet card.


*hmm* I've been using the driver for years with no problems.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Ionen
Guru
Guru


Joined: 06 Dec 2018
Posts: 525

PostPosted: Mon Mar 23, 2020 1:58 pm    Post subject: Reply with quote

^ likewise, using it on 3 different PCs with varying hardware age and no issues on any of them.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7468
Location: Saint Amant, Acadiana

PostPosted: Mon Mar 23, 2020 2:15 pm    Post subject: Reply with quote

Same here, this driver may emit firmware load errors, but it definitely works without firmware. There is also net-misc/r8168 in portage. I believe Ionen is on the right track diagnosing this issue.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum