Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[CLOSED] qutebrowser and anki ignore XKB options.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
crocket
Guru
Guru


Joined: 29 Apr 2017
Posts: 399

PostPosted: Wed Mar 11, 2020 2:06 pm    Post subject: [CLOSED] qutebrowser and anki ignore XKB options. Reply with quote

> setxkbmap -query
rules: evdev
model: pc104
layout: us
options: altwin:menu_win

> setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us+inet(evdev)+altwin(menu_win)" };
xkb_geometry { include "pc(pc104)" };
};

altwin:menu_win turns menu key into right win key. Qutebrowser and anki ignore altwin:menu_win. They may bypass xkb entirely. PyQt5 seems to be the culprit because qtgui itself doesn't have this issue.

Does anyone know how to make qutebrowser and anki respect xkb options?

Update: https://bugreports.qt.io/browse/QTBUG-82856
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum