Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(domanda) aggiornamente software con packages.use
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Mar 06, 2020 12:56 pm    Post subject: (domanda) aggiornamente software con packages.use Reply with quote

Salve, scusate la mia ignoranza e devo ancora capire come funziona del tutto Gentoo. Ma i software che li metto sul percorso /etc/portage/package.use per mettere i flags nel singolare pacchetto ma essendo che si mette anche la versione del pacchetto, quando esce la versione nuova del pacchetto cosa succede?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23989
Location: here

PostPosted: Fri Mar 06, 2020 1:03 pm    Post subject: Reply with quote

Dipende cosa hai messo in package.use. Prendiamo per esempio media-gfx/gimp di default ha attivato le seguenti flag
Code:
[ebuild   R    ] media-gfx/gimp-2.10.14-r1:2::gentoo  USE="alsa mng udev xpm -aalib (-altivec) (-aqua) -debug -doc -gnome -heif -jpeg2k -openexr -postscript -python -test -unwind -vector-icons -webp -wmf" CPU_FLAGS_X86="mmx sse" PYTHON_SINGLE_TARGET="python2_7" 0 KiB

Ora assumiamo che voglia attivare la use flag webp se mettiamo in package.use
Code:
=media-gfx/gimp-2.10.14-r1 webp

questo avra' effetto solo sulla specifica versione (2.10.14-r1) mentre se mettiamo
Code:
media-gfx/gimp webp

verra' attivata per ogni passata e futura versione.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Mar 06, 2020 1:06 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Dipende cosa hai messo in package.use. Prendiamo per esempio media-gfx/gimp di default ha attivato le seguenti flag
Code:
[ebuild   R    ] media-gfx/gimp-2.10.14-r1:2::gentoo  USE="alsa mng udev xpm -aalib (-altivec) (-aqua) -debug -doc -gnome -heif -jpeg2k -openexr -postscript -python -test -unwind -vector-icons -webp -wmf" CPU_FLAGS_X86="mmx sse" PYTHON_SINGLE_TARGET="python2_7" 0 KiB

Ora assumiamo che voglia attivare la use flag webp se mettiamo in package.use
Code:
=media-gfx/gimp-2.10.14-r1 webp

questo avra' effetto solo sulla specifica versione (2.10.14-r1) mentre se mettiamo
Code:
media-gfx/gimp webp

verra' attivata per ogni passata e futura versione.


allora sono io che sono stato poco attento. Mi sembrava che non mettendoli la versione poi portage mi dava come invalido
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8336
Location: ~Brussels - Belgique

PostPosted: Fri Mar 06, 2020 1:15 pm    Post subject: Reply with quote

Moved from Risorse italiane (documentazione e tools) to Forum italiano (Italian).
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Mar 06, 2020 1:25 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Dipende cosa hai messo in package.use. Prendiamo per esempio media-gfx/gimp di default ha attivato le seguenti flag
Code:
[ebuild   R    ] media-gfx/gimp-2.10.14-r1:2::gentoo  USE="alsa mng udev xpm -aalib (-altivec) (-aqua) -debug -doc -gnome -heif -jpeg2k -openexr -postscript -python -test -unwind -vector-icons -webp -wmf" CPU_FLAGS_X86="mmx sse" PYTHON_SINGLE_TARGET="python2_7" 0 KiB

Ora assumiamo che voglia attivare la use flag webp se mettiamo in package.use
Code:
=media-gfx/gimp-2.10.14-r1 webp

questo avra' effetto solo sulla specifica versione (2.10.14-r1) mentre se mettiamo
Code:
media-gfx/gimp webp

verra' attivata per ogni passata e futura versione.


forse ho capito, cioè che se voglio le flags solo sulla versione specifica devo mettere pure il maggiore e l'uguale ">=" all'inizio ma se voglio su tutte la future versione no, vero?
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1031
Location: Italy

PostPosted: Fri Mar 06, 2020 1:47 pm    Post subject: Reply with quote

Se vuoi le USE flags solo sulla versione specifica devi mettere solo l'uguale.
Se vuoi le USE flags sulla versione specifica e su tutte quelle successive devi mettere maggiore-uguale.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23989
Location: here

PostPosted: Fri Mar 06, 2020 1:51 pm    Post subject: Reply with quote

darkfor.del wrote:
forse ho capito, cioè che se voglio le flags solo sulla versione specifica devo mettere pure il maggiore e l'uguale ">=" all'inizio ma se voglio su tutte la future versione no, vero?

Code:
# applica la use flag a tutte le versioni di gimp
media-gfx/gimp webp
# applica la use flag solo alla versione 2.10.14-r1
=media-gfx/gimp-2.10.14-r1 webp
# applica la use flag dalla versione 2.10.14-r1, compresa, in poi
>=media-gfx/gimp-2.10.14-r1 webp
# applica la use flag fino alla versione 2.10.14-r1, compresa
<=media-gfx/gimp-2.10.14-r1 webp

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Mar 06, 2020 2:14 pm    Post subject: Reply with quote

fedeliallalinea wrote:
darkfor.del wrote:
forse ho capito, cioè che se voglio le flags solo sulla versione specifica devo mettere pure il maggiore e l'uguale ">=" all'inizio ma se voglio su tutte la future versione no, vero?

Code:
# applica la use flag a tutte le versioni di gimp
media-gfx/gimp webp
# applica la use flag solo alla versione 2.10.14-r1
=media-gfx/gimp-2.10.14-r1 webp
# applica la use flag dalla versione 2.10.14-r1, compresa, in poi
>=media-gfx/gimp-2.10.14-r1 webp
# applica la use flag fino alla versione 2.10.14-r1, compresa
<=media-gfx/gimp-2.10.14-r1 webp


Grazie non capivo perché io vedevo che mi mettevano il maggiore e l'uguale ">=" quando usavo etc-update e lo facevo anch'io pensando che fosse obbligatorio ma avevo tentato di mettere un software senza versione per prova ma mi dava invalido. Adesso ho capito, grazie :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum