Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -auvDN @world x11-base/xorg-server error [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 60

PostPosted: Sat Feb 22, 2020 7:04 am    Post subject: emerge -auvDN @world x11-base/xorg-server error [solved] Reply with quote

Code:
/usr/portage # emerge -auvDN @world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.7:0/1.20.7::gentoo, installed) USE="ipv6 suid systemd udev xorg -debug -dmx -doc (-elogind) -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
    x11-base/xorg-server:0/1.20.7= required by (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, installed) USE="" ABI_X86="(64)"
                        ^^^^^^^^^^
    (and 1 more with the same problem)

  (x11-base/xorg-server-1.20.6:0/1.20.6::gentoo, ebuild scheduled for merge) USE="ipv6 suid systemd udev xorg -debug -dmx -doc (-elogind) -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
    x11-base/xorg-server:0/1.20.6= required by (x11-drivers/xf86-video-ati-19.1.0:0/0::gentoo, installed) USE="udev" ABI_X86="(64)"
                        ^^^^^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "dev-libs/boost:0/1.71.0=".
(dependency required by "dev-util/mdds-1.4.3::gentoo" [installed])
(dependency required by "dev-libs/liborcus-0.14.1-r1::gentoo" [ebuild])
(dependency required by "app-office/libreoffice-bin-6.3.4.2::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by gentoo-find on Mon Feb 24, 2020 3:55 am; edited 1 time in total
Back to top
View user's profile Send private message
Lebkoungcity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2008
Posts: 140
Location: near Lebkoungcity (='Gingerbreadcity' =Nuremberg)

PostPosted: Sat Feb 22, 2020 11:05 am    Post subject: Reply with quote

Hello gentoo-find,

in your post I miss the question but I think you want to know why there's this trouble with these two versions of x11-base/xorg-server that portage wants to pull in but can't? I'm no expert but maybe I can put a little light on that issue.

First I assume that your system is amd64 and is on the stable branch (you don't have ACCEPT_KEYWORDS="~amd64" in /etc/portage/make.conf).

According to that your problem is that x11-drivers/xf86-input-keyboard-1.9.0 wants x11-base/xorg-server-1.20.7 (which is installed on your system):
Code:
(x11-base/xorg-server-1.20.7:0/1.20.7::gentoo, installed) USE="ipv6 suid systemd udev xorg -debug -dmx -doc (-elogind) -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
x11-base/xorg-server:0/1.20.7= required by (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, installed) USE="" ABI_X86="(64)"


And at the same time x11-drivers/xf86-video-ati-19.1.0 wants x11-base/xorg-server-1.20.6 (which is not installed in your system):
Code:
(x11-base/xorg-server-1.20.6:0/1.20.6::gentoo, ebuild scheduled for merge) USE="ipv6 suid systemd udev xorg -debug -dmx -doc (-elogind) -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
x11-base/xorg-server:0/1.20.6= required by (x11-drivers/xf86-video-ati-19.1.0:0/0::gentoo, installed) USE="udev" ABI_X86="(64)"



According to https://gpo.zugaina.org/x11-base/xorg-server x11-base/xorg-server-1.20.6 is stable. So I assume in /etc/portage/package.keywords you have an entry for x11-base/xorg-server because portage wants to pull in x11x11-base/xorg-server-1.20.7 and doesn't complain about it being keyworded.
What's the output for
Code:
cat /etc/portage/package.keywords/* | grep x11
?

Regards,
Andy
_________________
"The most dangerous world view is the world view of the ones who haven't viewed the world."
Alexander von Humboldt (1769-1859)
Back to top
View user's profile Send private message
gentoo-find
n00b
n00b


Joined: 07 Apr 2018
Posts: 60

PostPosted: Mon Feb 24, 2020 3:55 am    Post subject: Reply with quote

Lebkoungcity wrote:
Hello gentoo-find,

in your post I miss the question but I think you want to know why there's this trouble with these two versions of x11-base/xorg-server that portage wants to pull in but can't? I'm no expert but maybe I can put a little light on that issue.

First I assume that your system is amd64 and is on the stable branch (you don't have ACCEPT_KEYWORDS="~amd64" in /etc/portage/make.conf).

According to that your problem is that x11-drivers/xf86-input-keyboard-1.9.0 wants x11-base/xorg-server-1.20.7 (which is installed on your system):
Code:
(x11-base/xorg-server-1.20.7:0/1.20.7::gentoo, installed) USE="ipv6 suid systemd udev xorg -debug -dmx -doc (-elogind) -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
x11-base/xorg-server:0/1.20.7= required by (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, installed) USE="" ABI_X86="(64)"


And at the same time x11-drivers/xf86-video-ati-19.1.0 wants x11-base/xorg-server-1.20.6 (which is not installed in your system):
Code:
(x11-base/xorg-server-1.20.6:0/1.20.6::gentoo, ebuild scheduled for merge) USE="ipv6 suid systemd udev xorg -debug -dmx -doc (-elogind) -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
x11-base/xorg-server:0/1.20.6= required by (x11-drivers/xf86-video-ati-19.1.0:0/0::gentoo, installed) USE="udev" ABI_X86="(64)"



According to https://gpo.zugaina.org/x11-base/xorg-server x11-base/xorg-server-1.20.6 is stable. So I assume in /etc/portage/package.keywords you have an entry for x11-base/xorg-server because portage wants to pull in x11x11-base/xorg-server-1.20.7 and doesn't complain about it being keyworded.
What's the output for
Code:
cat /etc/portage/package.keywords/* | grep x11
?

Regards,
Andy




Thank you for your reply. The problem has been solved
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum