Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE and Xscreensaver... No longer working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1192

PostPosted: Wed Feb 05, 2020 4:06 pm    Post subject: KDE and Xscreensaver... No longer working Reply with quote

Hi.

I have experienced this on a couple PCs now. After upgrade, suddenly my KDE with Xscreensaver no longer works right. It will time-out just fine, but using CTRL+ALT+L doesn't work. Instead of starting Xscreensaver, it causes a keyboard lock-up. The mouse can still move on the screen, but you cannot interact with the desktop in any way. It looks like the system is "frozen".

When I go to a VT, I can use ck-unlock-session, and what do you think happens? I get my desktop back again and everything is hunky-dory, right? NO! When I go back to the desktop (CTRL+ALT+F7), Xscreen saver is up and running, and I have to enter my password to proceed!

I followed the manpage, which advised me to create a simple shell script and call it kscreenlocker_greet. In it is basically the she-bang, and one line: /usr/bin/xscreensaver-command -lock. When I execute this command as my non-privileged user from a konsole or xterm, it does what it should do: xscreen saver locks the screen, and I have a lovely screensaver to look at. If I execute /usr/lib64/libexec/kscreenlocker_greet -- that works too. So I know the script is good.

It is something that the latest stable version of KDE seems to be doing.. it isn't handing off correctly or something. Its like it locks the screen before handing it over to kscreenlocker_greet. I have checked my config, and I have told KDE never to start a screen locker on its own (Under Workspace behavior > Screen Locking). So I have followed the instructions correctly... but something has changed.

Is this a bug, or is there something I can do to get this working as it should?

I did find a work-around by disabling the CTRL+ALT+L on the screenlocker settings, and creating a shortcut combo that launches /usr/lib64/libexec/kscreenlocker_greet. It does the trick, but it is a little ugly... but I'll live with it if need be.

Thanks!

G
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum