Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
email with embedded safelinks.protection.outlook.com urls
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18439

PostPosted: Thu May 14, 2020 9:20 pm    Post subject: email with embedded safelinks.protection.outlook.com urls Reply with quote

Has anyone seen this?

Apparently it is a "service" from Microsoft they call "Advanced Threat Protection."

If you were to receive a plain email, the service "wraps it" so you would have to go out of your way to identify the real email. Seems odd. Anyway, in my case, I have set gmail to "always ask" before displaying images. Despite that setting, I still see an email "signature" image. When I hover over the email, the URL is wrapped by this MS service.

Example URL:
Code:
https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.example.com %2abc%2def20%2f10%2f1&data=01%7c01%7emailuserid%40example.com %7ca9f7b386fae94ca994bb08d38e3a59bb%7c9ef9f489e0a04eeb87cc3a526112fd0d%7c1 &sdata=st79jNKGyGbI%2fcDprP%2fgra%2fTQz7lni5uZCS7a1W83OI%3d


My initial concern was that it was a means to determine when an email was opened. So I verified my "always ask" before displaying images setting.

Whether or not that was the original purpose of the image, it does seem like the service does provide reporting to the organization, but it isn't clear if that includes "message opened".

Is there a way to use CSS so that gmail won't display an image? It needn't be CSS, that was just my first thought. I'd prefer to drop gmail, but I haven't found a alternative that seems usable.
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
coderanger
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2018
Posts: 109
Location: Ukraine

PostPosted: Fri May 15, 2020 12:05 pm    Post subject: Reply with quote

It is a known practice to embed signature image into message body to make sure the company's logo is displayed properly despite the settings on receiver side. Also, the embedded image can be put inside <a> tag therefore showing a link to the external server when hovering. Try inspecting the raw message body markup and check if this is your case
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum