Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]TigerVNC - Black Screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
C666PO
n00b
n00b


Joined: 21 Oct 2019
Posts: 30

PostPosted: Tue Jan 14, 2020 7:37 pm    Post subject: [SOLVED]TigerVNC - Black Screen Reply with quote

Hello,

I've been using TigerVNC server in my Gentoo(kde plasma) for a few months where i usually connect to it from my laptop Arch(gnome). I also use tigervnc as client to connect.

Yesterday i did an update and upgrade on my Gentoo, basically:

# emerge --sync
# emerge --update --deep --with-bdeps y @world

Today as usually, i connect to display 1 and i have a black screen.

/etc/conf.d/tigervnc:

Code:

occlus@Gentoo-PC ~/.vnc $ cat /etc/conf.d/tigervnc
# Config file for /etc/init.d/tigervnc

# Specify the user(s) Xvnc(1) should be run for. The syntax is: "username:display".
# example: "DISPLAYS="foo:1 bar:2" You can specify more users separated by space.
# DISPLAYS="myuser:1"

# Specify any of vncserver(1) and Xvnc(1) options. See the respective man pages for more information.
# VNC_OPTS=""

DISPLAYS="occlus:1"


/.vnc/xstartup:

Code:

#!/bin/sh

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
#exec /etc/X11/xinit/xinitrc

startkde &


/.vnc/display log:

Code:

Xvnc TigerVNC 1.9.0 - built Jan 13 2020 23:54:05
Copyright (C) 1999-2018 TigerVNC Team and many others (see README.rst)
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 12000000, The X.Org Foundation


Tue Jan 14 18:38:26 2020
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5901
 vncext:      created VNC server for screen 0
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
Errors from xkbcomp are not fatal to the X server
/home/occlus/.vnc/xstartup: line 7: startkde: command not found

Tue Jan 14 18:38:35 2020
 Connections: accepted: 192.168.1.30::38696
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)

Tue Jan 14 18:38:36 2020
 SVeNCrypt:   Client requests security type TLSVnc (258)

Tue Jan 14 18:38:46 2020
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888

Tue Jan 14 18:38:58 2020
 Connections: closed: 192.168.1.30::38696 (Clean disconnection)
 EncodeManager: Framebuffer updates: 3
 EncodeManager:   Tight:
 EncodeManager:     Solid: 2 rects, 1.57286 Mpixels
 EncodeManager:            32 B (1:196609 ratio)
 EncodeManager:   Total: 2 rects, 1.57286 Mpixels
 EncodeManager:          32 B (1:196609 ratio)
 TLS:         TLS session wasn't terminated gracefully
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)


If you need more logs, please let me know.

Kind regards,


Last edited by C666PO on Wed Jan 15, 2020 8:03 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16011

PostPosted: Wed Jan 15, 2020 1:51 am    Post subject: Re: TigerVNC - Black Screen Reply with quote

C666PO wrote:
/.vnc/xstartup:
Code:
#!/bin/sh

startkde &
Shouldn't that be exec program instead of program &?
C666PO wrote:
/.vnc/display log:
Code:
/home/occlus/.vnc/xstartup: line 7: startkde: command not found
You should run a program that exists. I recall another thread here recently that concluded that the command startkde had been renamed to something else, along with the project's rebranding itself as "Plasma."
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24691
Location: here

PostPosted: Wed Jan 15, 2020 6:40 am    Post subject: Re: TigerVNC - Black Screen Reply with quote

Hu wrote:
C666PO wrote:
/.vnc/display log:
Code:
/home/occlus/.vnc/xstartup: line 7: startkde: command not found
You should run a program that exists. I recall another thread here recently that concluded that the command startkde had been renamed to something else, along with the project's rebranding itself as "Plasma."

New name is startplasma-x11
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
C666PO
n00b
n00b


Joined: 21 Oct 2019
Posts: 30

PostPosted: Wed Jan 15, 2020 8:03 am    Post subject: Reply with quote

Hi Hu,

I tried "exec" before but it didn't work, same message appeared " Command not found " i also checked the gentoo guide and it still has "startkde &" as information, i thought it could be a bug from the update or incompatibility.

fedeliallalinea, " startplasma-x11 & " worked.

Thank you both for your help!

With thanks and regards,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum