Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Errore nell'aggiornamento
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
aenigma
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2019
Posts: 84
Location: 45°13'52.1"N 9°16'21.2"E Italy

PostPosted: Fri Jan 03, 2020 9:33 am    Post subject: [Risolto] Errore nell'aggiornamento Reply with quote

Ciao a tutti e buon anno,
durante un aggiornamento ho rilevato questi errori:
Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

net-libs/webkit-gtk:4

  (net-libs/webkit-gtk-2.26.2:4/37::gentoo, ebuild scheduled for merge) conflicts with
    <net-libs/webkit-gtk-2.25:4 required by (mail-client/evolution-3.32.4:2.0/2.0::gentoo, installed)
    ^                    ^^^^ 

dev-libs/icu:0

  (dev-libs/icu-65.1:0/65.1::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/icu:0/64.2 required by (app-office/libreoffice-bin-6.2.8.2:0/0::gentoo, installed)
                ^^^^^^^
    dev-libs/icu:0/64.2= required by (app-office/libreoffice-bin-6.2.8.2:0/0::gentoo, installed)
                ^^^^^^^^
    >=dev-libs/icu-3.8.1-r1:0/64.2= required by (net-libs/webkit-gtk-2.24.4:4/37::gentoo, installed)
                           ^^^^^^^^


Nothing to merge; quitting.




So che c'è un bug in dev-libs/icu ma questo non mi risulta per quanto riguarda net-libs/webkit-gtk
Grazie in anticipo.
_________________
GentooMATE+LightDM+OpenRC
Descriverei Gentoo con una sola parola: GENIALE!


Last edited by aenigma on Sat Jan 04, 2020 5:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23989
Location: here

PostPosted: Sat Jan 04, 2020 1:42 pm    Post subject: Reply with quote

Puoi postare tutto l'output di emerge e il comando che hai eseguito?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2019
Posts: 84
Location: 45°13'52.1"N 9°16'21.2"E Italy

PostPosted: Sat Jan 04, 2020 2:17 pm    Post subject: Reply with quote

Ecco l'output:
Code:
Password:
gentoo /home/davide # emerge -auDNv --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/icu:0

  (dev-libs/icu-65.1:0/65.1::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/icu:0/64.2= required by (app-office/libreoffice-bin-6.2.8.2:0/0::gentoo, installed)
                ^^^^^^^^
    dev-libs/icu:0/64.2 required by (app-office/libreoffice-bin-6.2.8.2:0/0::gentoo, installed)
                ^^^^^^^

net-libs/webkit-gtk:4

  (net-libs/webkit-gtk-2.26.2:4/37::gentoo, ebuild scheduled for merge) conflicts with
    <net-libs/webkit-gtk-2.25:4 required by (mail-client/evolution-3.32.4:2.0/2.0::gentoo, installed)
    ^                    ^^^^ 


Nothing to merge; quitting.

gentoo /home/davide #


_________________
GentooMATE+LightDM+OpenRC
Descriverei Gentoo con una sola parola: GENIALE!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23989
Location: here

PostPosted: Sat Jan 04, 2020 3:02 pm    Post subject: Reply with quote

Non sono ni sono degli avvisi.
Il primo per icu ti dice che libreoffice-bin ha bisogno di dev-libs/icu:0/64.2 e quindi non puo' aggiornare a dev-libs/icu-65.1. Prima o poi uscira' una versione di libreoffice-bin ricompilato con icu-65 e il messaggio sparira'.
Una situazione simile per net-libs/webkit-gtk che portage vorrebbe aggiornarla alla versione 2.26.2 ma mail-client/evolution ha bisogno net-libs/webkit-gtk-2.24.4 e quindi non puo' aggirnare questo pacchetto.
Ripeto non sono errori se avessi altri pacchetti da aggiornare portage lo farebbe
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2019
Posts: 84
Location: 45°13'52.1"N 9°16'21.2"E Italy

PostPosted: Sat Jan 04, 2020 4:12 pm    Post subject: Reply with quote

Grazie mille.
_________________
GentooMATE+LightDM+OpenRC
Descriverei Gentoo con una sola parola: GENIALE!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum