Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dual display problems after upgrading MATE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 22 Mar 2006
Posts: 18
Location: Świdnica, Poland

PostPosted: Sat Jan 04, 2020 2:02 pm    Post subject: Dual display problems after upgrading MATE Reply with quote

Hoping to fix the more and more annoying bugs, i decided to upgrade the MATE DE. mate-base/mate version was 1.18, now it's 1.22.
The lightdm login manager still works as usual. But after login the second screen goes black. I can move the cursor over it (causing some artifacts to appear at the top of screen, disappearing when the cursor is moved back). This can be temporarily "fixed" by the following steps:
- go into system -> hardware -> screens (the names in English version may differ as i'm translating it from the language i'm using)
- set "the same display on all screens" and click "apply" (it's working as expected)
- in the confirmation dialog, click "restore previous configuration"
After restoring the original settings, the screens work correctly. The issue reappears with next login.
Another problem appears intermittently after the screen is locked. I can input my password, but then both screens goes black, and the cursor is visible only on the main one, changing its shape when moving across the desktop (apparently according to the windows that are opened and should be visible).
Display driver is nouveau.
I have upgraded the system, including the kernel, thinking the problem is caused by incompatibility with some old installed software. This did not fix nor change the problem in any way. I also wanted to try to downgrade mate, but unfortunately there are no other ebuilds available.
I may want to downgrade the whole system recovering it from a backup to get rid of the problem if no other solutions are found.

EDIT: forgot to mention that i also deleted xorg.conf file (moving to autoconfiguration), and tried to create a new home directory and a completely new user account to rule out bad configuration data.

emerge --info:
python-exec: Invalid impl in /etc/python-exec/python-exec.conf: python3.4
Portage 2.3.79 (python 2.7.17-final-0, default/linux/amd64/17.0/desktop, gcc-9.2.0, glibc-2.29-r7, 4.19.86-gentoo-k4be x86_64)
System uname: Linux-4.19.86-gentoo-k4be-x86_64-AMD_Athlon-tm-_II_X2_250_Processor-with-gentoo-2.6
KiB Mem:     8163788 total,   4498984 free
KiB Swap:   19559132 total,  19559132 free
Timestamp of repository gentoo: Wed, 01 Jan 2020 09:30:01 +0000
Head commit of repository gentoo: 0d26cd53faf5654bd32ed715613ad9bc046d7aa6
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.31.1 p5) 2.31.1
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17::gentoo, 3.6.9::gentoo, 3.7.5-r1::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo, 2.30-r4::gentoo, 2.31.1-r4::gentoo, 2.32-r1::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo, 8.2.0-r6::gentoo, 9.2.0-r2::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r7::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24

    location: /usr/local/portage
    masters: gentoo
    priority: 0

    location: /var/lib/layman/cg
    masters: gentoo
    priority: 50

    location: /var/lib/layman/waebbl
    masters: gentoo
    priority: 50

CFLAGS="-O2 -pipe -march=native -mtune=native"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -mtune=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync:// rsync:// rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo caja cdda cdr cli consolekit crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg flac fortran gconf gdbm gif gnome-keyring gpm gtk iconv icu imagemagick ipv6 jpeg lcms ldap libnotify libtirpc lzma mad mng mp3 mp4 mpeg multilib mysql ncurses nfs nls nptl ogg opengl openmp pam pango pcre pdf perl png policykit postscript ppds python qt5 readline rtmp sasl sdl seccomp spell split-usr ssl startup-notification subversion svg tcpd theora tiff truetype udev udisks unicode upower usb v4l vorbis wxwidgets x264 xattr xcb xinerama xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext 3dnow 3dnowext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="pl en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" QEMU_SOFTMMU_TARGETS="arm x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="nv vesa nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Back to top
View user's profile Send private message

Joined: 30 Aug 2004
Posts: 1234
Location: Burgas, Bulgaria

PostPosted: Tue Jan 07, 2020 10:53 pm    Post subject: Reply with quote

Doesn't seems to be MATE related, cause it works over here quite well.

I would blame VIDEO_CARDS="nv vesa nouveau"

nouveau is the most broken driver out there.
You wish to use open source drivers - buy AMD.
If you bought already nvidia use the proper well working driver.

Read this
Back to top
View user's profile Send private message

Joined: 22 Mar 2006
Posts: 18
Location: Świdnica, Poland

PostPosted: Wed Jan 08, 2020 5:30 am    Post subject: Reply with quote

I've used this videocard for years (so it's not supported by the newest vendor drivers).
The problem did appear after upgrading of only the MATE DM, it used to work correctly before.
Switching to nvidia-drivers fixes this problem at the moment indeed, though i have switched to nouveau precisely due to nividia-drivers causing instability problems (although this may be not the case with current version), so i'm not willing to mark it as SOLVED now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum