Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dvd in gentoo?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
dcstimm
Guru
Guru


Joined: 19 Jun 2002
Posts: 321

PostPosted: Thu Aug 08, 2002 12:40 am    Post subject: dvd in gentoo? Reply with quote

I know dvd in gentoo works, I use libdvdnav libdvdcss and xine-dvdnav but to get these to work I had to downgrade to:
xine-lib-0.9.8.tar.gz
xine-ui-0.9.8.tar.gz
xine-dvdnav-0.9.8.beta.tar.gz
libdvdcss-0.0.3.ogle3.tar.gz
libdvdread-0.9.2.tar.gz

is there a way to get dvd to work by using more uptodate packages?

the new versions of libdvdcss and libdvdnav are seriously broken.

Even ogle and mplayer have problems playing encrypted dvds.

Any ideas?

Thanks.
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Thu Aug 08, 2002 12:54 am    Post subject: Reply with quote

DVDs run under X, so moving to Desktop Environments forum.
_________________
I don't believe in witty sigs.
Back to top
View user's profile Send private message
kraqrawk
n00b
n00b


Joined: 07 Aug 2002
Posts: 40
Location: Jackson,MS

PostPosted: Thu Aug 08, 2002 2:26 am    Post subject: Reply with quote

I'm just emerged Xine, DVDNav, and all the other packages today, and it has played all the dvds I've tried.
_________________
Duh.
Back to top
View user's profile Send private message
gate
n00b
n00b


Joined: 15 May 2002
Posts: 33

PostPosted: Thu Aug 08, 2002 3:02 am    Post subject: Ogle Reply with quote

I have not run xine in a while but ogle works great and its menu support blew the crap out of xine last time I used it. I was having problems with ogle and some dvds but a emerg -u ogle fixed that last night when I tried to watch LOTR.
_________________
Java, the 3rd coming of Cobol

Gate.Ilive4Code.net
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1145
Location: Williamsburg Virginia

PostPosted: Thu Aug 08, 2002 5:22 am    Post subject: Reply with quote

try uninstalling everything then installing them in this order libdvdcss libdvdread xine-lib xine-dvdnav xine-ui

for some reason i think it can make a difference...the first time i installed xine i ahd no idea what i needed and installed the stuff in an ass backward order...ENCRYPTION FAILURE ....i was like screw xine...then i tried after someone posted that they installed the css followed by blah blah blah...and it worked...i am runnning the masked version too without issue
Back to top
View user's profile Send private message
IWBCMAN
Guru
Guru


Joined: 25 Jun 2002
Posts: 474

PostPosted: Sat Aug 10, 2002 3:04 pm    Post subject: Reply with quote

just a footnote:

if you want to install xine-dvdnav using gentoo 1.4 or gcc3.2 simply edit

/usr/portage/media-libs/libdvdnav/libdvdnav-0.1.2-r2.ebuild

and change the "3.1" to "3.2" in ine 25......
it compiles fine then.......
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum