Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Anki crashing on startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 133

PostPosted: Sun Dec 22, 2019 3:28 pm    Post subject: Anki crashing on startup Reply with quote

Hello.

I just installed Anki and when i start it the first time, it asks the language.
I selected English, and after that it gives me an error message.

on a popup window i see this error message:
https://pastebin.com/tmZYi6Nd

On the terminal i can see this:
Code:
$ anki
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib64/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/anki/mpv.py", line 232, in _reader
    b = self._sock.recv(1024)
ConnectionResetError: [Errno 104] Connection reset by peer

mpv timed out, restarting
Exception in thread Thread-4:
Traceback (most recent call last):
  File "/usr/lib64/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/anki/mpv.py", line 232, in _reader
    b = self._sock.recv(1024)
ConnectionResetError: [Errno 104] Connection reset by peer
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24341
Location: here

PostPosted: Sun Dec 22, 2019 3:34 pm    Post subject: Reply with quote

Maybe related to this bug?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 133

PostPosted: Sun Dec 22, 2019 3:40 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Maybe related to this bug?


Code:
emerge -1 --ask --verbose dev-python/jsonschema

emerging 19 new packages....
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 133

PostPosted: Sun Dec 22, 2019 4:01 pm    Post subject: Reply with quote

no, not related to that bug.

I still can't run Anki.
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 133

PostPosted: Sun Dec 22, 2019 4:16 pm    Post subject: Reply with quote

ANOTHER BUG:
Anki also needs dev-python/pyaudio
which is not in dependencies, since it wasn't installed automatically.

But that didn't solve my problem since i installed dev-python/pyaudio BEFORE asking here due to the crash
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15603

PostPosted: Sun Dec 22, 2019 5:46 pm    Post subject: Reply with quote

heikkikk wrote:
Anki also needs dev-python/pyaudio
which is not in dependencies, since it wasn't installed automatically.
Please file a bug to have the dependency information updated so that the next person does not hit this problem. Include in your bug report the output that led you to believe that this dependency is required.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24341
Location: here

PostPosted: Mon Dec 23, 2019 6:52 am    Post subject: Reply with quote

Hu wrote:
Please file a bug to have the dependency information updated so that the next person does not hit this problem. Include in your bug report the output that led you to believe that this dependency is required.

There is already a bug report
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 133

PostPosted: Mon Dec 23, 2019 5:29 pm    Post subject: Reply with quote

fedeliallalinea wrote:
There is already a bug report


That's a different bug. I have recording and sound -fags set but it is not running.
And that's an old bug anyhow....
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15603

PostPosted: Tue Dec 24, 2019 3:37 am    Post subject: Reply with quote

OP stated that there was no dependency recorded in the ebuild. I checked the latest ebuild, =app-misc/anki-2.1.13, found no dependency, and suggested filing a report. It looks like older ebuilds had the dependency behind a USE flag, but the latest one does not have it at all.
Back to top
View user's profile Send private message
heikkikk
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2008
Posts: 133

PostPosted: Tue Dec 24, 2019 4:33 am    Post subject: Reply with quote

Any ideas on what dependencies i need to install to get it working?

Thanks :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum