Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
optimus with lxde
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
NTwoO
n00b
n00b


Joined: 01 Jun 2007
Posts: 68

PostPosted: Sat Dec 21, 2019 7:22 pm    Post subject: optimus with lxde Reply with quote

Hi,

With my system I now have the nvidia working, partially. When launching my environment from the terminal with startx, the NVidia driver is loaded properly. I have the xrandr settings of the NVIDIA/Optimus wiki page in both my .xinitrc of my user account and in the LoginReady section of the lxdm. Somehow the lxdm section is not hit when starting X via xdm. Is this section possibly handled by xdm-setup? What should be done to ensure that this is executed?
Back to top
View user's profile Send private message
gengreen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2017
Posts: 125

PostPosted: Wed Dec 25, 2019 1:38 am    Post subject: Reply with quote

sure :
https://wiki.gentoo.org/wiki/NVIDIA/Optimus#LXDE_Display_Manager_.28LXDM9

I suppose you want your login manager to handle the setprovideroutputsource instead of the .xinitrc file
Back to top
View user's profile Send private message
NTwoO
n00b
n00b


Joined: 01 Jun 2007
Posts: 68

PostPosted: Wed Dec 25, 2019 1:52 pm    Post subject: Reply with quote

Indeed. As mentioned in my first post the section you mention is applied in my LoginReady of lxdm. I would expect that it should thus work, but it doesn't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum