Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nextcloud-client - turn off update notification
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
KPF
n00b
n00b


Joined: 27 Oct 2019
Posts: 3

PostPosted: Sat Dec 21, 2019 8:41 am    Post subject: [SOLVED] nextcloud-client - turn off update notification Reply with quote

Hi,
not sure how to ask properly.

x86-64 system
KDE Plasma (latest stable version 5.16.5)
Nextcloud-client (stable version 2.5.2)
while the latest is unstable 2.6.1 (~amd64)

The problem is: each time the desktop is started,
the client shows the always-visible notification "There is newer version (2.6.1) - please update"

1) there is no newer version for my system (if we count only stable ebuilds)
2) It is annoying, as I must go and explicitly close it each time - otherwise it will stay forever and take my attention.
3) looks like this sort of notifications can not be disabled: in client options we can switch off only the notifications from the server. While this is the notification from client itself, probably.

I think emerging unstable latest version can not be a recommended solution.
So, is there possibility to stop notifications from one specific application using System Settings? I see only checkbox to disable notifications completely at all.
Or other solutions?


Last edited by KPF on Sat Dec 21, 2019 7:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
Banana
Guru
Guru


Joined: 21 May 2004
Posts: 335
Location: Germany

PostPosted: Sat Dec 21, 2019 10:39 am    Post subject: Reply with quote

Looks like a bug: https://github.com/nextcloud/desktop/issues/1594
_________________
My personal space
Back to top
View user's profile Send private message
KPF
n00b
n00b


Joined: 27 Oct 2019
Posts: 3

PostPosted: Sat Dec 21, 2019 10:42 am    Post subject: Reply with quote

*_-=Banana=-_*, thanks!
Will wait, then.
Back to top
View user's profile Send private message
KPF
n00b
n00b


Joined: 27 Oct 2019
Posts: 3

PostPosted: Sat Dec 21, 2019 7:22 pm    Post subject: Solved: Reply with quote

SOLVED!

Thanks for the bug report URL.

Looks like they used wrong path for config file 'nextcloud.cfg'.
It should be ~/.config/Nextcloud/nextcloud.cfg

I found it in the source: (doc/conffile.rst)
Quote:
The Nextcloud Client reads a configuration file. You can locate this configuration file as follows:

On Linux distributions:
``$HOME/.config/Nextcloud/nextcloud.cfg``


So, adding this option in this file worked for me:

Code:
[General]
skipUpdateCheck=true
Back to top
View user's profile Send private message
Banana
Guru
Guru


Joined: 21 May 2004
Posts: 335
Location: Germany

PostPosted: Wed Dec 25, 2019 9:37 am    Post subject: Reply with quote

Happy to help ;-)
_________________
My personal space
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum