Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Squid Proxy with SSL did no work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
boospy
Guru
Guru


Joined: 07 Feb 2010
Posts: 307
Location: Austria

PostPosted: Sat Dec 21, 2019 12:24 am    Post subject: [solved] Squid Proxy with SSL did no work Reply with quote

Hello all,

i installed Squid on Gentoo in Version 4.9. I've configured the server and HTTP works fine. Here is the important part of my config:

http_port 80
https_port 443 cert=/etc/squid/cert.pem key=/etc/squid/key.pem

I installed the proxy for Linux and Windowsupate. So if i test it with an APTsource with https, it get this error on the Client.
Code:
Fehl:2 https://apt.iteas.at/iteas bionic Release                                                                                                                         
  Could not handshake: Key usage violation in the certificate was discovered. [IP:192.168.0.5]

The clientcert is installed. And yes the cert/key does work fine for other services like apache. So what i have to do here that SSL is working?

Thanks :)


Last edited by boospy on Sun Dec 22, 2019 12:44 am; edited 1 time in total
Back to top
View user's profile Send private message
boospy
Guru
Guru


Joined: 07 Feb 2010
Posts: 307
Location: Austria

PostPosted: Sat Dec 21, 2019 8:29 pm    Post subject: Reply with quote

There was an certissue. Now it is working.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum