Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] unlösbare (?) Konflikte beim Update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Sun Dec 15, 2019 4:18 pm    Post subject: [gelöst] unlösbare (?) Konflikte beim Update Reply with quote

Seit Tagen hänge ich an diesen Fehlermeldungen, die hartnäckig immer wieder kommen:

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
''
media-gfx/imagemagick:0
''
(media-gfx/imagemagick-7.0.9.8:0/7.0.9::gentoo, ebuild scheduled for merge) conflicts with
<media-gfx/imagemagick-7:0/6.9.10.78=[cxx] required by (media-gfx/inkscape-0.92.4:0/0::gentoo, installed)                                                                                                                                                         
^                       ^^^^^^^^^^^^^
<media-gfx/imagemagick-7:=[cxx] required by (media-gfx/inkscape-0.92.4:0/0::gentoo, installed)
^                      ^
''
dev-libs/libpcre2:0
''
(dev-libs/libpcre2-10.33-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
dev-libs/libpcre2[pcre16,unicode] required by (dev-qt/qtcore-5.12.5-r1:5/5.12::gentoo, installed)                                                                                                                                           
^^^^^^
''


Anscheinend besteht inkscape auf imagemagick < 7.0 mit dem USE cxx.

So ist es installiert:
Code:
[U] media-gfx/imagemagick
     Verfügbare Versionen:   6.9.10.78(0/6.9.10.78)^tu 7.0.9.8(0/7.0.9)^t **9999(0/7.0.9)*l^t {X bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf xml zlib}                                                                           
     Installierte Versionen: 6.9.10.78(0/6.9.10.78)^t(14:22:36 15.12.2019)(X bzip2 corefonts cxx fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr openmp png raw svg tiff truetype webp wmf zlib -djvu -lzma -opencl -openexr -pango -perl -postscript -q32 -q8 -static-libs -test -xml)                                                                                   
     Startseite:             https://www.imagemagick.org/
     Beschreibung:           A collection of tools and libraries for many image formats


Inkscape kann ich wohl nicht updaten:

Code:
[I] media-gfx/inkscape
     Verfügbare Versionen:   0.92.4^t ~1.0_beta2^t **9999*l^t {cdr dbus dia exif gnome graphicsmagick imagemagick inkjar jemalloc jpeg latex lcms nls openmp postscript spell static-libs svg2 visio wpg PYTHON_SINGLE_TARGET="+python2_7 python3_5 python3_6 python3_7" PYTHON_TARGETS="+python2_7 python3_5 python3_6 python3_7"}                                                         
     Installierte Versionen: 0.92.4^t(14:31:35 15.12.2019)(cdr dia exif imagemagick inkjar jpeg latex lcms nls openmp postscript spell visio wpg -dbus -gnome -static-libs PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7")                                                                                                                                                     
     Startseite:             https://inkscape.org/
     Beschreibung:           SVG based generic vector-drawing program


Damit bleibt das so oder kann ich da noch etwas machen?

Das andere ist qtcore & libpcre2:

So habe ich qtcore installiert:
Code:
I] dev-qt/qtcore
     Verfügbare Versionen:   (5) 5.12.3(5/5.12)^t 5.12.5-r1(5/5.12)^t ~5.13.2(5/5.13)^t
       {debug icu systemd test}
     Installierte Versionen: 5.12.5-r1(5/5.12)^t(17:16:51 08.12.2019)(icu systemd -debug -test)
     Startseite:             https://www.qt.io/
     Beschreibung:           Cross-platform application development framework


und libpcre2:
Code:
[I] dev-libs/libpcre2
     Verfügbare Versionen:   10.32 10.33-r1 ~10.34 {bzip2 +jit libedit pcre16 pcre32 +readline +recursion-limit split-usr static-libs unicode zlib ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32"}                                                                                                                                                     
     Installierte Versionen: 10.33-r1(20:50:19 03.11.2019)(bzip2 jit pcre16 readline recursion-limit split-usr unicode zlib -libedit -pcre32 -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")                                                                                                                                     
     Startseite:             http://www.pcre.org/
     Beschreibung:           Perl-compatible regular expression library


Das sieht für mich richtig aus. Aktuellste VErsion von libpcre2 mit den USE-Flags für qtcore. Also was löst dann den block aus???

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Fri Dec 20, 2019 2:43 pm; edited 3 times in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Sun Dec 15, 2019 5:07 pm    Post subject: Reply with quote

Brauchst du imagemagick >7 ? Brauchst du inkscape mit imagemagick?
Wenn ja:
* inkscape bauen mit USE="imagemagick graphicsmagick"
* graphicsmagick bauen mit USE="cxx -imagemagick"
So wird inkscpae graphicsmagick für die import/export Funktionen benutzen und nicht imagemagick, und imagemagick kann auf >=7 aktualisiert werden.

Wg. libpcre2 und qtcore wäre ein vollständiges "emerge -uDNpvt @world" nicht schlecht. Komplette Ausgabe posten bittedanke.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Sun Dec 15, 2019 6:23 pm    Post subject: Reply with quote

So, da ist die Ausgabe von emerge -uDNpvt @world:

Code:
 emerge -uDNpvt @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] net-misc/iputils-20180629::gentoo  USE="arping filecaps ipv6 ssl -SECURITY_HAZARD -caps -clockdiff -doc -gcrypt -idn -libressl -nettle -rarpd -rdisc -static -tftpd -tracepath -traceroute6"                                                                                                                                                                               
[nomerge       ]  sys-libs/libcap-2.26-r2::gentoo  USE="pam (split-usr) -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   sys-kernel/linux-headers-4.19::gentoo  USE="-headers-only"
[nomerge       ]    dev-lang/perl-5.30.1:0/5.30::gentoo  USE="berkdb gdbm -debug -doc -ithreads"
[nomerge       ]     sys-libs/zlib-1.2.11-r2:0/1::gentoo  USE="minizip (split-usr) -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ]      sys-devel/libtool-2.4.6-r3:2::gentoo  USE="-vanilla"
[nomerge       ]       sys-devel/automake-1.16.1-r1:1.16::gentoo  USE="-test"
[nomerge       ]        sys-apps/help2man-1.47.10::gentoo  USE="nls"
[nomerge       ]         dev-perl/Locale-gettext-1.70.0::gentoo
[nomerge       ]          sys-devel/gettext-0.19.8.1::gentoo  USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]           dev-libs/libxml2-2.9.9-r2:2::gentoo  USE="icu ipv6 python readline -debug -examples -lzma -static-libs -test" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7) (-python3_8)"                                                                                                                                               
[nomerge       ]            dev-lang/python-3.6.9:3.6/3.6m::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) tk xml -bluetooth -build -examples -hardened -libressl -test -wininst"
[nomerge       ]             dev-tcltk/tix-8.4.3-r1::gentoo
[nomerge       ]              x11-libs/libXdmcp-1.1.3::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ]               x11-base/xorg-proto-2019.2::gentoo
[nomerge       ]                dev-util/ninja-1.8.2::gentoo  USE="vim-syntax -doc -emacs -test"
[ebuild     U  ]                 dev-util/re2c-1.2.1::gentoo [1.1.1::gentoo] USE="-debug%" 2.012 KiB

Total: 1 package (1 upgrade), Size of downloads: 2.012 KiB
''
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
''
media-gfx/imagemagick:0
''
($'[32mmedia-gfx/imagemagick-7.0.9.8:0/7.0.9::gentoo$'[39;49;00m, ebuild scheduled for merge) conflicts with
$'[31;01m<$'[39;49;00mmedia-gfx/imagemagick-7$'[31;01m:$'[39;49;00m$'[31;01m0$'[39;49;00m$'[31;01m/$'[39;49;00m$'[31;01m6$'[39;49;00m$'[31;01m.$'[39;49;00m$'[31;01m9$'[39;49;00m$'[31;01m.$'[39;49;00m$'[31;01m1$'[39;49;00m$'[31;01m0$'[39;49;00m$'[31;01m.$'[39;49;00m$'[31;01m7$'[39;49;00m$'[31;01m8$'[39;49;00m$'[31;01m=$'[39;49;00m[cxx] required by ($'[34mmedia-gfx/inkscape-0.92.4:0/0::gentoo$'[39;49;00m, installed)                                                                                                                                                         
^                       ^^^^^^^^^^^^^
$'[31;01m<$'[39;49;00mmedia-gfx/imagemagick-$'[31;01m7$'[39;49;00m:=[cxx] required by ($'[34mmedia-gfx/inkscape-0.92.4:0/0::gentoo$'[39;49;00m, installed)
^                      ^
''


Sorry für die Escape-Codes am ende, da bin ich auch noch nicht weitergekommen....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Sun Dec 15, 2019 6:58 pm    Post subject: Reply with quote

graphicagick & imagemagick - trotz geänderten USE-Flags noch immer ein Block:

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
''
media-gfx/imagemagick:0
''
(media-gfx/imagemagick-7.0.9.8:0/7.0.9::gentoo, ebuild scheduled for merge) conflicts with
<media-gfx/imagemagick-7:=[cxx] required by (media-gfx/inkscape-0.92.4:0/0::gentoo, installed)
^                      ^
<media-gfx/imagemagick-7:0/6.9.10.78=[cxx] required by (media-gfx/inkscape-0.92.4:0/0::gentoo, installed)                                                                                                                                                         
^                       ^^^^^^^^^^^^^


Code:
[I] media-gfx/inkscape
     Verfügbare Versionen:   0.92.4^t ~1.0_beta2^t **9999*l^t {cdr dbus dia exif gnome graphicsmagick imagemagick inkjar jemalloc jpeg latex lcms nls openmp postscript spell static-libs svg2 visio wpg PYTHON_SINGLE_TARGET="+python2_7 python3_5 python3_6 python3_7" PYTHON_TARGETS="+python2_7 python3_5 python3_6 python3_7"}                                                         
     Installierte Versionen: 0.92.4^t(14:31:35 15.12.2019)(cdr dia exif imagemagick inkjar jpeg latex lcms nls openmp postscript spell visio wpg -dbus -gnome -static-libs PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7")                                                                                                                                                     
     Startseite:             https://inkscape.org/
     Beschreibung:           SVG based generic vector-drawing program


Die gänderten USE-Flags nimmt portage nicht auf... Hier ist die package.use/inkscape:

Code:
# 2017-03-28
media-gfx/inkscape cdr dia exif graphicsmagick imagemagick inkjar latex lcms lzma postscript spell visio wpg

# 2019-12-07 Update
# required by media-gfx/inkscape-0.92.4::gentoo[latex]
# required by @selected
# required by @world (argument)
>=media-gfx/pstoedit-3.70-r1 plotutils


Oder habe ich einen Tippfehler?
Geht graphicsmagick parallel zu imagemagick überhaupt? Sieht nach einem neuen BLock aus:

Code:
 emerge -a graphicsmagick

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-gfx/graphicsmagick-1.3.32  USE="X bzip2 cxx imagemagick jbig jpeg lcms openmp png svg threads tiff truetype webp wmf zlib -debug -fpx -lzma -modules -perl -postscript -q16 -q32 -static-libs"                                                                                                                                                                       
[blocks B      ] media-gfx/imagemagick ("media-gfx/imagemagick" is blocking media-gfx/graphicsmagick-1.3.32)
''
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
''
(media-gfx/imagemagick-6.9.10.78:0/6.9.10.78::gentoo, installed) pulled in by
media-gfx/imagemagick required by @selected
''
(media-gfx/graphicsmagick-1.3.32:0/1.3::gentoo, ebuild scheduled for merge) pulled in by
graphicsmagick
''
''
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
''
https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2289
Location: Germany

PostPosted: Sun Dec 15, 2019 8:11 pm    Post subject: Reply with quote

Hi Uhai,

ich hab mir grad mal die Mühe gemacht zu schauen... bei mir ist folgendes installiert:

Code:

media-gfx/imagemagick

...

Installierte Versionen: 7.0.9.8(0/7.0.9)^t(xx:xx:xx xx.xx.2019)(X bzip2 cxx jpeg lcms openmp pango png svg tiff truetype xml zlib -corefonts -djvu -fftw -fontconfig -fpx -graphviz -hdri -heif -jbig -jpeg2k -lqr -lzma -opencl -openexr -perl -postscript -q32 -q8 -raw -static-libs -test -webp -wmf)
     Startseite:             https://www.imagemagick.org/
     Beschreibung:           A collection of tools and libraries for many image formats



Und Portage hätte nichts dagegen wenn ich graphicsmagick installieren wollen würde.

Code:
emerge -av graphicsmagick

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-gfx/graphicsmagick-1.3.32:0/1.3::gentoo  USE="X bzip2 cxx jpeg lcms openmp png svg tiff truetype zlib -debug -fpx -imagemagick -jbig -lzma -modules -perl -postscript -q16 -q32 -static-libs -threads -webp -wmf" 5.406 KiB

Total: 1 package (1 new), Size of downloads: 5.406 KiB

Would you like to merge these packages? [Yes/No]


Lediglich bei Inkscape bekomme ich halt die Fehlermeldung da sich dafür ein andere Python Single Target brauchen würden.

Code:
!!! The ebuild selected to satisfy "media-gfx/inkscape" has unmet requirements.
- media-gfx/inkscape-0.92.4::gentoo USE="cdr dbus exif gnome jpeg lcms nls openmp spell -dia -imagemagick -inkjar -latex -postscript -static-libs -visio -wpg" ABI_X86="(64)" PYTHON_SINGLE_TARGET="-python2_7" PYTHON_TARGETS="python2_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_single_target_python2_7

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python2_7 ) python_single_target_python2_7? ( python_targets_python2_7 )


Sollte also gehen. Wenn du die Maschine schon länger nicht mehr mit Updates versorgt hast und wie ich schon mal auf dirty Updates stehst, probiere bei so einem Block mal die Portage Option --changed-deps. wiki.gentoo.org Edit: Das Bezieht sich nicht auf dein aktuelles Problem, sondern eher wenn viel Zeit zwischen Updates verstrichen war und du Teile des Systems einzeln mit Updates versorgt hast.. und dein --world Update schon länger zurück liegt! /edit-ende

Aber ich bin da eh unkritisch und entferne die Pakete.. und versuch die später neu zu bauen. Da QT immer so ein Sauhaufen ist, hab ich dafür eine Datei die mir alle installierte QT Pakete entfernt und alle noch mal neu baut.

Zurück zu dem python2_7 und wegen der möglichen Abhängigkeit. Da wird im dem bug Thread immer noch drüber geschrieben. Entweder wartest du noch etwas ab, bis inscape 1.0 fertig wird, oder du verwendest vorzeitig ein Ebuild aus dem Bug. Miroslav berichtete in Kommentar 16 er hatte Erfolg mit dem bauen von Imagemagick 1.0 (beta_1) wenn man die Useflags anders setzt.

Musst halt schauen was du jetzt wie dringend brauchst.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Sun Dec 15, 2019 8:54 pm    Post subject: Reply with quote

Danke ChrisJumper,

ich hatte die eltzten Monate mehrere Blocks und daher die world-Updates ausgesetzt. Nachdem ich letzte Woche etwas Zeit hatte, konnte ich die Blocks weitgehend auflösen. Seitdem sind mir nur die beiden offenen Blocks geblieben. --changed-deps habe ich dabei auch schon benutzt....

Die python-Targets aus der make.conf habe ich im Zuge der vielen Blocks auch beseitigt...

Wenn das an inkscape liegt, warte ich einfach auf die nächste Version.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Tyrus
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 299

PostPosted: Sun Dec 15, 2019 11:11 pm    Post subject: Reply with quote

@uhai:
Ich hab auch mal nachgesehen wegen der Versionen und USE-Flags:

Code:

[I] media-gfx/imagemagick
     Verfügbare Versionen:   6.9.10.78(0/6.9.10.78)^tu 7.0.9.8(0/7.0.9)^t **9999(0/7.0.9)*l^t {X bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf xml zlib}
     Installierte Versionen: 7.0.9.8(0/7.0.9)^t(14:27:15 15.12.2019)(X bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri jbig jpeg jpeg2k lcms lzma openexr openmp pango perl png postscript raw svg tiff truetype webp wmf xml zlib -heif -lqr -opencl -q32 -q8 -static-libs -test)
     Startseite:             https://www.imagemagick.org/
     Beschreibung:           A collection of tools and libraries for many image formats

------------

[I] media-gfx/inkscape
     Verfügbare Versionen:   0.92.4^t (~)1.0_beta2^t **9999*l^t {cdr dbus dia exif gnome graphicsmagick imagemagick inkjar jemalloc jpeg latex lcms nls openmp postscript spell static-libs svg2 visio wpg PYTHON_SINGLE_TARGET="+python2_7 python3_5 python3_6 python3_7" PYTHON_TARGETS="+python2_7 python3_5 python3_6 python3_7"}
     Installierte Versionen: 1.0_beta2^t(12:35:57 11.12.2019)(cdr dbus dia exif graphicsmagick imagemagick inkjar jpeg lcms nls openmp postscript spell svg2 visio wpg -jemalloc -static-libs PYTHON_SINGLE_TARGET="python3_6 -python3_5 -python3_7" PYTHON_TARGETS="python3_6 -python3_5 -python3_7")
     Startseite:             https://inkscape.org/
     Beschreibung:           SVG based generic vector-drawing program

------------

[I] media-gfx/graphicsmagick
     Verfügbare Versionen:   1.3.32(0/1.3) ~1.3.33(0/1.3) **9999(0/9999)*l {X bzip2 cxx debug fpx imagemagick jbig jpeg lcms lzma modules openmp perl png postscript q16 q32 static-libs svg threads tiff truetype webp wmf zlib}
     Installierte Versionen: 1.3.32(0/1.3)(12:02:07 06.12.2019)(X bzip2 cxx fpx jbig jpeg lcms lzma modules openmp perl png postscript svg threads tiff truetype webp wmf zlib -debug -imagemagick -q16 -q32 -static-libs)
     Startseite:             http://www.graphicsmagick.org/
     Beschreibung:           Collection of tools and libraries for many image formats


Mit media-gfx/inkscape-1.0_beta2 geht es bei mir zumindest. Dazu musst du auf die unstable Version wechseln.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Mon Dec 16, 2019 5:32 am    Post subject: Reply with quote

uhai wrote:
So, da ist die Ausgabe von emerge -uDNpvt @world:

Code:
 emerge -uDNpvt @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] net-misc/iputils-20180629::gentoo  USE="arping filecaps ipv6 ssl -SECURITY_HAZARD -caps -clockdiff -doc -gcrypt -idn -libressl -nettle -rarpd -rdisc -static -tftpd -tracepath -traceroute6"                                                                                                                                                                               
[nomerge       ]  sys-libs/libcap-2.26-r2::gentoo  USE="pam (split-usr) -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   sys-kernel/linux-headers-4.19::gentoo  USE="-headers-only"
[nomerge       ]    dev-lang/perl-5.30.1:0/5.30::gentoo  USE="berkdb gdbm -debug -doc -ithreads"
[nomerge       ]     sys-libs/zlib-1.2.11-r2:0/1::gentoo  USE="minizip (split-usr) -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ]      sys-devel/libtool-2.4.6-r3:2::gentoo  USE="-vanilla"
[nomerge       ]       sys-devel/automake-1.16.1-r1:1.16::gentoo  USE="-test"
[nomerge       ]        sys-apps/help2man-1.47.10::gentoo  USE="nls"
[nomerge       ]         dev-perl/Locale-gettext-1.70.0::gentoo
[nomerge       ]          sys-devel/gettext-0.19.8.1::gentoo  USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]           dev-libs/libxml2-2.9.9-r2:2::gentoo  USE="icu ipv6 python readline -debug -examples -lzma -static-libs -test" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7) (-python3_8)"                                                                                                                                               
[nomerge       ]            dev-lang/python-3.6.9:3.6/3.6m::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) tk xml -bluetooth -build -examples -hardened -libressl -test -wininst"
[nomerge       ]             dev-tcltk/tix-8.4.3-r1::gentoo
[nomerge       ]              x11-libs/libXdmcp-1.1.3::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ]               x11-base/xorg-proto-2019.2::gentoo
[nomerge       ]                dev-util/ninja-1.8.2::gentoo  USE="vim-syntax -doc -emacs -test"
[ebuild     U  ]                 dev-util/re2c-1.2.1::gentoo [1.1.1::gentoo] USE="-debug%" 2.012 KiB

Total: 1 package (1 upgrade), Size of downloads: 2.012 KiB
''
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
''
media-gfx/imagemagick:0
''
($'[32mmedia-gfx/imagemagick-7.0.9.8:0/7.0.9::gentoo$'[39;49;00m, ebuild scheduled for merge) conflicts with
$'[31;01m<$'[39;49;00mmedia-gfx/imagemagick-7$'[31;01m:$'[39;49;00m$'[31;01m0$'[39;49;00m$'[31;01m/$'[39;49;00m$'[31;01m6$'[39;49;00m$'[31;01m.$'[39;49;00m$'[31;01m9$'[39;49;00m$'[31;01m.$'[39;49;00m$'[31;01m1$'[39;49;00m$'[31;01m0$'[39;49;00m$'[31;01m.$'[39;49;00m$'[31;01m7$'[39;49;00m$'[31;01m8$'[39;49;00m$'[31;01m=$'[39;49;00m[cxx] required by ($'[34mmedia-gfx/inkscape-0.92.4:0/0::gentoo$'[39;49;00m, installed)                                                                                                                                                         
^                       ^^^^^^^^^^^^^
$'[31;01m<$'[39;49;00mmedia-gfx/imagemagick-$'[31;01m7$'[39;49;00m:=[cxx] required by ($'[34mmedia-gfx/inkscape-0.92.4:0/0::gentoo$'[39;49;00m, installed)
^                      ^
''


Sorry für die Escape-Codes am ende, da bin ich auch noch nicht weitergekommen....

uhai

Danke. Aber leider taucht das Problem mit qtcore vs. libpcre2 da nicht auf. Ist das schon gelöst?
Und @Tyrus hat recht, mein Lösungsvorschlag bezügl. inkscape vs. imagemagick benötigt die unstable inkscape Version. Hatte ich vergessen. Sorry.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 6:37 am    Post subject: Reply with quote

Anscheinend habe ich das PProblem, dass graphicsmagick das USE=-imagemagick nicht akzeptieren will. Ich habe das so gesetzt:
Code:
# 2017-03-29
media-gfx/graphicsmagick cxx ms truetype wmf -imagemagick

und so kommt das heraus:

Code:
emerge -a graphicsmagick

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-gfx/graphicsmagick-1.3.32  USE="X bzip2 cxx imagemagick jbig jpeg lcms openmp png svg threads tiff truetype webp wmf zlib -debug -fpx -lzma -modules -perl -postscript -q16 -q32 -static-libs"                                                                                                                                                                       
[blocks B      ] media-gfx/imagemagick ("media-gfx/imagemagick" is blocking media-gfx/graphicsmagick-1.3.32)
''
* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.
''
(media-gfx/imagemagick-6.9.10.78:0/6.9.10.78::gentoo, installed) pulled in by
media-gfx/imagemagick required by @selected
''
(media-gfx/graphicsmagick-1.3.32:0/1.3::gentoo, ebuild scheduled for merge) pulled in by
graphicsmagick
''
''
For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
''
https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
''


Woran kann das liegen? Habe ich einen Schreibfehler?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Mon Dec 16, 2019 6:44 am    Post subject: Reply with quote

Hast du irgendwo evtl. noch einen anderen Eintrag, der USE="imagemagick" wieder aktiviert? Du kannst ja mal grep auf dein komplettes /etc/portage loslassen, wenn du unsicher bist.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 7:48 am    Post subject: Reply with quote

Bingo!
Beim xorg-server war noch ein USE=imagemagick versteckt. auf grep hätte ich auch selber kommen können.... Sorry, manchmal ist man so festgefressen das man den Wald vor lauter BÄumen nicht sieht. Jetzt habe ich erstmal 126 Pakete am laufen....

Bleibt der Block zwischen qtcore und libpcre2... oder vielleicht löst der sich gleich mit?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Mon Dec 16, 2019 8:07 am    Post subject: Reply with quote

Wie hast du denn die 126 Pakete in dem Update zustande bekommen?
Das emerge -uDNpvt @world, das du gepostet hast, listet nur 1 Update und sagt auch nichts mit libpcre2 und qtcore.
Ich würde halt gerne sehen, warum libpcre2[pcre16,unicode], wie es auch bereits installiert ist, auf einmal nicht mehr passt.
Das -v (--verbose) und -t (--tree) zeigt in der Paketliste alle USE-Flags, ebenso den gesamten dependency tree.
Ich nehme an, dass du an den pcre2-USE-Flags etwas geändert hast, was jetzt bockt, aber sicher sagen kann ich das erst, wenn ich die gesamte emerge Ausgabe sehe.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 8:29 am    Post subject: Reply with quote

Ich habe anscheinend jetzt keine Pakete mehr mit Python 2.7 drin, daher wird eine ganze Menge neu übersetzt....

Den Block mit libprce2 habe ich schon von Anfang an, siehe ersten Post. Mein Fehler, ich dachte, die beiden Dinge hängen evtl. zusammen.... Das hätte ich doch eher trennen sollen.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3920
Location: Germany

PostPosted: Mon Dec 16, 2019 12:50 pm    Post subject: Reply with quote

Hi,
schau zb mal mit einem
Code:
emerge -pvO =dev-libs/libpcre2-10.33-r1
mit welchen Flags das Paket tatsächlich gebaut werden würde.
Und dann ggf noch mit einem
Code:
grep -r dev-libs/libpcre2 /etc/portage/
um zu schauen was ggf wo gesetzt ist.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 2:01 pm    Post subject: Reply with quote

Hallo Josef.95,

das ist seltsam:
Code:
emerge -pvO =dev-libs/libpcre2-10.33-r1
After8 ~ # zsh: dev-libs/libpcre2-10.33-r1 not found


Laut eix ist es in der Version aber installiert:
Code:

eix libpcre2
[I] dev-libs/libpcre2
     Verfügbare Versionen:   10.32 10.33-r1 ~10.34 {bzip2 +jit libedit pcre16 pcre32 +readline +recursion-limit split-usr static-libs unicode zlib ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32"}                                                                                                                                                     
     Installierte Versionen: 10.33-r1(20:50:19 03.11.2019)(bzip2 jit pcre16 readline recursion-limit split-usr unicode zlib -libedit -pcre32 -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")                                                                                                                                     
     Startseite:             http://www.pcre.org/
     Beschreibung:           Perl-compatible regular expression library


grep gibt keine Treffer in /etc/portage.

BTW:
Meine Aktion mit imagmagick & graphicmagick ist durch, gibt aber Verluste:
media-gfx/entangle-2.0 und digikam-6.3.0-r1 haben abgebrochen und ich mußte mit --skipfirst weitermachen....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2480
Location: Frankfurt, Germany

PostPosted: Mon Dec 16, 2019 2:18 pm    Post subject: Reply with quote

Code:
zsh: dev-libs/libpcre2-10.33-r1 not found

Verwendest Du die zsh als System-Shell? Im englischsprachigen Forum hatten wir 2 oder 3 Mal sehr merkwürdige Probleme, die sich dann als Folge der zsh herausgestellt haben. Das hat vermutlich NICHTS mit Deinem aktuellen Problem zu tun, aber Du solltest das im Hinterkopf behalten...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3920
Location: Germany

PostPosted: Mon Dec 16, 2019 2:36 pm    Post subject: Reply with quote

Hm, ich glaub mit zsh müsste man es dann wegen dem "=" in Anführungszeichen setzen. Versuche es mal mit
Code:
emerge -pvO "=dev-libs/libpcre2-10.33-r1"
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 2:37 pm    Post subject: Reply with quote

guter Hinweis, ich habe gestern mit chsh umgestellt....

Allerdings noch keinen Neustart gemacht. Soweit ich weiß wird das erst nach dem Neustart aktiv, oder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2480
Location: Frankfurt, Germany

PostPosted: Mon Dec 16, 2019 3:49 pm    Post subject: Reply with quote

Schau Dir mal die Ausgabe an von
Code:
emerge --info

Meiner Erfahrung nach sollte dort stehen:
Code:
Portage ....
======= ....
System uname: ....
KiB Mem: ....
KiB Swap: ....
Timestamp of ....
Head commit ....
sh bash 4.4_p23-r1    <<<<< ================
ld GNU ld ....

Wenn dort etwas anderes steht als "sh bash" sollte man besser auf bash umstellen - sonst kann es Probleme geben.

Hier sind übrigens Fälle, in denen die zsh zu Problemen geführt hat:
  1. https://forums.gentoo.org/viewtopic-t-1104332.html
  2. https://forums.gentoo.org/viewtopic-t-1090426.html
Wie man die System-Shell umschaltet, wird hier erklärt: https://wiki.gentoo.org/wiki/Shell


Last edited by mike155 on Mon Dec 16, 2019 3:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 3:53 pm    Post subject: Reply with quote

Code:
sh bash 4.4_p23-r1
habe ich da stehen. Also sollte es doch funktionieren...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2480
Location: Frankfurt, Germany

PostPosted: Mon Dec 16, 2019 6:11 pm    Post subject: Reply with quote

Sorry, ich wollte mit dem "zsh" Thema niemanden verwirren.

Ich habe das "zsh" in der Ausgabe von emerge gesehen - und das triggert bei mir zusammen mit "merkwürdigen Problemen" sofort die "Vorsicht, es könnte mit zsh zusammenhängen" Alarm-Lampe...

Ich glaube aber nicht, dass es im aktuellen Fall ein Problem mit der "zsh" gibt.

Es ist trotzdem gut, dass 'emerge --info' bei uhai die bash anzeigt :-)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Mon Dec 16, 2019 8:18 pm    Post subject: Reply with quote

Ich habe mit portpeek noch die Konfigurationsdateien aufgeräumt und emerge -auDNtv world angeschoben. Einen Block habe ich imemr noch:

Code:
'
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
''
dev-libs/libpcre2:0
''
($'[32mdev-libs/libpcre2-10.33-r1:0/0::gentoo$'[39;49;00m, ebuild scheduled for merge) conflicts with
dev-libs/libpcre2[$'[31;01mp$'[39;49;00m$'[31;01mc$'[39;49;00m$'[31;01mr$'[39;49;00m$'[31;01me$'[39;49;00m$'[31;01m1$'[39;49;00m$'[31;01m6$'[39;49;00m,unicode] required by ($'[34mdev-qt/qtcore-5.12.5-r1:5/5.12::gentoo$'[39;49;00m, installed)                                                     
^^^^^^
''


und diese ganzen bescheuerten Escape-Codes. Woher kommen die denn?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3920
Location: Germany

PostPosted: Tue Dec 17, 2019 3:25 am    Post subject: Reply with quote

uhai,
wie das dev-libs/libpcre2 Paket aktuell laut eix Ausgabe installiert ist, ist doch wurscht. Zum auflösen des dep trees ist es für portage interessant wie (mit welchen Flags) das Paket konfiguriert ist, und wie es gebaut werden würde.

Siehe https://forums.gentoo.org/viewtopic-p-8398538.html#8398538 , ich denke die Ausgabe sollte weiterhelfen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1234
Location: Eppingen, Germany

PostPosted: Tue Dec 17, 2019 10:13 am    Post subject: Reply with quote

Da habe ich bisher keine Asugabe bekommen. Jetzt klappt das aber:

Code:
 emerge -pvO "=dev-libs/libpcre2-10.33-r1"

These are the packages that would be merged, in order:

[ebuild   R    ] dev-libs/libpcre2-10.33-r1::gentoo  USE="bzip2 jit readline recursion-limit (split-usr) unicode zlib -libedit -pcre16* -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB                                                                                                         

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Was bedeutet das * bei prce16? Kommt das use-flag aus dem Profil?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Tue Dec 17, 2019 10:23 am    Post subject: Reply with quote

man emerge -> "--verbose"
* suffix transition to or from the enabled state
Das USE Flag wird also von enabled nach disabled verändert.
Wo kommt das her?
make.conf und /etc/portage/package.use durchgraben.

EDIT:
USE=pcre16 wird auch über desktop-profiles aktiviert, ist also für andere Profile aus.
Hast du denn kürzlich dein Profile geändert?
Wenn du es nicht über USE Flags selber ausgemacht hast: Was sagt eselect profile show?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum